[jira] [Commented] (HDFS-4868) Clean up error message when trying to snapshot using ViewFileSystem

2015-05-14 Thread Rakesh R (JIRA)

[ 
https://issues.apache.org/jira/browse/HDFS-4868?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14544986#comment-14544986
 ] 

Rakesh R commented on HDFS-4868:


[~cnauroth] shall we close this jira as we have done the necessary changes to 
support snapshot methods in {{ViewFileSystem}}.

> Clean up error message when trying to snapshot using ViewFileSystem
> ---
>
> Key: HDFS-4868
> URL: https://issues.apache.org/jira/browse/HDFS-4868
> Project: Hadoop HDFS
>  Issue Type: Improvement
>  Components: snapshots
>Affects Versions: 3.0.0
>Reporter: Stephen Chu
>Priority: Minor
>
> Snapshots aren't supported for the ViewFileSystem. When users try to create a 
> snapshot, they'll run into a message like the following:
> {code}
> schu-mbp:presentation schu$ hadoop fs -createSnapshot /user/schu
> -createSnapshot: Fatal internal error
> java.lang.UnsupportedOperationException: ViewFileSystem doesn't support 
> createSnapshot
>   at org.apache.hadoop.fs.FileSystem.createSnapshot(FileSystem.java:2285)
>   at 
> org.apache.hadoop.fs.shell.SnapshotCommands$CreateSnapshot.processArguments(SnapshotCommands.java:87)
>   at 
> org.apache.hadoop.fs.shell.Command.processRawArguments(Command.java:194)
>   at org.apache.hadoop.fs.shell.Command.run(Command.java:155)
>   at org.apache.hadoop.fs.FsShell.run(FsShell.java:255)
>   at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
>   at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:84)
>   at org.apache.hadoop.fs.FsShell.main(FsShell.java:305)
> {code}
> To make things more readable and avoid confusion, it would be helpful to 
> clean up the error message stacktrace and just state that ViewFileSystem 
> doesn't support createSnapshot, similar to what was done in HDFS-4846. The 
> "fatal internal error" message is a bit scary and it might be useful to 
> remove that message to avoid confusion from operators.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (HDFS-4868) Clean up error message when trying to snapshot using ViewFileSystem

2013-12-07 Thread Stephen Chu (JIRA)

[ 
https://issues.apache.org/jira/browse/HDFS-4868?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13842378#comment-13842378
 ] 

Stephen Chu commented on HDFS-4868:
---

Hey, [~cnauroth]. Sounds good, feel free to close as Won't Fix. Thanks!

> Clean up error message when trying to snapshot using ViewFileSystem
> ---
>
> Key: HDFS-4868
> URL: https://issues.apache.org/jira/browse/HDFS-4868
> Project: Hadoop HDFS
>  Issue Type: Improvement
>  Components: snapshots
>Affects Versions: 3.0.0
>Reporter: Stephen Chu
>Priority: Minor
>
> Snapshots aren't supported for the ViewFileSystem. When users try to create a 
> snapshot, they'll run into a message like the following:
> {code}
> schu-mbp:presentation schu$ hadoop fs -createSnapshot /user/schu
> -createSnapshot: Fatal internal error
> java.lang.UnsupportedOperationException: ViewFileSystem doesn't support 
> createSnapshot
>   at org.apache.hadoop.fs.FileSystem.createSnapshot(FileSystem.java:2285)
>   at 
> org.apache.hadoop.fs.shell.SnapshotCommands$CreateSnapshot.processArguments(SnapshotCommands.java:87)
>   at 
> org.apache.hadoop.fs.shell.Command.processRawArguments(Command.java:194)
>   at org.apache.hadoop.fs.shell.Command.run(Command.java:155)
>   at org.apache.hadoop.fs.FsShell.run(FsShell.java:255)
>   at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
>   at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:84)
>   at org.apache.hadoop.fs.FsShell.main(FsShell.java:305)
> {code}
> To make things more readable and avoid confusion, it would be helpful to 
> clean up the error message stacktrace and just state that ViewFileSystem 
> doesn't support createSnapshot, similar to what was done in HDFS-4846. The 
> "fatal internal error" message is a bit scary and it might be useful to 
> remove that message to avoid confusion from operators.



--
This message was sent by Atlassian JIRA
(v6.1#6144)


[jira] [Commented] (HDFS-4868) Clean up error message when trying to snapshot using ViewFileSystem

2013-12-06 Thread Chris Nauroth (JIRA)

[ 
https://issues.apache.org/jira/browse/HDFS-4868?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13842091#comment-13842091
 ] 

Chris Nauroth commented on HDFS-4868:
-

Hi, [~schu].  I think we ought to support the snapshot methods through 
{{ViewFileSystem}}, so I filed HDFS-5641 for adding that support.  Considering 
that, do you think we can close out HDFS-4868 as Won't Fix?

> Clean up error message when trying to snapshot using ViewFileSystem
> ---
>
> Key: HDFS-4868
> URL: https://issues.apache.org/jira/browse/HDFS-4868
> Project: Hadoop HDFS
>  Issue Type: Improvement
>  Components: snapshots
>Affects Versions: 3.0.0
>Reporter: Stephen Chu
>Priority: Minor
>
> Snapshots aren't supported for the ViewFileSystem. When users try to create a 
> snapshot, they'll run into a message like the following:
> {code}
> schu-mbp:presentation schu$ hadoop fs -createSnapshot /user/schu
> -createSnapshot: Fatal internal error
> java.lang.UnsupportedOperationException: ViewFileSystem doesn't support 
> createSnapshot
>   at org.apache.hadoop.fs.FileSystem.createSnapshot(FileSystem.java:2285)
>   at 
> org.apache.hadoop.fs.shell.SnapshotCommands$CreateSnapshot.processArguments(SnapshotCommands.java:87)
>   at 
> org.apache.hadoop.fs.shell.Command.processRawArguments(Command.java:194)
>   at org.apache.hadoop.fs.shell.Command.run(Command.java:155)
>   at org.apache.hadoop.fs.FsShell.run(FsShell.java:255)
>   at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
>   at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:84)
>   at org.apache.hadoop.fs.FsShell.main(FsShell.java:305)
> {code}
> To make things more readable and avoid confusion, it would be helpful to 
> clean up the error message stacktrace and just state that ViewFileSystem 
> doesn't support createSnapshot, similar to what was done in HDFS-4846. The 
> "fatal internal error" message is a bit scary and it might be useful to 
> remove that message to avoid confusion from operators.



--
This message was sent by Atlassian JIRA
(v6.1#6144)