[jira] [Commented] (HDFS-7610) Should use StorageDirectory.getCurrentDIr() to construct FsVolumeImpl

2015-01-20 Thread Colin Patrick McCabe (JIRA)

[ 
https://issues.apache.org/jira/browse/HDFS-7610?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=14284413#comment-14284413
 ] 

Colin Patrick McCabe commented on HDFS-7610:


{code}
+  try {
+volumeSet.add(sl.getFile().getCanonicalFile());
+  } catch (IOException e) {
+// Thrown because File#getCanoicalFile(). Ignored.
+  }
{code}

We can't ignore exceptions like this.  Anyway, I don't think we need the 
canonical filename anyway.  If someone is playing games with symlinks, that's 
their own problem, not ours.  Just get the absolute pathname, an operation that 
can't fail.

{code}
-SetString expectedVolumes = new HashSetString();
+SetString expectedVolumes = new HashSet();
{code}

Changes like this are just churn that makes it harder to read the diff, so 
let's not

thanks

 Should use StorageDirectory.getCurrentDIr() to construct FsVolumeImpl
 -

 Key: HDFS-7610
 URL: https://issues.apache.org/jira/browse/HDFS-7610
 Project: Hadoop HDFS
  Issue Type: Bug
  Components: datanode
Affects Versions: 2.6.0
Reporter: Lei (Eddy) Xu
Assignee: Lei (Eddy) Xu
 Attachments: HDFS-7610.000.patch


 In the hot swap feature, {{FsDatasetImpl#addVolume}} uses the base volume dir 
 (e.g. {{/foo/data0}}, instead of volume's current dir 
 {{/foo/data/current}} to construct {{FsVolumeImpl}}. As a result, DataNode 
 can not remove this newly added volume, because its 
 {{FsVolumeImpl#getBasePath}} returns {{/foo}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (HDFS-7610) Should use StorageDirectory.getCurrentDIr() to construct FsVolumeImpl

2015-01-20 Thread Hadoop QA (JIRA)

[ 
https://issues.apache.org/jira/browse/HDFS-7610?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=14284950#comment-14284950
 ] 

Hadoop QA commented on HDFS-7610:
-

{color:green}+1 overall{color}.  Here are the results of testing the latest 
attachment 
  http://issues.apache.org/jira/secure/attachment/12693398/HDFS-7610.001.patch
  against trunk revision dd0228b.

{color:green}+1 @author{color}.  The patch does not contain any @author 
tags.

{color:green}+1 tests included{color}.  The patch appears to include 1 new 
or modified test files.

{color:green}+1 javac{color}.  The applied patch does not increase the 
total number of javac compiler warnings.

{color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

{color:green}+1 eclipse:eclipse{color}.  The patch built with 
eclipse:eclipse.

{color:green}+1 findbugs{color}.  The patch does not introduce any new 
Findbugs (version 2.0.3) warnings.

{color:green}+1 release audit{color}.  The applied patch does not increase 
the total number of release audit warnings.

{color:green}+1 core tests{color}.  The patch passed unit tests in 
hadoop-hdfs-project/hadoop-hdfs.

Test results: 
https://builds.apache.org/job/PreCommit-HDFS-Build/9281//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9281//console

This message is automatically generated.

 Should use StorageDirectory.getCurrentDIr() to construct FsVolumeImpl
 -

 Key: HDFS-7610
 URL: https://issues.apache.org/jira/browse/HDFS-7610
 Project: Hadoop HDFS
  Issue Type: Bug
  Components: datanode
Affects Versions: 2.6.0
Reporter: Lei (Eddy) Xu
Assignee: Lei (Eddy) Xu
 Attachments: HDFS-7610.000.patch, HDFS-7610.001.patch


 In the hot swap feature, {{FsDatasetImpl#addVolume}} uses the base volume dir 
 (e.g. {{/foo/data0}}, instead of volume's current dir 
 {{/foo/data/current}} to construct {{FsVolumeImpl}}. As a result, DataNode 
 can not remove this newly added volume, because its 
 {{FsVolumeImpl#getBasePath}} returns {{/foo}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (HDFS-7610) Should use StorageDirectory.getCurrentDIr() to construct FsVolumeImpl

2015-01-20 Thread Colin Patrick McCabe (JIRA)

[ 
https://issues.apache.org/jira/browse/HDFS-7610?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=14285136#comment-14285136
 ] 

Colin Patrick McCabe commented on HDFS-7610:


+1.  Thanks, [~eddyxu].

 Should use StorageDirectory.getCurrentDIr() to construct FsVolumeImpl
 -

 Key: HDFS-7610
 URL: https://issues.apache.org/jira/browse/HDFS-7610
 Project: Hadoop HDFS
  Issue Type: Bug
  Components: datanode
Affects Versions: 2.6.0
Reporter: Lei (Eddy) Xu
Assignee: Lei (Eddy) Xu
 Attachments: HDFS-7610.000.patch, HDFS-7610.001.patch


 In the hot swap feature, {{FsDatasetImpl#addVolume}} uses the base volume dir 
 (e.g. {{/foo/data0}}, instead of volume's current dir 
 {{/foo/data/current}} to construct {{FsVolumeImpl}}. As a result, DataNode 
 can not remove this newly added volume, because its 
 {{FsVolumeImpl#getBasePath}} returns {{/foo}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (HDFS-7610) Should use StorageDirectory.getCurrentDIr() to construct FsVolumeImpl

2015-01-14 Thread Hadoop QA (JIRA)

[ 
https://issues.apache.org/jira/browse/HDFS-7610?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=14277903#comment-14277903
 ] 

Hadoop QA commented on HDFS-7610:
-

{color:red}-1 overall{color}.  Here are the results of testing the latest 
attachment 
  http://issues.apache.org/jira/secure/attachment/12692341/HDFS-7610.000.patch
  against trunk revision 6464a89.

{color:green}+1 @author{color}.  The patch does not contain any @author 
tags.

{color:green}+1 tests included{color}.  The patch appears to include 1 new 
or modified test files.

{color:green}+1 javac{color}.  The applied patch does not increase the 
total number of javac compiler warnings.

{color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

{color:green}+1 eclipse:eclipse{color}.  The patch built with 
eclipse:eclipse.

{color:red}-1 findbugs{color}.  The patch appears to introduce 1 new 
Findbugs (version 2.0.3) warnings.

{color:green}+1 release audit{color}.  The applied patch does not increase 
the total number of release audit warnings.

{color:red}-1 core tests{color}.  The patch failed these unit tests in 
hadoop-hdfs-project/hadoop-hdfs:

  org.apache.hadoop.hdfs.qjournal.TestSecureNNWithQJM

  The following test timeouts occurred in 
hadoop-hdfs-project/hadoop-hdfs:

org.apache.hadoop.hdfs.TestFileCreation

Test results: 
https://builds.apache.org/job/PreCommit-HDFS-Build/9215//testReport/
Findbugs warnings: 
https://builds.apache.org/job/PreCommit-HDFS-Build/9215//artifact/patchprocess/newPatchFindbugsWarningshadoop-hdfs.html
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9215//console

This message is automatically generated.

 Should use StorageDirectory.getCurrentDIr() to construct FsVolumeImpl
 -

 Key: HDFS-7610
 URL: https://issues.apache.org/jira/browse/HDFS-7610
 Project: Hadoop HDFS
  Issue Type: Bug
  Components: datanode
Affects Versions: 2.6.0
Reporter: Lei (Eddy) Xu
Assignee: Lei (Eddy) Xu
 Attachments: HDFS-7610.000.patch


 In the hot swap feature, {{FsDatasetImpl#addVolume}} uses the base volume dir 
 (e.g. {{/foo/data0}}, instead of volume's current dir 
 {{/foo/data/current}} to construct {{FsVolumeImpl}}. As a result, DataNode 
 can not remove this newly added volume, because its 
 {{FsVolumeImpl#getBasePath}} returns {{/foo}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)