[jira] [Commented] (HDFS-8631) WebHDFS : Support list/setQuota

2015-10-21 Thread Surendra Singh Lilhore (JIRA)

[ 
https://issues.apache.org/jira/browse/HDFS-8631?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=14967254#comment-14967254
 ] 

Surendra Singh Lilhore commented on HDFS-8631:
--

Thanks  [~andreina] for review...

I have one doubt...

{quote}
Both in NamespaceQuotaParam and in StoragespaceQuotaParam, can update below as 
default value:
public static final String DEFAULT = 
String.valueOf(HdfsConstants.QUOTA_DONT_SET);
instead of 
public static final String DEFAULT = String.valueOf(Long.MAX_VALUE);
{quote}

I am not using anywhere in my patch {{String.valueOf(Long.MAX_VALUE);}}. If you 
are talking about
{code}public static final String DEFAULT = "9223372036854775807";{code}

We can't use expression as default value for annotation attribute. If we use, 
we will get compilation error like this..
{code}The value for annotation attribute DefaultValue.value must be a constant 
expression{code}
So I used "9223372036854775807" as default value and this is same as 
{{QUOTA_DONT_SET}} and {{Long.MAX_VALUE}}.

Please can you check once?

> WebHDFS : Support list/setQuota
> ---
>
> Key: HDFS-8631
> URL: https://issues.apache.org/jira/browse/HDFS-8631
> Project: Hadoop HDFS
>  Issue Type: Sub-task
>Reporter: nijel
>Assignee: Surendra Singh Lilhore
> Attachments: HDFS-8631-001.patch
>
>
> User is able do quota management from filesystem object. Same operation can 
> be allowed trough REST API.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (HDFS-8631) WebHDFS : Support list/setQuota

2015-10-21 Thread J.Andreina (JIRA)

[ 
https://issues.apache.org/jira/browse/HDFS-8631?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=14968574#comment-14968574
 ] 

J.Andreina commented on HDFS-8631:
--

bq.So I used "9223372036854775807" as default value and this is same as 
QUOTA_DONT_SET and Long.MAX_VALUE.
You are correct [~surendrasingh] , annotation members expect constant 
expressions. 
We can ignore review comment #1.

> WebHDFS : Support list/setQuota
> ---
>
> Key: HDFS-8631
> URL: https://issues.apache.org/jira/browse/HDFS-8631
> Project: Hadoop HDFS
>  Issue Type: Sub-task
>Reporter: nijel
>Assignee: Surendra Singh Lilhore
> Attachments: HDFS-8631-001.patch
>
>
> User is able do quota management from filesystem object. Same operation can 
> be allowed trough REST API.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (HDFS-8631) WebHDFS : Support list/setQuota

2015-10-19 Thread J.Andreina (JIRA)

[ 
https://issues.apache.org/jira/browse/HDFS-8631?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=14963013#comment-14963013
 ] 

J.Andreina commented on HDFS-8631:
--

Thanks [~surendrasingh] for the patch. 
It looks great. 

I have few comments :

1.
Both in NamespaceQuotaParam and in StoragespaceQuotaParam, can update below as 
default value:
{code}
public static final String DEFAULT = 
String.valueOf(HdfsConstants.QUOTA_DONT_SET);
instead of 
public static final String DEFAULT = String.valueOf(Long.MAX_VALUE);
{code}

2.
Both in NamespaceQuotaParam and in StoragespaceQuotaParam, can update the 
constructor code as below for more readability
{code}
super(DOMAIN, value, HdfsConstants.QUOTA_RESET, null);
instead of
super(DOMAIN, value, -1L, null);
{code}

3.
Inorder to make test run faster, start 0 datanodes in both testcases, as there 
is no file is been written in tests.

4.
Can update the webhdfs document for supporting list/setQuota.

> WebHDFS : Support list/setQuota
> ---
>
> Key: HDFS-8631
> URL: https://issues.apache.org/jira/browse/HDFS-8631
> Project: Hadoop HDFS
>  Issue Type: Sub-task
>Reporter: nijel
>Assignee: Surendra Singh Lilhore
> Attachments: HDFS-8631-001.patch
>
>
> User is able do quota management from filesystem object. Same operation can 
> be allowed trough REST API.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (HDFS-8631) WebHDFS : Support list/setQuota

2015-10-13 Thread Hadoop QA (JIRA)

[ 
https://issues.apache.org/jira/browse/HDFS-8631?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=14954907#comment-14954907
 ] 

Hadoop QA commented on HDFS-8631:
-

\\
\\
| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:blue}0{color} | pre-patch |  24m  8s | Pre-patch trunk compilation is 
healthy. |
| {color:green}+1{color} | @author |   0m  0s | The patch does not contain any 
@author tags. |
| {color:green}+1{color} | tests included |   0m  0s | The patch appears to 
include 2 new or modified test files. |
| {color:green}+1{color} | javac |   8m 45s | There were no new javac warning 
messages. |
| {color:red}-1{color} | javadoc |  11m 21s | The applied patch generated  3  
additional warning messages. |
| {color:green}+1{color} | release audit |   0m 26s | The applied patch does 
not increase the total number of release audit warnings. |
| {color:red}-1{color} | checkstyle |   2m 55s | The applied patch generated  1 
new checkstyle issues (total was 140, now 140). |
| {color:red}-1{color} | whitespace |   0m  1s | The patch has 8  line(s) that 
end in whitespace. Use git apply --whitespace=fix. |
| {color:green}+1{color} | install |   1m 47s | mvn install still works. |
| {color:green}+1{color} | eclipse:eclipse |   0m 37s | The patch built with 
eclipse:eclipse. |
| {color:green}+1{color} | findbugs |   7m  8s | The patch does not introduce 
any new Findbugs (version 3.0.0) warnings. |
| {color:red}-1{color} | common tests |   7m 49s | Tests failed in 
hadoop-common. |
| {color:red}-1{color} | hdfs tests | 198m 13s | Tests failed in hadoop-hdfs. |
| {color:green}+1{color} | hdfs tests |   0m 33s | Tests passed in 
hadoop-hdfs-client. |
| | | 264m 26s | |
\\
\\
|| Reason || Tests ||
| Failed unit tests | hadoop.fs.TestFilterFileSystem |
|   | hadoop.fs.TestHarFileSystem |
|   | hadoop.ipc.TestIPC |
|   | hadoop.hdfs.TestDFSUpgradeFromImage |
\\
\\
|| Subsystem || Report/Notes ||
| Patch URL | 
http://issues.apache.org/jira/secure/attachment/12766286/HDFS-8631-001.patch |
| Optional Tests | javadoc javac unit findbugs checkstyle |
| git revision | trunk / 5b6bae0 |
| javadoc | 
https://builds.apache.org/job/PreCommit-HDFS-Build/12949/artifact/patchprocess/diffJavadocWarnings.txt
 |
| checkstyle |  
https://builds.apache.org/job/PreCommit-HDFS-Build/12949/artifact/patchprocess/diffcheckstylehadoop-common.txt
 |
| whitespace | 
https://builds.apache.org/job/PreCommit-HDFS-Build/12949/artifact/patchprocess/whitespace.txt
 |
| hadoop-common test log | 
https://builds.apache.org/job/PreCommit-HDFS-Build/12949/artifact/patchprocess/testrun_hadoop-common.txt
 |
| hadoop-hdfs test log | 
https://builds.apache.org/job/PreCommit-HDFS-Build/12949/artifact/patchprocess/testrun_hadoop-hdfs.txt
 |
| hadoop-hdfs-client test log | 
https://builds.apache.org/job/PreCommit-HDFS-Build/12949/artifact/patchprocess/testrun_hadoop-hdfs-client.txt
 |
| Test Results | 
https://builds.apache.org/job/PreCommit-HDFS-Build/12949/testReport/ |
| Java | 1.7.0_55 |
| uname | Linux asf901.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP 
PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux |
| Console output | 
https://builds.apache.org/job/PreCommit-HDFS-Build/12949/console |


This message was automatically generated.

> WebHDFS : Support list/setQuota
> ---
>
> Key: HDFS-8631
> URL: https://issues.apache.org/jira/browse/HDFS-8631
> Project: Hadoop HDFS
>  Issue Type: Sub-task
>Reporter: nijel
>Assignee: Surendra Singh Lilhore
> Attachments: HDFS-8631-001.patch
>
>
> User is able do quota management from filesystem object. Same operation can 
> be allowed trough REST API.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)