[jira] [Updated] (HDFS-8655) Refactor accesses to INodeFile#blocks

2017-01-06 Thread Junping Du (JIRA)

 [ 
https://issues.apache.org/jira/browse/HDFS-8655?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Junping Du updated HDFS-8655:
-
Target Version/s:   (was: 2.8.0)

> Refactor accesses to INodeFile#blocks
> -
>
> Key: HDFS-8655
> URL: https://issues.apache.org/jira/browse/HDFS-8655
> Project: Hadoop HDFS
>  Issue Type: Improvement
>  Components: namenode
>Affects Versions: 2.7.0
>Reporter: Zhe Zhang
>Assignee: Zhe Zhang
> Attachments: HDFS-8655.00.patch, HDFS-8655.01.patch
>
>
> When enabling INodeFile support for striped blocks (mainly in HDFS-7749), 
> HDFS-7285 branch generalized the concept of blocks under an inode. Now 
> {{INodeFile#blocks}} only contains contiguous blocks of an inode. This JIRA 
> separates out code refactors for this purpose. Two main changes:
> # Rename {{setBlocks}} to {{setContiguousBlocks}}
> # Replace direct accesses to {{INodeFile#blocks}} to {{getBlocks}}
> It also contains some code cleanups introduced in the branch.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org



Auto-Re: [jira] [Updated] (HDFS-8655) Refactor accesses to INodeFile#blocks

2015-06-26 Thread wsb
您的邮件已收到!谢谢!

[jira] [Updated] (HDFS-8655) Refactor accesses to INodeFile#blocks

2015-06-26 Thread Zhe Zhang (JIRA)

 [ 
https://issues.apache.org/jira/browse/HDFS-8655?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhe Zhang updated HDFS-8655:

Attachment: HDFS-8655.01.patch

Updating patch to address comments from Haohui and Jing.

It also includes more consolidation so that {{blocks}} is only accessed by a 
getter and a setter now. Moreover, {{setBlocks}}) is changed to private because 
the only external use can be converted to a safer {{clearBlocks}} call.

 Refactor accesses to INodeFile#blocks
 -

 Key: HDFS-8655
 URL: https://issues.apache.org/jira/browse/HDFS-8655
 Project: Hadoop HDFS
  Issue Type: Improvement
  Components: namenode
Affects Versions: 2.7.0
Reporter: Zhe Zhang
Assignee: Zhe Zhang
 Attachments: HDFS-8655.00.patch, HDFS-8655.01.patch


 When enabling INodeFile support for striped blocks (mainly in HDFS-7749), 
 HDFS-7285 branch generalized the concept of blocks under an inode. Now 
 {{INodeFile#blocks}} only contains contiguous blocks of an inode. This JIRA 
 separates out code refactors for this purpose. Two main changes:
 # Rename {{setBlocks}} to {{setContiguousBlocks}}
 # Replace direct accesses to {{INodeFile#blocks}} to {{getBlocks}}
 It also contains some code cleanups introduced in the branch.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


Auto-Re: [jira] [Updated] (HDFS-8655) Refactor accesses to INodeFile#blocks

2015-06-26 Thread wsb
您的邮件已收到!谢谢!

[jira] [Updated] (HDFS-8655) Refactor accesses to INodeFile#blocks

2015-06-26 Thread Zhe Zhang (JIRA)

 [ 
https://issues.apache.org/jira/browse/HDFS-8655?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhe Zhang updated HDFS-8655:

Status: Open  (was: Patch Available)

 Refactor accesses to INodeFile#blocks
 -

 Key: HDFS-8655
 URL: https://issues.apache.org/jira/browse/HDFS-8655
 Project: Hadoop HDFS
  Issue Type: Improvement
  Components: namenode
Affects Versions: 2.7.0
Reporter: Zhe Zhang
Assignee: Zhe Zhang
 Attachments: HDFS-8655.00.patch, HDFS-8655.01.patch


 When enabling INodeFile support for striped blocks (mainly in HDFS-7749), 
 HDFS-7285 branch generalized the concept of blocks under an inode. Now 
 {{INodeFile#blocks}} only contains contiguous blocks of an inode. This JIRA 
 separates out code refactors for this purpose. Two main changes:
 # Rename {{setBlocks}} to {{setContiguousBlocks}}
 # Replace direct accesses to {{INodeFile#blocks}} to {{getBlocks}}
 It also contains some code cleanups introduced in the branch.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Updated] (HDFS-8655) Refactor accesses to INodeFile#blocks

2015-06-23 Thread Zhe Zhang (JIRA)

 [ 
https://issues.apache.org/jira/browse/HDFS-8655?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhe Zhang updated HDFS-8655:

Status: Patch Available  (was: Open)

 Refactor accesses to INodeFile#blocks
 -

 Key: HDFS-8655
 URL: https://issues.apache.org/jira/browse/HDFS-8655
 Project: Hadoop HDFS
  Issue Type: Improvement
  Components: namenode
Affects Versions: 2.7.0
Reporter: Zhe Zhang
Assignee: Zhe Zhang
 Attachments: HDFS-8655.00.patch


 When enabling INodeFile support for striped blocks (mainly in HDFS-7749), 
 HDFS-7285 branch generalized the concept of blocks under an inode. Now 
 {{INodeFile#blocks}} only contains contiguous blocks of an inode. This JIRA 
 separates out code refactors for this purpose. Two main changes:
 # Rename {{setBlocks}} to {{setContiguousBlocks}}
 # Replace direct accesses to {{INodeFile#blocks}} to {{getBlocks}}
 It also contains some code cleanups introduced in the branch.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Updated] (HDFS-8655) Refactor accesses to INodeFile#blocks

2015-06-23 Thread Zhe Zhang (JIRA)

 [ 
https://issues.apache.org/jira/browse/HDFS-8655?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhe Zhang updated HDFS-8655:

Attachment: HDFS-8655.00.patch

 Refactor accesses to INodeFile#blocks
 -

 Key: HDFS-8655
 URL: https://issues.apache.org/jira/browse/HDFS-8655
 Project: Hadoop HDFS
  Issue Type: Improvement
  Components: namenode
Affects Versions: 2.7.0
Reporter: Zhe Zhang
Assignee: Zhe Zhang
 Attachments: HDFS-8655.00.patch


 When enabling INodeFile support for striped blocks (mainly in HDFS-7749), 
 HDFS-7285 branch generalized the concept of blocks under an inode. Now 
 {{INodeFile#blocks}} only contains contiguous blocks of an inode. This JIRA 
 separates out code refactors for this purpose. Two main changes:
 # Rename {{setBlocks}} to {{setContiguousBlocks}}
 # Replace direct accesses to {{INodeFile#blocks}} to {{getBlocks}}
 It also contains some code cleanups introduced in the branch.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


Auto-Re: [jira] [Updated] (HDFS-8655) Refactor accesses to INodeFile#blocks

2015-06-23 Thread wsb
您的邮件已收到!谢谢!

Auto-Re: [jira] [Updated] (HDFS-8655) Refactor accesses to INodeFile#blocks

2015-06-23 Thread wsb
您的邮件已收到!谢谢!