Re: [Hibernate] Re: API name changes

2005-02-17 Thread Christian Bauer
On Feb 18, 2005, at 2:14 AM, Lane Sharman wrote:
merge has got to be one of the weirdest choices conceived in all my 
years of writing code to describe a save operation.
It doesn't save, it merges state. It's fine, save/update are not really 
great in this context, but we need them.

--
Christian Bauer
callto://christian-bauer
Hibernate
[EMAIL PROTECTED]
http://hibernate.org
JBoss Inc
[EMAIL PROTECTED]
http://jboss.com

---
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
___
hibernate-devel mailing list
hibernate-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/hibernate-devel


Re: [Hibernate] Re: API name changes

2005-02-17 Thread Lane Sharman

Christian Bauer wrote:
Christian Bauer wrote:
Starting with H3, we recommend the new EJB3-style operations create() 
and merge(). 

merge has got to be one of the weirdest choices conceived in all my 
years of writing code to describe a save operation.

-Lane

---
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
___
hibernate-devel mailing list
hibernate-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/hibernate-devel


RE: [Hibernate] Re: API name changes

2005-02-14 Thread dchannon

My view is that this is a major version update and we are aligning with
a standard so we should change APIs to suite as well as behaviour.
+1  

Cheers David.


 
-Original Message-
From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] On Behalf Of
Christian Bauer
Sent: Monday, 14 February 2005 9:06 PM
To: hibernate-devel@lists.sourceforge.net
Subject: [Hibernate] Re: API name changes


Christian Bauer wrote:

> Starting with H3, we recommend the new EJB3-style operations create()
> and merge().
> 
> We still have our old methods: save(), update(), saveOrUpdate(), with
> slightly different semantics. What do you think about save(),
attach(), 
> saveOrAttach()? It might be too much code to change, but this is
really 
> our last chance to fix it and to help people think in object states,
not 
> SQL statements (something I repeat about 10 times during a Hibernate 
> training).

Again, I repeat this question. It's critical for our docs, training 
material, etc. Repeat: This is the last chance to make any changes. Even

if you don't really have much to say about it, express your opinion
please.

Also, should we rename create() to persist() to be aligned with EJB3
EDR2?

-- 
Christian Bauer
callto://christian-bauer

Hibernate
[EMAIL PROTECTED]
http://hibernate.org

JBoss Inc
[EMAIL PROTECTED]
http://jboss.com


---
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
___
hibernate-devel mailing list hibernate-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/hibernate-devel



---
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
___
hibernate-devel mailing list
hibernate-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/hibernate-devel


RE: [Hibernate] Re: API name changes

2005-02-14 Thread March, Andres


> -Original Message-
> From: [EMAIL PROTECTED]
[mailto:hibernate-devel-
> [EMAIL PROTECTED] On Behalf Of Emmanuel Bernard
> Sent: Monday, February 14, 2005 3:16 AM
> To: hibernate-devel@lists.sourceforge.net
> Subject: Re: [Hibernate] Re: API name changes
> 
> 
> Christian Bauer wrote:
> 
> > Christian Bauer wrote:
> >
> >> Starting with H3, we recommend the new EJB3-style operations
create()
> >> and merge().
> >>
> >> We still have our old methods: save(), update(), saveOrUpdate(),
with
> >> slightly different semantics. What do you think about save(),
> >> attach(), saveOrAttach()? It might be too much code to change, but
> >> this is really our last chance to fix it and to help people think
in
> >> object states, not SQL statements (something I repeat about 10
times
> >> during a Hibernate training).
> >
> 'save' and 'attach' seems not coherent with each other, I'm not a big
fan.

-1

> 
> >
> > Again, I repeat this question. It's critical for our docs, training
> > material, etc. Repeat: This is the last chance to make any changes.
> > Even if you don't really have much to say about it, express your
> > opinion please.
> >
> > Also, should we rename create() to persist() to be aligned with EJB3
> > EDR2?
> 
> +1
> 

+1

> 
> ---
> SF email is sponsored by - The IT Product Guide
> Read honest & candid reviews on hundreds of IT Products from real
users.
> Discover which products truly live up to the hype. Start reading now.
> http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
> ___
> hibernate-devel mailing list
> hibernate-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/hibernate-devel


---
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_ide95&alloc_id396&op=click
___
hibernate-devel mailing list
hibernate-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/hibernate-devel


Re: [Hibernate] Re: API name changes

2005-02-14 Thread Emmanuel Bernard
Christian Bauer wrote:
Christian Bauer wrote:
Starting with H3, we recommend the new EJB3-style operations create() 
and merge().

We still have our old methods: save(), update(), saveOrUpdate(), with 
slightly different semantics. What do you think about save(), 
attach(), saveOrAttach()? It might be too much code to change, but 
this is really our last chance to fix it and to help people think in 
object states, not SQL statements (something I repeat about 10 times 
during a Hibernate training).

'save' and 'attach' seems not coherent with each other, I'm not a big fan.
Again, I repeat this question. It's critical for our docs, training 
material, etc. Repeat: This is the last chance to make any changes. 
Even if you don't really have much to say about it, express your 
opinion please.

Also, should we rename create() to persist() to be aligned with EJB3 
EDR2?
+1
---
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
___
hibernate-devel mailing list
hibernate-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/hibernate-devel