[Intel-gfx] [PATCH v10 3/6] i915/hdcp: HDCP2.x Refactoring to agnostic hdcp

2023-02-01 Thread Suraj Kandpal
As now we have more then one type of content protection
secrity firmware. Let change the i915_hdcp_interface.h
header naming convention to suit generic f/w type.
%s/MEI_/HDCP_
%s/mei_dev/hdcp_dev

As interface to CP FW can be either a non i915 component or
i915 intergral component, change structure name Accordingly.
%s/i915_hdcp_comp_master/i915_hdcp_master
%s/i915_hdcp_component_ops/i915_hdcp_ops

--v3
-Changing names to drop cp_fw to make naming more agnostic[Jani]

Cc: Tomas Winkler 
Cc: Rodrigo Vivi 
Cc: Uma Shankar 
Cc: Ankit Nautiyal 
Signed-off-by: Anshuman Gupta 
Signed-off-by: Suraj Kandpal 
Reviewed-by: Ankit Nautiyal 
---
 drivers/gpu/drm/i915/display/intel_display_core.h | 1 +
 drivers/gpu/drm/i915/display/intel_hdcp.c | 4 ++--
 2 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/i915/display/intel_display_core.h 
b/drivers/gpu/drm/i915/display/intel_display_core.h
index 8e7a68339876..139100fe2383 100644
--- a/drivers/gpu/drm/i915/display/intel_display_core.h
+++ b/drivers/gpu/drm/i915/display/intel_display_core.h
@@ -15,6 +15,7 @@
 
 #include 
 #include 
+#include 
 
 #include "intel_cdclk.h"
 #include "intel_display_limits.h"
diff --git a/drivers/gpu/drm/i915/display/intel_hdcp.c 
b/drivers/gpu/drm/i915/display/intel_hdcp.c
index 262c76f21801..0d6aed1eb171 100644
--- a/drivers/gpu/drm/i915/display/intel_hdcp.c
+++ b/drivers/gpu/drm/i915/display/intel_hdcp.c
@@ -1409,7 +1409,7 @@ static int hdcp2_authenticate_port(struct intel_connector 
*connector)
return ret;
 }
 
-static int hdcp2_close_mei_session(struct intel_connector *connector)
+static int hdcp2_close_session(struct intel_connector *connector)
 {
struct intel_digital_port *dig_port = 
intel_attached_dig_port(connector);
struct drm_i915_private *dev_priv = to_i915(connector->base.dev);
@@ -1433,7 +1433,7 @@ static int hdcp2_close_mei_session(struct intel_connector 
*connector)
 
 static int hdcp2_deauthenticate_port(struct intel_connector *connector)
 {
-   return hdcp2_close_mei_session(connector);
+   return hdcp2_close_session(connector);
 }
 
 /* Authentication flow starts from here */
-- 
2.25.1



Re: [Intel-gfx] [PATCH v10 3/6] i915/hdcp: HDCP2.x Refactoring to agnostic hdcp

2023-03-06 Thread Shankar, Uma



> -Original Message-
> From: Kandpal, Suraj 
> Sent: Wednesday, February 1, 2023 2:38 PM
> To: intel-gfx@lists.freedesktop.org
> Cc: Nautiyal, Ankit K ; Kandpal, Suraj
> ; Winkler, Tomas ; Vivi,
> Rodrigo ; Shankar, Uma ; Gupta,
> Anshuman 
> Subject: [PATCH v10 3/6] i915/hdcp: HDCP2.x Refactoring to agnostic hdcp

Prefix drm.

> As now we have more then one type of content protection secrity firmware. Let

Typo in security

> change the i915_hdcp_interface.h header naming convention to suit generic f/w
> type.
> %s/MEI_/HDCP_
> %s/mei_dev/hdcp_dev
> 
> As interface to CP FW can be either a non i915 component or
> i915 intergral component, change structure name Accordingly.
> %s/i915_hdcp_comp_master/i915_hdcp_master
> %s/i915_hdcp_component_ops/i915_hdcp_ops

Description seems to be off from the changes in the patch. Please fix.

> --v3
> -Changing names to drop cp_fw to make naming more agnostic[Jani]
> 
> Cc: Tomas Winkler 
> Cc: Rodrigo Vivi 
> Cc: Uma Shankar 
> Cc: Ankit Nautiyal 
> Signed-off-by: Anshuman Gupta 
> Signed-off-by: Suraj Kandpal 
> Reviewed-by: Ankit Nautiyal 
> ---
>  drivers/gpu/drm/i915/display/intel_display_core.h | 1 +
>  drivers/gpu/drm/i915/display/intel_hdcp.c | 4 ++--
>  2 files changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/display/intel_display_core.h
> b/drivers/gpu/drm/i915/display/intel_display_core.h
> index 8e7a68339876..139100fe2383 100644
> --- a/drivers/gpu/drm/i915/display/intel_display_core.h
> +++ b/drivers/gpu/drm/i915/display/intel_display_core.h
> @@ -15,6 +15,7 @@
> 
>  #include 
>  #include 
> +#include 

This change doesn't seem to affect the changes below. Please move this
to the right patch.

> 
>  #include "intel_cdclk.h"
>  #include "intel_display_limits.h"
> diff --git a/drivers/gpu/drm/i915/display/intel_hdcp.c
> b/drivers/gpu/drm/i915/display/intel_hdcp.c
> index 262c76f21801..0d6aed1eb171 100644
> --- a/drivers/gpu/drm/i915/display/intel_hdcp.c
> +++ b/drivers/gpu/drm/i915/display/intel_hdcp.c
> @@ -1409,7 +1409,7 @@ static int hdcp2_authenticate_port(struct 
> intel_connector
> *connector)
>   return ret;
>  }
> 
> -static int hdcp2_close_mei_session(struct intel_connector *connector)
> +static int hdcp2_close_session(struct intel_connector *connector)
>  {
>   struct intel_digital_port *dig_port = 
> intel_attached_dig_port(connector);
>   struct drm_i915_private *dev_priv = to_i915(connector->base.dev); @@ -
> 1433,7 +1433,7 @@ static int hdcp2_close_mei_session(struct intel_connector
> *connector)
> 
>  static int hdcp2_deauthenticate_port(struct intel_connector *connector)  {
> - return hdcp2_close_mei_session(connector);
> + return hdcp2_close_session(connector);
>  }
> 
>  /* Authentication flow starts from here */
> --
> 2.25.1



Re: [Intel-gfx] [PATCH v10 3/6] i915/hdcp: HDCP2.x Refactoring to agnostic hdcp

2023-03-06 Thread Kandpal, Suraj
> 
> 
> 
> > -Original Message-
> > From: Kandpal, Suraj 
> > Sent: Wednesday, February 1, 2023 2:38 PM
> > To: intel-gfx@lists.freedesktop.org
> > Cc: Nautiyal, Ankit K ; Kandpal, Suraj
> > ; Winkler, Tomas ;
> > Vivi, Rodrigo ; Shankar, Uma
> > ; Gupta, Anshuman
> 
> > Subject: [PATCH v10 3/6] i915/hdcp: HDCP2.x Refactoring to agnostic
> > hdcp
> 
> Prefix drm.
> 
Sure

> > As now we have more then one type of content protection secrity
> > firmware. Let
> 
> Typo in security
> 
Will fix
> > change the i915_hdcp_interface.h header naming convention to suit
> > generic f/w type.
> > %s/MEI_/HDCP_
> > %s/mei_dev/hdcp_dev
> >
> > As interface to CP FW can be either a non i915 component or
> > i915 intergral component, change structure name Accordingly.
> > %s/i915_hdcp_comp_master/i915_hdcp_master
> > %s/i915_hdcp_component_ops/i915_hdcp_ops
> 
> Description seems to be off from the changes in the patch. Please fix.
> 
> > --v3
> > -Changing names to drop cp_fw to make naming more agnostic[Jani]
> >
> > Cc: Tomas Winkler 
> > Cc: Rodrigo Vivi 
> > Cc: Uma Shankar 
> > Cc: Ankit Nautiyal 
> > Signed-off-by: Anshuman Gupta 
> > Signed-off-by: Suraj Kandpal 
> > Reviewed-by: Ankit Nautiyal 
> > ---
> >  drivers/gpu/drm/i915/display/intel_display_core.h | 1 +
> >  drivers/gpu/drm/i915/display/intel_hdcp.c | 4 ++--
> >  2 files changed, 3 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/gpu/drm/i915/display/intel_display_core.h
> > b/drivers/gpu/drm/i915/display/intel_display_core.h
> > index 8e7a68339876..139100fe2383 100644
> > --- a/drivers/gpu/drm/i915/display/intel_display_core.h
> > +++ b/drivers/gpu/drm/i915/display/intel_display_core.h
> > @@ -15,6 +15,7 @@
> >
> >  #include 
> >  #include 
> > +#include 
> 
> This change doesn't seem to affect the changes below. Please move this to
> the right patch.

Okay got it

Regards,
Suraj Kandpal
> 
> >
> >  #include "intel_cdclk.h"
> >  #include "intel_display_limits.h"
> > diff --git a/drivers/gpu/drm/i915/display/intel_hdcp.c
> > b/drivers/gpu/drm/i915/display/intel_hdcp.c
> > index 262c76f21801..0d6aed1eb171 100644
> > --- a/drivers/gpu/drm/i915/display/intel_hdcp.c
> > +++ b/drivers/gpu/drm/i915/display/intel_hdcp.c
> > @@ -1409,7 +1409,7 @@ static int hdcp2_authenticate_port(struct
> > intel_connector
> > *connector)
> > return ret;
> >  }
> >
> > -static int hdcp2_close_mei_session(struct intel_connector *connector)
> > +static int hdcp2_close_session(struct intel_connector *connector)
> >  {
> > struct intel_digital_port *dig_port =
> intel_attached_dig_port(connector);
> > struct drm_i915_private *dev_priv = to_i915(connector->base.dev);
> @@
> > -
> > 1433,7 +1433,7 @@ static int hdcp2_close_mei_session(struct
> > intel_connector
> > *connector)
> >
> >  static int hdcp2_deauthenticate_port(struct intel_connector *connector)  {
> > -   return hdcp2_close_mei_session(connector);
> > +   return hdcp2_close_session(connector);
> >  }
> >
> >  /* Authentication flow starts from here */
> > --
> > 2.25.1