[jira] [Closed] (ARTEMIS-1822) Inconsistent method name

2018-04-26 Thread clebert suconic (JIRA)

 [ 
https://issues.apache.org/jira/browse/ARTEMIS-1822?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

clebert suconic closed ARTEMIS-1822.

Resolution: Fixed

> Inconsistent method name
> 
>
> Key: ARTEMIS-1822
> URL: https://issues.apache.org/jira/browse/ARTEMIS-1822
> Project: ActiveMQ Artemis
>  Issue Type: Task
>  Components: Broker
>Reporter: KuiLIU
>Priority: Trivial
> Fix For: 2.5.1
>
>
> The following method is named "lookupRecord".
> "lookupRecord" seems to find a related record.
> But the method is checking whether recordsSnapshot contains the id or not.
> Thus, the method name "containsRecord" is more intuitive than "lookupRecord".
> {code:java}
>public boolean lookupRecord(final long id) {
>   return recordsSnapshot.contains(id);
>}
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)


[jira] [Closed] (ARTEMIS-1822) Inconsistent method name

2018-05-16 Thread clebert suconic (JIRA)

 [ 
https://issues.apache.org/jira/browse/ARTEMIS-1822?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

clebert suconic closed ARTEMIS-1822.

Resolution: Fixed

> Inconsistent method name
> 
>
> Key: ARTEMIS-1822
> URL: https://issues.apache.org/jira/browse/ARTEMIS-1822
> Project: ActiveMQ Artemis
>  Issue Type: Task
>  Components: Broker
>Reporter: KuiLIU
>Priority: Trivial
> Fix For: 2.6.0
>
>
> The following method is named "lookupRecord".
> "lookupRecord" seems to find a related record.
> But the method is checking whether recordsSnapshot contains the id or not.
> Thus, the method name "containsRecord" is more intuitive than "lookupRecord".
> {code:java}
>public boolean lookupRecord(final long id) {
>   return recordsSnapshot.contains(id);
>}
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)