[jira] [Updated] (CAMEL-4494) Allow replyTo message header to be different from actual reply queue

2014-10-21 Thread Jens Granseuer (JIRA)

 [ 
https://issues.apache.org/jira/browse/CAMEL-4494?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jens Granseuer updated CAMEL-4494:
--
Attachment: camel-jms-replyto2.diff

reattached with license grant

 Allow replyTo message header to be different from actual reply queue
 

 Key: CAMEL-4494
 URL: https://issues.apache.org/jira/browse/CAMEL-4494
 Project: Camel
  Issue Type: New Feature
  Components: camel-jms
Affects Versions: 2.8.1
Reporter: Jens Granseuer
 Attachments: camel-jms-replyto.diff, camel-jms-replyto2.diff, 
 camel-jms-replyto2.diff


 We have an application that acts as a JMS client in the following setup:
 * a local queue manager (L) with queues for request (L.REQUEST) and reply 
 (L.REPLY) messages
 * a remote queue manager (R) with queues for request (R.REQUEST) and reply 
 (R.REPLY) messages
 The remote queue manager is unknown to the client application, and messages 
 sent to L.REQUEST are automatically forwarded to R.REQUEST. Similarly, there 
 is a server application listening on R.REQUEST, posting responses in R.REPLY. 
 The local queue manager is unknown to the server application. Messages sent 
 to R.REPLY are automatically forwarded to L.REPLY.
 The client needs to put message in L.REQUEST and receive the reply in 
 L.REPLY. However, in the message header it must set R.REPLY as the reply 
 queue because L.REPLY is not known to the server application.
 The Camel JMS component currently doesn't seem to support this scenario.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Updated] (CAMEL-4494) Allow replyTo message header to be different from actual reply queue

2012-03-20 Thread Jens Granseuer (Updated) (JIRA)

 [ 
https://issues.apache.org/jira/browse/CAMEL-4494?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jens Granseuer updated CAMEL-4494:
--

Patch Info: Patch Available

 Allow replyTo message header to be different from actual reply queue
 

 Key: CAMEL-4494
 URL: https://issues.apache.org/jira/browse/CAMEL-4494
 Project: Camel
  Issue Type: New Feature
  Components: camel-jms
Affects Versions: 2.8.1
Reporter: Jens Granseuer
 Attachments: camel-jms-replyto.diff, camel-jms-replyto2.diff, 
 camel-jms-replyto2.diff


 We have an application that acts as a JMS client in the following setup:
 * a local queue manager (L) with queues for request (L.REQUEST) and reply 
 (L.REPLY) messages
 * a remote queue manager (R) with queues for request (R.REQUEST) and reply 
 (R.REPLY) messages
 The remote queue manager is unknown to the client application, and messages 
 sent to L.REQUEST are automatically forwarded to R.REQUEST. Similarly, there 
 is a server application listening on R.REQUEST, posting responses in R.REPLY. 
 The local queue manager is unknown to the server application. Messages sent 
 to R.REPLY are automatically forwarded to L.REPLY.
 The client needs to put message in L.REQUEST and receive the reply in 
 L.REPLY. However, in the message header it must set R.REPLY as the reply 
 queue because L.REPLY is not known to the server application.
 The Camel JMS component currently doesn't seem to support this scenario.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Updated] (CAMEL-4494) Allow replyTo message header to be different from actual reply queue

2012-03-20 Thread Jens Granseuer (Updated) (JIRA)

 [ 
https://issues.apache.org/jira/browse/CAMEL-4494?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jens Granseuer updated CAMEL-4494:
--

Attachment: (was: camel-jms-replyto2.diff)

 Allow replyTo message header to be different from actual reply queue
 

 Key: CAMEL-4494
 URL: https://issues.apache.org/jira/browse/CAMEL-4494
 Project: Camel
  Issue Type: New Feature
  Components: camel-jms
Affects Versions: 2.8.1
Reporter: Jens Granseuer
 Attachments: camel-jms-replyto.diff, camel-jms-replyto2.diff


 We have an application that acts as a JMS client in the following setup:
 * a local queue manager (L) with queues for request (L.REQUEST) and reply 
 (L.REPLY) messages
 * a remote queue manager (R) with queues for request (R.REQUEST) and reply 
 (R.REPLY) messages
 The remote queue manager is unknown to the client application, and messages 
 sent to L.REQUEST are automatically forwarded to R.REQUEST. Similarly, there 
 is a server application listening on R.REQUEST, posting responses in R.REPLY. 
 The local queue manager is unknown to the server application. Messages sent 
 to R.REPLY are automatically forwarded to L.REPLY.
 The client needs to put message in L.REQUEST and receive the reply in 
 L.REPLY. However, in the message header it must set R.REPLY as the reply 
 queue because L.REPLY is not known to the server application.
 The Camel JMS component currently doesn't seem to support this scenario.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Updated] (CAMEL-4494) Allow replyTo message header to be different from actual reply queue

2012-03-19 Thread Jens Granseuer (Updated) (JIRA)

 [ 
https://issues.apache.org/jira/browse/CAMEL-4494?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jens Granseuer updated CAMEL-4494:
--

Attachment: camel-jms-replyto2.diff

Okay, so I noticed that the current code actually simply dynamically creates 
destinations if the endpoint doesn't have a resolver set. So I just did the 
same here.

I would hope that this patch is actually fit for inclusion.

 Allow replyTo message header to be different from actual reply queue
 

 Key: CAMEL-4494
 URL: https://issues.apache.org/jira/browse/CAMEL-4494
 Project: Camel
  Issue Type: New Feature
  Components: camel-jms
Affects Versions: 2.8.1
Reporter: Jens Granseuer
 Attachments: camel-jms-replyto.diff, camel-jms-replyto2.diff


 We have an application that acts as a JMS client in the following setup:
 * a local queue manager (L) with queues for request (L.REQUEST) and reply 
 (L.REPLY) messages
 * a remote queue manager (R) with queues for request (R.REQUEST) and reply 
 (R.REPLY) messages
 The remote queue manager is unknown to the client application, and messages 
 sent to L.REQUEST are automatically forwarded to R.REQUEST. Similarly, there 
 is a server application listening on R.REQUEST, posting responses in R.REPLY. 
 The local queue manager is unknown to the server application. Messages sent 
 to R.REPLY are automatically forwarded to L.REPLY.
 The client needs to put message in L.REQUEST and receive the reply in 
 L.REPLY. However, in the message header it must set R.REPLY as the reply 
 queue because L.REPLY is not known to the server application.
 The Camel JMS component currently doesn't seem to support this scenario.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Updated] (CAMEL-4494) Allow replyTo message header to be different from actual reply queue

2012-02-29 Thread Jens Granseuer (Updated) (JIRA)

 [ 
https://issues.apache.org/jira/browse/CAMEL-4494?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jens Granseuer updated CAMEL-4494:
--

Attachment: camel-jms-replyto.diff

Here's a (fairly naive) implementation of this feature. The included test case 
works for me but I'm not sure of the proper way to get hold of a 
DestinationResolver when setting the header (see FIXMEs in the patch). I'm also 
not fond of the name of the new configuration property.

Please let me know if you have any suggestions.

 Allow replyTo message header to be different from actual reply queue
 

 Key: CAMEL-4494
 URL: https://issues.apache.org/jira/browse/CAMEL-4494
 Project: Camel
  Issue Type: New Feature
  Components: camel-jms
Affects Versions: 2.8.1
Reporter: Jens Granseuer
 Attachments: camel-jms-replyto.diff


 We have an application that acts as a JMS client in the following setup:
 * a local queue manager (L) with queues for request (L.REQUEST) and reply 
 (L.REPLY) messages
 * a remote queue manager (R) with queues for request (R.REQUEST) and reply 
 (R.REPLY) messages
 The remote queue manager is unknown to the client application, and messages 
 sent to L.REQUEST are automatically forwarded to R.REQUEST. Similarly, there 
 is a server application listening on R.REQUEST, posting responses in R.REPLY. 
 The local queue manager is unknown to the server application. Messages sent 
 to R.REPLY are automatically forwarded to L.REPLY.
 The client needs to put message in L.REQUEST and receive the reply in 
 L.REPLY. However, in the message header it must set R.REPLY as the reply 
 queue because L.REPLY is not known to the server application.
 The Camel JMS component currently doesn't seem to support this scenario.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira