[jira] [Updated] (CAMEL-8362) Camel Components - Generate per component Java fluent builder

2019-06-11 Thread Guillaume Nodet (JIRA)


 [ 
https://issues.apache.org/jira/browse/CAMEL-8362?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Guillaume Nodet updated CAMEL-8362:
---
Fix Version/s: 3.0.0.M4

> Camel Components - Generate per component Java fluent builder
> -
>
> Key: CAMEL-8362
> URL: https://issues.apache.org/jira/browse/CAMEL-8362
> Project: Camel
>  Issue Type: New Feature
>  Components: tooling
>Reporter: Claus Ibsen
>Assignee: Guillaume Nodet
>Priority: Major
> Fix For: 3.0.0, 3.0.0.M4
>
>
> Similar to CAMEL-8361, but for generating java source code fluent builder, so 
> people can configured components and endpoints in a nicer style.
> {code}
> Endpoint file = 
> FileEndpointBuilder.directory("somepath").recursive(true).includes("*.txt").build();
> ...
> {code}
> Though there is a few tasks to figure out.
> We would need some template as skeleton for generating the source code. And 
> we would need a naming convention for the class name. And also we should 
> allow each builder method to have 2 options. As its original type, eg String, 
> boolean, int, etc. And then an alternative that uses a String so people can 
> use property placeholders, eg "{{foo}}".
> And besides endpoints we should also generate for components as well, so its 
> easier to configure them. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)


[jira] [Updated] (CAMEL-8362) Camel Components - Generate per component Java fluent builder

2015-02-15 Thread Claus Ibsen (JIRA)

 [ 
https://issues.apache.org/jira/browse/CAMEL-8362?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Claus Ibsen updated CAMEL-8362:
---
Component/s: tooling

 Camel Components - Generate per component Java fluent builder
 -

 Key: CAMEL-8362
 URL: https://issues.apache.org/jira/browse/CAMEL-8362
 Project: Camel
  Issue Type: New Feature
  Components: tooling
Reporter: Claus Ibsen
 Fix For: 3.0.0


 Similar to CAMEL-8361, but for generating java source code fluent builder, so 
 people can configured components and endpoints in a nicer style.
 {code}
 Endpoint file = 
 FileEndpointBuilder.directory(somepath).recursive(true).includes(*.txt).build();
 ...
 {code}
 Though there is a few tasks to figure out.
 We would need some template as skeleton for generating the source code. And 
 we would need a naming convention for the class name. And also we should 
 allow each builder method to have 2 options. As its original type, eg String, 
 boolean, int, etc. And then an alternative that uses a String so people can 
 use property placeholders, eg {{foo}}.
 And besides endpoints we should also generate for components as well, so its 
 easier to configure them. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)