[jira] [Commented] (IO-253) Test Failures using IBM JDK

2011-09-29 Thread Joerg Schaible (Commented) (JIRA)

[ 
https://issues.apache.org/jira/browse/IO-253?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13117039#comment-13117039
 ] 

Joerg Schaible commented on IO-253:
---

Just for the record. The current IBM JDK 6 (1.6.0.9 Linux/x64) has improved, 
but still fails for UTF-16 only. UTF-16LE and UTF16-BE is handled properly. It 
might be that UTF-16 defaults here to UTF-16LE although Javadoc specifies 
UTF-16BE in this case (see Javadoc java.nio.Charset).

{noformat}
testUTF16WithSingleByteWrite(org.apache.commons.io.output.WriterOutputStreamTest):
expected:[à peine arrivés nous entrâmes dans sa chambre] but was:[＀瀀攀椀渀 攀 
愀爀爀椀瘀猀 渀漀甀猀 攀渀琀爀洀攀猀 搀愀渀猀 猀愀 挀栀愀洀戀爀]
{noformat}

 Test Failures using IBM JDK
 ---

 Key: IO-253
 URL: https://issues.apache.org/jira/browse/IO-253
 Project: Commons IO
  Issue Type: Bug
Affects Versions: 2.0
Reporter: Niall Pemberton
Priority: Minor

 Jörg Schaible reports the following test failures in RC5 of Commons IO 2.0
 * http://markmail.org/message/eoo5bk6n3pfsvfwk
 IBM JDK 1.5 does not like the OOME handling in the FileCleanerTestCase and 
 FileCleanerTrackingTestCase, while IBM JDK 1.6 has problems with the 
 WriterOutputStream handling UTF16.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (DBUTILS-78) Add asynchronous batch, query, and update calls

2011-09-29 Thread Simone Tripodi (Commented) (JIRA)

[ 
https://issues.apache.org/jira/browse/DBUTILS-78?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13117139#comment-13117139
 ] 

Simone Tripodi commented on DBUTILS-78:
---

Patch applied, thanks for contributing William!!!

 Add asynchronous batch, query, and update calls
 ---

 Key: DBUTILS-78
 URL: https://issues.apache.org/jira/browse/DBUTILS-78
 Project: Commons DbUtils
  Issue Type: New Feature
Reporter: William R. Speirs
Assignee: Simone Tripodi
Priority: Minor
 Fix For: 1.4

 Attachments: 08_16_2011.diff, AsyncQueryRunner.java, 
 AsyncQueryRunnerTest.java, DBUTILS-78_Future.patch, 
 DBUTILS-78_Future_v2.diff, DBUTILS-78_Future_v2.patch, 
 DBUTILS-78_Future_v3.diff, async.diff, pom.diff


 I propose a new QueryRunner class, AsyncQueryRunner, which changes the return 
 type of batch, query, and update methods. Instead of returning their 
 respective return types, the methods would return a RunnableFuture. This 
 would allow callers to either execute the RunnableFuture in a thread or via 
 an CompletionService like the ExecutorCompletionService.
 I have attached a first cut at this class.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Created] (CONFIGURATION-464) Download URL incorrect.

2011-09-29 Thread Silas Jones (Created) (JIRA)
Download URL incorrect.
---

 Key: CONFIGURATION-464
 URL: https://issues.apache.org/jira/browse/CONFIGURATION-464
 Project: Commons Configuration
  Issue Type: Bug
Affects Versions: 1.7
 Environment: N/A
Reporter: Silas Jones
Priority: Minor


This is a website issue, so apologies if I'm reporting in the wrong place.

The link provided on the downloads page is 
{mirror}/commons/configuration/binaries/commons-configuration-1.7.zip whereas 
the actual filename has a '-bin' suffix: 
{mirror}/commons/configuration/binaries/commons-configuration-1.7-bin.zip .  
Can be worked around by amending the URL in the browser.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Created] (MATH-677) About package transform

2011-09-29 Thread Gilles (Created) (JIRA)
About package transform
-

 Key: MATH-677
 URL: https://issues.apache.org/jira/browse/MATH-677
 Project: Commons Math
  Issue Type: Improvement
Reporter: Gilles
Priority: Minor
 Fix For: 3.0


Classes in package o.a.c.m.transform might require some changes in order to 
conform to goals set for the next major release.

Some observations:
* Exceptions
** Should remove use of deprecated MathRuntimeException
** Should throw more specific Math...Exception instances instead of standard 
IAE
* Interface RealTransformer (and implementations) contain non-conformant 
method names (e.g. inversetransform instead of inverseTransform)
* FastFourierTransformer:
** Methods mdfft and verifyDataSet take an argument of type Object (to 
allow an argument with an unspecified number of dimensions)
** The RootsOfUnity helper class could be moved to the complex package
** For clarity, multidimensional transform should be moved to a class of its 
own (and I also wonder whether the MultiDimensionalComplexMatrix name is not 
misleading)
* FastFourierTransformer, FastSineTranformer and FastCosineTranformer 
define public methods tranform2 and inversetransform2 but they are not part 
of an interface
* Code uses variables that start with an uppercase
* FastHadamardTransformer contains illegible developer documentation (see 
Javadoc for protected method fht)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Created] (COLLECTIONS-380) UnmodifiableBoundedCollection.unmodifiableBoundedCollection is an infinite loop

2011-09-29 Thread Dave Brosius (Created) (JIRA)
UnmodifiableBoundedCollection.unmodifiableBoundedCollection is an infinite loop
---

 Key: COLLECTIONS-380
 URL: https://issues.apache.org/jira/browse/COLLECTIONS-380
 Project: Commons Collections
  Issue Type: Bug
  Components: Collection
Reporter: Dave Brosius
Priority: Minor


This method, just calls itself. As BoundedCollection extends Collection, it 
would seem to me that this method should be removed:


/**
 * Factory method to create an unmodifiable bounded collection.
 *
 * @param coll  the codeBoundedCollection/code to decorate, must not be 
null
 * @return a new unmodifiable bounded collection
 * @throws IllegalArgumentException if bag is null
 */
public static E BoundedCollectionE 
unmodifiableBoundedCollection(BoundedCollectionE coll) {
return unmodifiableBoundedCollection(coll);
}


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (CONFIGURATION-464) Download URL incorrect.

2011-09-29 Thread Oliver Heger (Commented) (JIRA)

[ 
https://issues.apache.org/jira/browse/CONFIGURATION-464?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13117588#comment-13117588
 ] 

Oliver Heger commented on CONFIGURATION-464:


Thanks for reporting this. I have re-generated the site and published it. Now 
we have to wait until the mirrors catch up.

For the record: The problem was caused by incorrect properties in the pom which 
are evaluated by the templating mechanism for generating the download page.

 Download URL incorrect.
 ---

 Key: CONFIGURATION-464
 URL: https://issues.apache.org/jira/browse/CONFIGURATION-464
 Project: Commons Configuration
  Issue Type: Bug
Affects Versions: 1.7
 Environment: N/A
Reporter: Silas Jones
Priority: Minor

 This is a website issue, so apologies if I'm reporting in the wrong place.
 The link provided on the downloads page is 
 {mirror}/commons/configuration/binaries/commons-configuration-1.7.zip whereas 
 the actual filename has a '-bin' suffix: 
 {mirror}/commons/configuration/binaries/commons-configuration-1.7-bin.zip .  
 Can be worked around by amending the URL in the browser.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Closed] (VFS-356) RamFileRandomAccessContent.seek() allows seeking before file start.

2011-09-29 Thread Miroslav Pokorny (Closed) (JIRA)

 [ 
https://issues.apache.org/jira/browse/VFS-356?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Miroslav Pokorny closed VFS-356.



!:)

 RamFileRandomAccessContent.seek() allows seeking before file start.
 ---

 Key: VFS-356
 URL: https://issues.apache.org/jira/browse/VFS-356
 Project: Commons VFS
  Issue Type: Bug
Affects Versions: 1.0
 Environment: None.
Reporter: Miroslav Pokorny
 Fix For: 2.1


 MRAC simply calls RFRAC with no attempt to clip pos which results in 
 filepoitner being set to negative values which are wrong.
 MonitorRandomAccessContent {
 public void seek(long pos) throws IOException
 {
 content.seek(pos);
 }
 }
 RamFileRandomAccessContent
 public void seek(long pos) throws IOException {
 this.filePointer = (int) pos;
 }

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Closed] (VFS-355) RamFileProvider: ReadingRamFileRandomAccessContent InputStream of file does not return -1 when empty...

2011-09-29 Thread Miroslav Pokorny (Closed) (JIRA)

 [ 
https://issues.apache.org/jira/browse/VFS-355?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Miroslav Pokorny closed VFS-355.



;)

 RamFileProvider: ReadingRamFileRandomAccessContent InputStream of file does 
 not return -1 when empty...
 ---

 Key: VFS-355
 URL: https://issues.apache.org/jira/browse/VFS-355
 Project: Commons VFS
  Issue Type: Bug
Affects Versions: 1.0
 Environment: N/A
Reporter: Miroslav Pokorny
 Fix For: 2.1


 RamFileRandomAccessContent
 public int read(byte b[], int off, int len) throws IOException
   {
   int retLen = Math.min(len, getLeftBytes());
   RamFileRandomAccessContent.this.readFully(b, 
 off, retLen);
   return retLen;
   }
 Notice retLen should return 1 if getLeftBytes() returns 0 but it doesnt. When 
 empty it simply returns 0 which means if one reads until -1 it never 
 happens...

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira