[ 
https://issues.apache.org/jira/browse/IMAGING-327?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17484408#comment-17484408
 ] 

Gary Lucas commented on IMAGING-327:
------------------------------------

The new TiffImagingParameters class offers a welcome improvement over the 
previous API, but I suggest that we should rename one of the methods to better 
reflect what it does.

When creating a new TIFF file, an application passes in a new TiffDirectory 
using an instance of TiffOutputSet.

 
{code:java}
      TiffOutputSet tiffOutputSet = new TiffOutputSet();
      tiffOutputSet.addDirectory(tiffDirectory);
      TiffImagingParameters tiffParams = new TiffImagingParameters();
      tiffParams.setExif(tiffOutputSet); {code}
I propose to change the name of the setExif() method to be setOutputSet().  
This change will affect some of the unit tests as well as the main API.   
Although output sets may include TIFF tags related to the EXIF standard, not 
all output sets are EXIF data.

I believe that the setExif() method owes its name to the code used in the 
legacy implementation and the API that has now been replaced.  SInce we are 
improving the API, it makes sense to change it.  Here's an example of the 
legacy version:
{code:java}
      TiffOutputSet tiffOutputSet = new TiffOutputSet();
      tiffOutputSet.addDirectory(tiffDirectory);
      params.put(ImagingConstants.PARAM_KEY_EXIF, tiffOutputSet); {code}
 

> Rename setExif method in TiffImagingParameters
> ----------------------------------------------
>
>                 Key: IMAGING-327
>                 URL: https://issues.apache.org/jira/browse/IMAGING-327
>             Project: Commons Imaging
>          Issue Type: Improvement
>          Components: Format: TIFF
>            Reporter: Gary Lucas
>            Priority: Minor
>




--
This message was sent by Atlassian Jira
(v8.20.1#820001)

Reply via email to