[jira] [Updated] (FLINK-18997) Rename type_info to result_type to make it more clear

2020-08-19 Thread ASF GitHub Bot (Jira)


 [ 
https://issues.apache.org/jira/browse/FLINK-18997?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

ASF GitHub Bot updated FLINK-18997:
---
Labels: pull-request-available  (was: )

> Rename type_info to result_type to make it more clear
> -
>
> Key: FLINK-18997
> URL: https://issues.apache.org/jira/browse/FLINK-18997
> Project: Flink
>  Issue Type: Improvement
>  Components: API / Python
>Reporter: Hequn Cheng
>Assignee: Hequn Cheng
>Priority: Major
>  Labels: pull-request-available
> Fix For: 1.12.0
>
>
> Currently, the name of result type parameter for Python DataStream.map() and 
> flat_map() is type_info. 
> {code}
> def map(self, func: Union[Callable, MapFunction], type_info: 
> TypeInformation = None) \
> -> 'DataStream':
> {code}
> I think rename it to result_type would be more clear for users. 
> {code}
> def map(self, func: Union[Callable, MapFunction], result_type: 
> TypeInformation = None) \
> -> 'DataStream':
> {code}



--
This message was sent by Atlassian Jira
(v8.3.4#803005)


[jira] [Updated] (FLINK-18997) Rename type_info to result_type to make it more clear

2020-08-19 Thread Hequn Cheng (Jira)


 [ 
https://issues.apache.org/jira/browse/FLINK-18997?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Hequn Cheng updated FLINK-18997:

Description: 
Currently, the name of result type parameter for Python DataStream.map() and 
flat_map() is type_info. 
{code}
def map(self, func: Union[Callable, MapFunction], type_info: 
TypeInformation = None) \
-> 'DataStream':
{code}
I think rename it to result_type would be more clear for users. 
{code}
def map(self, func: Union[Callable, MapFunction], result_type: 
TypeInformation = None) \
-> 'DataStream':
{code}

> Rename type_info to result_type to make it more clear
> -
>
> Key: FLINK-18997
> URL: https://issues.apache.org/jira/browse/FLINK-18997
> Project: Flink
>  Issue Type: Improvement
>  Components: API / Python
>Reporter: Hequn Cheng
>Assignee: Hequn Cheng
>Priority: Major
> Fix For: 1.12.0
>
>
> Currently, the name of result type parameter for Python DataStream.map() and 
> flat_map() is type_info. 
> {code}
> def map(self, func: Union[Callable, MapFunction], type_info: 
> TypeInformation = None) \
> -> 'DataStream':
> {code}
> I think rename it to result_type would be more clear for users. 
> {code}
> def map(self, func: Union[Callable, MapFunction], result_type: 
> TypeInformation = None) \
> -> 'DataStream':
> {code}



--
This message was sent by Atlassian Jira
(v8.3.4#803005)