Blake Bender created GEODE-5092:
-----------------------------------

             Summary: TSSDataOutput class should be using modern memory 
management, and have a meaningful name
                 Key: GEODE-5092
                 URL: https://issues.apache.org/jira/browse/GEODE-5092
             Project: Geode
          Issue Type: Improvement
          Components: native client
            Reporter: Blake Bender


This class is called TSSDataOutput because it is using ACE Thread Specific 
Storage (TSS).  As far as a name, TSS(whatever) falls into the category of 
"true but not helpful," because it doesn't tell us anything about what the 
class does.  It should probably be called something like DataOutputBufferPool, 
because that's what it is.  Also, this class is keeping a list of structures 
containing a raw byte pointer and a size, and using std::malloc and std::free 
to manage the buffer memory.  It should be using something modern - most likely 
the structs in the vector should contain a std::unique_ptr and a size, and pass 
ownership back and forth to DataOutput.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to