[jira] [Updated] (MNG-6081) Log refactoring - Method Invocation Replaced By Variable

2016-10-11 Thread Nemo Chen (JIRA)

 [ 
https://issues.apache.org/jira/browse/MNG-6081?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Nemo Chen updated MNG-6081:
---
Attachment: MNG-6081.patch

> Log refactoring - Method Invocation Replaced By Variable
> 
>
> Key: MNG-6081
> URL: https://issues.apache.org/jira/browse/MNG-6081
> Project: Maven
>  Issue Type: Bug
>Affects Versions: 3.3.9
>Reporter: Nemo Chen
>Priority: Minor
> Attachments: MNG-6081.patch
>
>
> *Method Invocation Replaced By Variable*
> In file: 
> apache-maven-3.3.9/maven-compat/src/main/java/org/apache/maven/artifact/resolver/DebugResolutionListener.java
> from line 70:
> {code}
> String keptVersion = kept.getVersion();
> if ( omittedVersion != null ? !omittedVersion.equals( keptVersion ) : 
> keptVersion != null )
> {
> logger.debug( indent + omitted + " (removed - nearer found: " + 
> kept.getVersion() + ")" );
> }
> {code}
> the "kept.getVersion()" can be replaced with "keptVersion" for the sake of 
> simplicity and readability.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Updated] (MNG-6081) Log refactoring - Method Invocation Replaced By Variable

2016-10-11 Thread Nemo Chen (JIRA)

 [ 
https://issues.apache.org/jira/browse/MNG-6081?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Nemo Chen updated MNG-6081:
---
Attachment: (was: MNG-6081.diff)

> Log refactoring - Method Invocation Replaced By Variable
> 
>
> Key: MNG-6081
> URL: https://issues.apache.org/jira/browse/MNG-6081
> Project: Maven
>  Issue Type: Bug
>Affects Versions: 3.3.9
>Reporter: Nemo Chen
>Priority: Minor
>
> *Method Invocation Replaced By Variable*
> In file: 
> apache-maven-3.3.9/maven-compat/src/main/java/org/apache/maven/artifact/resolver/DebugResolutionListener.java
> from line 70:
> {code}
> String keptVersion = kept.getVersion();
> if ( omittedVersion != null ? !omittedVersion.equals( keptVersion ) : 
> keptVersion != null )
> {
> logger.debug( indent + omitted + " (removed - nearer found: " + 
> kept.getVersion() + ")" );
> }
> {code}
> the "kept.getVersion()" can be replaced with "keptVersion" for the sake of 
> simplicity and readability.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Updated] (MNG-6081) Log refactoring - Method Invocation Replaced By Variable

2016-10-11 Thread Nemo Chen (JIRA)

 [ 
https://issues.apache.org/jira/browse/MNG-6081?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Nemo Chen updated MNG-6081:
---
Attachment: MNG-6081.diff

> Log refactoring - Method Invocation Replaced By Variable
> 
>
> Key: MNG-6081
> URL: https://issues.apache.org/jira/browse/MNG-6081
> Project: Maven
>  Issue Type: Bug
>Affects Versions: 3.3.9
>Reporter: Nemo Chen
>Priority: Minor
>
> *Method Invocation Replaced By Variable*
> In file: 
> apache-maven-3.3.9/maven-compat/src/main/java/org/apache/maven/artifact/resolver/DebugResolutionListener.java
> from line 70:
> {code}
> String keptVersion = kept.getVersion();
> if ( omittedVersion != null ? !omittedVersion.equals( keptVersion ) : 
> keptVersion != null )
> {
> logger.debug( indent + omitted + " (removed - nearer found: " + 
> kept.getVersion() + ")" );
> }
> {code}
> the "kept.getVersion()" can be replaced with "keptVersion" for the sake of 
> simplicity and readability.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Created] (MNG-6081) Log refactoring - Method Invocation Replaced By Variable

2016-08-17 Thread Nemo Chen (JIRA)
Nemo Chen created MNG-6081:
--

 Summary: Log refactoring - Method Invocation Replaced By Variable
 Key: MNG-6081
 URL: https://issues.apache.org/jira/browse/MNG-6081
 Project: Maven
  Issue Type: Bug
Affects Versions: 3.3.9
Reporter: Nemo Chen


*Method Invocation Replaced By Variable*
In file: 
apache-maven-3.3.9/maven-compat/src/main/java/org/apache/maven/artifact/resolver/DebugResolutionListener.java

from line 70:
{code}
String keptVersion = kept.getVersion();

if ( omittedVersion != null ? !omittedVersion.equals( keptVersion ) : 
keptVersion != null )
{
logger.debug( indent + omitted + " (removed - nearer found: " + 
kept.getVersion() + ")" );
}
{code}

the "kept.getVersion()" can be replaced with "keptVersion" for the sake of 
simplicity and readability.





--
This message was sent by Atlassian JIRA
(v6.3.4#6332)