[JBoss-dev] [ jboss-Bugs-937767 ] left-join descriptor is problematic

2004-12-29 Thread SourceForge.net
Bugs item #937767, was opened at 2004-04-19 02:54
Message generated for change (Comment added) made by starksm
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detailatid=376685aid=937767group_id=22866

Category: JBossCMP
Group: v3.2
Status: Open
Resolution: None
Priority: 5
Submitted By: Micah Spears (lamarguy)
Assigned to: Alexey Loubyansky (loubyansky)
Summary: left-join descriptor is problematic

Initial Comment:
I applaud the new the left-join read ahead option but
the xml descriptors in jbosscmp-jdbc.xml are difficult
to configure.  reasons for descriptor change are:

1.) for each query I wish to left-join, I have to
specify the cmr fields each time which leads to
redundancy.  grouping the joins is more logical like
load-groups are handled.

2.) writing xdoclet support is non-trivial for the
current left-join descriptors.

so I propose the syntax change from, for example,

read-ahead
  strategyon-find/strategy
  eager-load-groupreport/eager-load-group
  left-join cmr-field=lineItems/
 left-join cmr-field=product
eager-load-group=short/
  /left-join
  left-join cmr-field=customer
eager-load-group=basic/
/read-ahead

to

read-ahead
  strategyon-find/strategy
  eager-load-groupreport/eager-load-group
  left-join-groupgroup_a/left-join-group
/read-ahead

left-join-groups
  left-join-group
 namegroup_a/name
 descriptionexample left join group/description
 left-join
   cmr-fieldlineItems/cmr-field
   left-join
 cmr-fieldproduct/cmr-field
 eager-load-groupshort/eager-load-group
   /left-join
 /left-join
 left-join
   cmr-fieldcustomer/cmr-field
   eager-load-groupbasic/eager-load-group
 /left-join
  /left-join-group
/left-join-groups
 
in addition, maybe left-join should be renamed to
relation-join for clarity.





--

Comment By: Scott M Stark (starksm)
Date: 2004-12-29 12:52

Message:
Logged In: YES 
user_id=175228

All issues have been moved to http://jira.jboss.com. Existing
issues have been moved. New issues will be closed with this
canned reponse.

--

Comment By: Alexey Loubyansky (loubyansky)
Date: 2004-04-20 09:35

Message:
Logged In: YES 
user_id=543482

This is not a bug. I reposted this to the forums. Let's
discuss it there. Thanks!
http://www.jboss.org/index.html?module=bbop=viewtopicp=3831614

--

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detailatid=376685aid=937767group_id=22866


---
SF email is sponsored by - The IT Product Guide
Read honest  candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. 
http://productguide.itmanagersjournal.com/
___
JBoss-Development mailing list
JBoss-Development@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/jboss-development


[JBoss-dev] [ jboss-Bugs-937767 ] left-join descriptor is problematic

2004-04-20 Thread SourceForge.net
Bugs item #937767, was opened at 2004-04-19 12:54
Message generated for change (Comment added) made by loubyansky
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detailatid=376685aid=937767group_id=22866

Category: JBossCMP
Group: v3.2
Status: Open
Resolution: None
Priority: 5
Submitted By: Micah Spears (lamarguy)
Assigned to: Alexey Loubyansky (loubyansky)
Summary: left-join descriptor is problematic

Initial Comment:
I applaud the new the left-join read ahead option but
the xml descriptors in jbosscmp-jdbc.xml are difficult
to configure.  reasons for descriptor change are:

1.) for each query I wish to left-join, I have to
specify the cmr fields each time which leads to
redundancy.  grouping the joins is more logical like
load-groups are handled.

2.) writing xdoclet support is non-trivial for the
current left-join descriptors.

so I propose the syntax change from, for example,

read-ahead
  strategyon-find/strategy
  eager-load-groupreport/eager-load-group
  left-join cmr-field=lineItems/
 left-join cmr-field=product
eager-load-group=short/
  /left-join
  left-join cmr-field=customer
eager-load-group=basic/
/read-ahead

to

read-ahead
  strategyon-find/strategy
  eager-load-groupreport/eager-load-group
  left-join-groupgroup_a/left-join-group
/read-ahead

left-join-groups
  left-join-group
 namegroup_a/name
 descriptionexample left join group/description
 left-join
   cmr-fieldlineItems/cmr-field
   left-join
 cmr-fieldproduct/cmr-field
 eager-load-groupshort/eager-load-group
   /left-join
 /left-join
 left-join
   cmr-fieldcustomer/cmr-field
   eager-load-groupbasic/eager-load-group
 /left-join
  /left-join-group
/left-join-groups
 
in addition, maybe left-join should be renamed to
relation-join for clarity.





--

Comment By: Alexey Loubyansky (loubyansky)
Date: 2004-04-20 19:35

Message:
Logged In: YES 
user_id=543482

This is not a bug. I reposted this to the forums. Let's
discuss it there. Thanks!
http://www.jboss.org/index.html?module=bbop=viewtopicp=3831614

--

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detailatid=376685aid=937767group_id=22866


---
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470alloc_id=3638op=click
___
JBoss-Development mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/jboss-development


[JBoss-dev] [ jboss-Bugs-937767 ] left-join descriptor is problematic

2004-04-19 Thread SourceForge.net
Bugs item #937767, was opened at 2004-04-19 04:54
Message generated for change (Tracker Item Submitted) made by Item Submitter
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detailatid=376685aid=937767group_id=22866

Category: JBossCMP
Group: v3.2
Status: Open
Resolution: None
Priority: 5
Submitted By: Micah Spears (lamarguy)
Assigned to: Nobody/Anonymous (nobody)
Summary: left-join descriptor is problematic

Initial Comment:
I applaud the new the left-join read ahead option but
the xml descriptors in jbosscmp-jdbc.xml are difficult
to configure.  reasons for descriptor change are:

1.) for each query I wish to left-join, I have to
specify the cmr fields each time which leads to
redundancy.  grouping the joins is more logical like
load-groups are handled.

2.) writing xdoclet support is non-trivial for the
current left-join descriptors.

so I propose the syntax change from, for example,

read-ahead
  strategyon-find/strategy
  eager-load-groupreport/eager-load-group
  left-join cmr-field=lineItems/
 left-join cmr-field=product
eager-load-group=short/
  /left-join
  left-join cmr-field=customer
eager-load-group=basic/
/read-ahead

to

read-ahead
  strategyon-find/strategy
  eager-load-groupreport/eager-load-group
  left-join-groupgroup_a/left-join-group
/read-ahead

left-join-groups
  left-join-group
 namegroup_a/name
 descriptionexample left join group/description
 left-join
   cmr-fieldlineItems/cmr-field
   left-join
 cmr-fieldproduct/cmr-field
 eager-load-groupshort/eager-load-group
   /left-join
 /left-join
 left-join
   cmr-fieldcustomer/cmr-field
   eager-load-groupbasic/eager-load-group
 /left-join
  /left-join-group
/left-join-groups
 
in addition, maybe left-join should be renamed to
relation-join for clarity.





--

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detailatid=376685aid=937767group_id=22866


---
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470alloc_id=3638op=click
___
JBoss-Development mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/jboss-development