[JIRA] (JENKINS-17222) Add ability to specify more than one location when using the svn method

2013-03-14 Thread oesoluti...@gmail.com (JIRA)














































Chris Dore
 created  JENKINS-17222


Add ability to specify more than one location when using the svn method















Issue Type:


Improvement



Assignee:


Justin Ryan



Components:


job-dsl-plugin



Created:


15/Mar/13 2:50 AM



Description:


The SVN plugin supports multiple locations via the UI.  The resulting XML contains multiple hudson.scm.SubversionSCM_-ModuleLocation nodes within the locations node.

For example:

...
locations
hudson.scm.SubversionSCM_-ModuleLocation
remotehttps://some.repo.com/proj1/trunk/remote
localproject1/local
/hudson.scm.SubversionSCM_-ModuleLocation
hudson.scm.SubversionSCM_-ModuleLocation
remotehttps://some.repo.com/proj2/branches/qwe/remote
localproject2_qwe/local
/hudson.scm.SubversionSCM_-ModuleLocation
/locations
...


The job-dsl-plugin could/should also support this.




Project:


Jenkins



Priority:


Minor



Reporter:


Chris Dore

























This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators.
For more information on JIRA, see: http://www.atlassian.com/software/jira







-- 
You received this message because you are subscribed to the Google Groups Jenkins Issues group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.




[JIRA] (JENKINS-17222) Add ability to specify more than one location when using the svn method

2013-03-14 Thread oesoluti...@gmail.com (JIRA)














































Chris Dore
 commented on  JENKINS-17222


Add ability to specify more than one location when using the svn method















I'm willing to take a shot at adding this functionality.

The solution I currently have in my head is to create another overload of the svn method which takes a list of maps. Each map containing the remote and local strings.  So you could call it something like:


scm([[svnUrl:'https://some.repo.com/proj1/trunk', localDir:'project1'],
 [svnUrl:'https://some.repo.com/proj2/branches/qwe', localDir:'project2_qwe']])


or maybe just a list of lists:


scm([['https://some.repo.com/proj1/trunk', 'project1'],
 ['https://some.repo.com/proj2/branches/qwe', 'project2_qwe']])


Thoughts?



























This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators.
For more information on JIRA, see: http://www.atlassian.com/software/jira







-- 
You received this message because you are subscribed to the Google Groups Jenkins Issues group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.




[JIRA] (JENKINS-17222) Add ability to specify more than one location when using the svn method

2013-03-14 Thread oesoluti...@gmail.com (JIRA)












































 
Chris Dore
 edited a comment on  JENKINS-17222


Add ability to specify more than one location when using the svn method
















I'm willing to take a shot at adding this functionality.

The solution I currently have in my head is to create another overload of the svn method which takes a list of maps. Each map containing the remote and local strings.  So you could call it something like:


scm([[svnUrl:'https://some.repo.com/proj1/trunk', localDir:'project1'],
 [svnUrl:'https://some.repo.com/proj2/branches/qwe', localDir:'project2_qwe']])


or maybe just a list of lists:


scm([['https://some.repo.com/proj1/trunk', 'project1'],
 ['https://some.repo.com/proj2/branches/qwe', 'project2_qwe']])


Thoughts on this interface?



























This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators.
For more information on JIRA, see: http://www.atlassian.com/software/jira







-- 
You received this message because you are subscribed to the Google Groups Jenkins Issues group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.




[JIRA] (JENKINS-17222) Add ability to specify more than one location when using the svn method

2013-03-14 Thread oesoluti...@gmail.com (JIRA)












































 
Chris Dore
 edited a comment on  JENKINS-17222


Add ability to specify more than one location when using the svn method
















I'm willing to take a shot at adding this functionality.

The solution I currently have in my head is to create another overload of the svn method which takes a list of maps. Each map containing the remote and local strings.  So you could call it something like:


svn([[svnUrl:'https://some.repo.com/proj1/trunk', localDir:'project1'],
 [svnUrl:'https://some.repo.com/proj2/branches/qwe', localDir:'project2_qwe']])


or maybe just a list of lists:


svn([['https://some.repo.com/proj1/trunk', 'project1'],
 ['https://some.repo.com/proj2/branches/qwe', 'project2_qwe']])


Thoughts on this interface?



























This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators.
For more information on JIRA, see: http://www.atlassian.com/software/jira







-- 
You received this message because you are subscribed to the Google Groups Jenkins Issues group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.




[JIRA] (JENKINS-17222) Add ability to specify more than one location when using the svn method

2013-03-14 Thread oesoluti...@gmail.com (JIRA)














































Chris Dore
 commented on  JENKINS-17222


Add ability to specify more than one location when using the svn method















I already don't like the above idea at all.  I don't think it's going to work out too well in groovy (ya, I'm new to groovy).



























This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators.
For more information on JIRA, see: http://www.atlassian.com/software/jira







-- 
You received this message because you are subscribed to the Google Groups Jenkins Issues group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.




[JIRA] (JENKINS-17222) Add ability to specify more than one location when using the svn method

2013-03-14 Thread jus...@halfempty.org (JIRA)














































Justin Ryan
 commented on  JENKINS-17222


Add ability to specify more than one location when using the svn method















Copying from email:


Ideally we'd create a inner context to define concepts like this, like we do for the ant dsl method. The problem is that svn was written before we knew how to do that, so we just took a "configure" object. It's not really possible to make a change to the signature to take a context instead of a configure closure, without making it a breaking change. What do people feel about this? Should we "fix" the p4, svn and git commands?

In some respects, the resulting XML is pretty straightforward, though not completely obvious to someone new. E.g. from the ticket:


svn('https://some.repo.com/proj1/trunk', 'project1') \{
it / locations / 'hudson.scm.SubversionSCM_-ModuleLocation' \{
remote 'https://some.repo.com/proj2/branches/qwe'
local 'project2_qwe'
  }
}


Maybe we can just document this (and pretend that the scm commands aren't as ugly as they are)?



























This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators.
For more information on JIRA, see: http://www.atlassian.com/software/jira







-- 
You received this message because you are subscribed to the Google Groups Jenkins Issues group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.