triggering a multi-configuration matrix with Successful=true?

2017-03-27 Thread Max Spring
With the Matrix Combinations Plugin 
 I 
am able to *manually* trigger all combinations which have been successful 
previously.
Is it possible to do the same trigger by an upstream job via "Trigger/call 
builds on other projects"?

I see there a parameter flavor "Restrict matrix execution to a subset" 
where I would provide a Groovy script.
Is this the only way?

Thanks!
-Max

-- 
You received this message because you are subscribed to the Google Groups 
"Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/jenkinsci-users/2593fd9c-ba65-4e2b-aa19-841a16348b38%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: Git Plugin: Clean after checkout exclusions?

2014-02-17 Thread Max Spring

James,

job-private local Maven repositories do work for me.
I don't mind the overhead in disk space.

By not using option Clean after checkout and trimming the workspace by script 
instead,
I am able to reuse a populated private local repository from one job run to the 
next.

I also like to see Maven to support layered repositories.

-Max


On 02/14/2014 08:03 AM, James Nord (jnord) wrote:

You can't clean in the maven pom - as the maven pom is what will use what you 
are trying to clean :-o

However - even if Max could selectively clean the repo I don't think it would 
scale.

With Gerrit - you can end up with many changes submitted at the same time - and 
you don't want to run them serially (feedback loop is too long).

As such you need multiple workspaces - and you need multiple executors as well.

As no one writes well behaved unit tests the best practice is to use 1 executor 
per slave.  At this point the likely hood of getting a slave that has the 
workspace that Jenkins wants is possibly slim.

So even if you could - you may end up getting wildly different build times in 
various cases.

There is likely more to be gained (long term) from using shallow clones and 
reference repositories.

If you have a good maven chache close to you build server - the time to 
download isn't the dominating factor anymore (and downloads can be performed in 
parallel, and modules can be built in parallel with Maven3 - so the download 
time end up not blocking/contributing to the build time by any significant 
amount)

What possibly would help is layered local maven repository support (something 
that Jason has mooted several times on the Maven lists) - but nothing is 
available yet.  (but that then assumes that all projects use the same maven 
settings (for all mirrors and have a mirror of * fallback).

/James

*From:*jenkinsci-users@googlegroups.com 
[mailto:jenkinsci-users@googlegroups.com] *On Behalf Of *Mark Waite
*Sent:* 13 February 2014 23:53
*To:* jenkinsci-users@googlegroups.com
*Subject:* Re: Git Plugin: Clean after checkout exclusions?

If the Clean after checkout option you are referencing is the option from the 
git plugin, then I would rather suggest that you should adapt and maintain some form of 
build specific clean within your maven pom.xml, rather than complicating the git plugin 
with inclusions and exclusions for the operation.

The Clean after checkout option in the git plugin is conceptually mapped to git 
clean -xfd.  Your exclusion / inclusion proposal has no matching concept in the git command 
line nor in JGit.  I'd rather not see the git plugin stray from its conceptual mapping to git 
commands.  It is complicated enough already.

Mark Waite

On Thu, Feb 13, 2014 at 4:34 PM, Max Spring m2spr...@springdot.org 
mailto:m2spr...@springdot.org wrote:

I'm using the Clean after checkout option a lot with my Gerrit verification 
Maven jobs.
I also have these jobs use a local repository, sitting in the job's workspace.

Because of the Clean after checkout option set, the job's local repository 
gets wiped and
the subsequent build has to time-consumingly repopulate it with lots of 
artifacts.

I'd like to speed this up.

Ideally, I'd like to exclude certain directories/files from being removed when using the 
Clean after checkout option is set.
Sort of: exclude=$WORKSPACE/.repository

In addition to an exclude option for Clean after checkout,
I would like to have an include option, where I would then specify
certain hierarchies within the private local repository to be cleaned,
like include=$WORKSPACE/.repository/org/myorg/.

-Max

--
You received this message because you are subscribed to the Google Groups Jenkins 
Users group.
To unsubscribe from this group and stop receiving emails from it, send an email to 
jenkinsci-users+unsubscr...@googlegroups.com 
mailto:jenkinsci-users%2bunsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.



--

Thanks!

Mark Waite

--
You received this message because you are subscribed to the Google Groups Jenkins 
Users group.
To unsubscribe from this group and stop receiving emails from it, send an email to 
jenkinsci-users+unsubscr...@googlegroups.com 
mailto:jenkinsci-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups Jenkins 
Users group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


--
You received this message because you are subscribed to the Google Groups Jenkins 
Users group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Re: Git Plugin: Clean after checkout exclusions?

2014-02-14 Thread Max Spring

Hi Mark,

good feedback.  Haven't used git clean before.

I turned off Clean after checkout and do this before the actual build:

  ( set +x
git clean -n -xfd \
| grep -v ' \.repository/' \
| while read f; do \
p=${f#Would remove }
(set -x; rm -rf $WORKSPACE/$p)
  done
  )
  rm -rf $WORKSPACE/.repository/org/myorg

That gives me what I want.

(Yes, I could have use some | cut ... | xargs rm pipe to achieve the same, but
I like the console output I get with my way.)

Regards,
-Max


On 02/13/2014 03:53 PM, Mark Waite wrote:

If the Clean after checkout option you are referencing is the option from the 
git plugin, then I would rather suggest that you should adapt and maintain some form of 
build specific clean within your maven pom.xml, rather than complicating the git plugin 
with inclusions and exclusions for the operation.

The Clean after checkout option in the git plugin is conceptually mapped to git 
clean -xfd.  Your exclusion / inclusion proposal has no matching concept in the git command 
line nor in JGit.  I'd rather not see the git plugin stray from its conceptual mapping to git 
commands.  It is complicated enough already.

Mark Waite


On Thu, Feb 13, 2014 at 4:34 PM, Max Spring m2spr...@springdot.org 
mailto:m2spr...@springdot.org wrote:

I'm using the Clean after checkout option a lot with my Gerrit 
verification Maven jobs.
I also have these jobs use a local repository, sitting in the job's 
workspace.

Because of the Clean after checkout option set, the job's local 
repository gets wiped and
the subsequent build has to time-consumingly repopulate it with lots of 
artifacts.

I'd like to speed this up.

Ideally, I'd like to exclude certain directories/files from being removed when using 
the Clean after checkout option is set.
Sort of: exclude=$WORKSPACE/.__repository

In addition to an exclude option for Clean after checkout,
I would like to have an include option, where I would then specify
certain hierarchies within the private local repository to be cleaned,
like include=$WORKSPACE/.__repository/org/myorg/.

-Max

--
You received this message because you are subscribed to the Google Groups 
Jenkins Users group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscribe@__googlegroups.com 
mailto:jenkinsci-users%2bunsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/__groups/opt_out 
https://groups.google.com/groups/opt_out.




--
Thanks!
Mark Waite

--
You received this message because you are subscribed to the Google Groups Jenkins 
Users group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


--
You received this message because you are subscribed to the Google Groups Jenkins 
Users group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Git Plugin: Clean after checkout exclusions?

2014-02-13 Thread Max Spring

I'm using the Clean after checkout option a lot with my Gerrit verification 
Maven jobs.
I also have these jobs use a local repository, sitting in the job's workspace.

Because of the Clean after checkout option set, the job's local repository 
gets wiped and
the subsequent build has to time-consumingly repopulate it with lots of 
artifacts.

I'd like to speed this up.

Ideally, I'd like to exclude certain directories/files from being removed when using the 
Clean after checkout option is set.
Sort of: exclude=$WORKSPACE/.repository

In addition to an exclude option for Clean after checkout,
I would like to have an include option, where I would then specify
certain hierarchies within the private local repository to be cleaned,
like include=$WORKSPACE/.repository/org/myorg/.

-Max

--
You received this message because you are subscribed to the Google Groups Jenkins 
Users group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Jenkow: Activiti Explorer Jenkins integration 0.3 release

2013-03-09 Thread Max Spring

I just released version 0.3 of the Jenkow plugin which integrates the Activiti 
Explorer into Jenkins.
It allows the orchestration of Jenkins jobs using Activiti BPMN workflows.
Part of this release is Activiti Modeler, the web-based workflow editor.
More details here: 
https://wiki.jenkins-ci.org/display/JENKINS/Jenkow+Activiti+Explorer
Thanks to Kohsuke for his help on this integration!
-Max

--
You received this message because you are subscribed to the Google Groups Jenkins 
Users group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.




Re: Is it called Project or is it called Job?

2012-07-16 Thread Max Spring

IMO, project is a complete misnomer in Jenkins, because a project is 
something a human works on.
A job is something Jenkins executes.
A project has zero or more jobs.
-Max


On 05/16/2012 07:30 AM, Stephen Connolly wrote:

It really starts to break down when you have

* Freestyle project

* Maven 2 project

* Folder

* Update center

* Backup job

* Some random name corresponding to a template you have created

* Some random name corresponding to a template you have created

* Some random name corresponding to a template you have created

* External job

* Copy existing job

[Submit]

Which is what you start to see when you install the CloudBees Plugin
Gateway (to get the folders and backup to the cloud plugins that
CloudBees are giving away free as beer) or when you switch to
CloudBees Enterprise (for all our non-free plugins)

Which is why I think it might be better to just switch everything to
either New Item or New... and be done with it ;-)

Of course that could just be a personal bias ;-)

-Stephen

On 16 May 2012 15:10, Christoph Kutzinskiku...@gmx.de  wrote:

IMHO the average user either wouldn't understand these subtle differences 
anyway or if she would understand she probably wouldn't care.

So, I would like to see a single name for this in the UI.
E.g. I cannot see any significant difference between 'external job' and 
'external project' (just personal liking that job sounds better in that case), 
so both would work. Same for maven job or maven project.


Just my 2 cents.

Christoph




 Original-Nachricht 

Datum: Wed, 16 May 2012 14:26:31 +0200
Von: Simon Wiestsimon.wi...@web.de
An: jenkinsci-users@googlegroups.com
Betreff: Re: Is it called Project or is it called Job?



Hi bl0ck3r,

this puzzled me as well at the beginning, but there's actually quite
some logic to it ;O):

A project is a special case of a job, i.e. all projects are jobs, but
not all jobs are projects.

Cheers,
Simon.


The long story:

Perhaps it helps to extend to mentally the names to *general purpose*
jobs and *software building* projects (although the latter don't need
build software, they are tailored to this use case).

In the case of new job, Jenkins can't not know yet, if the new job
will be of the project subtype. On the other hand, once you have chosen
to create a project, this is reflected as specific as possible in the UI
(Project Foo). If you look at the precise wording on the New Job
page, you'll realize the subtle differences (e.g. Build a free-style
software *project* as opposed to Monitor an external *job*).

An example of a job that is *not* a project is the lesser known
external job that receives  notifications from events that happen
outside Jenkins, but should be tracked inside Jenkins (e.g. system
restarts etc.). See
https://wiki.jenkins-ci.org/display/JENKINS/Monitoring+external+jobs for
more about this job type.

For the records, this is actual class model used by Jenkins internally
(extending sub-classes are indented below their super-class:

Job
AbstractProject
  MatrixProject (a.k.a. multi-configuration project)
  Project
FreeStyleProject
MatrixConfiguration (a single configuration of a matrix project)
StubJob
ViewJob
  ExternalJob

Only FreeStyleProject, MatrixProject, and ExternalJob are visible on the
New Job page.

So, how could we could improve the understanding of the difference
between Job and Project in the UI? Any suggestions?
--
bl0ck3r (15.05.2012 15:02):

The UI needs to be more consistent. In the main Jenkins menu, I can
create a New Job called Foo, but after it is created, the page is
titled Project Foo. This is inconsistent and got me confused for a
couple of days as I was learning Jenkins.