hg: jigsaw/jake/langtools: fix test and update problem list

2016-02-19 Thread jonathan . gibbons
Changeset: 6f0f4866caa3
Author:jjg
Date:  2016-02-19 18:56 -0800
URL:   http://hg.openjdk.java.net/jigsaw/jake/langtools/rev/6f0f4866caa3

fix test and update problem list

! test/ProblemList.jake.txt
! test/tools/javac/options/xprefer/XPreferTest.java



hg: jigsaw/jake/langtools: fix test and update problem list

2016-02-19 Thread jonathan . gibbons
Changeset: f2d3110f3fe7
Author:jjg
Date:  2016-02-19 18:39 -0800
URL:   http://hg.openjdk.java.net/jigsaw/jake/langtools/rev/f2d3110f3fe7

fix test and update problem list

! test/ProblemList.jake.txt
! test/tools/javac/api/TestSearchPaths.java



hg: jigsaw/jake/langtools: fix test and update problem list

2016-02-19 Thread jonathan . gibbons
Changeset: 2cd6834696ec
Author:jjg
Date:  2016-02-19 18:07 -0800
URL:   http://hg.openjdk.java.net/jigsaw/jake/langtools/rev/2cd6834696ec

fix test and update problem list

! src/java.compiler/share/classes/javax/tools/StandardLocation.java
! test/ProblemList.jake.txt
! test/tools/javac/api/T6397104.java



hg: jigsaw/jake/langtools: fix test and update problem list

2016-02-19 Thread jonathan . gibbons
Changeset: a2035933e3a2
Author:jjg
Date:  2016-02-19 17:41 -0800
URL:   http://hg.openjdk.java.net/jigsaw/jake/langtools/rev/a2035933e3a2

fix test and update problem list

! test/ProblemList.jake.txt
! test/tools/javac/Paths/Diagnostics.sh



hg: jigsaw/jake/langtools: update problem list

2016-02-19 Thread jonathan . gibbons
Changeset: 03020ca5f4ce
Author:jjg
Date:  2016-02-19 16:47 -0800
URL:   http://hg.openjdk.java.net/jigsaw/jake/langtools/rev/03020ca5f4ce

update problem list

! test/ProblemList.jake.txt



hg: jigsaw/jake/langtools: update problem list

2016-02-19 Thread jonathan . gibbons
Changeset: e73cc88f52e6
Author:jjg
Date:  2016-02-19 16:39 -0800
URL:   http://hg.openjdk.java.net/jigsaw/jake/langtools/rev/e73cc88f52e6

update problem list

! test/ProblemList.jake.txt



Re: RFR 8130302: jarsigner and keytool -providerClass needs be re-examined for modules

2016-02-19 Thread Mandy Chung

> On Feb 19, 2016, at 2:47 AM, Wang Weijun  wrote:
> 
> Updated at the same URL
> 
>  http://cr.openjdk.java.net/~weijun/8130302/webrev.01
> 
> The help looks like this now:
> 
> -provider   add security provider by name (e.g. SunPKCS11)
>   [-providerArg ]  configure argument for -provider
> -providerclass add security provider by fully-qualified classname
>   [-providerArg ]  configure argument for -providerclass
> 

The help message looks good.  

On the change, I suggest not to duplicate the code from ProviderConfig (I 
mentioned in my previous reply).  One way to do is to add 
sun.security.jca.Providers.addProvider(String name, String argument) that will 
do the same as loading a provider listed in java.security config file 
(ProviderConfig::getProvider I believe).  I think this change can go into 
jdk9/dev as ProviderConfig has the right changes there. 

 303 // A provider in module can also be use class name
 304 if (p.getClass().getName().equals(provClass)) {

ProviderConfig::getProvider doesn’t compare the classname. I thought we agree 
to discourage the use of -providerClass to load a provider and also will be 
consistent with java.security.

1719 testOK("", "-list -storepass password" +
1720 " -providerClass sun.security.provider.Sun" +
1721 " -keystore x.jks -storetype JKS”);

This should use -providerName.  You may want to test both 
“sun.security.provider.Sun” and “SUN”.

ProviderConfig::getProvider has some fast path to support both classname and 
provider name for our built-in security providers for compatibility because 
these names are used in java.security.

Mandy



hg: jigsaw/jake/jdk: Update jar tool to handle URLs to modular JARs

2016-02-19 Thread alan . bateman
Changeset: ad6821d810e3
Author:alanb
Date:  2016-02-19 17:25 +
URL:   http://hg.openjdk.java.net/jigsaw/jake/jdk/rev/ad6821d810e3

Update jar tool to handle URLs to modular JARs

! src/jdk.jartool/share/classes/sun/tools/jar/Main.java



hg: jigsaw/jake/hotspot: Improve -Xpatch implementation

2016-02-19 Thread alan . bateman
Changeset: 558702aea623
Author:alanb
Date:  2016-02-19 16:14 +
URL:   http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/558702aea623

Improve -Xpatch implementation

! test/runtime/modules/XpatchCDS.java



hg: jigsaw/jake/jdk: Improve -Xpatch implementation

2016-02-19 Thread alan . bateman
Changeset: 6c9673d50a04
Author:alanb
Date:  2016-02-19 16:25 +
URL:   http://hg.openjdk.java.net/jigsaw/jake/jdk/rev/6c9673d50a04

Improve -Xpatch implementation
Fix CodeSource URLs for modular JAR files

! src/java.base/share/classes/java/lang/module/InstalledModuleFinder.java
! src/java.base/share/classes/java/lang/module/ModuleDescriptor.java
- src/java.base/share/classes/java/lang/module/ModulePatcher.java
! src/java.base/share/classes/java/lang/module/ModulePath.java
! src/java.base/share/classes/java/lang/module/ModuleReferences.java
! src/java.base/share/classes/jdk/internal/misc/BuiltinClassLoader.java
! src/java.base/share/classes/jdk/internal/misc/ClassLoaders.java
! src/java.base/share/classes/jdk/internal/misc/JavaLangModuleAccess.java
+ src/java.base/share/classes/jdk/internal/module/ModulePatcher.java
! src/java.base/share/native/libjli/java.c
! src/jdk.jlink/share/classes/jdk/tools/jlink/internal/JlinkTask.java
! src/jdk.jlink/share/classes/jdk/tools/jmod/JmodTask.java



Re: CFV: New Jigsaw Committer: Igor Ignatyev

2016-02-19 Thread Karen Kinnear
Vote: yes

thanks,
Karen

> On Feb 3, 2016, at 3:03 PM, Christian Tornqvist 
>  wrote:
> 
> I hereby nominate Igor Ignatyev to Jigsaw Committer.
> 
> 
> 
> Igor is already a Reviewer for the JDK 9 project, and has made the following
> contributions to the jigsaw/jake forest:
> 
> 
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/a801d93d
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/845bcd09258e
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/1fcdf0688256
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/975c5229431a
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/28038047e832
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/48c11894ec7b
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/fcae15d894d9
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/7ed4aa5d4df6
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/e22bfd0e7851
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/d780fdc29a98
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/85982fe1c251
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/f819cf7b7963
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/53dee96e310e
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/e69f047abf8f
> 
> http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/fc6886fa172c
> 
> http://hg.openjdk.java.net/jigsaw/jake/rev/e36a1f987b77
> 
> 
> 
> Votes are due by the end of Feb 17, 2015.
> 
> 
> 
> Only current Jigsaw Committers [1] are eligible to vote on this nomination.
> Votes must be cast in the open by replying to this mailing list.
> 
> 
> 
> For Lazy Consensus voting instructions, see [2].
> 
> 
> 
> Christian Tornqvist
> 
> 
> 
> [1] http://openjdk.java.net/census#jigsaw
> 
> [2] http://openjdk.java.net/projects/#committer-vote|
> 



JDK 9 Early Access with Project Jigsaw, build 106 on 02-18-2016 (#4481)

2016-02-19 Thread Alan Bateman
jigsaw/jake has been sync'ed up to jdk-9+106 and the EA build [1] has 
been refreshed.


-Alan.

[1] https://jdk9.java.net/jigsaw/


hg: jigsaw/jake/jdk: 8148391: JLink needs an option to dump current command line options

2016-02-19 Thread sundararajan . athijegannathan
Changeset: c75f491603c0
Author:sundar
Date:  2016-02-19 18:59 +0530
URL:   http://hg.openjdk.java.net/jigsaw/jake/jdk/rev/c75f491603c0

8148391: JLink needs an option to dump current command line options

! src/jdk.jlink/share/classes/jdk/tools/jlink/internal/JlinkTask.java
! src/jdk.jlink/share/classes/jdk/tools/jlink/resources/jlink.properties



Re: RFR 8130302: jarsigner and keytool -providerClass needs be re-examined for modules

2016-02-19 Thread Alan Bateman


On 19/02/2016 11:17, Wang Weijun wrote:

:
When and which repo should this change go into? Certainly this is all about 
jake but there are a lot of other changes, esp, the option list.



Good question. Ideally jdk9/dev as we are trying to minimize the changes 
in the jake forest. If you do that they there should only be a small 
delta patch to carry in jake, right?


-Alan.


hg: jigsaw/jake: Fix jprt config

2016-02-19 Thread erik . joelsson
Changeset: 947386030f5a
Author:erikj
Date:  2016-02-19 12:21 +0100
URL:   http://hg.openjdk.java.net/jigsaw/jake/rev/947386030f5a

Fix jprt config

! make/jprt.properties



Re: RFR 8130302: jarsigner and keytool -providerClass needs be re-examined for modules

2016-02-19 Thread Wang Weijun

> On Feb 19, 2016, at 6:58 PM, Alan Bateman  wrote:
> 
> One other thing is whether we should add a section to JEP 261 on these tool 
> updates. I had originally assumed that the updates to these tools would 
> follow the module system into JDK 9 but you've turned up early :-)

When and which repo should this change go into? Certainly this is all about 
jake but there are a lot of other changes, esp, the option list.

--Max



Re: RFR 8130302: jarsigner and keytool -providerClass needs be re-examined for modules

2016-02-19 Thread Alan Bateman



On 19/02/2016 10:47, Wang Weijun wrote:

Updated at the same URL

   http://cr.openjdk.java.net/~weijun/8130302/webrev.01

The help looks like this now:

  -provider   add security provider by name (e.g. SunPKCS11)
[-providerArg ]  configure argument for -provider
  -providerclass add security provider by fully-qualified classname
[-providerArg ]  configure argument for -providerclass

--Max


This looks good to me and I see you've switched to using List too.

Mandy may have comments so let's how off pushing this until she looks at 
the latest patch.


One other thing is whether we should add a section to JEP 261 on these 
tool updates. I had originally assumed that the updates to these tools 
would follow the module system into JDK 9 but you've turned up early :-)


-Alan


Re: CFV: New Jigsaw Committer: Igor Ignatyev

2016-02-19 Thread Christian Tornqvist
Vote: yes

- Original Message -
From: christian.tornqv...@oracle.com
To: jigsaw-dev@openjdk.java.net
Sent: Wednesday, February 3, 2016 3:04:17 PM GMT -05:00 US/Canada Eastern
Subject: CFV: New Jigsaw Committer: Igor Ignatyev

I hereby nominate Igor Ignatyev to Jigsaw Committer.

 

Igor is already a Reviewer for the JDK 9 project, and has made the following
contributions to the jigsaw/jake forest:

 

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/a801d93d

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/845bcd09258e

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/1fcdf0688256

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/975c5229431a

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/28038047e832

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/48c11894ec7b

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/fcae15d894d9

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/7ed4aa5d4df6

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/e22bfd0e7851

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/d780fdc29a98

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/85982fe1c251

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/f819cf7b7963

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/53dee96e310e

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/e69f047abf8f

http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/fc6886fa172c

http://hg.openjdk.java.net/jigsaw/jake/rev/e36a1f987b77

 

Votes are due by the end of Feb 17, 2015.

 

Only current Jigsaw Committers [1] are eligible to vote on this nomination.
Votes must be cast in the open by replying to this mailing list.

 

For Lazy Consensus voting instructions, see [2].

 

Christian Tornqvist

 

[1] http://openjdk.java.net/census#jigsaw

[2] http://openjdk.java.net/projects/#committer-vote|



Re: RFR 8130302: jarsigner and keytool -providerClass needs be re-examined for modules

2016-02-19 Thread Wang Weijun

> On Feb 19, 2016, at 5:36 PM, Alan Bateman  wrote:
> 
> 
> On 19/02/2016 09:07, Wang Weijun wrote:
>> :
>> I don't want the line to be too long. Is the preferred terminal width still 
>> 80 now? I noticed the java help output still fits with 80 chars but javac is 
>> already not.
> It could fit on a second line, the java launcher usage output does this. I 
> see jarsigner already uses multiple lines so it shouldn't be an issue.

Help screen of jarsigner is hardcoded, but keytool is a little different. I 
will find a way to make it look nice.

--Max



Re: RFR 8130302: jarsigner and keytool -providerClass needs be re-examined for modules

2016-02-19 Thread Wang Weijun

> On Feb 19, 2016, at 4:42 PM, Alan Bateman  wrote:
> 
> On 19/02/2016 08:22, Wang Weijun wrote:
>> A new webrev at
>> 
>>http://cr.openjdk.java.net/~weijun/8130302/webrev.01/
>> 
>> The options for keytool have
>> 
>>  -provider  [-providerArg ]add a provider by name
>>  -providerclass  [-providerArg ]  add a provider by classname
>> 
>> (omit some words because line is too long)
>> 
>> for jarsigner
>> 
>>   [-provideradd a security provider by a provider name
>> [-providerArg ]] ... configure argument for -provider
>> 
>>   [-providerClass  add a security provider by a fully-qualified 
>> classname
>> [-providerArg ]] ... configure argument for -providerClass
>> 
>> In the test AltProvider.java, I compiled 2 classes (DummyProvider and 
>> module-info) for a new module and they manually create the modulepath 
>> directory. Is there a more formal way to do that?
>> 
> Thanks, this looks quite good. If the usage output "add a provider by name" 
> had something like "e.g. SunPKCS11" or other example name then I think it 
> would be clearer.

I don't want the line to be too long. Is the preferred terminal width still 80 
now? I noticed the java help output still fits with 80 chars but javac is 
already not. 

> 
> A minor annoyance but the list of providers (and provide classes) is a 
> maintained in jarsigner as a Vector, any reason why this can't be a List?

No reason. It's just history. I can fix it.

--Max


> 
> -Alan.



Re: RFR 8130302: jarsigner and keytool -providerClass needs be re-examined for modules

2016-02-19 Thread Alan Bateman

On 19/02/2016 08:22, Wang Weijun wrote:

A new webrev at

http://cr.openjdk.java.net/~weijun/8130302/webrev.01/

The options for keytool have

  -provider  [-providerArg ]add a provider by name
  -providerclass  [-providerArg ]  add a provider by classname

(omit some words because line is too long)

for jarsigner

   [-provideradd a security provider by a provider name
 [-providerArg ]] ... configure argument for -provider

   [-providerClass  add a security provider by a fully-qualified 
classname
 [-providerArg ]] ... configure argument for -providerClass

In the test AltProvider.java, I compiled 2 classes (DummyProvider and 
module-info) for a new module and they manually create the modulepath 
directory. Is there a more formal way to do that?

Thanks, this looks quite good. If the usage output "add a provider by 
name" had something like "e.g. SunPKCS11" or other example name then I 
think it would be clearer.


A minor annoyance but the list of providers (and provide classes) is a 
maintained in jarsigner as a Vector, any reason why this can't be a List?


-Alan.


hg: jigsaw/jake/jdk: Update exclude list

2016-02-19 Thread alan . bateman
Changeset: 123aa9950982
Author:alanb
Date:  2016-02-19 08:30 +
URL:   http://hg.openjdk.java.net/jigsaw/jake/jdk/rev/123aa9950982

Update exclude list

! test/ProblemList.jake.txt



Re: RFR 8130302: jarsigner and keytool -providerClass needs be re-examined for modules

2016-02-19 Thread Wang Weijun
A new webrev at

   http://cr.openjdk.java.net/~weijun/8130302/webrev.01/

The options for keytool have

 -provider  [-providerArg ]add a provider by name
 -providerclass  [-providerArg ]  add a provider by classname

(omit some words because line is too long)

for jarsigner

  [-provideradd a security provider by a provider name
[-providerArg ]] ... configure argument for -provider

  [-providerClass  add a security provider by a fully-qualified 
classname
[-providerArg ]] ... configure argument for -providerClass

In the test AltProvider.java, I compiled 2 classes (DummyProvider and 
module-info) for a new module and they manually create the modulepath 
directory. Is there a more formal way to do that?

Thanks
Max

> On Feb 18, 2016, at 10:55 PM, Mandy Chung  wrote:
> 
> 
>> On Feb 18, 2016, at 1:52 AM, Alan Bateman  wrote:
>> 
>> 
>> On 18/02/2016 09:08, Weijun Wang wrote:
>>> OK, but with -providerClass I'd like to support a class name even if it is 
>>> already defined in a module as a service and has its own name. This makes 
>>> sure old commands still work.
>> I think it should work fine but I assume we would want to discourage this. 
>> That is, these security providers are service provider and there should be 
>> no need for anyone to know the name of the implementation class.
>> 
> 
> Exactly.
> 
> Note that the current ProviderConfig implementation doesn’t support 
> security.provider.N= if this is loaded from the another named 
> module.  It should throw IAE.
> 
> Mandy