[jira] [Assigned] (KAFKA-16899) Rename MembershipManagerImpl's rebalanceTimeoutMs for clarity

2024-06-07 Thread Linu Shibu (Jira)


 [ 
https://issues.apache.org/jira/browse/KAFKA-16899?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Linu Shibu reassigned KAFKA-16899:
--

Assignee: Linu Shibu

> Rename MembershipManagerImpl's rebalanceTimeoutMs for clarity
> -
>
> Key: KAFKA-16899
> URL: https://issues.apache.org/jira/browse/KAFKA-16899
> Project: Kafka
>  Issue Type: Improvement
>  Components: clients, consumer
>Affects Versions: 3.8.0
>Reporter: Kirk True
>Assignee: Linu Shibu
>Priority: Minor
>  Labels: kip-848-client-support
> Fix For: 4.0.0
>
>
> The naming of {{{}MembershipManagerImpl{}}}'s {{rebalanceTimeoutMs}} is a 
> little confusing.
> Ultimately the broker enforces the rebalance process' timeout, not the 
> client. It's therefore a little misleading to use {{rebalanceTimeoutMs}} as 
> the name of a variable that only handles the client's commit portion of the 
> process. It is used in {{MembershipManagerImpl}} as a means to limit the 
> client's efforts in the case where it is repeatedly trying to commit but 
> failing.
> A suggested name change was {{{}commitTimeoutDuringReconciliation{}}}.
> It is not clear to me that simply changing the name from 
> {{rebalanceTimeoutMs}} to {{commitTimeoutDuringReconciliation}} is 
> sufficient. When a caller instantiates a  {{{}MembershipManagerImpl{}}}, it 
> is passing in a variable named {{rebalanceTimeoutMs}} that ultimately comes 
> from the {{ClientConfig}} object. I can imagine it being a little confusing 
> that a value for {{rebalanceTimeoutMs}} is passed in, but then really only 
> used as the value for {{commitTimeoutDuringReconciliation}}.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)


[jira] [Commented] (KAFKA-16899) Rename MembershipManagerImpl's rebalanceTimeoutMs for clarity

2024-06-05 Thread Linu Shibu (Jira)


[ 
https://issues.apache.org/jira/browse/KAFKA-16899?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17852591#comment-17852591
 ] 

Linu Shibu commented on KAFKA-16899:


Could I pick this up [~kirktrue] if you are not working on this?

> Rename MembershipManagerImpl's rebalanceTimeoutMs for clarity
> -
>
> Key: KAFKA-16899
> URL: https://issues.apache.org/jira/browse/KAFKA-16899
> Project: Kafka
>  Issue Type: Improvement
>  Components: clients, consumer
>Affects Versions: 3.8.0
>Reporter: Kirk True
>Priority: Minor
>  Labels: kip-848-client-support
> Fix For: 4.0.0
>
>
> The naming of {{{}MembershipManagerImpl{}}}'s {{rebalanceTimeoutMs}} is a 
> little confusing.
> Ultimately the broker enforces the rebalance process' timeout, not the 
> client. It's therefore a little misleading to use {{rebalanceTimeoutMs}} as 
> the name of a variable that only handles the client's commit portion of the 
> process. It is used in {{MembershipManagerImpl}} as a means to limit the 
> client's efforts in the case where it is repeatedly trying to commit but 
> failing.
> A suggested name change was {{{}commitTimeoutDuringReconciliation{}}}.
> It is not clear to me that simply changing the name from 
> {{rebalanceTimeoutMs}} to {{commitTimeoutDuringReconciliation}} is 
> sufficient. When a caller instantiates a  {{{}MembershipManagerImpl{}}}, it 
> is passing in a variable named {{rebalanceTimeoutMs}} that ultimately comes 
> from the {{ClientConfig}} object. I can imagine it being a little confusing 
> that a value for {{rebalanceTimeoutMs}} is passed in, but then really only 
> used as the value for {{commitTimeoutDuringReconciliation}}.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)


[jira] [Assigned] (KAFKA-16834) add the reason for the failure of PartitionRegistration#toRecord

2024-06-05 Thread Linu Shibu (Jira)


 [ 
https://issues.apache.org/jira/browse/KAFKA-16834?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Linu Shibu reassigned KAFKA-16834:
--

Assignee: Linu Shibu

> add the reason for the failure of PartitionRegistration#toRecord
> 
>
> Key: KAFKA-16834
> URL: https://issues.apache.org/jira/browse/KAFKA-16834
> Project: Kafka
>  Issue Type: Wish
>Affects Versions: 3.7.0
>Reporter: Jianbin Chen
>Assignee: Linu Shibu
>Priority: Minor
>
> Transform it into the following output, which is easier for users to 
> understand and identify the cause of the problem.
> {code:java}
> options.handleLoss("the directory " + (directory == DirectoryId.UNASSIGNED ? 
> "unassigned" : "lost")
> + " state of one or more replicas");{code}



--
This message was sent by Atlassian Jira
(v8.20.10#820010)


[jira] [Commented] (KAFKA-16834) add the reason for the failure of PartitionRegistration#toRecord

2024-05-28 Thread Linu Shibu (Jira)


[ 
https://issues.apache.org/jira/browse/KAFKA-16834?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17850163#comment-17850163
 ] 

Linu Shibu commented on KAFKA-16834:


[~jianbin] can I pick up and work on this?

> add the reason for the failure of PartitionRegistration#toRecord
> 
>
> Key: KAFKA-16834
> URL: https://issues.apache.org/jira/browse/KAFKA-16834
> Project: Kafka
>  Issue Type: Wish
>Affects Versions: 3.7.0
>Reporter: Jianbin Chen
>Priority: Minor
>
> Transform it into the following output, which is easier for users to 
> understand and identify the cause of the problem.
> {code:java}
> options.handleLoss("the directory " + (directory == DirectoryId.UNASSIGNED ? 
> "unassigned" : "lost")
> + " state of one or more replicas");{code}



--
This message was sent by Atlassian Jira
(v8.20.10#820010)


[jira] [Commented] (KAFKA-16356) Remove class-name dispatch in RemoteLogMetadataSerde

2024-03-25 Thread Linu Shibu (Jira)


[ 
https://issues.apache.org/jira/browse/KAFKA-16356?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17830781#comment-17830781
 ] 

Linu Shibu commented on KAFKA-16356:


Yes [~yondy] , I will update this soon, thanks!

> Remove class-name dispatch in RemoteLogMetadataSerde
> 
>
> Key: KAFKA-16356
> URL: https://issues.apache.org/jira/browse/KAFKA-16356
> Project: Kafka
>  Issue Type: Task
>  Components: Tiered-Storage
>Affects Versions: 3.7.0
>Reporter: Greg Harris
>Assignee: Linu Shibu
>Priority: Trivial
>  Labels: newbie
>
> The RemoteLogMetadataSerde#serialize receives a RemoteLogMetadata object, and 
> has to dispatch to one of four serializers depending on it's type. This is 
> done by taking the class name of the RemoteLogMetadata and looking it up in 
> maps to find the corresponding serializer for that class.
> This later requires an unchecked cast, because the RemoteLogMetadataTransform 
> is generic. This is all type-unsafe, and can be replaced with type-safe 
> if-elseif-else statements that may also be faster than the double-indirect 
> map lookups.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)


[jira] [Commented] (KAFKA-16356) Remove class-name dispatch in RemoteLogMetadataSerde

2024-03-13 Thread Linu Shibu (Jira)


[ 
https://issues.apache.org/jira/browse/KAFKA-16356?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17826075#comment-17826075
 ] 

Linu Shibu commented on KAFKA-16356:


Thanks [~gharris1727]! I have assigned it to myself and will be working on it 
[~yondy] .

> Remove class-name dispatch in RemoteLogMetadataSerde
> 
>
> Key: KAFKA-16356
> URL: https://issues.apache.org/jira/browse/KAFKA-16356
> Project: Kafka
>  Issue Type: Task
>  Components: Tiered-Storage
>Affects Versions: 3.7.0
>Reporter: Greg Harris
>Assignee: Linu Shibu
>Priority: Trivial
>  Labels: newbie
>
> The RemoteLogMetadataSerde#serialize receives a RemoteLogMetadata object, and 
> has to dispatch to one of four serializers depending on it's type. This is 
> done by taking the class name of the RemoteLogMetadata and looking it up in 
> maps to find the corresponding serializer for that class.
> This later requires an unchecked cast, because the RemoteLogMetadataTransform 
> is generic. This is all type-unsafe, and can be replaced with type-safe 
> if-elseif-else statements that may also be faster than the double-indirect 
> map lookups.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)


[jira] [Assigned] (KAFKA-16356) Remove class-name dispatch in RemoteLogMetadataSerde

2024-03-13 Thread Linu Shibu (Jira)


 [ 
https://issues.apache.org/jira/browse/KAFKA-16356?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Linu Shibu reassigned KAFKA-16356:
--

Assignee: Linu Shibu

> Remove class-name dispatch in RemoteLogMetadataSerde
> 
>
> Key: KAFKA-16356
> URL: https://issues.apache.org/jira/browse/KAFKA-16356
> Project: Kafka
>  Issue Type: Task
>  Components: Tiered-Storage
>Affects Versions: 3.7.0
>Reporter: Greg Harris
>Assignee: Linu Shibu
>Priority: Trivial
>  Labels: newbie
>
> The RemoteLogMetadataSerde#serialize receives a RemoteLogMetadata object, and 
> has to dispatch to one of four serializers depending on it's type. This is 
> done by taking the class name of the RemoteLogMetadata and looking it up in 
> maps to find the corresponding serializer for that class.
> This later requires an unchecked cast, because the RemoteLogMetadataTransform 
> is generic. This is all type-unsafe, and can be replaced with type-safe 
> if-elseif-else statements that may also be faster than the double-indirect 
> map lookups.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)


[jira] [Comment Edited] (KAFKA-16356) Remove class-name dispatch in RemoteLogMetadataSerde

2024-03-09 Thread Linu Shibu (Jira)


[ 
https://issues.apache.org/jira/browse/KAFKA-16356?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17824971#comment-17824971
 ] 

Linu Shibu edited comment on KAFKA-16356 at 3/9/24 5:30 PM:


Can I assign this to myself and work on it [~gharris1727] ?


was (Author: JIRAUSER304485):
Can I assign this to myself and work on it?

> Remove class-name dispatch in RemoteLogMetadataSerde
> 
>
> Key: KAFKA-16356
> URL: https://issues.apache.org/jira/browse/KAFKA-16356
> Project: Kafka
>  Issue Type: Task
>  Components: Tiered-Storage
>Affects Versions: 3.7.0
>Reporter: Greg Harris
>Priority: Trivial
>  Labels: newbie
>
> The RemoteLogMetadataSerde#serialize receives a RemoteLogMetadata object, and 
> has to dispatch to one of four serializers depending on it's type. This is 
> done by taking the class name of the RemoteLogMetadata and looking it up in 
> maps to find the corresponding serializer for that class.
> This later requires an unchecked cast, because the RemoteLogMetadataTransform 
> is generic. This is all type-unsafe, and can be replaced with type-safe 
> if-elseif-else statements that may also be faster than the double-indirect 
> map lookups.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)


[jira] [Commented] (KAFKA-16356) Remove class-name dispatch in RemoteLogMetadataSerde

2024-03-09 Thread Linu Shibu (Jira)


[ 
https://issues.apache.org/jira/browse/KAFKA-16356?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17824971#comment-17824971
 ] 

Linu Shibu commented on KAFKA-16356:


Can I assign this to myself and work on it?

> Remove class-name dispatch in RemoteLogMetadataSerde
> 
>
> Key: KAFKA-16356
> URL: https://issues.apache.org/jira/browse/KAFKA-16356
> Project: Kafka
>  Issue Type: Task
>  Components: Tiered-Storage
>Affects Versions: 3.7.0
>Reporter: Greg Harris
>Priority: Trivial
>  Labels: newbie
>
> The RemoteLogMetadataSerde#serialize receives a RemoteLogMetadata object, and 
> has to dispatch to one of four serializers depending on it's type. This is 
> done by taking the class name of the RemoteLogMetadata and looking it up in 
> maps to find the corresponding serializer for that class.
> This later requires an unchecked cast, because the RemoteLogMetadataTransform 
> is generic. This is all type-unsafe, and can be replaced with type-safe 
> if-elseif-else statements that may also be faster than the double-indirect 
> map lookups.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)