[j-nsp] SRX - routing between VPLS

2016-07-26 Thread Dan Rimal
Hello all,

I would like to ask you about opinion on routing between VPLS instances
on the SRX platform. I have 3 routers, 2x MX104 and SRX240 (SRX550 works
in the same manner) in MPLS domain using RSVP. There are two VPLS
instances. VPLS1 between MX1 and SRX and VPLS2 between MX2 and SRX. VPLS
are configured with BGP signalling and works good. There is also L3
(vrf) instance on SRX router. There are terminated L3 ifaces from both
VPLS using LT interface in this VRF instance, like this:

unit 4 {
encapsulation vlan-vpls;
vlan-id 1060;
peer-unit 5;
}
unit 5 {
encapsulation vlan;
vlan-id 1060;
peer-unit 4;
family inet {
mtu 1500;
address 10.60.0.1/24;
}
}

unit 6 {
encapsulation vlan-vpls;
vlan-id 1061;
peer-unit 7;
}
unit 7 {
encapsulation vlan;
vlan-id 1061;
peer-unit 6;
family inet {
mtu 1500;
filter {
output 60_to_61;
}
address 10.61.0.1/24;
}
}



__VPLS conf on SRX:__

VPLS-V1060 {
instance-type vpls;
interface lt-0/0/0.4;
interface ge-0/0/3.1060;
route-distinguisher 21.270.16.81:1060;
vrf-target target:24136:1060;
protocols {
vpls {
site-range 4;
mac-table-size {
64;
packet-action drop;
}
no-tunnel-services;
site srx240-1060 {
site-identifier 2;
interface ge-0/0/3.1060;
interface lt-0/0/0.4;
}
connectivity-type ce;
}
}
}


__VRF conf on SRX:__

TEST-L3VPN {
instance-type vrf;
interface lt-0/0/0.5;
interface lt-0/0/0.7;
route-distinguisher 21.270.16.81:1062;
vrf-target target:24136:1062;
vrf-table-label;
routing-options {
maximum-prefixes 100 threshold 90 log-interval 3600;
}
}


lt-0/0/0.4 (and 6) is defined under VPLS instance, lt-0/0/0.5 (and 7) is
defined in the VRF instance. IP adresses of LT unit 5 (and unit 7 for
second VPLS) is gateway for devices in appropriates VLAN (VPLS). There
are also external ifaces to servers and other devices in the VPLSs
instances.

I'm expecting packets forwarding from one VPLS to another and vice versa
with this configuration. But it is not true in some cases/traffic
direction.
When pinging between VLANs (VPLSs) originated and terminated packets on
the remote sides of VPLSs ( example input iface: lt-0/0/0.5 and output
iface: lt-0/0/0.7 from SRX point of view), it doesn't work.

I have port mirror on the switch on SRX uplink and i can see valid
incoming packets from remote side VPLS1 with valid MPLS/VPLS label, etc.
I also have firewall filter on outgoing lt-0/0/0.7 interface for logging
outgoing traffic and it is incrementing/logging:

20:07:16  pfe   A  lt-0/0/0.5ICMP10.60.0.251
 10.61.0.251
20:07:15  pfe   A  lt-0/0/0.5ICMP10.60.0.251
 10.61.0.251
20:07:14  pfe   A  lt-0/0/0.5ICMP10.60.0.251
 10.61.0.251

But there is no corresponding outgoing packets on SRX uplinks to VPLS2
endpoint.

Another communication between VPLS works, for example:

1) ping between VLANs (VPLSs) originated and terminated on local
interface (for example iif ge-0/0/3.1060 and oif ge-0/0/4.1061) and vice
versa works ok

2) ping between VLANs (VPLSs) originated on remote side of VPLS and
terminated on local iface (for example iif lt-0/0/0.5 and oif
ge-0/0/4/1061) and vice versa works ok

3) ping between VLANs (VPLSs) originated on remote side of VPLS and
terminated on lt iface ( iif lt-0/0/0.5 and pointed to local 10.61.0.1
(lt-0/0/0.7) and vice versa works ok


It looks like problem with traffic originated and terminated in VPLS
tunnel (routing from one remote VPLS endpoint to another remote VPLS
endpoint). Has somebody experience with this or similar issue? It looks
like bug for me (or some SRX platform limitation), because output
firewall filter catch (and accept) given traffic, but this traffic
missing on physical link.

It is on SRX240B. I tried upgrade from 12.1X46-D40.2 to 12.1X46-D50.4,
problem persist. The same problem have also on SRX550 with 12.1X46-D40.2

I really appreciate your help/opinion.

Best regards,

Daniel
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


[j-nsp] SRX RVI MPLS facing

2015-12-27 Thread Dan Rimal
Hi,

I am trying to use SRX240B as a VLAN capable switch and also VPLS
endpoint. VPLS works "well" for me with standard routed port, but when i
tried to use uplink port as a "switch port" and use RVI (routed vlan
interface) to connect to MPLS core, VPLS stop working: OSPF, BGP and
RSVP works well, VPLS instances also goes UP, but VPLS instances cannot
learn remote MAC adressess.

Remote VPLS instance (MX series) learn MAC from SRX side, but VPLS on
SRX with RVI cannot learn mac from MX side. L2 looks like works well,
for example, VRRP (on lt interface) was established (because SRX master
use VRRP well known dst MAC).

It is Junos 12.1X46-D35

My working uplink config:

interfaces {
ge-0/0/1 {
vlan-tagging;
mtu 1590;
unit 500 {
vlan-id 500;
family inet {
mtu 1500;
address 31.31.176.193/30;
}
family mpls;
}
}
}


And not working RVI configuration:

interfaces {
ge-0/0/1 {
mtu 1590;
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members [ 500 520 ];
}
}
}
}
vlan {
mtu 1590;
unit 500 {
family inet {
mtu 1500;
address 31.31.176.193/30;
}
family mpls;
}
}
}
vlans {
vl500 {
vlan-id 500;
l3-interface vlan.500;
}
vl520 {
vlan-id 520;
}
}


It looks like a junos bug for me (or maybe SRX L2 limitation). Has
anyone run into the same problem?

Thanks a lot,

Daniel

___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


[j-nsp] SRX VPLS learning domains

2015-12-24 Thread Dan Rimal
Hi,

I am trying to pass multiple VLAN via single VPLS routing instance and
assume separate learning domain for every single VLAN. I tried knob
"vlan-id all" under routing instance without success. O MX series it
works, it create multiple learning domain, on SRX 240 (second site) nope
and same MAC from different VLANs collide. Is it some SRX limitation or
something like this?

Junos 12.1X46-D35 on SRX240B

My config:

ge-0/0/3 {
vlan-tagging;
mtu 1590;
encapsulation flexible-ethernet-services;
unit 512 {
description CE-facing-1;
encapsulation vlan-vpls;
vlan-id 512;
family vpls {
policer {
input vpls-10m;
output vpls-10m;
}
}
}

   unit 513 {
description CE-facing-1;
encapsulation vlan-vpls;
vlan-id 513;
family vpls {
policer {
input vpls-10m;
output vpls-10m;
}
}
}


   VPLS-ALGO-V512 {
instance-type vpls;
interface lt-0/0/0.0;
interface ge-0/0/3.512;
interface ge-0/0/3.513;
vlan-id all;
route-distinguisher 31.41.176.64:512;
vrf-target target:36736:512;
protocols {
vpls {
site-range 4;
mac-table-size {
128;
packet-action drop;
}
no-tunnel-services;
site j3r-512 {
site-identifier 2;
interface ge-0/0/3.512;
interface ge-0/0/3.513;
interface lt-0/0/0.0;
}
connectivity-type ce;
}
}
}


Thanks,

Dan

___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp