[konsole] [Bug 445846] "Bi-directional text rendering" should be renamed to something like "Support for complex scripts"

2022-12-06 Thread bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=445846

ninj...@gmail.com changed:

   What|Removed |Added

 Status|ASSIGNED|RESOLVED
 Resolution|--- |FIXED

--- Comment #10 from ninj...@gmail.com ---
See: https://invent.kde.org/utilities/konsole/-/merge_requests/544#note_549530

-- 
You are receiving this mail because:
You are watching all bug changes.

[konsole] [Bug 445846] "Bi-directional text rendering" should be renamed to something like "Support for complex scripts"

2022-08-26 Thread Kurt Hindenburg
https://bugs.kde.org/show_bug.cgi?id=445846

--- Comment #9 from Kurt Hindenburg  ---
Git commit 76f879cd70fb494ab2334d2660b34679546f3d9d by Kurt Hindenburg, on
behalf of Matan Ziv-Av.
Committed on 26/08/2022 at 19:24.
Pushed by hindenburg into branch 'master'.

Draw characters in exact positions

QT can't be made to draw monospaced text (if the font does not cooperate),
so avoid combining characters, using a QPainter::drawText() call for each
character.

For bidi text support this change requires konsole to reorder and reshape
the characters. This is done using the ICU library (which QT also uses).

This change allows for some improvements related to text rendering:

- More precise bidi reordering, which is no longer changed by characters'
  attributes and selection.
- underlines drawn separately from the text, allowing for differing
  underline modes (double, curly, dashed, dotted, colored).
- Overriding font for emoji characters.

This commit fixes a few bugs and addresses a lot more:

Feature requests: More standard conforming RTL and various underlines:
Related: bug 403729, bug 387811, bug 416508, bug 452087, bug 425973, bug
430822, bug 442742, bug 441037, bug 430822, bug 440070, bug 450017, bug 453086,
bug 381593, bug 451716

Using non-monospace font:



Emoji:

Regression: devanagari rendering

M  +2-0CMakeLists.txt
M  +1-0src/CMakeLists.txt
M  +47   -25   src/FontDialog.cpp
M  +2-1src/FontDialog.h
M  +127  -23   src/Screen.cpp
M  +18   -5src/Screen.h
M  +28   -13   src/Vt102Emulation.cpp
M  +0-29   src/autotests/CharacterTest.cpp
M  +0-1src/autotests/CharacterTest.h
M  +1-1src/autotests/TerminalCharacterDecoderTest.cpp
M  +119  -29   src/characters/Character.h
M  +1-1src/characters/Hangul.cpp
M  +5-4src/decoders/HTMLDecoder.cpp
M  +1-1src/decoders/PlainTextDecoder.cpp
M  +3-0src/profile/Profile.cpp
M  +29   -0src/profile/Profile.h
M  +101  -6src/terminalDisplay/TerminalDisplay.cpp
M  +7-0src/terminalDisplay/TerminalDisplay.h
M  +42   -0src/terminalDisplay/TerminalFonts.cpp
M  +12   -0src/terminalDisplay/TerminalFonts.h
M  +542  -269  src/terminalDisplay/TerminalPainter.cpp
M  +40   -13   src/terminalDisplay/TerminalPainter.h
M  +2-0src/widgets/EditProfileAdvancedPage.ui
M  +113  -3src/widgets/EditProfileAppearancePage.ui
M  +61   -3src/widgets/EditProfileDialog.cpp
M  +6-1src/widgets/EditProfileDialog.h

https://invent.kde.org/utilities/konsole/commit/76f879cd70fb494ab2334d2660b34679546f3d9d

-- 
You are receiving this mail because:
You are watching all bug changes.

[konsole] [Bug 445846] "Bi-directional text rendering" should be renamed to something like "Support for complex scripts"

2022-08-06 Thread Bug Janitor Service
https://bugs.kde.org/show_bug.cgi?id=445846

--- Comment #8 from Bug Janitor Service  ---
A possibly relevant merge request was started @
https://invent.kde.org/utilities/konsole/-/merge_requests/722

-- 
You are receiving this mail because:
You are watching all bug changes.

[konsole] [Bug 445846] "Bi-directional text rendering" should be renamed to something like "Support for complex scripts"

2021-12-04 Thread Bug Janitor Service
https://bugs.kde.org/show_bug.cgi?id=445846

Bug Janitor Service  changed:

   What|Removed |Added

 Ever confirmed|0   |1
 Status|REPORTED|ASSIGNED

--- Comment #7 from Bug Janitor Service  ---
A possibly relevant merge request was started @
https://invent.kde.org/utilities/konsole/-/merge_requests/544

-- 
You are receiving this mail because:
You are watching all bug changes.

[konsole] [Bug 445846] "Bi-directional text rendering" should be renamed to something like "Support for complex scripts"

2021-11-30 Thread Ahmad Samir
https://bugs.kde.org/show_bug.cgi?id=445846

--- Comment #6 from Ahmad Samir  ---
Well, if it's a choice between UI text being clear or short, I vote clear;
ideally it should be both, but until someone has a better suggestion, we can go
with your text.

-- 
You are receiving this mail because:
You are watching all bug changes.

[konsole] [Bug 445846] "Bi-directional text rendering" should be renamed to something like "Support for complex scripts"

2021-11-29 Thread bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=445846

--- Comment #5 from ninj...@gmail.com ---
Chinese doesn't need this setting, it just needs support for wide characters
(Unicode property East_Asian_Width), which take 2 cells. Urdu is a RTL
language.

So maybe something like "Support for complex scripts (Right to left languages,
Brahmic/Indic scripts, ...)"?

Currently, at src/widgets/EditProfileAdvancedPage.ui we have this:

  
   

 0
 0

   
   
Enable Bi-Directional display on terminals (valid for Arabic,
Farsi or Hebrew only)
   
   
Bi-Directional text rendering
   
  


Both the text and the tooltip need to be rewritten, and I can't think off-hand
of something short, concise and sufficiently clear to people without previous
knowledge of RTL and Indic text rendering.

BTW, the setting now does two things:
 - It enables RTL display by not putting a Left-to-Right Mark in front of text
to be rendered.
 - It allows rendering a run of text as a whole unit.

-- 
You are receiving this mail because:
You are watching all bug changes.

[konsole] [Bug 445846] "Bi-directional text rendering" should be renamed to something like "Support for complex scripts"

2021-11-24 Thread Duncan
https://bugs.kde.org/show_bug.cgi?id=445846

--- Comment #4 from Duncan <1i5t5.dun...@cox.net> ---
(In reply to Ahmad Samir from comment #3)
> To disambiguate, "Support for complex scripts (RTL, Chinese, Urdu ...etc)" ?

Works for me! =:^)

-- 
You are receiving this mail because:
You are watching all bug changes.

[konsole] [Bug 445846] "Bi-directional text rendering" should be renamed to something like "Support for complex scripts"

2021-11-23 Thread Ahmad Samir
https://bugs.kde.org/show_bug.cgi?id=445846

--- Comment #3 from Ahmad Samir  ---
To disambiguate, "Support for complex scripts (RTL, Chinese, Urdu ...etc)" ?

-- 
You are receiving this mail because:
You are watching all bug changes.

[konsole] [Bug 445846] "Bi-directional text rendering" should be renamed to something like "Support for complex scripts"

2021-11-22 Thread Duncan
https://bugs.kde.org/show_bug.cgi?id=445846

Duncan <1i5t5.dun...@cox.net> changed:

   What|Removed |Added

 CC||1i5t5.dun...@cox.net

--- Comment #2 from Duncan <1i5t5.dun...@cox.net> ---
"Support for complex scripts" doesn't work in konsole AKA terminal context
because there, many (most?) would think "scripts" refers to shell-scripts -- I
was browsing new bugs and was *very* confused seeing the bug title.

Would "complex fonts" be the correct term?  But that would get tangled up with
font choice.  Maybe "complex character rendering"?

-- 
You are receiving this mail because:
You are watching all bug changes.

[konsole] [Bug 445846] "Bi-directional text rendering" should be renamed to something like "Support for complex scripts"

2021-11-21 Thread Ahmad Samir
https://bugs.kde.org/show_bug.cgi?id=445846

Ahmad Samir  changed:

   What|Removed |Added

 CC||a.samir...@gmail.com

--- Comment #1 from Ahmad Samir  ---
IMHO, this makes sense.

-- 
You are receiving this mail because:
You are watching all bug changes.