Re: [PATCH 04/13] pci: New pci_dma_quirk()

2012-05-17 Thread Anonymous
Alex,

On Sat, May 12, 2012 at 6:55 AM, Alex Williamson
alex.william...@redhat.com wrote:
 Integrating IOMMU groups more closely into the driver core allows
 us to more easily work around DMA quirks.  The Ricoh multifunction
 controller is a favorite example of devices that are currently
 incompatible with IOMMU isolation as all the functions use the
 requestor ID of function 0 for DMA.  Passing this device into
 pci_dma_quirk returns the PCI device to use for DMA.  The IOMMU
 driver can then construct an IOMMU group including both devices.


Please give some thought to the Marvell SATA controller quirk as well.

Instead of multiple visible functions using the same requester ID of
function 0, the Marvell device only makes function 0 visible, but uses
the requestor ID of function 1 as well during DMA.

See https://bugzilla.redhat.com/show_bug.cgi?id=757166

--
A.
--
To unsubscribe from this list: send the line unsubscribe kvm in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 04/13] pci: New pci_dma_quirk()

2012-05-17 Thread Alex Williamson
On Thu, 2012-05-17 at 15:19 +0800, Anonymous wrote:
 Alex,
 
 On Sat, May 12, 2012 at 6:55 AM, Alex Williamson
 alex.william...@redhat.com wrote:
  Integrating IOMMU groups more closely into the driver core allows
  us to more easily work around DMA quirks.  The Ricoh multifunction
  controller is a favorite example of devices that are currently
  incompatible with IOMMU isolation as all the functions use the
  requestor ID of function 0 for DMA.  Passing this device into
  pci_dma_quirk returns the PCI device to use for DMA.  The IOMMU
  driver can then construct an IOMMU group including both devices.
 
 
 Please give some thought to the Marvell SATA controller quirk as well.
 
 Instead of multiple visible functions using the same requester ID of
 function 0, the Marvell device only makes function 0 visible, but uses
 the requestor ID of function 1 as well during DMA.
 
 See https://bugzilla.redhat.com/show_bug.cgi?id=757166

Wow.  That one isn't quite as easy to deal with since there's no
existing device in the kernel to point to.  This comment might be on the
right track:

https://bugzilla.kernel.org/show_bug.cgi?id=42679#c11

Perhaps David Woodhouse can comment on support for phantom functions.
If we had infrastructure for that it might be easy for the quirk to
update the pci_dev struct, inserting a new phantom function.  Otherwise
we'd need to create a new device in the kernel for it.  Thanks,

Alex


--
To unsubscribe from this list: send the line unsubscribe kvm in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 04/13] pci: New pci_dma_quirk()

2012-05-16 Thread David Gibson
On Fri, May 11, 2012 at 04:55:55PM -0600, Alex Williamson wrote:
 Integrating IOMMU groups more closely into the driver core allows
 us to more easily work around DMA quirks.  The Ricoh multifunction
 controller is a favorite example of devices that are currently
 incompatible with IOMMU isolation as all the functions use the
 requestor ID of function 0 for DMA.  Passing this device into
 pci_dma_quirk returns the PCI device to use for DMA.  The IOMMU
 driver can then construct an IOMMU group including both devices.
 
 Signed-off-by: Alex Williamson alex.william...@redhat.com
 ---
 
  drivers/pci/quirks.c |   22 ++
  include/linux/pci.h  |2 ++
  2 files changed, 24 insertions(+), 0 deletions(-)
 
 diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
 index 4bf7102..6f9f7f9 100644
 --- a/drivers/pci/quirks.c
 +++ b/drivers/pci/quirks.c
 @@ -3109,3 +3109,25 @@ int pci_dev_specific_reset(struct pci_dev *dev, int 
 probe)
  
   return -ENOTTY;
  }
 +
 +struct pci_dev *pci_dma_quirk(struct pci_dev *dev)
 +{
 + struct pci_dev *dma_dev = dev;
 +
 + /*
 +  * https://bugzilla.redhat.com/show_bug.cgi?id=605888
 +  *
 +  * Some Ricoh devices use the function 0 source ID for DMA on
 +  * other functions of a multifunction device.  The DMA devices
 +  * is therefore function 0, which will have implications of the
 +  * iommu grouping of these devices.
 +  */
 + if (dev-vendor == PCI_VENDOR_ID_RICOH 
 + (dev-device == 0xe822 || dev-device == 0xe230 ||
 +  dev-device == 0xe832 || dev-device == 0xe476)) {
 + dma_dev = pci_get_slot(dev-bus,
 +PCI_DEVFN(PCI_SLOT(dev-devfn), 0));
 + }

Hrm.  This seems like a very generic name for a function performing a
very specific test.  We could well have devices with the same problem
in future, so shouldn't this be set up so the same quirk can be easily
added to new device ids without changing the function code itself.

-- 
David Gibson| I'll have my music baroque, and my code
david AT gibson.dropbear.id.au  | minimalist, thank you.  NOT _the_ _other_
| _way_ _around_!
http://www.ozlabs.org/~dgibson
--
To unsubscribe from this list: send the line unsubscribe kvm in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 04/13] pci: New pci_dma_quirk()

2012-05-16 Thread Alex Williamson
On Thu, 2012-05-17 at 13:39 +1000, David Gibson wrote:
 On Fri, May 11, 2012 at 04:55:55PM -0600, Alex Williamson wrote:
  Integrating IOMMU groups more closely into the driver core allows
  us to more easily work around DMA quirks.  The Ricoh multifunction
  controller is a favorite example of devices that are currently
  incompatible with IOMMU isolation as all the functions use the
  requestor ID of function 0 for DMA.  Passing this device into
  pci_dma_quirk returns the PCI device to use for DMA.  The IOMMU
  driver can then construct an IOMMU group including both devices.
  
  Signed-off-by: Alex Williamson alex.william...@redhat.com
  ---
  
   drivers/pci/quirks.c |   22 ++
   include/linux/pci.h  |2 ++
   2 files changed, 24 insertions(+), 0 deletions(-)
  
  diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
  index 4bf7102..6f9f7f9 100644
  --- a/drivers/pci/quirks.c
  +++ b/drivers/pci/quirks.c
  @@ -3109,3 +3109,25 @@ int pci_dev_specific_reset(struct pci_dev *dev, int 
  probe)
   
  return -ENOTTY;
   }
  +
  +struct pci_dev *pci_dma_quirk(struct pci_dev *dev)
  +{
  +   struct pci_dev *dma_dev = dev;
  +
  +   /*
  +* https://bugzilla.redhat.com/show_bug.cgi?id=605888
  +*
  +* Some Ricoh devices use the function 0 source ID for DMA on
  +* other functions of a multifunction device.  The DMA devices
  +* is therefore function 0, which will have implications of the
  +* iommu grouping of these devices.
  +*/
  +   if (dev-vendor == PCI_VENDOR_ID_RICOH 
  +   (dev-device == 0xe822 || dev-device == 0xe230 ||
  +dev-device == 0xe832 || dev-device == 0xe476)) {
  +   dma_dev = pci_get_slot(dev-bus,
  +  PCI_DEVFN(PCI_SLOT(dev-devfn), 0));
  +   }
 
 Hrm.  This seems like a very generic name for a function performing a
 very specific test.  We could well have devices with the same problem
 in future, so shouldn't this be set up so the same quirk can be easily
 added to new device ids without changing the function code itself.

I've since added a USB quirk here to group all the USB functions in a
slot.  I'll take a closer look at the quirk helpers to see if anything
makes this easier, but I didn't see much point in spending a lot of time
over-optimizing this for 1 or 2 quirks that we can just step through in
a monolithic function.  Thanks,

Alex

--
To unsubscribe from this list: send the line unsubscribe kvm in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html