On Fri, Jun 21, 2019 at 10:37:53AM +0100, Marc Zyngier wrote: > From: Christoffer Dall <christoffer.d...@arm.com> > > When running a nested hypervisor we commonly have to figure out if > the VCPU mode is running in the context of a guest hypervisor or guest > guest, or just a normal guest. > > Add convenient primitives for this. > > Signed-off-by: Christoffer Dall <christoffer.d...@arm.com> > Signed-off-by: Marc Zyngier <marc.zyng...@arm.com> > --- > arch/arm64/include/asm/kvm_emulate.h | 55 ++++++++++++++++++++++++++++ > 1 file changed, 55 insertions(+) > > diff --git a/arch/arm64/include/asm/kvm_emulate.h > b/arch/arm64/include/asm/kvm_emulate.h > index 39ffe41855bc..8f201ea56f6e 100644 > --- a/arch/arm64/include/asm/kvm_emulate.h > +++ b/arch/arm64/include/asm/kvm_emulate.h > @@ -191,6 +191,61 @@ static inline void vcpu_set_reg(struct kvm_vcpu *vcpu, > u8 reg_num, > vcpu_gp_regs(vcpu)->regs.regs[reg_num] = val; > } > > +static inline bool vcpu_mode_el2_ctxt(const struct kvm_cpu_context *ctxt) > +{ > + unsigned long cpsr = ctxt->gp_regs.regs.pstate; > + u32 mode; > + > + if (cpsr & PSR_MODE32_BIT) > + return false; > + > + mode = cpsr & PSR_MODE_MASK; > + > + return mode == PSR_MODE_EL2h || mode == PSR_MODE_EL2t;
We could also treat PSR_MODE32_BIT and PSR_MODE_MASK as a single field, similarly as in the next patch, say: switch (ctxt->gp_regs.regs.pstate & (PSR_MODE32_BIT | PSR_MODE_MASK)) { case PSR_MODE_EL2h: case PSR_MODE_EL2t: return true; } return false; (This is blatant bikeshedding...) [...] Cheers ---Dave _______________________________________________ kvmarm mailing list kvmarm@lists.cs.columbia.edu https://lists.cs.columbia.edu/mailman/listinfo/kvmarm