Re: [PATCH]fdo#52636:VIEWING: unintuitive Heading for 'Enable experimental Features

2012-08-08 Thread Joel Madero
3rd try is a charm? Thanks for that fix regarding the size of the space 
between the options - that was creating a snag for me and I couldn't 
figure it out. Again, feel free to comment.



Joel


On 08/06/2012 11:28 AM, Ivan Timofeev wrote:

Hi Joel,

On 02.08.2012 21:57, Joel Madero wrote:

Here is an updated patch.


not that it is essential, but it is good if the commit message is 
wrapped so that it does not exceed a reasonable width (say 70-80 
characters). (Yes, my e-mail client seems unable to do that, ugh.)



 Please enter the commit message for your changes. Lines starting
 with '#' will be ignored, and an empty message aborts the commit.


Something wrong with your editor? These lines should start with '#' 
and be ignored, why they are in the commit message again?



Text [ en-US ] = Optional features ;


uhm, IMHO optional means not necessary in most cases, but sometimes 
might be helpful. So a user would think Ok, let's enable all these, 
won't hurt anyway. But this features aren't stable and somewhat 
dangerous to enable, and



-Text [ en-US ] = Enable experimental (unstable) features;
+Text [ en-US ] = Enable experimental features;


makes it sound even more safe. Maybe Unstable features as a header 
then?


Another nit-picking:
you placed two labels in one row, not good IMHO: consider long 
translations. But then the last row could go out of the visible area, 
it would be great to check that - play with #define ROW.. constants in

optgdlg.hrc, remove my ugly +6 in ROW14 etc... :)

Thanks!

Ivan


From fea8e91665e2b9e52f004514a796f01c13bf81d0 Mon Sep 17 00:00:00 2001
From: Joel Madero jmadero@gmail.com
Date: Wed, 8 Aug 2012 17:04:09 -0700
Subject: [PATCH] Addition of linear divider and header Optional (unstable)
 Features

Put two experimental options (Experimental  Macro Recording) below
a linear divider with the header of Optional (Unstable) Features
Had to adjust distance between two options in order for them to fit
properly in the dialog.

Change-Id: I784f99c282d5b70e7e025b1ca05a7c8d73869cef
---
 cui/source/options/optgdlg.cxx |7 ---
 cui/source/options/optgdlg.hrc |6 --
 cui/source/options/optgdlg.hxx |1 +
 cui/source/options/optgdlg.src |   14 ++
 4 files changed, 19 insertions(+), 9 deletions(-)

diff --git a/cui/source/options/optgdlg.cxx b/cui/source/options/optgdlg.cxx
index 8800e11..4f83368 100644
--- a/cui/source/options/optgdlg.cxx
+++ b/cui/source/options/optgdlg.cxx
@@ -213,6 +213,7 @@ OfaMiscTabPage::OfaMiscTabPage(Window* pParent, const SfxItemSet rSet ) :
 aInterpretFT( this, CUI_RES( FT_INTERPRET ) ),
 aYearValueField ( this, CUI_RES( NF_YEARVALUE ) ),
 aToYearFT   ( this, CUI_RES( FT_TOYEAR ) ),
+aExperimentalFL ( this, CUI_RES( FL_EXPERIMENTAL ) ),
 aExperimentalCB ( this, CUI_RES( CB_EXPERIMENTAL ) ),
 aMacroRecorderCB( this, CUI_RES( CB_MACRORECORDER ) )
 {
@@ -244,7 +245,7 @@ OfaMiscTabPage::OfaMiscTabPage(Window* pParent, const SfxItemSet rSet ) :
 Window* pWins[] =
 {
 aPrintDlgFL, aPrintDlgCB, aDocStatusFL, aDocStatusCB, aSaveAlwaysCB,
-aTwoFigureFL, aInterpretFT, aYearValueField, aToYearFT, aExperimentalCB, aMacroRecorderCB
+aTwoFigureFL, aInterpretFT, aYearValueField, aToYearFT, aExperimentalFL, aExperimentalCB, aMacroRecorderCB
 };
 Window** pCurrent = pWins;
 const sal_Int32 nCount = SAL_N_ELEMENTS( pWins );
@@ -265,7 +266,7 @@ OfaMiscTabPage::OfaMiscTabPage(Window* pParent, const SfxItemSet rSet ) :
 Window* pWins[] =
 {
 aPrintDlgFL, aPrintDlgCB, aDocStatusFL, aDocStatusCB, aSaveAlwaysCB,
-aTwoFigureFL, aInterpretFT, aYearValueField, aToYearFT, aExperimentalCB, aMacroRecorderCB
+aTwoFigureFL, aInterpretFT, aYearValueField, aToYearFT, aExperimentalFL, aExperimentalCB, aMacroRecorderCB
 };
 Window** pCurrent = pWins;
 const sal_Int32 nCount = SAL_N_ELEMENTS( pWins );
@@ -291,7 +292,7 @@ OfaMiscTabPage::OfaMiscTabPage(Window* pParent, const SfxItemSet rSet ) :
 Window* pWins[] =
 {
 aDocStatusFL, aDocStatusCB, aSaveAlwaysCB, aTwoFigureFL,
-aInterpretFT, aYearValueField, aToYearFT, aExperimentalCB, aMacroRecorderCB
+aInterpretFT, aYearValueField, aToYearFT, aExperimentalFL, aExperimentalCB, aMacroRecorderCB
 };
 Window** pCurrent = pWins;
 const sal_Int32 nCount = SAL_N_ELEMENTS( pWins );
diff --git a/cui/source/options/optgdlg.hrc b/cui/source/options/optgdlg.hrc
index 9be9051..2bf4343 100644
--- a/cui/source/options/optgdlg.hrc
+++ b/cui/source/options/optgdlg.hrc
@@ -51,6 +51,7 @@
 #define ROW13   (ROW12+RSC_CD_FIXEDLINE_HEIGHT+ROWSPACE)
 #define ROW14   (ROW13+RSC_CD_CHECKBOX_HEIGHT+ROWSPACE+6)
 #define ROW15   (ROW14+RSC_CD_CHECKBOX_HEIGHT+ROWSPACE)
+#define ROW16

Re: [PATCH]fdo#52636:VIEWING: unintuitive Heading for 'Enable experimental Features

2012-08-07 Thread Ivan Timofeev

On 07.08.2012 00:57, Joel Madero wrote:

I'll take care of these issues. I put 2 in one row because there is a
limit as to how many rows can be in the general tab and we've hit that
limit :-/


Hmm, what limit? =) See the attached diff (no ROWSPACE between row15 and 
row16 to keep it inside the visible area).


Best regards,
Ivan

diff --git a/cui/source/options/optgdlg.hrc b/cui/source/options/optgdlg.hrc
index f31ad53..a5436cb 100644
--- a/cui/source/options/optgdlg.hrc
+++ b/cui/source/options/optgdlg.hrc
@@ -49,8 +49,9 @@
 #define ROW11   (ROW10+RSC_CD_CHECKBOX_HEIGHT+ROWSPACE)
 #define ROW12   (ROW11+RSC_CD_CHECKBOX_HEIGHT+ROWSPACE)
 #define ROW13   (ROW12+RSC_CD_FIXEDLINE_HEIGHT+ROWSPACE)
-#define ROW14   (ROW13+RSC_CD_CHECKBOX_HEIGHT+ROWSPACE+6)
-#define ROW15   (ROW14+RSC_CD_CHECKBOX_HEIGHT+ROWSPACE)
+#define ROW14   (ROW13+RSC_CD_TEXTBOX_HEIGHT+ROWSPACE)
+#define ROW15   (ROW14+RSC_CD_FIXEDLINE_HEIGHT+ROWSPACE)
+#define ROW16   (ROW15+RSC_CD_CHECKBOX_HEIGHT)
 
 #define DIFF(v1,v2) (v2-v1)
 #define OFFS_TEXTBOX_FIXEDTEXT(base)(base+(RSC_CD_TEXTBOX_HEIGHT-RSC_CD_FIXEDTEXT_HEIGHT)/2)
diff --git a/cui/source/options/optgdlg.src b/cui/source/options/optgdlg.src
index f326d4b..9c7e9ad 100644
--- a/cui/source/options/optgdlg.src
+++ b/cui/source/options/optgdlg.src
@@ -175,7 +175,7 @@ TabPage OFA_TP_MISC
 };
 CheckBox CB_MACRORECORDER
 {
-Pos = MAP_APPFONT( COL3, ROW15 );
+Pos = MAP_APPFONT( COL1, ROW16 );
 Size = MAP_APPFONT( WHOLE_WIDTH - COL1, RSC_CD_CHECKBOX_HEIGHT );
 Text [ en-US ] = Enable macro recording;
 };
___
LibreOffice mailing list
LibreOffice@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/libreoffice


Re: [PATCH]fdo#52636:VIEWING: unintuitive Heading for 'Enable experimental Features

2012-08-06 Thread Ivan Timofeev

Hi Joel,

On 02.08.2012 21:57, Joel Madero wrote:

Here is an updated patch.


not that it is essential, but it is good if the commit message is 
wrapped so that it does not exceed a reasonable width (say 70-80 
characters). (Yes, my e-mail client seems unable to do that, ugh.)



 Please enter the commit message for your changes. Lines starting
 with '#' will be ignored, and an empty message aborts the commit.


Something wrong with your editor? These lines should start with '#' and 
be ignored, why they are in the commit message again?



Text [ en-US ] = Optional features ;


uhm, IMHO optional means not necessary in most cases, but sometimes 
might be helpful. So a user would think Ok, let's enable all these, 
won't hurt anyway. But this features aren't stable and somewhat 
dangerous to enable, and



-Text [ en-US ] = Enable experimental (unstable) features;
+Text [ en-US ] = Enable experimental features;


makes it sound even more safe. Maybe Unstable features as a header then?

Another nit-picking:
you placed two labels in one row, not good IMHO: consider long 
translations. But then the last row could go out of the visible area, it 
would be great to check that - play with #define ROW.. constants in

optgdlg.hrc, remove my ugly +6 in ROW14 etc... :)

Thanks!

Ivan
___
LibreOffice mailing list
LibreOffice@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/libreoffice


Re: [PATCH]fdo#52636:VIEWING: unintuitive Heading for 'Enable experimental Features

2012-08-06 Thread Joel Madero
I'll take care of these issues. I put 2 in one row because there is a limit
as to how many rows can be in the general tab and we've hit that limit :-/
I'm not sure how that is being handled or if we want to increase the # but
if I increase the row by one it shoots out an error for me. Let me know how
to proceed, I'll deal with the other two issues as soon as possible. Thanks
for the comments

Joel

On Mon, Aug 6, 2012 at 11:28 AM, Ivan Timofeev timofeev@gmail.comwrote:

 Hi Joel,


 On 02.08.2012 21:57, Joel Madero wrote:

 Here is an updated patch.


 not that it is essential, but it is good if the commit message is wrapped
 so that it does not exceed a reasonable width (say 70-80 characters). (Yes,
 my e-mail client seems unable to do that, ugh.)

   Please enter the commit message for your changes. Lines starting
  with '#' will be ignored, and an empty message aborts the commit.


 Something wrong with your editor? These lines should start with '#' and be
 ignored, why they are in the commit message again?

  Text [ en-US ] = Optional features ;


 uhm, IMHO optional means not necessary in most cases, but sometimes
 might be helpful. So a user would think Ok, let's enable all these, won't
 hurt anyway. But this features aren't stable and somewhat dangerous to
 enable, and

  -Text [ en-US ] = Enable experimental (unstable) features;
 +Text [ en-US ] = Enable experimental features;


 makes it sound even more safe. Maybe Unstable features as a header then?

 Another nit-picking:
 you placed two labels in one row, not good IMHO: consider long
 translations. But then the last row could go out of the visible area, it
 would be great to check that - play with #define ROW.. constants in
 optgdlg.hrc, remove my ugly +6 in ROW14 etc... :)

 Thanks!

 Ivan

___
LibreOffice mailing list
LibreOffice@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/libreoffice


Re: [PATCH]fdo#52636:VIEWING: unintuitive Heading for 'Enable experimental Features

2012-08-03 Thread Stephan Bergmann

On 08/02/2012 07:57 PM, Joel Madero wrote:

Here is an updated patch. Also here is a link for everyone to see what
we could make Java tab look like:

https://lh5.googleusercontent.com/-lzTcvXoWhOw/UBq_VGFqL2I/ACc/TnxVpfV5WL0/s937/Advanced_Options.jpg

Notes:
1. Changed name to Advanced
2. Shrunk Java dialog box
3. Added bottom section for experimental features


Which reminds me of the long-standing issue that the Java tab's list of 
already installed JREs is assembled synchronously, blocking the dialog 
during that time (which might be more or less noticeable depending on 
the environment specifics).  That might make it undesirable to combine 
that tab's content with other stuff, for technical reasons.


Stephan

___
LibreOffice mailing list
LibreOffice@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/libreoffice


Re: [PATCH]fdo#52636:VIEWING: unintuitive Heading for 'Enable experimental Features

2012-08-02 Thread Stefan Knorr
Hi Joel,

On Wed, 2012-08-01 at 13:53 -0700, Joel Madero wrote:
 I'll fix both. I'll leave limited since it fits, I actually noticed
 that right after I sent out the email.

What does that limited mean, can I ask? I can't really make that out.


 I'll be moving a lot of stuff around when I move the measurement unit
 to the general tree, maybe a good solution is moving the experimental
 stuff to its own tab.

Well, the Java panel is quite empty (or at least its space isn't used
very well). Renaming that to Advanced and putting the experiments
section there might be viable.

Astron.


___
LibreOffice mailing list
LibreOffice@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/libreoffice


Re: [PATCH]fdo#52636:VIEWING: unintuitive Heading for 'Enable experimental Features

2012-08-02 Thread Joel Madero
Perfect idea! I'm going to go ahead and work on that. I will take out
limited (I have no clue what it means either, I figured someone else must
have known when they added it ;)).

I have a quick question though. What's the best way to modify a patch? The
only way I know how is to go back to dismiss my changes and start from
scratch. I'm sure there is a better way that I don't know of. Is it to
directly modify the patch file in an editor or is there a way for me to
edit the cxx/hxx/etc...files and then add/modify the patch using some git
command? Thanks for the input


Joel

On Thu, Aug 2, 2012 at 12:45 AM, Stefan Knorr heinzless...@gmail.comwrote:

 Hi Joel,

 On Wed, 2012-08-01 at 13:53 -0700, Joel Madero wrote:
  I'll fix both. I'll leave limited since it fits, I actually noticed
  that right after I sent out the email.

 What does that limited mean, can I ask? I can't really make that out.


  I'll be moving a lot of stuff around when I move the measurement unit
  to the general tree, maybe a good solution is moving the experimental
  stuff to its own tab.

 Well, the Java panel is quite empty (or at least its space isn't used
 very well). Renaming that to Advanced and putting the experiments
 section there might be viable.

 Astron.



___
LibreOffice mailing list
LibreOffice@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/libreoffice


Re: [PATCH]fdo#52636:VIEWING: unintuitive Heading for 'Enable experimental Features

2012-08-02 Thread Stefan Knorr
Hello there,

On Thu, 2012-08-02 at 08:14 -0700, Joel Madero wrote:
 Perfect idea! I'm going to go ahead and work on that. I will take out
 limited (I have no clue what it means either, I figured someone else
 must have known when they added it ;)).

Well, hopefully, I didn't sound overly assertive here.

 I have a quick question though. What's the best way to modify a patch?
 The only way I know how is to go back to dismiss my changes and start
 from scratch. I'm sure there is a better way that I don't know of.

So, I am by no means the git expert here (I still barely understand the
basics of it) but ... you probably still have the original patch
committed locally, (and if not, you can do
$ git am path/to.patch
), so, do all the modifications you want to do, then do the usual
$ git add .
$ git commit
At the end, you can just use
$ git rebase -i HEAD~2
to either squash (merge the commits and edit the commit message) or
fixup (just merge the commits) (assuming you had only your original
commit and the new one = HEAD~2).

Also: Note that you should only ever use rebase -i on local commits –
modifying the global commit history is evil. (It won't do any harm to
everyone else, if you don't have commit access, but still.)

Modifying the patch in a text editor can easily go wrong, so that's not
recommended.

Astron.

___
LibreOffice mailing list
LibreOffice@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/libreoffice


Re: [PATCH]fdo#52636:VIEWING: unintuitive Heading for 'Enable experimental Features

2012-08-02 Thread Joel Madero
Here is an updated patch. Also here is a link for everyone to see what we
could make Java tab look like:

https://lh5.googleusercontent.com/-lzTcvXoWhOw/UBq_VGFqL2I/ACc/TnxVpfV5WL0/s937/Advanced_Options.jpg

Notes:
1. Changed name to Advanced
2. Shrunk Java dialog box
3. Added bottom section for experimental features

This would clear up enough space in the general tab for me to move the
measurement units over.

I've cc'ed the ux team since this is now a visual thing also. Please
respond to the dev mailing list as I'll be pushing out a few patches
corresponding to these changes.



Joel

On Thu, Aug 2, 2012 at 11:29 AM, Stefan Knorr heinzless...@gmail.comwrote:

 Hello there,

 On Thu, 2012-08-02 at 08:14 -0700, Joel Madero wrote:
  Perfect idea! I'm going to go ahead and work on that. I will take out
  limited (I have no clue what it means either, I figured someone else
  must have known when they added it ;)).

 Well, hopefully, I didn't sound overly assertive here.

  I have a quick question though. What's the best way to modify a patch?
  The only way I know how is to go back to dismiss my changes and start
  from scratch. I'm sure there is a better way that I don't know of.

 So, I am by no means the git expert here (I still barely understand the
 basics of it) but ... you probably still have the original patch
 committed locally, (and if not, you can do
 $ git am path/to.patch
 ), so, do all the modifications you want to do, then do the usual
 $ git add .
 $ git commit
 At the end, you can just use
 $ git rebase -i HEAD~2
 to either squash (merge the commits and edit the commit message) or
 fixup (just merge the commits) (assuming you had only your original
 commit and the new one = HEAD~2).

 Also: Note that you should only ever use rebase -i on local commits –
 modifying the global commit history is evil. (It won't do any harm to
 everyone else, if you don't have commit access, but still.)

 Modifying the patch in a text editor can easily go wrong, so that's not
 recommended.

 Astron.




0001-fdo-52636-Added-Sectional-Line-and-Header-for-Experi.patch
Description: Binary data
___
LibreOffice mailing list
LibreOffice@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/libreoffice


Re: [PATCH]fdo#52636:VIEWING: unintuitive Heading for 'Enable experimental Features

2012-08-01 Thread Stefan Knorr
Hi Joel,

your idea sounds good [even though I think that if these features aren't
ready yet, they shouldn't be so prominent in the options – but that's a
fight for another day].

However, please have a look at your patch again, it leaves in the
(limited) and also changes the capitalisation to title case which we
don't for elements on dialogue boxes (only for menus and toolbars).

Astron.

___
LibreOffice mailing list
LibreOffice@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/libreoffice


Re: [PATCH]fdo#52636:VIEWING: unintuitive Heading for 'Enable experimental Features

2012-08-01 Thread Joel Madero
I'll fix both. I'll leave limited since it fits, I actually noticed that
right after I sent out the email.

I'll be moving a lot of stuff around when I move the measurement unit to
the general tree, maybe a good solution is moving the experimental stuff to
its own tab.


Joel

On Wed, Aug 1, 2012 at 3:48 PM, Stefan Knorr heinzless...@gmail.com wrote:

 Hi Joel,

 your idea sounds good [even though I think that if these features aren't
 ready yet, they shouldn't be so prominent in the options – but that's a
 fight for another day].

 However, please have a look at your patch again, it leaves in the
 (limited) and also changes the capitalisation to title case which we
 don't for elements on dialogue boxes (only for menus and toolbars).

 Astron.


___
LibreOffice mailing list
LibreOffice@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/libreoffice