[libvirt] [PATCH] vbox: fix typo in warning message

2017-08-11 Thread Guido Günther
---
 src/vbox/vbox_tmpl.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/vbox/vbox_tmpl.c b/src/vbox/vbox_tmpl.c
index 07f25ba24f..dffeabde02 100644
--- a/src/vbox/vbox_tmpl.c
+++ b/src/vbox/vbox_tmpl.c
@@ -1836,7 +1836,7 @@ _mediumCreateDiffStorage(IMedium *medium ATTRIBUTE_UNUSED,
 if (variantSize == 0)
 return 0;
 if (variantSize > 1)
-VIR_WARN("Only one variant is avaible in current version");
+VIR_WARN("Only one variant is available in current version");
 return medium->vtbl->CreateDiffStorage(medium, target, variant[0], 
progress);
 #else /* VBOX_API_VERSION >= 4003000 */
 return medium->vtbl->CreateDiffStorage(medium, target, variantSize, 
variant, progress);
-- 
2.14.0

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list


Re: [libvirt] [PATCH] apparmor, libvirt-qemu: Allow QEMU to gather information about available host resources.

2017-08-11 Thread Guido Günther
Hi,
On Tue, Aug 08, 2017 at 09:57:26PM +, intrigeri wrote:
> ---
>  examples/apparmor/libvirt-qemu | 6 ++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/examples/apparmor/libvirt-qemu b/examples/apparmor/libvirt-qemu
> index f462d7428c..dcfb1a5985 100644
> --- a/examples/apparmor/libvirt-qemu
> +++ b/examples/apparmor/libvirt-qemu
> @@ -169,3 +169,9 @@
>@{PROC}/device-tree/ r,
>@{PROC}/device-tree/** r,
>/sys/firmware/devicetree/** r,
> +
> +  # for gathering information about available host resources
> +  /sys/devices/system/cpu/ r,
> +  /sys/devices/system/node/ r,
> +  /sys/devices/system/node/node[0-9]*/meminfo r,
> +  /sys/module/vhost/parameters/max_mem_regions r,
> -- 

Pushed. Thanks. I'm still not used to adding the acked-by header. Will
do better next time.

Cheers,
 -- Guido

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list


Re: [libvirt] [PATCH] virt-aa-helper: locking disk files for qemu 2.10

2017-08-11 Thread intrigeri
Hi,

Christian Ehrhardt:
> With that qemu change in place the rules generated for the image
> and backing files need the allowance to also lock (k) the files.

I'm not a C developer so I cannot review the proposed patch, but FWIW
Christian's reasoning makes sense to me and from a high-level AppArmor
perspective, the proposed change seems entirely harmless.

Cheers,
-- 
intrigeri

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list


Re: [libvirt] [PATCH] m4: workaround clang/glibc problem with isnan()

2017-08-11 Thread Pavel Hrdina
On Fri, Aug 11, 2017 at 05:25:32PM +0100, Daniel P. Berrange wrote:
> When building libvirt with clang we get bogus warnings about
> 'double' being promoted to 'long double' when calling isnan().
> 
>   https://bugzilla.redhat.com/show_bug.cgi?id=1472437
> 
> Detect this broken isnan() / compiler combination and disable
> the -Wdouble-promotion flag.
> 
> Signed-off-by: Daniel P. Berrange 
> ---
>  m4/virt-compile-warnings.m4 | 18 ++
>  1 file changed, 18 insertions(+)

Reviewed-by: Pavel Hrdina 


signature.asc
Description: PGP signature
--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list

[libvirt] [PATCH] m4: workaround clang/glibc problem with isnan()

2017-08-11 Thread Daniel P. Berrange
When building libvirt with clang we get bogus warnings about
'double' being promoted to 'long double' when calling isnan().

  https://bugzilla.redhat.com/show_bug.cgi?id=1472437

Detect this broken isnan() / compiler combination and disable
the -Wdouble-promotion flag.

Signed-off-by: Daniel P. Berrange 
---
 m4/virt-compile-warnings.m4 | 18 ++
 1 file changed, 18 insertions(+)

diff --git a/m4/virt-compile-warnings.m4 b/m4/virt-compile-warnings.m4
index fa0940fc6..7b56115ce 100644
--- a/m4/virt-compile-warnings.m4
+++ b/m4/virt-compile-warnings.m4
@@ -134,6 +134,24 @@ AC_DEFUN([LIBVIRT_COMPILE_WARNINGS],[
 [lv_cv_gcc_wlogical_op_equal_expr_broken=yes])
 CFLAGS="$save_CFLAGS"])
 
+AC_CACHE_CHECK([whether clang gives bogus warnings for -Wdouble-promotion],
+  [lv_cv_clang_double_promotion_broken], [
+save_CFLAGS="$CFLAGS"
+CFLAGS="-O2 -Wdouble-promotion -Werror"
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+  #include 
+]], [[
+  float f = 0.0;
+ return isnan(f);]])],
+[lv_cv_clang_double_promotion_broken=no],
+[lv_cv_clang_double_promotion_broken=yes])
+CFLAGS="$save_CFLAGS"])
+
+if test "$lv_cv_clang_double_promotion_broken" = "yes";
+then
+  dontwarn="$dontwarn -Wdouble-promotion"
+fi
+
 # We might fundamentally need some of these disabled forever, but
 # ideally we'd turn many of them on
 dontwarn="$dontwarn -Wfloat-equal"
-- 
2.13.3

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list


Re: [libvirt] [PATCH 0/5] Random pre-CAT cleanups

2017-08-11 Thread Michal Privoznik
On 08/10/2017 03:31 PM, Martin Kletzander wrote:
> There are some patches that don't look related, but I found out they
> are messed up when working on previous versions that got discarded.
> Why not keep the cleanups, though, right?
> 
> Martin Kletzander (5):
>   virxml: Fix indentation
>   tests: Fix indentation in virfilewrapper.c
>   Move resctrl-related code from conf/capabilities to util/virresctrl
>   util: Make virResctrlGetCacheControlType() behave like other functions
>   util: Rename virResctrl to virResctrlInfo
> 
>  include/libvirt/virterror.h |   1 +
>  src/Makefile.am |   1 +
>  src/conf/capabilities.c | 144 +-
>  src/conf/capabilities.h |  26 +-
>  src/libvirt_private.syms|   7 ++
>  src/util/virerror.c |   1 +
>  src/util/virresctrl.c   | 187 
> 
>  src/util/virresctrl.h   |  63 +++
>  src/util/virxml.c   |  34 
>  tests/virfilewrapper.c  |   4 +-
>  10 files changed, 302 insertions(+), 166 deletions(-)
>  create mode 100644 src/util/virresctrl.c
>  create mode 100644 src/util/virresctrl.h
> 


ACK series.

Michal

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list


Re: [libvirt] [PATCH v2 0/7] properly deal with multiple netdevs on a single PF (i.e. Mellanox dual port NICS)

2017-08-11 Thread Michal Privoznik
On 08/11/2017 03:42 AM, Laine Stump wrote:
> I had already sent 3 patches to properly support macvtap passthrough
> of both ports of a dual port VF, and those patches were ACKed by
> Michal:
> 
>   https://www.redhat.com/archives/libvir-list/2017-August/msg00170.html
> 
> When Michal sent the ACK, I was already working on a V2 that updated
> Patch 2 (now Patch 3), and added on some more patches in order to
> properly support VFIO device assignment of VFs on these cards (but
> only if they've been setup in single port mode). A scorecard:
> 
>Patch 1 - same as V1, already ACKed
>Patch 2 - NEW trivial patch to make an arg of a function const
>Patch 3 - update virPCIGetNetName() - improved from V1
>Patch 4 - match phys_port_id, slightly modified from V1 due to change
>  in virPCIGetNetName in new Patch 3.
>Patch 5 - NEW save/set/restore using correct PF netdev during vfio
>Patch 6 - NEW eliminate bogus error logs when trying to read saved net 
> config
>Patch 7 - NEW fix checking of PF online status for dual port cards
> 
> Here's the original cover letter blurb:
> 
> The commit log of Patch 1 explains the majority of the reason for
> these patches. In short, they disambiguate the multiple netdevs per
> PCI device on the SRIOV PF and VFs of a Mellanox dual port NIC *when
> converting from a VF netdev to a PF netdev and vice versa*. This
> permits us to set the vlan tag and MAC address for the correct VF
> netdev (and detect the online status of the correct PF netdev for that
> VF) when using a VF in macvtap passthrough mode. (in other words, with
> these patches in place, it is possible to use *all* the VF netdevs on
> both ports of a dual port mellanox NIC for macvtap passthrough.)
> 
> These patches *do not* solve the problem of saving/setting the mac
> address/vlan tag for *both* ports when using a dual port VF for PCI
> device assignment with VFIO (see my RFC email from last week). Since I
> learned from responses to the RFC that these "dual netdevs on a single
> PCI PF/VF" cards are legacy, and all new Mellanox products have only
> one netdev per PF/VF (like all the other SRIOV NICs on the market),
> I've decided that it's not worth cluttering up libvirt's XML with
> config for a dying breed. Since it's possible to support VFIO device
> assignment on those cards when the VFs are in single port mode, I
> think it is worthwhile to make that work, so that owners of the older
> cards can get maximum value from their investment.
> 
> 
> 
> 
> Laine Stump (7):
>   util: new function virNetDevGetPhysPortID()
>   util: Fix const'ness of 1st arg to virPCIGetNetName()
>   util: make virPCIGetNetName() more versatile
>   util: match phys_port_id when converting PF-netdev to/from VF-netdev
>   util: save the correct VF's info when using a dual port SRIOV NIC in
> single port mode
>   util: restructure virNetDevReadNetConfig() to eliminate false error
> logs
>   util: check for PF online status earlier in guest startup
> 
>  src/libvirt_private.syms|   1 +
>  src/util/virhostdev.c   | 137 ++
>  src/util/virnetdev.c| 159 
> ++--
>  src/util/virnetdev.h|   5 ++
>  src/util/virnetdevmacvlan.c |   5 +-
>  src/util/virpci.c   |  97 +++
>  src/util/virpci.h   |   9 ++-
>  7 files changed, 316 insertions(+), 97 deletions(-)
> 

Unfortunately, I don't have a machine to test this, but the code looks
good. Therefore you have my ACK.

Michal

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list