[libvirt] [PATCH 2/2] guestfwd code tidy up

2009-11-13 Thread Matthew Booth
This patch removes qemudBuildCommandLineChrDevTargetStr and inlines its single
use. It was intended to be generic, but on reflection this can't work. Instead
it just makes the code slightly harder to read.

* src/qemu/qemu_conf.c: Remove and inline qemudBuildCommandLineChrDevTargetStr
---
 src/qemu/qemu_conf.c |   32 
 1 files changed, 8 insertions(+), 24 deletions(-)

diff --git a/src/qemu/qemu_conf.c b/src/qemu/qemu_conf.c
index 62b42fe..c807688 100644
--- a/src/qemu/qemu_conf.c
+++ b/src/qemu/qemu_conf.c
@@ -1495,29 +1495,6 @@ static void 
qemudBuildCommandLineChrDevChardevStr(virDomainChrDefPtr dev,
 }
 }
 
-static int qemudBuildCommandLineChrDevTargetStr(virDomainChrDefPtr dev,
-const char *const id,
-virBufferPtr buf)
-{
-int ret = 0;
-const char *addr = NULL;
-
-int port;
-switch (dev-targetType) {
-case VIR_DOMAIN_CHR_TARGET_TYPE_GUESTFWD:
-addr = virSocketFormatAddr(dev-target.addr);
-port = virSocketGetPort(dev-target.addr);
-
-virBufferVSprintf(buf, user,guestfwd=tcp:%s:%i-chardev:%s,
-  addr, port, id);
-
-VIR_FREE(addr);
-break;
-}
-
-return ret;
-}
-
 static void qemudBuildCommandLineChrDevStr(virDomainChrDefPtr dev,
virBufferPtr buf)
 {
@@ -2205,7 +2182,14 @@ int qemudBuildCommandLine(virConnectPtr conn,
 ADD_ARG_LIT(-chardev);
 ADD_ARG(virBufferContentAndReset(buf));
 
-qemudBuildCommandLineChrDevTargetStr(channel, id, buf);
+const char *addr = virSocketFormatAddr(channel-target.addr);
+int port = virSocketGetPort(channel-target.addr);
+
+virBufferVSprintf(buf, user,guestfwd=tcp:%s:%i-chardev:%s,
+  addr, port, id);
+
+VIR_FREE(addr);
+
 if (virBufferError(buf))
 goto error;
 
-- 
1.6.2.5

--
Libvir-list mailing list
Libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list


Re: [libvirt] [PATCH 2/2] guestfwd code tidy up

2009-11-13 Thread Daniel Veillard
On Fri, Nov 13, 2009 at 12:42:12PM +, Matthew Booth wrote:
 This patch removes qemudBuildCommandLineChrDevTargetStr and inlines its single
 use. It was intended to be generic, but on reflection this can't work. Instead
 it just makes the code slightly harder to read.
 
 * src/qemu/qemu_conf.c: Remove and inline qemudBuildCommandLineChrDevTargetStr
 ---
  src/qemu/qemu_conf.c |   32 
  1 files changed, 8 insertions(+), 24 deletions(-)

  Okay, I have applied and pushed the 2 cleanup patches,

   thanks !

Daniel

-- 
Daniel Veillard  | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
dan...@veillard.com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/

--
Libvir-list mailing list
Libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list