make web fails for LilyPond 2.8.0/2.9.0 source drop [Also] Re: Futile attempts to build LilyPond 2.8.0

2006-04-01 Thread R. Mattes
On Thu, 30 Mar 2006 21:15:57 +0200, R. Mattes wrote:

 Ok, I've almost been able to build LilyPond 2.6.0
 ex fontes on our Debian/Ubuntu Package builder 
 using a pbuilder environment (read: strict building 
 in a clean and well-defined build environment).
 Unfortunately the package build process stops with
 the following error message (slightly shortened where
 indicated):
 

Ok, i found the bug. It looks like this is triggered
by using guile-1.6.n instead of guile-1.8 - this also
explains why Andreas' build failed. The distributed binary
ships with guile-1.8.
Hmm, i thought the n.8-Branch was supposed to be stable?

 Cheers, Ralf Mattes




___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


Re: al niente / de niente - was Re: (no subject)

2006-04-01 Thread Trevor Bača
On 4/1/06, Erlend Aasland [EMAIL PROTECTED] wrote:
 Hi Trevor, and thanks for the scans! I did some work last night, and a new
 and better patch is attached.

 I've renamed the property to circled-tip. Height and thickness is now read
 from the hairpin properties. The width of the hairpin is now modified when
 circled tips are used. I also use a circle drawing routine now (instead of
 the hack in the previous patch).

Hi Erlend,

Cool :-) If Han-Wen likes the patch then I'll use 2.9.2 to typeset an
example or two for the NEWS (and, eventually, for the 3.0 manual!).

Really cool of you to cook up the code; I'll actually be using the
setting in my current piece.



--
Trevor Bača
[EMAIL PROTECTED]
___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


More improvements to PostScript backend

2006-04-01 Thread David Feuer
In my nonexistent free time I've done some more work.  I'd really like
to do something about the compulsive gsave x y translate 0 0 moveto
grestore wrapping that everything gets.  Could someone give me an idea
of what could get stuffed into placebox?  Is there actually some kind
of global graphics state that we need to maintain as a default?  It
looks like pretty much everything sets all the variables it cares
about.  I'd like to change all the drawing procedures to draw at the
current point.  If they want to translate to make their lives easier
they should clean up after themselves.  Then the box wrapper becomes
simply x y moveto, and we don't have to waste our time pushing and
popping graphics states for no reason.  By the way, in the future,
should I include patches inline or attach them?  This time I did both.
 The attached one is less likely to have line wrapping problems.  This
patch is against the versions in CVS.

Changelog:

* Cleaned up PostScript code

* Cleaned up interfaces between PostScript and Scheme

* Moved computations from PostScript to Scheme

* Rewrote glyph-string: it should now be much easier to read and edit.

* Removed apparently-unused draw_box (note: if something actually uses this,
  it should be implemented using draw_round_box, rather than
duplicating all the code.)

* Removed print_letter (print_glyphs is now simple enough not to need a helper)

David Feuer


diff -u --strip-trailing-cr original/framework-ps.scm latest/framework-ps.scm
--- original/framework-ps.scm   2006-04-01 11:57:18.109097600 -0500
+++ latest/framework-ps.scm 2006-04-01 11:32:15.448377600 -0500
@@ -43,9 +43,6 @@
   (define (define-font command fontname scaling)
 (string-append
   / command  { / fontname   (ly:number-string scaling) 
output-scale div selectfont } bind def\n))
-;(string-append
-; / command  { / fontname  findfont 
-; (ly:number-string scaling)  output-scale div scalefont } bind def\n))

   (define (standard-tex-font? x)
 (or (equal? (substring x 0 2) ms)
diff -u --strip-trailing-cr original/lilyponddefs.ps latest/lilyponddefs.ps
--- original/lilyponddefs.ps2006-04-01 11:57:18.109097600 -0500
+++ latest/lilyponddefs.ps  2006-04-01 11:26:32.515264000 -0500
@@ -11,8 +11,7 @@


 /set-ps-scale-to-lily-scale {
-   lily-output-units output-scale mul
-   lily-output-units output-scale mul scale
+   lily-output-units output-scale mul dup scale
 } bind def


diff -u --strip-trailing-cr original/music-drawing-routines.ps
latest/music-drawing-routines.ps
--- original/music-drawing-routines.ps  2006-04-01 11:57:18.109097600 -0500
+++ latest/music-drawing-routines.ps2006-04-01 11:26:08.270401600 -0500
@@ -10,6 +10,36 @@
 /pdfmark where
 {pop} {userdict /pdfmark /cleartomark load put} ifelse

+% llx lly urx ury URI
+/mark_URI
+{
+/command exch def
+/ury exch def
+/urx exch def
+/lly exch def
+/llx exch def
+[
+   /Rect [ llx lly urx ury ]
+
+% it's possible to eliminate the coordinate variables by doing [ /Rect [ 7 3
+% roll It is, however, kind of ugly.  Another possibility, probably better, is
+% to put the [ and ] into the other side, so this procedure will take an array.
+% Yet another is to make pdfmark take its coordinates on the stack.
+
+
+/Border [ 0 0 0 ]
+
+/Action
+   
+   /Subtype /URI
+   /URI command
+   
+/Subtype /Link
+/ANN
+pdfmark
+}
+bind def
+
 % from adobe tech note 5002.
 /BeginEPSF { %def
 /b4_Inc_state save def % Save state for cleanup
@@ -28,7 +58,6 @@
 } if
 } bind def

-
 /EndEPSF { %def
   count op_count sub {pop} repeat % Clean up stacks
   countdictstack dict_count sub {end} repeat
@@ -54,28 +83,7 @@
 } bind def


-% llx lly urx ury URI
-/mark_URI
-{
-/command exch def
-/ury exch def
-/urx exch def
-/lly exch def
-/llx exch def
-[
-   /Rect [ llx lly urx ury ]
-   /Border [ 0 0 0 ]

-/Action
-   
-   /Subtype /URI
-   /URI command
-   
-/Subtype /Link
-/ANN
-pdfmark
-}
-bind def

 /set_tex_dimen
 {
@@ -89,104 +97,56 @@
1 copy mul exch 1 copy mul add sqrt
 } bind def

-% FIXME.  translate to middle of box.
-% Nice rectangle with rounded corners
-/draw_box % breapth width depth height
-{
-%  currentdict /testing known {
-   %% real thin lines for testing
-   /blot 0.005 def
-%  }{
-%  /blot blot-diameter def
-%  } ifelse
-
-   0 setlinecap
-   blot setlinewidth
-   1 setlinejoin
-
-   blot 2 div sub /h exch def
-   blot 2 div sub /d exch def
-   blot 2 div sub /w exch def
-   blot 2 div sub /b exch def
-
-   b neg d neg moveto
-   b w add 0 rlineto
-   0 d h add rlineto
-   b w add neg 0 rlineto
-   0 d h add neg rlineto
-
-   currentdict /testing known {
-   %% outline only, for testing:
+/stroke_and_fill {
+

Re: Improvements to Postscript backend (patches included)

2006-04-01 Thread Han-Wen Nienhuys

David Feuer schreef:

On 3/31/06, Han-Wen Nienhuys [EMAIL PROTECTED] wrote:


According to the Postscript reference, selectfont can be used with CID
resources as well as regular fonts.  Unfortunately, I can't make the
utf-8 regression test work either with or without my changes, so I
can't be sure I got this right.

unfortunately, Ghostscript disagrees. It throws a /typecheck error from
--glyphshow-- , if you load the font as a regular font.


Yech.  I suspect this is a bug in Ghostscript, though I could be
reading the PostScript reference wrong.  Could you take a look at
section 5.11.3 (CIDFont Dictionaries), the entry for selectfont in the
operator index (page 656, or PDF page 670), and the entry for
glyphshow (page 602, PDF page 616)?


I suspect you may know more about postscript than me, your guess is as 
good as mine; If you think it is bug, can you file a bug with 
ghostscript development?


I can send you a file with an embedded CFF CID font.


___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


Re: More improvements to PostScript backend

2006-04-01 Thread David Feuer
 +% it's possible to eliminate the coordinate variables by doing [ /Rect [ 7 3
 +% roll It is, however, kind of ugly.  Another possibility, probably better, 
 is
 +% to put the [ and ] into the other side, so this procedure will take an 
 array.
 +% Yet another is to make pdfmark take its coordinates on the stack.

I realized it would actually be very silly to put [ and ] at the
calling site.  That'll create a bunch of arrays for no reason that
will have to be GCed later.  Where is pdfmark defined, when it is
defined?

David


___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


Re: Improvements to Postscript backend (patches included)

2006-04-01 Thread David Feuer
On 4/1/06, Han-Wen Nienhuys [EMAIL PROTECTED] wrote:

 I suspect you may know more about postscript than me, your guess is as
 good as mine; If you think it is bug, can you file a bug with
 ghostscript development?

 I can send you a file with an embedded CFF CID font.

I don't actually know _too_ much about PostScript.  I write it with
the reference up on my screen, and fonts are one of the parts I
understand least.  If I get a chance, I'll ask the Ghostscript people
about it.

David Feuer


___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


Re: More improvements to PostScript backend

2006-04-01 Thread David Feuer
Would it be possible to put mark_URI wherever pdfmark is defined? 
That way, it won't be in the output unless it's actually used.

Could someone give me a clue about stencils and grobs?  My vague
general impression is that it would probably be a big win for code
maintenance, output quality, and output flexibility if the backend
code did all the stencil interpretation, rather than having a separate
stencil interpreter blindly paste together bits of PS or SVG.  I don't
know SVG, but the PostScript backend could certainly benefit from more
information.  The biggest wins would probably come from drawing all
the noteheads and accidentals at once (or perhaps even just using a
special procedure to draw noteheads, which can keep track of the
notehead font), linking noteheads to stems, and keeping track of the
stem width.  It'd also be cool if PostScript knew about staves, and
drew all the lines of the staff and all the clefs at once.  You get
the idea.

David Feuer


___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


Re: More improvements to PostScript backend

2006-04-01 Thread David Feuer
Grr I forgot to delete the euclidean_length procedure from
music-drawing-routines.ps.  It is no longer used.

David


___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


Re: More improvements to PostScript backend

2006-04-01 Thread Han-Wen Nienhuys

David Feuer schreef:
Would it be possible to put mark_URI wherever pdfmark is defined? 
That way, it won't be in the output unless it's actually used.


no. pdfmark is a routine that GS/Acrobat distiller provides to create 
URLs in the PDF output. It's defined in case the PS interpreter (say, 
one embedded in a printer) doesn't know about PDF.



Could someone give me a clue about stencils and grobs?  My vague
general impression is that it would probably be a big win for code
maintenance, output quality, and output flexibility if the backend
code did all the stencil interpretation, rather than having a separate
stencil interpreter blindly paste together bits of PS or SVG.  I don't
know SVG, but the PostScript backend could certainly benefit from more
information.  The biggest wins would probably come from drawing all
the noteheads and accidentals at once (or perhaps even just using a
special procedure to draw noteheads, which can keep track of the
notehead font), linking noteheads to stems, and keeping track of the
stem width.  It'd also be cool if PostScript knew about staves, and
drew all the lines of the staff and all the clefs at once.  You get
the idea.


Yes, I get the idea, but I don't get the actual way you'd make this 
work, and -more importantly- why you would bother; editing lilypond 
output by hand is a very bad idea, IMO.


Regarding stencils, see stencil.hh; it is a compositional method of 
dealing with graphics.


Re: grobs
http://lists.gnu.org/archive/html/lilypond-devel/2004-10/msg00241.html



___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


grace note synchronization and multi-rests

2006-04-01 Thread Werner LEMBERG

Assume the following score

  
 \new Voice \relative c' {
   R1*2 |
   \acciaccatura { c8 } c1 | c1 }

 \new Voice \relative c' {
   R1*2 |
   \acciaccatura { s8 } R1*2 }
  

To synchronize the grace notes it is necessary to insert them into the
second voice also (as skips).  Extracting this second voice in a part
I want to get

   4
   |---|


but I get

  2   2
   |-| |-|


due to the grace notes.  What must I do to have a 4-bar multi-rest
automatically?  I know that I can insert a kludge with \tag to provide
different versions for the part and the full score, but...


Werner


___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


Re: grace note synchronization and multi-rests

2006-04-01 Thread Werner LEMBERG
 To synchronize the grace notes it is necessary to insert them into the
 second voice also (as skips).  Extracting this second voice in a part
 I want to get
 
4
|---|
 
 
 but I get
 
   2   2
|-| |-|
 
 
 due to the grace notes.

It's even more annoying because I can't have grace notes in cues :-(

Any chance to fix this?


Werner


___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


Re: grace note synchronization and multi-rests

2006-04-01 Thread Han-Wen Nienhuys

Werner LEMBERG schreef:

To synchronize the grace notes it is necessary to insert them into the
second voice also (as skips).  Extracting this second voice in a part
I want to get

   4
   |---|


but I get

  2   2
   |-| |-|


due to the grace notes.


It's even more annoying because I can't have grace notes in cues :-(

Any chance to fix this?


not true iirc; there's even a regtest. Of course, you have to do insert 
grace skips into the cueDuring arguments too.


--

Han-Wen Nienhuys - [EMAIL PROTECTED] - http://www.xs4all.nl/~hanwen

LilyPond Software Design
 -- Code for Music Notation
http://www.lilypond-design.com



___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


Re: More improvements to PostScript backend

2006-04-01 Thread David Feuer
When might I expect feedback on the new patch?

David Feuer


___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


\killCues vs. redefining \cueDuring

2006-04-01 Thread Werner LEMBERG

There are two solutions to suppress cue notes in a full score.


Let's assume that file foo.ily defines a `foo' music macro:

  foo = \relative c' {
...
\queDuring ...
...
  }

The same for all other parts.

. Solution 1: Redefine `cueDuring' to do nothing before inclusion of
  the parts.

cueDuring = #(define-music-function
  (parser location what dir main-music)
  (string? ly:dir? ly:music?)
  main-music)

\include foo.ily
\include bar.ily
...


  ...
  \new Staff \foo
  ...
  \new Staff \bar
  ...


. Solution 2: Do not redefine `cueDuring' but use \killCues.

\include foo.ily
\include bar.ily
...


  ...
  \new Staff { \killCues \foo }
  ...
  \new Staff { \killCues \bar }
  ...



I wonder whether solution 1 (which I prefer since it is less typing)
is really equivalent to solution 2, or whether there are drawbacks
I've missed.


Werner


___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel


Re: grace note synchronization and multi-rests

2006-04-01 Thread Werner LEMBERG

  It's even more annoying because I can't have grace notes in cues :-(
 
 not true iirc; there's even a regtest. Of course, you have to do
 insert grace skips into the cueDuring arguments too.

OK, thanks.  The bug with cyclic cues (which I've just reported to
bug-lilypond) led me to a wrong conclusion.


Werner


___
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel