Re: [GIT PULL] extcon next for 3.15

2014-03-19 Thread Greg KH
On Wed, Mar 19, 2014 at 04:53:13PM +0900, Chanwoo Choi wrote:
> Dear Greg,
> 
> This is extcon-next full request for v3.15. I add detailed description of this
> pull request on below. Please pull extcon with following updates.
> 
> This patchset is rebased on 'Linux 3-14-rc5' because char-misc-next is based 
> on
> 'Linux 3-14-rc5'.
> 
> Best Regards,
> Chanwoo Choi
> 
> The following changes since commit 0414855fdc4a40da05221fc6062cccbc0c30f169:
> 
>   Linux 3.14-rc5 (2014-03-02 18:56:16 -0800)
> 
> are available in the git repository at:
> 
>   git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git 
> tags/extcon-next-for-3.15

Pulled and pushed out, thanks.

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[GIT PULL] extcon next for 3.15

2014-03-19 Thread Chanwoo Choi
Dear Greg,

This is extcon-next full request for v3.15. I add detailed description of this
pull request on below. Please pull extcon with following updates.

This patchset is rebased on 'Linux 3-14-rc5' because char-misc-next is based on
'Linux 3-14-rc5'.

Best Regards,
Chanwoo Choi

The following changes since commit 0414855fdc4a40da05221fc6062cccbc0c30f169:

  Linux 3.14-rc5 (2014-03-02 18:56:16 -0800)

are available in the git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git 
tags/extcon-next-for-3.15

for you to fetch changes up to 1ad94ffef22c0a6e2ee6ba90a800c32fd29ffa1f:

  extcon: Move OF helper function to extcon core and change function name 
(2014-03-19 14:41:58 +0900)


Update extcon for v3.15

This patchset fix minor issue.

The extcon-palmas/gpio use SIMPLE_DEV_PM_OPS macro instead of legacy method.
OF helper function of extcon move in extcon core to remove separate of_extcon.c
and change the name of OF helper function as following because previous function
name is complicated and ambiguous naming.
- of_extcon_get_extcon_dev() -> extcon_get_edev_by_phandle()


Chanwoo Choi (2):
  extcon: of: Remove unnecessary function call by using the name of 
device_node
  extcon: Move OF helper function to extcon core and change function name

Jingoo Han (2):
  extcon: palmas: Use SIMPLE_DEV_PM_OPS macro
  extcon: gpio: Use SIMPLE_DEV_PM_OPS macro

 drivers/extcon/Kconfig   |  4 ---
 drivers/extcon/Makefile  |  2 --
 drivers/extcon/extcon-class.c| 42 ++
 drivers/extcon/extcon-gpio.c |  4 +--
 drivers/extcon/extcon-palmas.c   |  5 +---
 drivers/extcon/of_extcon.c   | 64 
 drivers/usb/dwc3/dwc3-omap.c |  3 +-
 include/linux/extcon.h   | 12 
 include/linux/extcon/of_extcon.h | 31 ---
 9 files changed, 57 insertions(+), 110 deletions(-)
 delete mode 100644 drivers/extcon/of_extcon.c
 delete mode 100644 include/linux/extcon/of_extcon.h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[GIT PULL] extcon next for 3.15

2014-03-19 Thread Chanwoo Choi
Dear Greg,

This is extcon-next full request for v3.15. I add detailed description of this
pull request on below. Please pull extcon with following updates.

This patchset is rebased on 'Linux 3-14-rc5' because char-misc-next is based on
'Linux 3-14-rc5'.

Best Regards,
Chanwoo Choi

The following changes since commit 0414855fdc4a40da05221fc6062cccbc0c30f169:

  Linux 3.14-rc5 (2014-03-02 18:56:16 -0800)

are available in the git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git 
tags/extcon-next-for-3.15

for you to fetch changes up to 1ad94ffef22c0a6e2ee6ba90a800c32fd29ffa1f:

  extcon: Move OF helper function to extcon core and change function name 
(2014-03-19 14:41:58 +0900)


Update extcon for v3.15

This patchset fix minor issue.

The extcon-palmas/gpio use SIMPLE_DEV_PM_OPS macro instead of legacy method.
OF helper function of extcon move in extcon core to remove separate of_extcon.c
and change the name of OF helper function as following because previous function
name is complicated and ambiguous naming.
- of_extcon_get_extcon_dev() - extcon_get_edev_by_phandle()


Chanwoo Choi (2):
  extcon: of: Remove unnecessary function call by using the name of 
device_node
  extcon: Move OF helper function to extcon core and change function name

Jingoo Han (2):
  extcon: palmas: Use SIMPLE_DEV_PM_OPS macro
  extcon: gpio: Use SIMPLE_DEV_PM_OPS macro

 drivers/extcon/Kconfig   |  4 ---
 drivers/extcon/Makefile  |  2 --
 drivers/extcon/extcon-class.c| 42 ++
 drivers/extcon/extcon-gpio.c |  4 +--
 drivers/extcon/extcon-palmas.c   |  5 +---
 drivers/extcon/of_extcon.c   | 64 
 drivers/usb/dwc3/dwc3-omap.c |  3 +-
 include/linux/extcon.h   | 12 
 include/linux/extcon/of_extcon.h | 31 ---
 9 files changed, 57 insertions(+), 110 deletions(-)
 delete mode 100644 drivers/extcon/of_extcon.c
 delete mode 100644 include/linux/extcon/of_extcon.h
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [GIT PULL] extcon next for 3.15

2014-03-19 Thread Greg KH
On Wed, Mar 19, 2014 at 04:53:13PM +0900, Chanwoo Choi wrote:
 Dear Greg,
 
 This is extcon-next full request for v3.15. I add detailed description of this
 pull request on below. Please pull extcon with following updates.
 
 This patchset is rebased on 'Linux 3-14-rc5' because char-misc-next is based 
 on
 'Linux 3-14-rc5'.
 
 Best Regards,
 Chanwoo Choi
 
 The following changes since commit 0414855fdc4a40da05221fc6062cccbc0c30f169:
 
   Linux 3.14-rc5 (2014-03-02 18:56:16 -0800)
 
 are available in the git repository at:
 
   git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git 
 tags/extcon-next-for-3.15

Pulled and pushed out, thanks.

greg k-h
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/