Re: [RESEND PATCH 0/3] Convert mtk-dpi to drm_bridge API

2020-06-12 Thread Enric Balletbo i Serra
Hi,

On 18/5/20 19:39, Enric Balletbo i Serra wrote:
> The reason for this resend is because I forget to add some bridge
> maintainers. So adding them and collect the actual tags.
> 
> The mtk-dpi driver still uses the drm_encoder API which is now somewhat
> deprecated. We started to move all the Mediatek drivers to the drm_bridge API,
> like we did for the mtk-dsi driver [1], this is another small step to be able 
> to
> fully convert the DRM Mediatek drivers to the drm_bridge API. A dummy
> drm_encoder is maintained in the mtk-dpi driver but the end goal is move all 
> the
> dummy drm_encoder (mtk-dsi, mtk-dpi, etc) to the main mtk_drm_drv driver.
> 
> [1] https://lore.kernel.org/patchwork/project/lkml/list/?series=441559
> 
> 
> Enric Balletbo i Serra (3):
>   drm/mediatek: mtk_dpi: Rename bridge to next_bridge
>   drm/mediatek: mtk_dpi: Convert to bridge driver
>   drm/mediatek: mtk_dpi: Use simple encoder
> 
>  drivers/gpu/drm/mediatek/mtk_dpi.c | 84 ++

A gentle ping, I think this patchset still is missing a reviewed tag from bridge
maintainers if is fine.

Thanks,
 Enric


>  1 file changed, 39 insertions(+), 45 deletions(-)
> 


[RESEND PATCH 0/3] Convert mtk-dpi to drm_bridge API

2020-05-18 Thread Enric Balletbo i Serra
The reason for this resend is because I forget to add some bridge
maintainers. So adding them and collect the actual tags.

The mtk-dpi driver still uses the drm_encoder API which is now somewhat
deprecated. We started to move all the Mediatek drivers to the drm_bridge API,
like we did for the mtk-dsi driver [1], this is another small step to be able to
fully convert the DRM Mediatek drivers to the drm_bridge API. A dummy
drm_encoder is maintained in the mtk-dpi driver but the end goal is move all the
dummy drm_encoder (mtk-dsi, mtk-dpi, etc) to the main mtk_drm_drv driver.

[1] https://lore.kernel.org/patchwork/project/lkml/list/?series=441559


Enric Balletbo i Serra (3):
  drm/mediatek: mtk_dpi: Rename bridge to next_bridge
  drm/mediatek: mtk_dpi: Convert to bridge driver
  drm/mediatek: mtk_dpi: Use simple encoder

 drivers/gpu/drm/mediatek/mtk_dpi.c | 84 ++
 1 file changed, 39 insertions(+), 45 deletions(-)

-- 
2.26.2



Re: [PATCH 0/3] Convert mtk-dpi to drm_bridge API

2020-05-16 Thread Chun-Kuang Hu
Hi, Enric:

Chun-Kuang Hu  於 2020年5月10日 週日 上午9:24寫道:
>
> Hi, Enric:
>
> Enric Balletbo i Serra  於 2020年5月4日 週一 
> 下午10:14寫道:
> >
> > The mtk-dpi driver still uses the drm_encoder API which is now somehow
> > deprecated. We started to move all the Mediatek drivers to the drm_bridge 
> > API,
> > like we did for the mtk-dsi driver [1], this is another small step to be 
> > able to
> > fully convert the DRM Mediatek drivers to the drm_bridge API. A dummy
> > drm_encoder is maintained in the mtk-dpi driver but the end goal is move 
> > all the
> > dummy drm_encoder (mtk-dsi, mtk-dpi, etc) to the main mtk_drm_drv driver.
>
> For this series, applied to mediatek-drm-next [1], thanks.
>
> [1] 
> https://git.kernel.org/pub/scm/linux/kernel/git/chunkuang.hu/linux.git/log/?h=mediatek-drm-next
>

I remove this series from mediatek-drm-next because drm bridge driver
need ack of drm bridge maintainer.

Regards,
Chun-Kuang.

> Regards,
> Chun-Kuang.
>
> >
> > Best regards,
> >  Enric
> >
> > [1] https://lore.kernel.org/patchwork/project/lkml/list/?series=441559
> >
> > Enric Balletbo i Serra (3):
> >   drm/mediatek: mtk_dpi: Rename bridge to next_bridge
> >   drm/mediatek: mtk_dpi: Convert to bridge driver
> >   drm/mediatek: mtk_dpi: Use simple encoder
> >
> >  drivers/gpu/drm/mediatek/mtk_dpi.c | 84 ++
> >  1 file changed, 39 insertions(+), 45 deletions(-)
> >
> > --
> > 2.26.2
> >


Re: [PATCH 0/3] Convert mtk-dpi to drm_bridge API

2020-05-09 Thread Chun-Kuang Hu
Hi, Enric:

Enric Balletbo i Serra  於 2020年5月4日 週一 下午10:14寫道:
>
> The mtk-dpi driver still uses the drm_encoder API which is now somehow
> deprecated. We started to move all the Mediatek drivers to the drm_bridge API,
> like we did for the mtk-dsi driver [1], this is another small step to be able 
> to
> fully convert the DRM Mediatek drivers to the drm_bridge API. A dummy
> drm_encoder is maintained in the mtk-dpi driver but the end goal is move all 
> the
> dummy drm_encoder (mtk-dsi, mtk-dpi, etc) to the main mtk_drm_drv driver.

For this series, applied to mediatek-drm-next [1], thanks.

[1] 
https://git.kernel.org/pub/scm/linux/kernel/git/chunkuang.hu/linux.git/log/?h=mediatek-drm-next

Regards,
Chun-Kuang.

>
> Best regards,
>  Enric
>
> [1] https://lore.kernel.org/patchwork/project/lkml/list/?series=441559
>
> Enric Balletbo i Serra (3):
>   drm/mediatek: mtk_dpi: Rename bridge to next_bridge
>   drm/mediatek: mtk_dpi: Convert to bridge driver
>   drm/mediatek: mtk_dpi: Use simple encoder
>
>  drivers/gpu/drm/mediatek/mtk_dpi.c | 84 ++
>  1 file changed, 39 insertions(+), 45 deletions(-)
>
> --
> 2.26.2
>


[PATCH 0/3] Convert mtk-dpi to drm_bridge API

2020-05-04 Thread Enric Balletbo i Serra
The mtk-dpi driver still uses the drm_encoder API which is now somehow
deprecated. We started to move all the Mediatek drivers to the drm_bridge API,
like we did for the mtk-dsi driver [1], this is another small step to be able to
fully convert the DRM Mediatek drivers to the drm_bridge API. A dummy
drm_encoder is maintained in the mtk-dpi driver but the end goal is move all the
dummy drm_encoder (mtk-dsi, mtk-dpi, etc) to the main mtk_drm_drv driver.

Best regards,
 Enric

[1] https://lore.kernel.org/patchwork/project/lkml/list/?series=441559

Enric Balletbo i Serra (3):
  drm/mediatek: mtk_dpi: Rename bridge to next_bridge
  drm/mediatek: mtk_dpi: Convert to bridge driver
  drm/mediatek: mtk_dpi: Use simple encoder

 drivers/gpu/drm/mediatek/mtk_dpi.c | 84 ++
 1 file changed, 39 insertions(+), 45 deletions(-)

-- 
2.26.2