Re: [PATCH 01/11] clocksource: arm_arch_timer: Rename arch_timer_probed to reflect behaviour

2015-03-31 Thread Ingo Molnar

* Laurent Pinchart  wrote:

> Hi Ingo,
> 
> On Tuesday 31 March 2015 09:14:52 Ingo Molnar wrote:
> > * Daniel Lezcano  wrote:
> > > From: Laurent Pinchart 
> > > 
> > > The arch_timer_probed function returns whether the given time doesn't
> > > need to be probed. This can be the case when the timer has been probed
> > > already, but also when it has no corresponding enabled node in DT.
> > > 
> > > Rename the function to arch_timer_need_probe and invert its return value
> > > to better reflect the function's purpose and behaviour.
> > > 
> > > Acked-by: Sudeep Holla 
> > > Signed-off-by: Laurent Pinchart
> > > 
> > > Signed-off-by: Daniel Lezcano 
> > > ---
> > > 
> > >  drivers/clocksource/arm_arch_timer.c | 13 +++--
> > >  1 file changed, 7 insertions(+), 6 deletions(-)
> > > 
> > > diff --git a/drivers/clocksource/arm_arch_timer.c
> > > b/drivers/clocksource/arm_arch_timer.c index a3025e7..50bb7f2 100644
> > > --- a/drivers/clocksource/arm_arch_timer.c
> > > +++ b/drivers/clocksource/arm_arch_timer.c
> > > @@ -661,17 +661,17 @@ static const struct of_device_id
> > > arch_timer_mem_of_match[] __initconst = {> 
> > >  };
> > >  
> > >  static bool __init
> > > 
> > > -arch_timer_probed(int type, const struct of_device_id *matches)
> > > +arch_timer_need_probe(int type, const struct of_device_id *matches)
> > 
> > If we do a rename we might as well use valid English spelling such as
> > 'arch_timer_needs_probing()'?
> 
> Of course. Should I resend the patch or can you fix that while applying it ?

No need to resend, I've done the rename in the patch.

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH 01/11] clocksource: arm_arch_timer: Rename arch_timer_probed to reflect behaviour

2015-03-31 Thread Laurent Pinchart
Hi Ingo,

On Tuesday 31 March 2015 09:14:52 Ingo Molnar wrote:
> * Daniel Lezcano  wrote:
> > From: Laurent Pinchart 
> > 
> > The arch_timer_probed function returns whether the given time doesn't
> > need to be probed. This can be the case when the timer has been probed
> > already, but also when it has no corresponding enabled node in DT.
> > 
> > Rename the function to arch_timer_need_probe and invert its return value
> > to better reflect the function's purpose and behaviour.
> > 
> > Acked-by: Sudeep Holla 
> > Signed-off-by: Laurent Pinchart
> > 
> > Signed-off-by: Daniel Lezcano 
> > ---
> > 
> >  drivers/clocksource/arm_arch_timer.c | 13 +++--
> >  1 file changed, 7 insertions(+), 6 deletions(-)
> > 
> > diff --git a/drivers/clocksource/arm_arch_timer.c
> > b/drivers/clocksource/arm_arch_timer.c index a3025e7..50bb7f2 100644
> > --- a/drivers/clocksource/arm_arch_timer.c
> > +++ b/drivers/clocksource/arm_arch_timer.c
> > @@ -661,17 +661,17 @@ static const struct of_device_id
> > arch_timer_mem_of_match[] __initconst = {> 
> >  };
> >  
> >  static bool __init
> > 
> > -arch_timer_probed(int type, const struct of_device_id *matches)
> > +arch_timer_need_probe(int type, const struct of_device_id *matches)
> 
> If we do a rename we might as well use valid English spelling such as
> 'arch_timer_needs_probing()'?

Of course. Should I resend the patch or can you fix that while applying it ?

-- 
Regards,

Laurent Pinchart

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH 01/11] clocksource: arm_arch_timer: Rename arch_timer_probed to reflect behaviour

2015-03-31 Thread Ingo Molnar

* Daniel Lezcano  wrote:

> From: Laurent Pinchart 
> 
> The arch_timer_probed function returns whether the given time doesn't
> need to be probed. This can be the case when the timer has been probed
> already, but also when it has no corresponding enabled node in DT.
> 
> Rename the function to arch_timer_need_probe and invert its return value
> to better reflect the function's purpose and behaviour.
> 
> Acked-by: Sudeep Holla 
> Signed-off-by: Laurent Pinchart 
> Signed-off-by: Daniel Lezcano 
> ---
>  drivers/clocksource/arm_arch_timer.c | 13 +++--
>  1 file changed, 7 insertions(+), 6 deletions(-)
> 
> diff --git a/drivers/clocksource/arm_arch_timer.c 
> b/drivers/clocksource/arm_arch_timer.c
> index a3025e7..50bb7f2 100644
> --- a/drivers/clocksource/arm_arch_timer.c
> +++ b/drivers/clocksource/arm_arch_timer.c
> @@ -661,17 +661,17 @@ static const struct of_device_id 
> arch_timer_mem_of_match[] __initconst = {
>  };
>  
>  static bool __init
> -arch_timer_probed(int type, const struct of_device_id *matches)
> +arch_timer_need_probe(int type, const struct of_device_id *matches)

If we do a rename we might as well use valid English spelling such as 
'arch_timer_needs_probing()'?

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH 01/11] clocksource: arm_arch_timer: Rename arch_timer_probed to reflect behaviour

2015-03-31 Thread Ingo Molnar

* Daniel Lezcano daniel.lezc...@linaro.org wrote:

 From: Laurent Pinchart laurent.pinchart+rene...@ideasonboard.com
 
 The arch_timer_probed function returns whether the given time doesn't
 need to be probed. This can be the case when the timer has been probed
 already, but also when it has no corresponding enabled node in DT.
 
 Rename the function to arch_timer_need_probe and invert its return value
 to better reflect the function's purpose and behaviour.
 
 Acked-by: Sudeep Holla sudeep.ho...@arm.com
 Signed-off-by: Laurent Pinchart laurent.pinchart+rene...@ideasonboard.com
 Signed-off-by: Daniel Lezcano daniel.lezc...@linaro.org
 ---
  drivers/clocksource/arm_arch_timer.c | 13 +++--
  1 file changed, 7 insertions(+), 6 deletions(-)
 
 diff --git a/drivers/clocksource/arm_arch_timer.c 
 b/drivers/clocksource/arm_arch_timer.c
 index a3025e7..50bb7f2 100644
 --- a/drivers/clocksource/arm_arch_timer.c
 +++ b/drivers/clocksource/arm_arch_timer.c
 @@ -661,17 +661,17 @@ static const struct of_device_id 
 arch_timer_mem_of_match[] __initconst = {
  };
  
  static bool __init
 -arch_timer_probed(int type, const struct of_device_id *matches)
 +arch_timer_need_probe(int type, const struct of_device_id *matches)

If we do a rename we might as well use valid English spelling such as 
'arch_timer_needs_probing()'?

Thanks,

Ingo
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH 01/11] clocksource: arm_arch_timer: Rename arch_timer_probed to reflect behaviour

2015-03-31 Thread Laurent Pinchart
Hi Ingo,

On Tuesday 31 March 2015 09:14:52 Ingo Molnar wrote:
 * Daniel Lezcano daniel.lezc...@linaro.org wrote:
  From: Laurent Pinchart laurent.pinchart+rene...@ideasonboard.com
  
  The arch_timer_probed function returns whether the given time doesn't
  need to be probed. This can be the case when the timer has been probed
  already, but also when it has no corresponding enabled node in DT.
  
  Rename the function to arch_timer_need_probe and invert its return value
  to better reflect the function's purpose and behaviour.
  
  Acked-by: Sudeep Holla sudeep.ho...@arm.com
  Signed-off-by: Laurent Pinchart
  laurent.pinchart+rene...@ideasonboard.com
  Signed-off-by: Daniel Lezcano daniel.lezc...@linaro.org
  ---
  
   drivers/clocksource/arm_arch_timer.c | 13 +++--
   1 file changed, 7 insertions(+), 6 deletions(-)
  
  diff --git a/drivers/clocksource/arm_arch_timer.c
  b/drivers/clocksource/arm_arch_timer.c index a3025e7..50bb7f2 100644
  --- a/drivers/clocksource/arm_arch_timer.c
  +++ b/drivers/clocksource/arm_arch_timer.c
  @@ -661,17 +661,17 @@ static const struct of_device_id
  arch_timer_mem_of_match[] __initconst = { 
   };
   
   static bool __init
  
  -arch_timer_probed(int type, const struct of_device_id *matches)
  +arch_timer_need_probe(int type, const struct of_device_id *matches)
 
 If we do a rename we might as well use valid English spelling such as
 'arch_timer_needs_probing()'?

Of course. Should I resend the patch or can you fix that while applying it ?

-- 
Regards,

Laurent Pinchart

--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH 01/11] clocksource: arm_arch_timer: Rename arch_timer_probed to reflect behaviour

2015-03-31 Thread Ingo Molnar

* Laurent Pinchart laurent.pinch...@ideasonboard.com wrote:

 Hi Ingo,
 
 On Tuesday 31 March 2015 09:14:52 Ingo Molnar wrote:
  * Daniel Lezcano daniel.lezc...@linaro.org wrote:
   From: Laurent Pinchart laurent.pinchart+rene...@ideasonboard.com
   
   The arch_timer_probed function returns whether the given time doesn't
   need to be probed. This can be the case when the timer has been probed
   already, but also when it has no corresponding enabled node in DT.
   
   Rename the function to arch_timer_need_probe and invert its return value
   to better reflect the function's purpose and behaviour.
   
   Acked-by: Sudeep Holla sudeep.ho...@arm.com
   Signed-off-by: Laurent Pinchart
   laurent.pinchart+rene...@ideasonboard.com
   Signed-off-by: Daniel Lezcano daniel.lezc...@linaro.org
   ---
   
drivers/clocksource/arm_arch_timer.c | 13 +++--
1 file changed, 7 insertions(+), 6 deletions(-)
   
   diff --git a/drivers/clocksource/arm_arch_timer.c
   b/drivers/clocksource/arm_arch_timer.c index a3025e7..50bb7f2 100644
   --- a/drivers/clocksource/arm_arch_timer.c
   +++ b/drivers/clocksource/arm_arch_timer.c
   @@ -661,17 +661,17 @@ static const struct of_device_id
   arch_timer_mem_of_match[] __initconst = { 
};

static bool __init
   
   -arch_timer_probed(int type, const struct of_device_id *matches)
   +arch_timer_need_probe(int type, const struct of_device_id *matches)
  
  If we do a rename we might as well use valid English spelling such as
  'arch_timer_needs_probing()'?
 
 Of course. Should I resend the patch or can you fix that while applying it ?

No need to resend, I've done the rename in the patch.

Thanks,

Ingo
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH 01/11] clocksource: arm_arch_timer: Rename arch_timer_probed to reflect behaviour

2015-03-30 Thread Daniel Lezcano
From: Laurent Pinchart 

The arch_timer_probed function returns whether the given time doesn't
need to be probed. This can be the case when the timer has been probed
already, but also when it has no corresponding enabled node in DT.

Rename the function to arch_timer_need_probe and invert its return value
to better reflect the function's purpose and behaviour.

Acked-by: Sudeep Holla 
Signed-off-by: Laurent Pinchart 
Signed-off-by: Daniel Lezcano 
---
 drivers/clocksource/arm_arch_timer.c | 13 +++--
 1 file changed, 7 insertions(+), 6 deletions(-)

diff --git a/drivers/clocksource/arm_arch_timer.c 
b/drivers/clocksource/arm_arch_timer.c
index a3025e7..50bb7f2 100644
--- a/drivers/clocksource/arm_arch_timer.c
+++ b/drivers/clocksource/arm_arch_timer.c
@@ -661,17 +661,17 @@ static const struct of_device_id 
arch_timer_mem_of_match[] __initconst = {
 };
 
 static bool __init
-arch_timer_probed(int type, const struct of_device_id *matches)
+arch_timer_need_probe(int type, const struct of_device_id *matches)
 {
struct device_node *dn;
-   bool probed = true;
+   bool need_probe = false;
 
dn = of_find_matching_node(NULL, matches);
if (dn && of_device_is_available(dn) && !(arch_timers_present & type))
-   probed = false;
+   need_probe = true;
of_node_put(dn);
 
-   return probed;
+   return need_probe;
 }
 
 static void __init arch_timer_common_init(void)
@@ -680,9 +680,10 @@ static void __init arch_timer_common_init(void)
 
/* Wait until both nodes are probed if we have two timers */
if ((arch_timers_present & mask) != mask) {
-   if (!arch_timer_probed(ARCH_MEM_TIMER, arch_timer_mem_of_match))
+   if (arch_timer_need_probe(ARCH_MEM_TIMER,
+ arch_timer_mem_of_match))
return;
-   if (!arch_timer_probed(ARCH_CP15_TIMER, arch_timer_of_match))
+   if (arch_timer_need_probe(ARCH_CP15_TIMER, arch_timer_of_match))
return;
}
 
-- 
1.9.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH 01/11] clocksource: arm_arch_timer: Rename arch_timer_probed to reflect behaviour

2015-03-30 Thread Daniel Lezcano
From: Laurent Pinchart laurent.pinchart+rene...@ideasonboard.com

The arch_timer_probed function returns whether the given time doesn't
need to be probed. This can be the case when the timer has been probed
already, but also when it has no corresponding enabled node in DT.

Rename the function to arch_timer_need_probe and invert its return value
to better reflect the function's purpose and behaviour.

Acked-by: Sudeep Holla sudeep.ho...@arm.com
Signed-off-by: Laurent Pinchart laurent.pinchart+rene...@ideasonboard.com
Signed-off-by: Daniel Lezcano daniel.lezc...@linaro.org
---
 drivers/clocksource/arm_arch_timer.c | 13 +++--
 1 file changed, 7 insertions(+), 6 deletions(-)

diff --git a/drivers/clocksource/arm_arch_timer.c 
b/drivers/clocksource/arm_arch_timer.c
index a3025e7..50bb7f2 100644
--- a/drivers/clocksource/arm_arch_timer.c
+++ b/drivers/clocksource/arm_arch_timer.c
@@ -661,17 +661,17 @@ static const struct of_device_id 
arch_timer_mem_of_match[] __initconst = {
 };
 
 static bool __init
-arch_timer_probed(int type, const struct of_device_id *matches)
+arch_timer_need_probe(int type, const struct of_device_id *matches)
 {
struct device_node *dn;
-   bool probed = true;
+   bool need_probe = false;
 
dn = of_find_matching_node(NULL, matches);
if (dn  of_device_is_available(dn)  !(arch_timers_present  type))
-   probed = false;
+   need_probe = true;
of_node_put(dn);
 
-   return probed;
+   return need_probe;
 }
 
 static void __init arch_timer_common_init(void)
@@ -680,9 +680,10 @@ static void __init arch_timer_common_init(void)
 
/* Wait until both nodes are probed if we have two timers */
if ((arch_timers_present  mask) != mask) {
-   if (!arch_timer_probed(ARCH_MEM_TIMER, arch_timer_mem_of_match))
+   if (arch_timer_need_probe(ARCH_MEM_TIMER,
+ arch_timer_mem_of_match))
return;
-   if (!arch_timer_probed(ARCH_CP15_TIMER, arch_timer_of_match))
+   if (arch_timer_need_probe(ARCH_CP15_TIMER, arch_timer_of_match))
return;
}
 
-- 
1.9.1

--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/