Re: [PATCH 24/32] dma-debug: Use pr_warn instead of pr_warning
On 2019/9/26 1:13, Christoph Hellwig wrote: > On Fri, Sep 20, 2019 at 02:25:36PM +0800, Kefeng Wang wrote: >> As said in commit f2c2cbcc35d4 ("powerpc: Use pr_warn instead of >> pr_warning"), removing pr_warning so all logging messages use a >> consistent _warn style. Let's do it. > Please just send a script after -rc1 instead of sending all these > little patches. For all changes, just git grep -w pr_warning | cut -d ':' -f1 | uniq | sort | xargs sed -i 's/pr_warning/pr_warn/g', but I do need check them manually and make some minor improvements, like coalesce format, realign arguments, and remove unnecessary line continuations. thus, send these littles patches. Thanks. > . >
Re: [PATCH 24/32] dma-debug: Use pr_warn instead of pr_warning
On Fri, Sep 20, 2019 at 02:25:36PM +0800, Kefeng Wang wrote: > As said in commit f2c2cbcc35d4 ("powerpc: Use pr_warn instead of > pr_warning"), removing pr_warning so all logging messages use a > consistent _warn style. Let's do it. Please just send a script after -rc1 instead of sending all these little patches.
[PATCH 24/32] dma-debug: Use pr_warn instead of pr_warning
As said in commit f2c2cbcc35d4 ("powerpc: Use pr_warn instead of pr_warning"), removing pr_warning so all logging messages use a consistent _warn style. Let's do it. Cc: Christoph Hellwig Cc: Marek Szyprowski Cc: Robin Murphy Signed-off-by: Kefeng Wang --- kernel/dma/debug.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/kernel/dma/debug.c b/kernel/dma/debug.c index 099002d84f46..a26170469543 100644 --- a/kernel/dma/debug.c +++ b/kernel/dma/debug.c @@ -161,7 +161,7 @@ static inline void dump_entry_trace(struct dma_debug_entry *entry) { #ifdef CONFIG_STACKTRACE if (entry) { - pr_warning("Mapped at:\n"); + pr_warn("Mapped at:\n"); stack_trace_print(entry->stack_entries, entry->stack_len, 0); } #endif -- 2.20.1