Re: [PATCH v16 2/2] i2c: core: support bus regulator controlling in adapter

2021-04-07 Thread Hsin-Yi Wang
On Tue, Mar 9, 2021 at 9:34 PM Hsin-Yi Wang  wrote:
>
> On Tue, Mar 9, 2021 at 1:17 AM Mark Brown  wrote:
> >
> > On Mon, Mar 08, 2021 at 12:36:07PM +0800, Hsin-Yi Wang wrote:
> >
> > > + adap->bus_regulator = devm_regulator_get(>dev, "bus");
> > > + if (IS_ERR(adap->bus_regulator)) {
> > > + res = PTR_ERR(adap->bus_regulator);
> > > + goto out_reg;
> > > + }
> >
> > Idiomatically supplies should be named as they are by the chip datasheet
> > rather than just a generic name like this, and I'm guessing that systems
> > that have supplies like this will often already have something
> > requesting the supply (eg, it's quite common for consumer drivers to do
> > this) under that name.  I can see this being a useful thing to factor
> > out into the core but it seems like it'd be better to have it enabled by
> > having the controllers (or devices) pass a supply name (or possibly
> > requested regulator) to the core rather than by just hard coding a name
> > in the core so bindings look as expected.
> >
>
> I'll move the regulator request into device instead of core in the
> next version. Thanks.
>
Hi Mark,

v17 is sent here:
https://patchwork.kernel.org/project/linux-mediatek/cover/20210309133131.1585838-1-hsi...@chromium.org/

Thanks.

> > I do also wonder if it's better to put the feature on the clients rather
> > than the controller, I don't think it makes much difference though.


Re: [PATCH v16 2/2] i2c: core: support bus regulator controlling in adapter

2021-03-09 Thread Hsin-Yi Wang
On Tue, Mar 9, 2021 at 1:17 AM Mark Brown  wrote:
>
> On Mon, Mar 08, 2021 at 12:36:07PM +0800, Hsin-Yi Wang wrote:
>
> > + adap->bus_regulator = devm_regulator_get(>dev, "bus");
> > + if (IS_ERR(adap->bus_regulator)) {
> > + res = PTR_ERR(adap->bus_regulator);
> > + goto out_reg;
> > + }
>
> Idiomatically supplies should be named as they are by the chip datasheet
> rather than just a generic name like this, and I'm guessing that systems
> that have supplies like this will often already have something
> requesting the supply (eg, it's quite common for consumer drivers to do
> this) under that name.  I can see this being a useful thing to factor
> out into the core but it seems like it'd be better to have it enabled by
> having the controllers (or devices) pass a supply name (or possibly
> requested regulator) to the core rather than by just hard coding a name
> in the core so bindings look as expected.
>

I'll move the regulator request into device instead of core in the
next version. Thanks.

> I do also wonder if it's better to put the feature on the clients rather
> than the controller, I don't think it makes much difference though.


Re: [PATCH v16 2/2] i2c: core: support bus regulator controlling in adapter

2021-03-08 Thread Mark Brown
On Mon, Mar 08, 2021 at 12:36:07PM +0800, Hsin-Yi Wang wrote:

> + adap->bus_regulator = devm_regulator_get(>dev, "bus");
> + if (IS_ERR(adap->bus_regulator)) {
> + res = PTR_ERR(adap->bus_regulator);
> + goto out_reg;
> + }

Idiomatically supplies should be named as they are by the chip datasheet
rather than just a generic name like this, and I'm guessing that systems
that have supplies like this will often already have something
requesting the supply (eg, it's quite common for consumer drivers to do
this) under that name.  I can see this being a useful thing to factor
out into the core but it seems like it'd be better to have it enabled by
having the controllers (or devices) pass a supply name (or possibly
requested regulator) to the core rather than by just hard coding a name
in the core so bindings look as expected.

I do also wonder if it's better to put the feature on the clients rather
than the controller, I don't think it makes much difference though.


signature.asc
Description: PGP signature


[PATCH v16 2/2] i2c: core: support bus regulator controlling in adapter

2021-03-07 Thread Hsin-Yi Wang
From: Bibby Hsieh 

Although in the most platforms, the bus power of i2c
are alway on, some platforms disable the i2c bus power
in order to meet low power request.

We get and enable bulk regulator in i2c adapter device.

Signed-off-by: Bibby Hsieh 
Signed-off-by: Marek Szyprowski 
Signed-off-by: Hsin-Yi Wang 
---
 drivers/i2c/i2c-core-base.c | 93 +
 include/linux/i2c.h |  2 +
 2 files changed, 95 insertions(+)

diff --git a/drivers/i2c/i2c-core-base.c b/drivers/i2c/i2c-core-base.c
index 63ebf722a424..667f4a4de7cc 100644
--- a/drivers/i2c/i2c-core-base.c
+++ b/drivers/i2c/i2c-core-base.c
@@ -439,12 +439,14 @@ static int i2c_smbus_host_notify_to_irq(const struct 
i2c_client *client)
 static int i2c_device_probe(struct device *dev)
 {
struct i2c_client   *client = i2c_verify_client(dev);
+   struct i2c_adapter  *adap;
struct i2c_driver   *driver;
int status;
 
if (!client)
return 0;
 
+   adap = client->adapter;
client->irq = client->init_irq;
 
if (!client->irq) {
@@ -510,6 +512,12 @@ static int i2c_device_probe(struct device *dev)
 
dev_dbg(dev, "probe\n");
 
+   status = regulator_enable(adap->bus_regulator);
+   if (status < 0) {
+   dev_err(>dev, "Failed to enable power regulator\n");
+   goto err_clear_wakeup_irq;
+   }
+
status = of_clk_set_defaults(dev->of_node, false);
if (status < 0)
goto err_clear_wakeup_irq;
@@ -550,8 +558,10 @@ static int i2c_device_probe(struct device *dev)
 static int i2c_device_remove(struct device *dev)
 {
struct i2c_client   *client = to_i2c_client(dev);
+   struct i2c_adapter  *adap;
struct i2c_driver   *driver;
 
+   adap = client->adapter;
driver = to_i2c_driver(dev->driver);
if (driver->remove) {
int status;
@@ -564,6 +574,8 @@ static int i2c_device_remove(struct device *dev)
}
 
dev_pm_domain_detach(>dev, true);
+   if (!pm_runtime_status_suspended(>dev))
+   regulator_disable(adap->bus_regulator);
 
dev_pm_clear_wake_irq(>dev);
device_init_wakeup(>dev, false);
@@ -576,6 +588,80 @@ static int i2c_device_remove(struct device *dev)
return 0;
 }
 
+#ifdef CONFIG_PM_SLEEP
+static int i2c_resume_early(struct device *dev)
+{
+   struct i2c_client *client = i2c_verify_client(dev);
+   int err;
+
+   if (!client)
+   return 0;
+
+   if (!pm_runtime_status_suspended(>dev)) {
+   err = regulator_enable(client->adapter->bus_regulator);
+   if (err)
+   return err;
+   }
+
+   return pm_generic_resume_early(>dev);
+}
+
+static int i2c_suspend_late(struct device *dev)
+{
+   struct i2c_client *client = i2c_verify_client(dev);
+   int err;
+
+   if (!client)
+   return 0;
+
+   err = pm_generic_suspend_late(>dev);
+   if (err)
+   return err;
+
+   if (!pm_runtime_status_suspended(>dev))
+   return regulator_disable(client->adapter->bus_regulator);
+
+   return 0;
+}
+#endif
+
+#ifdef CONFIG_PM
+static int i2c_runtime_resume(struct device *dev)
+{
+   struct i2c_client *client = i2c_verify_client(dev);
+   int err;
+
+   if (!client)
+   return 0;
+
+   err = regulator_enable(client->adapter->bus_regulator);
+   if (err)
+   return err;
+
+   return pm_generic_runtime_resume(>dev);
+}
+
+static int i2c_runtime_suspend(struct device *dev)
+{
+   struct i2c_client *client = i2c_verify_client(dev);
+   int err;
+
+   if (!client)
+   return 0;
+
+   err = pm_generic_runtime_suspend(>dev);
+   if (err)
+   return err;
+
+   return regulator_disable(client->adapter->bus_regulator);
+}
+#endif
+
+static const struct dev_pm_ops i2c_device_pm = {
+   SET_LATE_SYSTEM_SLEEP_PM_OPS(i2c_suspend_late, i2c_resume_early)
+   SET_RUNTIME_PM_OPS(i2c_runtime_suspend, i2c_runtime_resume, NULL)
+};
+
 static void i2c_device_shutdown(struct device *dev)
 {
struct i2c_client *client = i2c_verify_client(dev);
@@ -633,6 +719,7 @@ struct bus_type i2c_bus_type = {
.probe  = i2c_device_probe,
.remove = i2c_device_remove,
.shutdown   = i2c_device_shutdown,
+   .pm = _device_pm,
 };
 EXPORT_SYMBOL_GPL(i2c_bus_type);
 
@@ -1446,6 +1533,12 @@ static int i2c_register_adapter(struct i2c_adapter *adap)
if (res)
goto out_reg;
 
+   adap->bus_regulator = devm_regulator_get(>dev, "bus");
+   if (IS_ERR(adap->bus_regulator)) {
+   res = PTR_ERR(adap->bus_regulator);
+   goto out_reg;
+   }
+
pm_runtime_no_callbacks(>dev);
pm_suspend_ignore_children(>dev, true);
pm_runtime_enable(>dev);
diff --git