Re: [PATCH v5 2/2] dt-bindings: mtd: Document Macronix raw NAND controller bindings

2019-07-22 Thread masonccyang


Hi Rob,


> 
> Re: [PATCH v5 2/2] dt-bindings: mtd: Document Macronix raw NAND 
controller bindings
> 
> On Wed, Jul 03, 2019 at 03:15:44PM +0800, Mason Yang wrote:
> > Document the bindings used by the Macronix raw NAND controller.
> > 
> > Signed-off-by: Mason Yang 
> > ---
> >  Documentation/devicetree/bindings/mtd/mxic-nand.txt | 20 

> >  1 file changed, 20 insertions(+)
> >  create mode 100644 
Documentation/devicetree/bindings/mtd/mxic-nand.txt
> > 
> > diff --git a/Documentation/devicetree/bindings/mtd/mxic-nand.txt b/
> Documentation/devicetree/bindings/mtd/mxic-nand.txt
> > new file mode 100644
> > index 000..ddd7660
> > --- /dev/null
> > +++ b/Documentation/devicetree/bindings/mtd/mxic-nand.txt
> > @@ -0,0 +1,20 @@
> > +Macronix Raw NAND Controller Device Tree Bindings
> > +-
> > +
> > +Required properties:
> > +- compatible: should be "macronix,nand-controller"
> 
> That's not very specific. There's only 1 version of this h/w?

okay, will give it a apposite name.

> 
> > +- reg: should contain 1 entrie for the registers
> 
> s/entrie/entry/

will fix it.

> 
> > +- interrupts: interrupt line connected to this raw NAND controller
> > +- clock-names: should contain "ps_clk", "send_clk" and "send_dly_clk"
> > +- clocks: should contain 3 phandles for the "ps_clk", "send_clk" and
> > +"send_dly_clk" clocks
> 
> You can drop '_clk' as that is redundant.

okay, got it.

> 
> > +
> > +Example:
> > +
> > +   nand: mxic-nfc@43c3 {
> > +  compatible = "macronix,nand-controller";
> > +  reg = <0x43c3 0x1>;
> > +  reg-names = "regs";
> 
> Not documented. You can drop as *-names is not generally useful when 
> there is only 1 entry.

okay, will fix it.

> 
> > +  clocks = < 0>, < 1>, < 15>;
> > +  clock-names = "send_clk", "send_dly_clk", "ps_clk";
> > +   };
> > -- 
> > 1.9.1
> > 

thanks for your time & review.
best regards,
Mason

CONFIDENTIALITY NOTE:

This e-mail and any attachments may contain confidential information 
and/or personal data, which is protected by applicable laws. Please be 
reminded that duplication, disclosure, distribution, or use of this e-mail 
(and/or its attachments) or any part thereof is prohibited. If you receive 
this e-mail in error, please notify us immediately and delete this mail as 
well as its attachment(s) from your system. In addition, please be 
informed that collection, processing, and/or use of personal data is 
prohibited unless expressly permitted by personal data protection laws. 
Thank you for your attention and cooperation.

Macronix International Co., Ltd.

=





CONFIDENTIALITY NOTE:

This e-mail and any attachments may contain confidential information and/or 
personal data, which is protected by applicable laws. Please be reminded that 
duplication, disclosure, distribution, or use of this e-mail (and/or its 
attachments) or any part thereof is prohibited. If you receive this e-mail in 
error, please notify us immediately and delete this mail as well as its 
attachment(s) from your system. In addition, please be informed that 
collection, processing, and/or use of personal data is prohibited unless 
expressly permitted by personal data protection laws. Thank you for your 
attention and cooperation.

Macronix International Co., Ltd.

=



Re: [PATCH v5 2/2] dt-bindings: mtd: Document Macronix raw NAND controller bindings

2019-07-22 Thread Rob Herring
On Wed, Jul 03, 2019 at 03:15:44PM +0800, Mason Yang wrote:
> Document the bindings used by the Macronix raw NAND controller.
> 
> Signed-off-by: Mason Yang 
> ---
>  Documentation/devicetree/bindings/mtd/mxic-nand.txt | 20 
>  1 file changed, 20 insertions(+)
>  create mode 100644 Documentation/devicetree/bindings/mtd/mxic-nand.txt
> 
> diff --git a/Documentation/devicetree/bindings/mtd/mxic-nand.txt 
> b/Documentation/devicetree/bindings/mtd/mxic-nand.txt
> new file mode 100644
> index 000..ddd7660
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/mtd/mxic-nand.txt
> @@ -0,0 +1,20 @@
> +Macronix Raw NAND Controller Device Tree Bindings
> +-
> +
> +Required properties:
> +- compatible: should be "macronix,nand-controller"

That's not very specific. There's only 1 version of this h/w?

> +- reg: should contain 1 entrie for the registers

s/entrie/entry/

> +- interrupts: interrupt line connected to this raw NAND controller
> +- clock-names: should contain "ps_clk", "send_clk" and "send_dly_clk"
> +- clocks: should contain 3 phandles for the "ps_clk", "send_clk" and
> +  "send_dly_clk" clocks

You can drop '_clk' as that is redundant.

> +
> +Example:
> +
> + nand: mxic-nfc@43c3 {
> + compatible = "macronix,nand-controller";
> + reg = <0x43c3 0x1>;
> + reg-names = "regs";

Not documented. You can drop as *-names is not generally useful when 
there is only 1 entry.

> + clocks = < 0>, < 1>, < 15>;
> + clock-names = "send_clk", "send_dly_clk", "ps_clk";
> + };
> -- 
> 1.9.1
> 


Re: [PATCH v5 2/2] dt-bindings: mtd: Document Macronix raw NAND controller bindings

2019-07-17 Thread masonccyang


Hi Sergei,

> > Document the bindings used by the Macronix raw NAND controller.
> > 
> > Signed-off-by: Mason Yang 
> > ---
> >   Documentation/devicetree/bindings/mtd/mxic-nand.txt | 20 

> >   1 file changed, 20 insertions(+)
> >   create mode 100644 
Documentation/devicetree/bindings/mtd/mxic-nand.txt
> > 
> > diff --git a/Documentation/devicetree/bindings/mtd/mxic-nand.txt b/
> Documentation/devicetree/bindings/mtd/mxic-nand.txt
> > new file mode 100644
> > index 000..ddd7660
> > --- /dev/null
> > +++ b/Documentation/devicetree/bindings/mtd/mxic-nand.txt
> > @@ -0,0 +1,20 @@
> > +Macronix Raw NAND Controller Device Tree Bindings
> > +-
> > +
> > +Required properties:
> > +- compatible: should be "macronix,nand-controller"
> > +- reg: should contain 1 entrie for the registers
> > +- interrupts: interrupt line connected to this raw NAND controller
> > +- clock-names: should contain "ps_clk", "send_clk" and "send_dly_clk"
> > +- clocks: should contain 3 phandles for the "ps_clk", "send_clk" and
> > +"send_dly_clk" clocks
> > +
> > +Example:
> > +
> > +   nand: mxic-nfc@43c3 {
> 
> The node names should be generic, and the DT spec 0.2 (section 
2.2.2) even 
> has documented "nand-controller", please rename.

okay, will fix it to

nand: nand-controller@43c3 {

}

> 
> > +  compatible = "macronix,nand-controller";
> > +  reg = <0x43c3 0x1>;
> > +  reg-names = "regs";
> > +  clocks = < 0>, < 1>, < 15>;
> > +  clock-names = "send_clk", "send_dly_clk", "ps_clk";
> > +   };
> > 
> 
> MBR, Sergei

thanks & best regards,
Mason

CONFIDENTIALITY NOTE:

This e-mail and any attachments may contain confidential information 
and/or personal data, which is protected by applicable laws. Please be 
reminded that duplication, disclosure, distribution, or use of this e-mail 
(and/or its attachments) or any part thereof is prohibited. If you receive 
this e-mail in error, please notify us immediately and delete this mail as 
well as its attachment(s) from your system. In addition, please be 
informed that collection, processing, and/or use of personal data is 
prohibited unless expressly permitted by personal data protection laws. 
Thank you for your attention and cooperation.

Macronix International Co., Ltd.

=





CONFIDENTIALITY NOTE:

This e-mail and any attachments may contain confidential information and/or 
personal data, which is protected by applicable laws. Please be reminded that 
duplication, disclosure, distribution, or use of this e-mail (and/or its 
attachments) or any part thereof is prohibited. If you receive this e-mail in 
error, please notify us immediately and delete this mail as well as its 
attachment(s) from your system. In addition, please be informed that 
collection, processing, and/or use of personal data is prohibited unless 
expressly permitted by personal data protection laws. Thank you for your 
attention and cooperation.

Macronix International Co., Ltd.

=



Re: [PATCH v5 2/2] dt-bindings: mtd: Document Macronix raw NAND controller bindings

2019-07-04 Thread Sergei Shtylyov

Hello!

On 03.07.2019 10:15, Mason Yang wrote:


Document the bindings used by the Macronix raw NAND controller.

Signed-off-by: Mason Yang 
---
  Documentation/devicetree/bindings/mtd/mxic-nand.txt | 20 
  1 file changed, 20 insertions(+)
  create mode 100644 Documentation/devicetree/bindings/mtd/mxic-nand.txt

diff --git a/Documentation/devicetree/bindings/mtd/mxic-nand.txt 
b/Documentation/devicetree/bindings/mtd/mxic-nand.txt
new file mode 100644
index 000..ddd7660
--- /dev/null
+++ b/Documentation/devicetree/bindings/mtd/mxic-nand.txt
@@ -0,0 +1,20 @@
+Macronix Raw NAND Controller Device Tree Bindings
+-
+
+Required properties:
+- compatible: should be "macronix,nand-controller"
+- reg: should contain 1 entrie for the registers
+- interrupts: interrupt line connected to this raw NAND controller
+- clock-names: should contain "ps_clk", "send_clk" and "send_dly_clk"
+- clocks: should contain 3 phandles for the "ps_clk", "send_clk" and
+"send_dly_clk" clocks
+
+Example:
+
+   nand: mxic-nfc@43c3 {


   The node names should be generic, and the DT spec 0.2 (section 2.2.2) even 
has documented "nand-controller", please rename.



+   compatible = "macronix,nand-controller";
+   reg = <0x43c3 0x1>;
+   reg-names = "regs";
+   clocks = < 0>, < 1>, < 15>;
+   clock-names = "send_clk", "send_dly_clk", "ps_clk";
+   };



MBR, Sergei


[PATCH v5 2/2] dt-bindings: mtd: Document Macronix raw NAND controller bindings

2019-07-03 Thread Mason Yang
Document the bindings used by the Macronix raw NAND controller.

Signed-off-by: Mason Yang 
---
 Documentation/devicetree/bindings/mtd/mxic-nand.txt | 20 
 1 file changed, 20 insertions(+)
 create mode 100644 Documentation/devicetree/bindings/mtd/mxic-nand.txt

diff --git a/Documentation/devicetree/bindings/mtd/mxic-nand.txt 
b/Documentation/devicetree/bindings/mtd/mxic-nand.txt
new file mode 100644
index 000..ddd7660
--- /dev/null
+++ b/Documentation/devicetree/bindings/mtd/mxic-nand.txt
@@ -0,0 +1,20 @@
+Macronix Raw NAND Controller Device Tree Bindings
+-
+
+Required properties:
+- compatible: should be "macronix,nand-controller"
+- reg: should contain 1 entrie for the registers
+- interrupts: interrupt line connected to this raw NAND controller
+- clock-names: should contain "ps_clk", "send_clk" and "send_dly_clk"
+- clocks: should contain 3 phandles for the "ps_clk", "send_clk" and
+"send_dly_clk" clocks
+
+Example:
+
+   nand: mxic-nfc@43c3 {
+   compatible = "macronix,nand-controller";
+   reg = <0x43c3 0x1>;
+   reg-names = "regs";
+   clocks = < 0>, < 1>, < 15>;
+   clock-names = "send_clk", "send_dly_clk", "ps_clk";
+   };
-- 
1.9.1