Re: [PATCH v6 14/35] i2c: tegra: Clean up probe function

2020-09-08 Thread Dmitry Osipenko
08.09.2020 11:40, Andy Shevchenko пишет:
> On Tue, Sep 8, 2020 at 5:11 AM Dmitry Osipenko  wrote:
>>
>> The driver's probe function code is a bit difficult to read. This patch
>> reorders code of the probe function, forming groups of code that are easy
>> to work with.
>>
>> The probe tear-down order now matches the driver-removal order.
> 
>> All dev/>dev are replaced with i2c_dev->dev in order to have uniform
>> code style across the driver.
> 
> You see, below is my point why leaving a temporary variable can reduce a 
> churn.
> 
>> The "ret" variable renamed to "err" since it only carries error code and
>> the new name clearly shows that.
> 
> Overall it sounds like you need to split this into a few patches.
> 
> ...
> 
>> -   struct device *dev = >dev;
> 
>> -   i2c_dev->rst = devm_reset_control_get_exclusive(>dev, "i2c");
> 
>> +   i2c_dev->rst = devm_reset_control_get_exclusive(i2c_dev->dev, "i2c");
> 
> You see, if it had been simple 'dev', this line would have not been changed.
> 
> And so on.
> 

Alright, I'll move all the renamings into the "Clean up variable names"
patch, thanks.


Re: [PATCH v6 14/35] i2c: tegra: Clean up probe function

2020-09-08 Thread Andy Shevchenko
On Tue, Sep 8, 2020 at 5:11 AM Dmitry Osipenko  wrote:
>
> The driver's probe function code is a bit difficult to read. This patch
> reorders code of the probe function, forming groups of code that are easy
> to work with.
>
> The probe tear-down order now matches the driver-removal order.

> All dev/>dev are replaced with i2c_dev->dev in order to have uniform
> code style across the driver.

You see, below is my point why leaving a temporary variable can reduce a churn.

> The "ret" variable renamed to "err" since it only carries error code and
> the new name clearly shows that.

Overall it sounds like you need to split this into a few patches.

...

> -   struct device *dev = >dev;

> -   i2c_dev->rst = devm_reset_control_get_exclusive(>dev, "i2c");

> +   i2c_dev->rst = devm_reset_control_get_exclusive(i2c_dev->dev, "i2c");

You see, if it had been simple 'dev', this line would have not been changed.

And so on.

-- 
With Best Regards,
Andy Shevchenko


[PATCH v6 14/35] i2c: tegra: Clean up probe function

2020-09-07 Thread Dmitry Osipenko
The driver's probe function code is a bit difficult to read. This patch
reorders code of the probe function, forming groups of code that are easy
to work with.

The probe tear-down order now matches the driver-removal order.

All dev/>dev are replaced with i2c_dev->dev in order to have uniform
code style across the driver.

The "ret" variable renamed to "err" since it only carries error code and
the new name clearly shows that.

Signed-off-by: Dmitry Osipenko 
---
 drivers/i2c/busses/i2c-tegra.c | 141 +
 1 file changed, 71 insertions(+), 70 deletions(-)

diff --git a/drivers/i2c/busses/i2c-tegra.c b/drivers/i2c/busses/i2c-tegra.c
index e20937041504..01637e1fccde 100644
--- a/drivers/i2c/busses/i2c-tegra.c
+++ b/drivers/i2c/busses/i2c-tegra.c
@@ -440,6 +440,9 @@ static int tegra_i2c_init_dma(struct tegra_i2c_dev *i2c_dev)
 
i2c_dev->tx_dma_chan = chan;
 
+   i2c_dev->dma_buf_size = i2c_dev->hw->quirks->max_write_len +
+   I2C_PACKET_HEADER_SIZE;
+
dma_buf = dma_alloc_coherent(i2c_dev->dev, i2c_dev->dma_buf_size,
 _phys, GFP_KERNEL | __GFP_NOWARN);
if (!dma_buf) {
@@ -1690,38 +1693,45 @@ static void tegra_i2c_release_clocks(struct 
tegra_i2c_dev *i2c_dev)
 
 static int tegra_i2c_probe(struct platform_device *pdev)
 {
-   struct device *dev = >dev;
struct tegra_i2c_dev *i2c_dev;
struct resource *res;
-   void __iomem *base;
-   phys_addr_t base_phys;
-   int irq;
-   int ret;
-
-   base = devm_platform_get_and_ioremap_resource(pdev, 0, );
-   if (IS_ERR(base))
-   return PTR_ERR(base);
-
-   base_phys = res->start;
-
-   irq = platform_get_irq(pdev, 0);
-   if (irq < 0)
-   return irq;
+   int err;
 
i2c_dev = devm_kzalloc(>dev, sizeof(*i2c_dev), GFP_KERNEL);
if (!i2c_dev)
return -ENOMEM;
 
-   i2c_dev->base = base;
-   i2c_dev->base_phys = base_phys;
-   i2c_dev->adapter.algo = _i2c_algo;
-   i2c_dev->adapter.retries = 1;
-   i2c_dev->adapter.timeout = 6 * HZ;
-   i2c_dev->irq = irq;
+   platform_set_drvdata(pdev, i2c_dev);
+
+   init_completion(_dev->msg_complete);
+   init_completion(_dev->dma_complete);
+
+   i2c_dev->hw = of_device_get_match_data(>dev);
i2c_dev->cont_id = pdev->id;
i2c_dev->dev = >dev;
 
-   i2c_dev->rst = devm_reset_control_get_exclusive(>dev, "i2c");
+   i2c_dev->base = devm_platform_get_and_ioremap_resource(pdev, 0, );
+   if (IS_ERR(i2c_dev->base))
+   return PTR_ERR(i2c_dev->base);
+
+   i2c_dev->base_phys = res->start;
+
+   err = platform_get_irq(pdev, 0);
+   if (err < 0)
+   return err;
+
+   i2c_dev->irq = err;
+
+   /* interrupt will be enabled during of transfer time */
+   irq_set_status_flags(i2c_dev->irq, IRQ_NOAUTOEN);
+
+   err = devm_request_irq(i2c_dev->dev, i2c_dev->irq, tegra_i2c_isr,
+  IRQF_NO_SUSPEND, dev_name(i2c_dev->dev),
+  i2c_dev);
+   if (err)
+   return err;
+
+   i2c_dev->rst = devm_reset_control_get_exclusive(i2c_dev->dev, "i2c");
if (IS_ERR(i2c_dev->rst)) {
dev_err_probe(i2c_dev->dev, PTR_ERR(i2c_dev->rst),
  "failed to get reset control\n");
@@ -1730,18 +1740,13 @@ static int tegra_i2c_probe(struct platform_device *pdev)
 
tegra_i2c_parse_dt(i2c_dev);
 
-   ret = tegra_i2c_init_clocks(i2c_dev);
-   if (ret)
-   return ret;
-
-   i2c_dev->hw = of_device_get_match_data(>dev);
-   i2c_dev->adapter.quirks = i2c_dev->hw->quirks;
-   i2c_dev->dma_buf_size = i2c_dev->adapter.quirks->max_write_len +
-   I2C_PACKET_HEADER_SIZE;
-   init_completion(_dev->msg_complete);
-   init_completion(_dev->dma_complete);
+   err = tegra_i2c_init_clocks(i2c_dev);
+   if (err)
+   return err;
 
-   platform_set_drvdata(pdev, i2c_dev);
+   err = tegra_i2c_init_dma(i2c_dev);
+   if (err)
+   goto release_clocks;
 
/*
 * VI I2C is in VE power domain which is not always on and not
@@ -1751,60 +1756,56 @@ static int tegra_i2c_probe(struct platform_device *pdev)
 * not be used for atomic transfers.
 */
if (!i2c_dev->is_vi)
-   pm_runtime_irq_safe(>dev);
-   pm_runtime_enable(>dev);
-   ret = pm_runtime_get_sync(i2c_dev->dev);
-   if (ret < 0) {
-   dev_err(dev, "runtime resume failed\n");
-   goto put_rpm;
-   }
+   pm_runtime_irq_safe(i2c_dev->dev);
 
-   if (i2c_dev->hw->supports_bus_clear)
-   i2c_dev->adapter.bus_recovery_info = _i2c_recovery_info;
+   pm_runtime_enable(i2c_dev->dev);
 
-   ret = tegra_i2c_init_dma(i2c_dev);
-   if (ret < 0)
+