Re: [RFC PATCH v1 1/6] badblocks: add more helper structure and routines in badblocks.h

2021-03-03 Thread Coly Li
On 3/3/21 4:20 PM, Hannes Reinecke wrote:
> On 3/2/21 5:02 AM, Coly Li wrote:
>> This patch adds the following helper structure and routines into
>> badblocks.h,
>> - struct bad_context
>>   This structure is used in improved badblocks code for bad table
>>   iteration.
>> - BB_END()
>>   The macro to culculate end LBA of a bad range record from bad
>>   table.
>> - badblocks_full() and badblocks_empty()
>>   The inline routines to check whether bad table is full or empty.
>> - set_changed() and clear_changed()
>>   The inline routines to set and clear 'changed' tag from struct
>>   badblocks.
>>
>> These new helper structure and routines can help to make the code more
>> clear, they will be used in the improved badblocks code in following
>> patches.
>>
>> Signed-off-by: Coly Li 
>> ---
>>  include/linux/badblocks.h | 32 
>>  1 file changed, 32 insertions(+)
>>
>> diff --git a/include/linux/badblocks.h b/include/linux/badblocks.h
>> index 2426276b9bd3..166161842d1f 100644
>> --- a/include/linux/badblocks.h
>> +++ b/include/linux/badblocks.h
>> @@ -15,6 +15,7 @@
>>  #define BB_OFFSET(x)(((x) & BB_OFFSET_MASK) >> 9)
>>  #define BB_LEN(x)   (((x) & BB_LEN_MASK) + 1)
>>  #define BB_ACK(x)   (!!((x) & BB_ACK_MASK))
>> +#define BB_END(x)   (BB_OFFSET(x) + BB_LEN(x))
>>  #define BB_MAKE(a, l, ack) (((a)<<9) | ((l)-1) | ((u64)(!!(ack)) << 63))
>>  
>>  /* Bad block numbers are stored sorted in a single page.
>> @@ -41,6 +42,14 @@ struct badblocks {
>>  sector_t size;  /* in sectors */
>>  };
>>  
>> +struct bad_context {
>> +sector_tstart;
>> +sector_tlen;
>> +int ack;
>> +sector_torig_start;
>> +sector_torig_len;
>> +};
>> +
> Maybe rename it to 'badblocks_context'.
> It's not the context which is bad ...
> 

Copied, I will modify it in next version.

Thanks for the suggestion.

Coly Li



Re: [RFC PATCH v1 1/6] badblocks: add more helper structure and routines in badblocks.h

2021-03-03 Thread Hannes Reinecke
On 3/2/21 5:02 AM, Coly Li wrote:
> This patch adds the following helper structure and routines into
> badblocks.h,
> - struct bad_context
>   This structure is used in improved badblocks code for bad table
>   iteration.
> - BB_END()
>   The macro to culculate end LBA of a bad range record from bad
>   table.
> - badblocks_full() and badblocks_empty()
>   The inline routines to check whether bad table is full or empty.
> - set_changed() and clear_changed()
>   The inline routines to set and clear 'changed' tag from struct
>   badblocks.
> 
> These new helper structure and routines can help to make the code more
> clear, they will be used in the improved badblocks code in following
> patches.
> 
> Signed-off-by: Coly Li 
> ---
>  include/linux/badblocks.h | 32 
>  1 file changed, 32 insertions(+)
> 
> diff --git a/include/linux/badblocks.h b/include/linux/badblocks.h
> index 2426276b9bd3..166161842d1f 100644
> --- a/include/linux/badblocks.h
> +++ b/include/linux/badblocks.h
> @@ -15,6 +15,7 @@
>  #define BB_OFFSET(x) (((x) & BB_OFFSET_MASK) >> 9)
>  #define BB_LEN(x)(((x) & BB_LEN_MASK) + 1)
>  #define BB_ACK(x)(!!((x) & BB_ACK_MASK))
> +#define BB_END(x)(BB_OFFSET(x) + BB_LEN(x))
>  #define BB_MAKE(a, l, ack) (((a)<<9) | ((l)-1) | ((u64)(!!(ack)) << 63))
>  
>  /* Bad block numbers are stored sorted in a single page.
> @@ -41,6 +42,14 @@ struct badblocks {
>   sector_t size;  /* in sectors */
>  };
>  
> +struct bad_context {
> + sector_tstart;
> + sector_tlen;
> + int ack;
> + sector_torig_start;
> + sector_torig_len;
> +};
> +
Maybe rename it to 'badblocks_context'.
It's not the context which is bad ...

Cheers,

Hannes
-- 
Dr. Hannes ReineckeKernel Storage Architect
h...@suse.de  +49 911 74053 688
SUSE Software Solutions Germany GmbH, Maxfeldstr. 5, 90409 Nürnberg
HRB 36809 (AG Nürnberg), GF: Felix Imendörffer


[RFC PATCH v1 1/6] badblocks: add more helper structure and routines in badblocks.h

2021-03-02 Thread Coly Li
This patch adds the following helper structure and routines into
badblocks.h,
- struct bad_context
  This structure is used in improved badblocks code for bad table
  iteration.
- BB_END()
  The macro to culculate end LBA of a bad range record from bad
  table.
- badblocks_full() and badblocks_empty()
  The inline routines to check whether bad table is full or empty.
- set_changed() and clear_changed()
  The inline routines to set and clear 'changed' tag from struct
  badblocks.

These new helper structure and routines can help to make the code more
clear, they will be used in the improved badblocks code in following
patches.

Signed-off-by: Coly Li 
---
 include/linux/badblocks.h | 32 
 1 file changed, 32 insertions(+)

diff --git a/include/linux/badblocks.h b/include/linux/badblocks.h
index 2426276b9bd3..166161842d1f 100644
--- a/include/linux/badblocks.h
+++ b/include/linux/badblocks.h
@@ -15,6 +15,7 @@
 #define BB_OFFSET(x)   (((x) & BB_OFFSET_MASK) >> 9)
 #define BB_LEN(x)  (((x) & BB_LEN_MASK) + 1)
 #define BB_ACK(x)  (!!((x) & BB_ACK_MASK))
+#define BB_END(x)  (BB_OFFSET(x) + BB_LEN(x))
 #define BB_MAKE(a, l, ack) (((a)<<9) | ((l)-1) | ((u64)(!!(ack)) << 63))
 
 /* Bad block numbers are stored sorted in a single page.
@@ -41,6 +42,14 @@ struct badblocks {
sector_t size;  /* in sectors */
 };
 
+struct bad_context {
+   sector_tstart;
+   sector_tlen;
+   int ack;
+   sector_torig_start;
+   sector_torig_len;
+};
+
 int badblocks_check(struct badblocks *bb, sector_t s, int sectors,
   sector_t *first_bad, int *bad_sectors);
 int badblocks_set(struct badblocks *bb, sector_t s, int sectors,
@@ -63,4 +72,27 @@ static inline void devm_exit_badblocks(struct device *dev, 
struct badblocks *bb)
}
badblocks_exit(bb);
 }
+
+static inline int badblocks_full(struct badblocks *bb)
+{
+   return (bb->count >= MAX_BADBLOCKS);
+}
+
+static inline int badblocks_empty(struct badblocks *bb)
+{
+   return (bb->count == 0);
+}
+
+static inline void set_changed(struct badblocks *bb)
+{
+   if (bb->changed != 1)
+   bb->changed = 1;
+}
+
+static inline void clear_changed(struct badblocks *bb)
+{
+   if (bb->changed != 0)
+   bb->changed = 0;
+}
+
 #endif
-- 
2.26.2