Re: [GIT PATCH] driver core fixes against 2.6.25-rc2 git

2008-02-22 Thread Sam Ravnborg
On Fri, Feb 22, 2008 at 11:56:52AM -0800, Greg KH wrote:
> On Fri, Feb 22, 2008 at 08:56:25AM +0100, Sam Ravnborg wrote:
> > Hi Greg.
> > 
> > On Thu, Feb 21, 2008 at 03:46:49PM -0800, Greg KH wrote:
> > > Here are a few driver core fixes against your current git tree that fix 
> > > some
> > > more problems that have cropped up:
> > >   - shutdown problem due to logic problem with cpufreq usage of
> > > kobjects.
> > >   - build fix for powerpc due to previous kobject changes.
> > >   - runtime errors when CONFIG_SYSFS=n
> > >   - UIO code now works properly from my previous messups
> > >   - proper encoding of the ja_JP stable_kernel_rules.txt file
> > >   - updates to the stable_kernel_rules.txt file
> > >   - mark ide=reverse as obsolete in preparation of 2.6.26 (Bart
> > > wanted this to go in through my tree as I have the .26 patches
> > > pending.)
> > >   - other minor fixes.
> > 
> > 
> > Do we have any outstanding issues with section mismatch warnings in PCI 
> > Core?
> > I am as always optimistic and hope to get down to zero warnings soon.
> 
> I do not know, I saw your patches earlier and thought that they were
> going in through another tree for some reason.  If you still see any
> remaining, please send me the needed patches again.
I looked and notice there were actually only one.
Andrew picked it up but I have attached it here again.
Then I leave the decision to you.

Sam

>From 426451c7c5d9447384b129ee3a750f66c0413a13 Mon Sep 17 00:00:00 2001
From: Sam Ravnborg <[EMAIL PROTECTED]>
Date: Sun, 17 Feb 2008 10:45:28 +0100
Subject: [PATCH 25/27] pci: fix section mismatch warning in pci_scan_child_bus

Fix following warning:
WARNING: vmlinux.o(.text+0x47bdb1): Section mismatch in reference from the 
function pci_scan_child_bus() to the function .devinit.text:pcibios_fixup_bus()

We had plenty of functions that could be annotated __devinit but
due to the former restriction that annotated symbols could not
be annotated they were not so.
So annotate these function and fix the references from the
pci/hotplug/* code to silence the resuting warnings.

Signed-off-by: Sam Ravnborg <[EMAIL PROTECTED]>
Cc: Greg KH <[EMAIL PROTECTED]>
---
 drivers/pci/hotplug-pci.c  |2 +-
 drivers/pci/hotplug/acpiphp_glue.c |2 +-
 drivers/pci/hotplug/cpci_hotplug_pci.c |2 +-
 drivers/pci/hotplug/pciehp_pci.c   |2 +-
 drivers/pci/hotplug/shpchp_pci.c   |2 +-
 drivers/pci/probe.c|8 
 6 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/drivers/pci/hotplug-pci.c b/drivers/pci/hotplug-pci.c
index a590ef6..4d4a644 100644
--- a/drivers/pci/hotplug-pci.c
+++ b/drivers/pci/hotplug-pci.c
@@ -4,7 +4,7 @@
 #include "pci.h"
 
 
-unsigned int pci_do_scan_bus(struct pci_bus *bus)
+unsigned int __devinit pci_do_scan_bus(struct pci_bus *bus)
 {
unsigned int max;
 
diff --git a/drivers/pci/hotplug/acpiphp_glue.c 
b/drivers/pci/hotplug/acpiphp_glue.c
index cf22f9e..5e50008 100644
--- a/drivers/pci/hotplug/acpiphp_glue.c
+++ b/drivers/pci/hotplug/acpiphp_glue.c
@@ -1085,7 +1085,7 @@ static int acpiphp_bus_trim(acpi_handle handle)
  * This function should be called per *physical slot*,
  * not per each slot object in ACPI namespace.
  */
-static int enable_device(struct acpiphp_slot *slot)
+static int __ref enable_device(struct acpiphp_slot *slot)
 {
struct pci_dev *dev;
struct pci_bus *bus = slot->bridge->pci_bus;
diff --git a/drivers/pci/hotplug/cpci_hotplug_pci.c 
b/drivers/pci/hotplug/cpci_hotplug_pci.c
index 5e9be44..dddac96 100644
--- a/drivers/pci/hotplug/cpci_hotplug_pci.c
+++ b/drivers/pci/hotplug/cpci_hotplug_pci.c
@@ -250,7 +250,7 @@ int cpci_led_off(struct slot* slot)
  * Device configuration functions
  */
 
-int cpci_configure_slot(struct slot* slot)
+int __ref cpci_configure_slot(struct slot* slot)
 {
struct pci_bus *parent;
int fn;
diff --git a/drivers/pci/hotplug/pciehp_pci.c b/drivers/pci/hotplug/pciehp_pci.c
index dd50713..9372a84 100644
--- a/drivers/pci/hotplug/pciehp_pci.c
+++ b/drivers/pci/hotplug/pciehp_pci.c
@@ -167,7 +167,7 @@ static void program_fw_provided_values(struct pci_dev *dev)
}
 }
 
-static int pciehp_add_bridge(struct pci_dev *dev)
+static int __ref pciehp_add_bridge(struct pci_dev *dev)
 {
struct pci_bus *parent = dev->bus;
int pass, busnr, start = parent->secondary;
diff --git a/drivers/pci/hotplug/shpchp_pci.c b/drivers/pci/hotplug/shpchp_pci.c
index 0a6b25e..a69a215 100644
--- a/drivers/pci/hotplug/shpchp_pci.c
+++ b/drivers/pci/hotplug/shpchp_pci.c
@@ -96,7 +96,7 @@ static void program_fw_provided_values(struct pci_dev *dev)
}
 }
 
-int shpchp_configure_device(struct slot *p_slot)
+int __ref shpchp_configure_device(struct slot *p_slot)
 {
struct pci_dev *dev;
struct pci_bus *parent = p_slot->ctrl->pci_dev->subordinate;
diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
index 4d23b9f..5ffd610 100644
--- a/dr

Re: [GIT PATCH] driver core fixes against 2.6.25-rc2 git

2008-02-22 Thread Greg KH
On Fri, Feb 22, 2008 at 08:56:25AM +0100, Sam Ravnborg wrote:
> Hi Greg.
> 
> On Thu, Feb 21, 2008 at 03:46:49PM -0800, Greg KH wrote:
> > Here are a few driver core fixes against your current git tree that fix some
> > more problems that have cropped up:
> > - shutdown problem due to logic problem with cpufreq usage of
> >   kobjects.
> > - build fix for powerpc due to previous kobject changes.
> > - runtime errors when CONFIG_SYSFS=n
> > - UIO code now works properly from my previous messups
> > - proper encoding of the ja_JP stable_kernel_rules.txt file
> > - updates to the stable_kernel_rules.txt file
> > - mark ide=reverse as obsolete in preparation of 2.6.26 (Bart
> >   wanted this to go in through my tree as I have the .26 patches
> >   pending.)
> > - other minor fixes.
> 
> 
> Do we have any outstanding issues with section mismatch warnings in PCI Core?
> I am as always optimistic and hope to get down to zero warnings soon.

I do not know, I saw your patches earlier and thought that they were
going in through another tree for some reason.  If you still see any
remaining, please send me the needed patches again.

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [GIT PATCH] driver core fixes against 2.6.25-rc2 git

2008-02-21 Thread Sam Ravnborg
Hi Greg.

On Thu, Feb 21, 2008 at 03:46:49PM -0800, Greg KH wrote:
> Here are a few driver core fixes against your current git tree that fix some
> more problems that have cropped up:
>   - shutdown problem due to logic problem with cpufreq usage of
> kobjects.
>   - build fix for powerpc due to previous kobject changes.
>   - runtime errors when CONFIG_SYSFS=n
>   - UIO code now works properly from my previous messups
>   - proper encoding of the ja_JP stable_kernel_rules.txt file
>   - updates to the stable_kernel_rules.txt file
>   - mark ide=reverse as obsolete in preparation of 2.6.26 (Bart
> wanted this to go in through my tree as I have the .26 patches
> pending.)
>   - other minor fixes.


Do we have any outstanding issues with section mismatch warnings in PCI Core?
I am as always optimistic and hope to get down to zero warnings soon.

Sam
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/