Re: [PATCH v2 01/10] of/irq: Rework of_irq_count()

2013-10-15 Thread Grant Likely
On Sun, 22 Sep 2013 16:19:27 -0500, Rob Herring  wrote:
> On Wed, Sep 18, 2013 at 8:24 AM, Thierry Reding
>  wrote:
> > The of_irq_to_resource() helper that is used to implement of_irq_count()
> > tries to resolve interrupts and in fact creates a mapping for resolved
> > interrupts. That's pretty heavy lifting for something that claims to
> > just return the number of interrupts requested by a given device node.
> >
> > Instead, use the more lightweight of_irq_map_one(), which, despite the
> > name, doesn't create an actual mapping. Perhaps a better name would be
> > of_irq_translate_one().
> >
> > Signed-off-by: Thierry Reding 
> 
> Acked-by: Rob Herring 

Applied, thanks.

g.

> 
> > ---
> >  drivers/of/irq.c | 3 ++-
> >  1 file changed, 2 insertions(+), 1 deletion(-)
> >
> > diff --git a/drivers/of/irq.c b/drivers/of/irq.c
> > index 1752988..5f44388 100644
> > --- a/drivers/of/irq.c
> > +++ b/drivers/of/irq.c
> > @@ -368,9 +368,10 @@ EXPORT_SYMBOL_GPL(of_irq_to_resource);
> >   */
> >  int of_irq_count(struct device_node *dev)
> >  {
> > +   struct of_irq irq;
> > int nr = 0;
> >
> > -   while (of_irq_to_resource(dev, nr, NULL))
> > +   while (of_irq_map_one(dev, nr, ) == 0)
> > nr++;
> >
> > return nr;
> > --
> > 1.8.4
> >
> >
> > ___
> > linux-arm-kernel mailing list
> > linux-arm-ker...@lists.infradead.org
> > http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 01/10] of/irq: Rework of_irq_count()

2013-10-15 Thread Grant Likely
On Sun, 22 Sep 2013 16:19:27 -0500, Rob Herring  wrote:
> On Wed, Sep 18, 2013 at 8:24 AM, Thierry Reding
>  wrote:
> > The of_irq_to_resource() helper that is used to implement of_irq_count()
> > tries to resolve interrupts and in fact creates a mapping for resolved
> > interrupts. That's pretty heavy lifting for something that claims to
> > just return the number of interrupts requested by a given device node.
> >
> > Instead, use the more lightweight of_irq_map_one(), which, despite the
> > name, doesn't create an actual mapping. Perhaps a better name would be
> > of_irq_translate_one().
> >
> > Signed-off-by: Thierry Reding 
> 
> Acked-by: Rob Herring 

Applied (and fixed to match the of_irq_map_one --> of_irq_parse_one
rename that I'm going to merge in v3.13).

g.

> 
> > ---
> >  drivers/of/irq.c | 3 ++-
> >  1 file changed, 2 insertions(+), 1 deletion(-)
> >
> > diff --git a/drivers/of/irq.c b/drivers/of/irq.c
> > index 1752988..5f44388 100644
> > --- a/drivers/of/irq.c
> > +++ b/drivers/of/irq.c
> > @@ -368,9 +368,10 @@ EXPORT_SYMBOL_GPL(of_irq_to_resource);
> >   */
> >  int of_irq_count(struct device_node *dev)
> >  {
> > +   struct of_irq irq;
> > int nr = 0;
> >
> > -   while (of_irq_to_resource(dev, nr, NULL))
> > +   while (of_irq_map_one(dev, nr, ) == 0)
> > nr++;
> >
> > return nr;
> > --
> > 1.8.4
> >
> >
> > ___
> > linux-arm-kernel mailing list
> > linux-arm-ker...@lists.infradead.org
> > http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 01/10] of/irq: Rework of_irq_count()

2013-10-15 Thread Grant Likely
On Sun, 22 Sep 2013 16:19:27 -0500, Rob Herring robherri...@gmail.com wrote:
 On Wed, Sep 18, 2013 at 8:24 AM, Thierry Reding
 thierry.red...@gmail.com wrote:
  The of_irq_to_resource() helper that is used to implement of_irq_count()
  tries to resolve interrupts and in fact creates a mapping for resolved
  interrupts. That's pretty heavy lifting for something that claims to
  just return the number of interrupts requested by a given device node.
 
  Instead, use the more lightweight of_irq_map_one(), which, despite the
  name, doesn't create an actual mapping. Perhaps a better name would be
  of_irq_translate_one().
 
  Signed-off-by: Thierry Reding tred...@nvidia.com
 
 Acked-by: Rob Herring rob.herr...@calxeda.com

Applied (and fixed to match the of_irq_map_one -- of_irq_parse_one
rename that I'm going to merge in v3.13).

g.

 
  ---
   drivers/of/irq.c | 3 ++-
   1 file changed, 2 insertions(+), 1 deletion(-)
 
  diff --git a/drivers/of/irq.c b/drivers/of/irq.c
  index 1752988..5f44388 100644
  --- a/drivers/of/irq.c
  +++ b/drivers/of/irq.c
  @@ -368,9 +368,10 @@ EXPORT_SYMBOL_GPL(of_irq_to_resource);
*/
   int of_irq_count(struct device_node *dev)
   {
  +   struct of_irq irq;
  int nr = 0;
 
  -   while (of_irq_to_resource(dev, nr, NULL))
  +   while (of_irq_map_one(dev, nr, irq) == 0)
  nr++;
 
  return nr;
  --
  1.8.4
 
 
  ___
  linux-arm-kernel mailing list
  linux-arm-ker...@lists.infradead.org
  http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 01/10] of/irq: Rework of_irq_count()

2013-10-15 Thread Grant Likely
On Sun, 22 Sep 2013 16:19:27 -0500, Rob Herring robherri...@gmail.com wrote:
 On Wed, Sep 18, 2013 at 8:24 AM, Thierry Reding
 thierry.red...@gmail.com wrote:
  The of_irq_to_resource() helper that is used to implement of_irq_count()
  tries to resolve interrupts and in fact creates a mapping for resolved
  interrupts. That's pretty heavy lifting for something that claims to
  just return the number of interrupts requested by a given device node.
 
  Instead, use the more lightweight of_irq_map_one(), which, despite the
  name, doesn't create an actual mapping. Perhaps a better name would be
  of_irq_translate_one().
 
  Signed-off-by: Thierry Reding tred...@nvidia.com
 
 Acked-by: Rob Herring rob.herr...@calxeda.com

Applied, thanks.

g.

 
  ---
   drivers/of/irq.c | 3 ++-
   1 file changed, 2 insertions(+), 1 deletion(-)
 
  diff --git a/drivers/of/irq.c b/drivers/of/irq.c
  index 1752988..5f44388 100644
  --- a/drivers/of/irq.c
  +++ b/drivers/of/irq.c
  @@ -368,9 +368,10 @@ EXPORT_SYMBOL_GPL(of_irq_to_resource);
*/
   int of_irq_count(struct device_node *dev)
   {
  +   struct of_irq irq;
  int nr = 0;
 
  -   while (of_irq_to_resource(dev, nr, NULL))
  +   while (of_irq_map_one(dev, nr, irq) == 0)
  nr++;
 
  return nr;
  --
  1.8.4
 
 
  ___
  linux-arm-kernel mailing list
  linux-arm-ker...@lists.infradead.org
  http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 01/10] of/irq: Rework of_irq_count()

2013-09-22 Thread Rob Herring
On Wed, Sep 18, 2013 at 8:24 AM, Thierry Reding
 wrote:
> The of_irq_to_resource() helper that is used to implement of_irq_count()
> tries to resolve interrupts and in fact creates a mapping for resolved
> interrupts. That's pretty heavy lifting for something that claims to
> just return the number of interrupts requested by a given device node.
>
> Instead, use the more lightweight of_irq_map_one(), which, despite the
> name, doesn't create an actual mapping. Perhaps a better name would be
> of_irq_translate_one().
>
> Signed-off-by: Thierry Reding 

Acked-by: Rob Herring 

> ---
>  drivers/of/irq.c | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/of/irq.c b/drivers/of/irq.c
> index 1752988..5f44388 100644
> --- a/drivers/of/irq.c
> +++ b/drivers/of/irq.c
> @@ -368,9 +368,10 @@ EXPORT_SYMBOL_GPL(of_irq_to_resource);
>   */
>  int of_irq_count(struct device_node *dev)
>  {
> +   struct of_irq irq;
> int nr = 0;
>
> -   while (of_irq_to_resource(dev, nr, NULL))
> +   while (of_irq_map_one(dev, nr, ) == 0)
> nr++;
>
> return nr;
> --
> 1.8.4
>
>
> ___
> linux-arm-kernel mailing list
> linux-arm-ker...@lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 01/10] of/irq: Rework of_irq_count()

2013-09-22 Thread Rob Herring
On Wed, Sep 18, 2013 at 8:24 AM, Thierry Reding
thierry.red...@gmail.com wrote:
 The of_irq_to_resource() helper that is used to implement of_irq_count()
 tries to resolve interrupts and in fact creates a mapping for resolved
 interrupts. That's pretty heavy lifting for something that claims to
 just return the number of interrupts requested by a given device node.

 Instead, use the more lightweight of_irq_map_one(), which, despite the
 name, doesn't create an actual mapping. Perhaps a better name would be
 of_irq_translate_one().

 Signed-off-by: Thierry Reding tred...@nvidia.com

Acked-by: Rob Herring rob.herr...@calxeda.com

 ---
  drivers/of/irq.c | 3 ++-
  1 file changed, 2 insertions(+), 1 deletion(-)

 diff --git a/drivers/of/irq.c b/drivers/of/irq.c
 index 1752988..5f44388 100644
 --- a/drivers/of/irq.c
 +++ b/drivers/of/irq.c
 @@ -368,9 +368,10 @@ EXPORT_SYMBOL_GPL(of_irq_to_resource);
   */
  int of_irq_count(struct device_node *dev)
  {
 +   struct of_irq irq;
 int nr = 0;

 -   while (of_irq_to_resource(dev, nr, NULL))
 +   while (of_irq_map_one(dev, nr, irq) == 0)
 nr++;

 return nr;
 --
 1.8.4


 ___
 linux-arm-kernel mailing list
 linux-arm-ker...@lists.infradead.org
 http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/