Re: [PATCH v2 05/14] arm64: dts: qcom: sc7280: Add RSC and PDC devices

2021-03-07 Thread Maulik Shah

Hi,

On 3/5/2021 11:12 AM, Rajendra Nayak wrote:


On 3/4/2021 5:34 AM, Stephen Boyd wrote:

Quoting Rajendra Nayak (2021-03-03 04:17:49)
diff --git a/arch/arm64/boot/dts/qcom/sc7280.dtsi 
b/arch/arm64/boot/dts/qcom/sc7280.dtsi

index 4a56d9c..21c2399 100644
--- a/arch/arm64/boot/dts/qcom/sc7280.dtsi
+++ b/arch/arm64/boot/dts/qcom/sc7280.dtsi
@@ -30,6 +31,18 @@
 };
 };
  +   reserved_memory: reserved-memory {


Do we plan to use this label at any point? I'd prefer we remove this
until it becomes useful.


sure, i'll drop it




+   #address-cells = <2>;
+   #size-cells = <2>;
+   ranges;
+
+   aop_cmd_db_mem: memory@8086 {
+   reg = <0x0 0x8086 0x0 0x2>;
+   compatible = "qcom,cmd-db";
+   no-map;
+   };
+   };
+
 cpus {
 #address-cells = <2>;
 #size-cells = <0>;
@@ -203,6 +229,7 @@
 interrupt-controller;
 #interrupt-cells = <2>;
 gpio-ranges = <&tlmm 0 0 175>;
+   wakeup-parent = <&pdc>;
   qup_uart5_default: qup-uart5-default {
 pins = "gpio46", "gpio47";
@@ -287,6 +314,23 @@
 status = "disabled";
 };
 };
+
+   apps_rsc: rsc@1820 {


Any better name than 'rsc'? Maybe 'power-controller'?


hmm, Maulik, any thoughts? This would perhaps need the bindings docs
to be updated as well (and maybe the existing platform DTs using rsc too)


I think we should be good with rsc (resource-state-coordinator). RSC 
itself don't do any resource power management.


Thanks,
Maulik





+   compatible = "qcom,rpmh-rsc";
+   reg = <0 0x1820 0 0x1>,
+ <0 0x1821 0 0x1>,
+ <0 0x1822 0 0x1>;
+   reg-names = "drv-0", "drv-1", "drv-2";
+   interrupts = ,
+    ,
+    ;
+   qcom,tcs-offset = <0xd00>;
+   qcom,drv-id = <2>;
+   qcom,tcs-config = ,
+ ,
+ ,
+ ;
+   };
 };



--
QUALCOMM INDIA, on behalf of Qualcomm Innovation Center, Inc. is a member of 
Code Aurora Forum, hosted by The Linux Foundation



Re: [PATCH v2 05/14] arm64: dts: qcom: sc7280: Add RSC and PDC devices

2021-03-23 Thread Stephen Boyd
Quoting Maulik Shah (2021-03-07 21:21:04)
> Hi,
> 
> On 3/5/2021 11:12 AM, Rajendra Nayak wrote:
> >
> > On 3/4/2021 5:34 AM, Stephen Boyd wrote:
> >> Quoting Rajendra Nayak (2021-03-03 04:17:49)
> >>> diff --git a/arch/arm64/boot/dts/qcom/sc7280.dtsi 
> >>> b/arch/arm64/boot/dts/qcom/sc7280.dtsi
> >>> index 4a56d9c..21c2399 100644
> >>> --- a/arch/arm64/boot/dts/qcom/sc7280.dtsi
> >>> +++ b/arch/arm64/boot/dts/qcom/sc7280.dtsi
> >>> @@ -30,6 +31,18 @@
> >>>  };
> >>>  };
> >>>   +   reserved_memory: reserved-memory {
> >>
> >> Do we plan to use this label at any point? I'd prefer we remove this
> >> until it becomes useful.
> >
> > sure, i'll drop it
> >
> >>
> >>> +   #address-cells = <2>;
> >>> +   #size-cells = <2>;
> >>> +   ranges;
> >>> +
> >>> +   aop_cmd_db_mem: memory@8086 {
> >>> +   reg = <0x0 0x8086 0x0 0x2>;
> >>> +   compatible = "qcom,cmd-db";
> >>> +   no-map;
> >>> +   };
> >>> +   };
> >>> +
> >>>  cpus {
> >>>  #address-cells = <2>;
> >>>  #size-cells = <0>;
> >>> @@ -203,6 +229,7 @@
> >>>  interrupt-controller;
> >>>  #interrupt-cells = <2>;
> >>>  gpio-ranges = <&tlmm 0 0 175>;
> >>> +   wakeup-parent = <&pdc>;
> >>>    qup_uart5_default: qup-uart5-default {
> >>>  pins = "gpio46", "gpio47";
> >>> @@ -287,6 +314,23 @@
> >>>  status = "disabled";
> >>>  };
> >>>  };
> >>> +
> >>> +   apps_rsc: rsc@1820 {
> >>
> >> Any better name than 'rsc'? Maybe 'power-controller'?
> >
> > hmm, Maulik, any thoughts? This would perhaps need the bindings docs
> > to be updated as well (and maybe the existing platform DTs using rsc too)
> 
> I think we should be good with rsc (resource-state-coordinator). RSC 
> itself don't do any resource power management.
> 

Maybe 'mailbox' then? Or 'remoteproc'? I am not "good" with rsc as it
isn't part of the standardized nodes names per the DT spec.


Re: [PATCH v2 05/14] arm64: dts: qcom: sc7280: Add RSC and PDC devices

2021-03-03 Thread Stephen Boyd
Quoting Rajendra Nayak (2021-03-03 04:17:49)
> diff --git a/arch/arm64/boot/dts/qcom/sc7280.dtsi 
> b/arch/arm64/boot/dts/qcom/sc7280.dtsi
> index 4a56d9c..21c2399 100644
> --- a/arch/arm64/boot/dts/qcom/sc7280.dtsi
> +++ b/arch/arm64/boot/dts/qcom/sc7280.dtsi
> @@ -30,6 +31,18 @@
> };
> };
>  
> +   reserved_memory: reserved-memory {

Do we plan to use this label at any point? I'd prefer we remove this
until it becomes useful.

> +   #address-cells = <2>;
> +   #size-cells = <2>;
> +   ranges;
> +
> +   aop_cmd_db_mem: memory@8086 {
> +   reg = <0x0 0x8086 0x0 0x2>;
> +   compatible = "qcom,cmd-db";
> +   no-map;
> +   };
> +   };
> +
> cpus {
> #address-cells = <2>;
> #size-cells = <0>;
> @@ -203,6 +229,7 @@
> interrupt-controller;
> #interrupt-cells = <2>;
> gpio-ranges = <&tlmm 0 0 175>;
> +   wakeup-parent = <&pdc>;
>  
> qup_uart5_default: qup-uart5-default {
> pins = "gpio46", "gpio47";
> @@ -287,6 +314,23 @@
> status = "disabled";
> };
> };
> +
> +   apps_rsc: rsc@1820 {

Any better name than 'rsc'? Maybe 'power-controller'?

> +   compatible = "qcom,rpmh-rsc";
> +   reg = <0 0x1820 0 0x1>,
> + <0 0x1821 0 0x1>,
> + <0 0x1822 0 0x1>;
> +   reg-names = "drv-0", "drv-1", "drv-2";
> +   interrupts = ,
> +,
> +;
> +   qcom,tcs-offset = <0xd00>;
> +   qcom,drv-id = <2>;
> +   qcom,tcs-config = ,
> + ,
> + ,
> + ;
> +   };
> };


Re: [PATCH v2 05/14] arm64: dts: qcom: sc7280: Add RSC and PDC devices

2021-03-04 Thread Rajendra Nayak



On 3/4/2021 5:34 AM, Stephen Boyd wrote:

Quoting Rajendra Nayak (2021-03-03 04:17:49)

diff --git a/arch/arm64/boot/dts/qcom/sc7280.dtsi 
b/arch/arm64/boot/dts/qcom/sc7280.dtsi
index 4a56d9c..21c2399 100644
--- a/arch/arm64/boot/dts/qcom/sc7280.dtsi
+++ b/arch/arm64/boot/dts/qcom/sc7280.dtsi
@@ -30,6 +31,18 @@
 };
 };
  
+   reserved_memory: reserved-memory {


Do we plan to use this label at any point? I'd prefer we remove this
until it becomes useful.


sure, i'll drop it




+   #address-cells = <2>;
+   #size-cells = <2>;
+   ranges;
+
+   aop_cmd_db_mem: memory@8086 {
+   reg = <0x0 0x8086 0x0 0x2>;
+   compatible = "qcom,cmd-db";
+   no-map;
+   };
+   };
+
 cpus {
 #address-cells = <2>;
 #size-cells = <0>;
@@ -203,6 +229,7 @@
 interrupt-controller;
 #interrupt-cells = <2>;
 gpio-ranges = <&tlmm 0 0 175>;
+   wakeup-parent = <&pdc>;
  
 qup_uart5_default: qup-uart5-default {

 pins = "gpio46", "gpio47";
@@ -287,6 +314,23 @@
 status = "disabled";
 };
 };
+
+   apps_rsc: rsc@1820 {


Any better name than 'rsc'? Maybe 'power-controller'?


hmm, Maulik, any thoughts? This would perhaps need the bindings docs
to be updated as well (and maybe the existing platform DTs using rsc too)




+   compatible = "qcom,rpmh-rsc";
+   reg = <0 0x1820 0 0x1>,
+ <0 0x1821 0 0x1>,
+ <0 0x1822 0 0x1>;
+   reg-names = "drv-0", "drv-1", "drv-2";
+   interrupts = ,
+,
+;
+   qcom,tcs-offset = <0xd00>;
+   qcom,drv-id = <2>;
+   qcom,tcs-config = ,
+ ,
+ ,
+ ;
+   };
 };


--
QUALCOMM INDIA, on behalf of Qualcomm Innovation Center, Inc. is a member
of Code Aurora Forum, hosted by The Linux Foundation