Re: [Patch Part3 V3 00/21] Enable support of Intel DMAR device hotplug

2014-06-26 Thread Jiang Liu
On 2014/6/26 2:00, Bjorn Helgaas wrote:
>>   iommu/vt-d: match segment number when searching for dev_iotlb capable
>> devices
>>   iommu/vt-d: use correct domain id to flush virtual machine domains
>>   iommu/vt-d: introduce helper functions to improve code readability
>>   iommu/vt-d: introduce helper functions to make code symmetric for
>> readability
>>   iommu/vt-d: only dynamically allocate domain id for virtual domains
>>   iommu/vt-d: fix possible invalid memory access caused by
>> free_dmar_iommu()
>>   iommu/vt-d: avoid freeing virtual machine domain in free_dmar_iommu()
>>   iommu/VT-d: simplify include/linux/dmar.h
>>   iommu/vt-d: change iommu_enable/disable_translation to return void
>>   iommu/vt-d: simplify intel_unmap_sg() and kill duplicated code
>>   iommu/vt-d: introduce helper domain_pfn_within_range() to simplify
>> code
>>   iommu/vt-d: introduce helper function iova_size() to improve code
>> readability
>>   iommu/vt-d: fix bug in computing domain's iommu_snooping flag
>>   IOMMU/vt-d: introduce helper function dmar_walk_resources()
>>   iommu/vt-d: dynamically allocate and free seq_id for DMAR units
>>   iommu/vt-d: implement DMAR unit hotplug framework
>>   iommu/vt-d: search _DSM method for DMAR hotplug
>>   iommu/vt-d: enhance intel_irq_remapping driver to support DMAR unit
>> hotplug
>>   iommu/vt-d: enhance error recovery in function
>> intel_enable_irq_remapping()
>>   iommu/vt-d: enhance intel-iommu driver to support DMAR unit hotplug
>>   pci, ACPI, iommu: enhance pci_root to support DMAR device hotplug
> 
> This looks a little sloppy; you have three different ways of
> capitalizing the area:
> 
>   iommu/vt-d:
>   iommu/VT-d:
>   IOMMU/vt-d:
> 
> Also, "git log --oneline drivers/iommu" says that the convention for
> drivers/iommu is to capitalize the first word of the rest of the
> subject line.
Hi Bjorn,
Really sorry about my careless. I just rebased the patch set
onto v3.16-rc1, I should do more careful check about the commit
messages. I will wait for more comments and resend a new version
to address the commit message issues.
Thanks for your reminder again.
Regards!
Gerry
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majord...@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [Patch Part3 V3 00/21] Enable support of Intel DMAR device hotplug

2014-06-26 Thread Jiang Liu
On 2014/6/26 2:00, Bjorn Helgaas wrote:
   iommu/vt-d: match segment number when searching for dev_iotlb capable
 devices
   iommu/vt-d: use correct domain id to flush virtual machine domains
   iommu/vt-d: introduce helper functions to improve code readability
   iommu/vt-d: introduce helper functions to make code symmetric for
 readability
   iommu/vt-d: only dynamically allocate domain id for virtual domains
   iommu/vt-d: fix possible invalid memory access caused by
 free_dmar_iommu()
   iommu/vt-d: avoid freeing virtual machine domain in free_dmar_iommu()
   iommu/VT-d: simplify include/linux/dmar.h
   iommu/vt-d: change iommu_enable/disable_translation to return void
   iommu/vt-d: simplify intel_unmap_sg() and kill duplicated code
   iommu/vt-d: introduce helper domain_pfn_within_range() to simplify
 code
   iommu/vt-d: introduce helper function iova_size() to improve code
 readability
   iommu/vt-d: fix bug in computing domain's iommu_snooping flag
   IOMMU/vt-d: introduce helper function dmar_walk_resources()
   iommu/vt-d: dynamically allocate and free seq_id for DMAR units
   iommu/vt-d: implement DMAR unit hotplug framework
   iommu/vt-d: search _DSM method for DMAR hotplug
   iommu/vt-d: enhance intel_irq_remapping driver to support DMAR unit
 hotplug
   iommu/vt-d: enhance error recovery in function
 intel_enable_irq_remapping()
   iommu/vt-d: enhance intel-iommu driver to support DMAR unit hotplug
   pci, ACPI, iommu: enhance pci_root to support DMAR device hotplug
 
 This looks a little sloppy; you have three different ways of
 capitalizing the area:
 
   iommu/vt-d:
   iommu/VT-d:
   IOMMU/vt-d:
 
 Also, git log --oneline drivers/iommu says that the convention for
 drivers/iommu is to capitalize the first word of the rest of the
 subject line.
Hi Bjorn,
Really sorry about my careless. I just rebased the patch set
onto v3.16-rc1, I should do more careful check about the commit
messages. I will wait for more comments and resend a new version
to address the commit message issues.
Thanks for your reminder again.
Regards!
Gerry
 --
 To unsubscribe from this list: send the line unsubscribe linux-kernel in
 the body of a message to majord...@vger.kernel.org
 More majordomo info at  http://vger.kernel.org/majordomo-info.html
 Please read the FAQ at  http://www.tux.org/lkml/
 
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [Patch Part3 V3 00/21] Enable support of Intel DMAR device hotplug

2014-06-25 Thread Bjorn Helgaas
>   iommu/vt-d: match segment number when searching for dev_iotlb capable
> devices
>   iommu/vt-d: use correct domain id to flush virtual machine domains
>   iommu/vt-d: introduce helper functions to improve code readability
>   iommu/vt-d: introduce helper functions to make code symmetric for
> readability
>   iommu/vt-d: only dynamically allocate domain id for virtual domains
>   iommu/vt-d: fix possible invalid memory access caused by
> free_dmar_iommu()
>   iommu/vt-d: avoid freeing virtual machine domain in free_dmar_iommu()
>   iommu/VT-d: simplify include/linux/dmar.h
>   iommu/vt-d: change iommu_enable/disable_translation to return void
>   iommu/vt-d: simplify intel_unmap_sg() and kill duplicated code
>   iommu/vt-d: introduce helper domain_pfn_within_range() to simplify
> code
>   iommu/vt-d: introduce helper function iova_size() to improve code
> readability
>   iommu/vt-d: fix bug in computing domain's iommu_snooping flag
>   IOMMU/vt-d: introduce helper function dmar_walk_resources()
>   iommu/vt-d: dynamically allocate and free seq_id for DMAR units
>   iommu/vt-d: implement DMAR unit hotplug framework
>   iommu/vt-d: search _DSM method for DMAR hotplug
>   iommu/vt-d: enhance intel_irq_remapping driver to support DMAR unit
> hotplug
>   iommu/vt-d: enhance error recovery in function
> intel_enable_irq_remapping()
>   iommu/vt-d: enhance intel-iommu driver to support DMAR unit hotplug
>   pci, ACPI, iommu: enhance pci_root to support DMAR device hotplug

This looks a little sloppy; you have three different ways of
capitalizing the area:

  iommu/vt-d:
  iommu/VT-d:
  IOMMU/vt-d:

Also, "git log --oneline drivers/iommu" says that the convention for
drivers/iommu is to capitalize the first word of the rest of the
subject line.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [Patch Part3 V3 00/21] Enable support of Intel DMAR device hotplug

2014-06-25 Thread Bjorn Helgaas
   iommu/vt-d: match segment number when searching for dev_iotlb capable
 devices
   iommu/vt-d: use correct domain id to flush virtual machine domains
   iommu/vt-d: introduce helper functions to improve code readability
   iommu/vt-d: introduce helper functions to make code symmetric for
 readability
   iommu/vt-d: only dynamically allocate domain id for virtual domains
   iommu/vt-d: fix possible invalid memory access caused by
 free_dmar_iommu()
   iommu/vt-d: avoid freeing virtual machine domain in free_dmar_iommu()
   iommu/VT-d: simplify include/linux/dmar.h
   iommu/vt-d: change iommu_enable/disable_translation to return void
   iommu/vt-d: simplify intel_unmap_sg() and kill duplicated code
   iommu/vt-d: introduce helper domain_pfn_within_range() to simplify
 code
   iommu/vt-d: introduce helper function iova_size() to improve code
 readability
   iommu/vt-d: fix bug in computing domain's iommu_snooping flag
   IOMMU/vt-d: introduce helper function dmar_walk_resources()
   iommu/vt-d: dynamically allocate and free seq_id for DMAR units
   iommu/vt-d: implement DMAR unit hotplug framework
   iommu/vt-d: search _DSM method for DMAR hotplug
   iommu/vt-d: enhance intel_irq_remapping driver to support DMAR unit
 hotplug
   iommu/vt-d: enhance error recovery in function
 intel_enable_irq_remapping()
   iommu/vt-d: enhance intel-iommu driver to support DMAR unit hotplug
   pci, ACPI, iommu: enhance pci_root to support DMAR device hotplug

This looks a little sloppy; you have three different ways of
capitalizing the area:

  iommu/vt-d:
  iommu/VT-d:
  IOMMU/vt-d:

Also, git log --oneline drivers/iommu says that the convention for
drivers/iommu is to capitalize the first word of the rest of the
subject line.
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/