State of the Linux Driver Core Subsystem for 2.6.23-rc8

2007-09-26 Thread Greg KH
Here's a summary of the current state of the Linux Driver core
subsystem, as of 2.6.23-rc8.

If the information in here is incorrect, or anyone knows of any
outstanding issues not listed here, please let me know.

List of outstanding regressions from 2.6.22:
- none known.

List of outstanding regressions from older kernel versions:
- none known.


There are no currently open Driver core or sysfs bugs in bugzilla.


Future patches that are currently in my quilt tree (as found at
http://www.kernel.org/pub/linux/kernel/people/gregkh/gregkh-2.6/
) for the Driver core subsystem are as follows.  All of these will be
submitted for inclusion into 2.6.24, except as noted.  The diffstat of
these patches is included at the bottom of this message for those that
are interested.

- HOWTO ja_JP updates
- metric boatload of changes and tweaks to sysfs from Tejun.
  These clean up the internal usage and implementation of sysfs,
  and split sysfs from the kobject model a lot, fixing a lot of
  problems along the way.  I can't thank him enough for this
  work.
- cleaned up the usage of struct subsystem some more by removing
  some functions that are not needed, or only used by the driver
  core.  Details on the api changes are below
- cleaned up the usage of the kobject->name field and removed it
  entirely.  This saves us some size on every kobject which
  really adds up on those s390 31 bit boxes with 20,000
  different block devices.
- uevent environment variable handling has been made simpler,
  and now hopefully, almost impossible to get wrong.  Previously
  we were forcing every subsystem to open-code a lot of this
  logic.  Thanks to Kay for this work.
- global list of sysdev_drivers is removed, as no one was using
  it at all.
- the number of legacy ptys can now be dynamically specified on
  the kernel command line, allowing people who refuse to fix
  their old applications to be able to still run on newer
  distros that want to limit this number at build time.
- dmi sysfs code cleanups and fixes
- block devices are moved from /sys/block to /sys/class/block.
  This patch has been hanging around for almost a year now, and
  hopefully we have worked out all of the kinks and userspace
  boot breakages.  If anyone has any problems with this, please
  let me and Kay know about it.  I'm hesitant to include it in
  2.6.24 as it has recently changed and needs more testing.
  Maybe it will go into 2.6.25.  Oh, udev has been able to
  handle this for over a year, so there should not be any
  problems with distros that are still supported.  It can also
  be turned off with the CONFIG_SYSFS_DEPRECATED build option
  for older distros.
- new debugfs functions for people who like hex numbers
- platform devices now have the "platform:" alias added to their
  modalias to fix the recursive modprobe loops that Red Hat,
  OLPC, SuSE, and Debian have reported in the current code.
- some struct class_device to struct device conversions were
  done for video and some various char drivers.  More of these
  are on the way.
- cdev kobject name cleanups.  The kobject name of a cdev does
  not do anything, so it should not be set.
- firmware collision fix between i2c and i2c-dev.
- uevent files for bus and driver have been added.  SuSE has
  shipped this for quite some time now.
- if CONFIG_HOTPLUG is not enabled, some more space is saved in
  the uevent code.
- the path to the uevent helper program (traditionally
  /sbin/hotplug) can be specified in the kernel config.  This
  keeps the kernel from having to call a program that is not
  present 300+ times before init starts up, speeding up boot
  time in theory.

New driver core api changes for 2.6.24:
- debugfs_create_x8(), debugfs_create_x16(), and
  debugfs_create_x32() have been added
- struct kobject.name field has been removed.  Use
  kobject_set_name() and kobject_name() to set and get the name.
- uevent callbacks in the driver core and for kobjects have been
  changed from:
int (*uevent)(struct device *dev, char **envp, int num_envp, char 
*buffer, int buffer_size);
  to:
int (*uevent)(struct device *dev, struct kobj_uevent_env *env);
  and struct kobj_uevent_env has been created to make it simpler
  to create environment variables for uevents.
- struct platform_device.id has changed from an u32 to an int.
- the following functions have been removed either entirely or
  from the global namespace:

State of the Linux Driver Core Subsystem for 2.6.23-rc8

2007-09-26 Thread Greg KH
Here's a summary of the current state of the Linux Driver core
subsystem, as of 2.6.23-rc8.

If the information in here is incorrect, or anyone knows of any
outstanding issues not listed here, please let me know.

List of outstanding regressions from 2.6.22:
- none known.

List of outstanding regressions from older kernel versions:
- none known.


There are no currently open Driver core or sysfs bugs in bugzilla.


Future patches that are currently in my quilt tree (as found at
http://www.kernel.org/pub/linux/kernel/people/gregkh/gregkh-2.6/
) for the Driver core subsystem are as follows.  All of these will be
submitted for inclusion into 2.6.24, except as noted.  The diffstat of
these patches is included at the bottom of this message for those that
are interested.

- HOWTO ja_JP updates
- metric boatload of changes and tweaks to sysfs from Tejun.
  These clean up the internal usage and implementation of sysfs,
  and split sysfs from the kobject model a lot, fixing a lot of
  problems along the way.  I can't thank him enough for this
  work.
- cleaned up the usage of struct subsystem some more by removing
  some functions that are not needed, or only used by the driver
  core.  Details on the api changes are below
- cleaned up the usage of the kobject-name field and removed it
  entirely.  This saves us some size on every kobject which
  really adds up on those s390 31 bit boxes with 20,000
  different block devices.
- uevent environment variable handling has been made simpler,
  and now hopefully, almost impossible to get wrong.  Previously
  we were forcing every subsystem to open-code a lot of this
  logic.  Thanks to Kay for this work.
- global list of sysdev_drivers is removed, as no one was using
  it at all.
- the number of legacy ptys can now be dynamically specified on
  the kernel command line, allowing people who refuse to fix
  their old applications to be able to still run on newer
  distros that want to limit this number at build time.
- dmi sysfs code cleanups and fixes
- block devices are moved from /sys/block to /sys/class/block.
  This patch has been hanging around for almost a year now, and
  hopefully we have worked out all of the kinks and userspace
  boot breakages.  If anyone has any problems with this, please
  let me and Kay know about it.  I'm hesitant to include it in
  2.6.24 as it has recently changed and needs more testing.
  Maybe it will go into 2.6.25.  Oh, udev has been able to
  handle this for over a year, so there should not be any
  problems with distros that are still supported.  It can also
  be turned off with the CONFIG_SYSFS_DEPRECATED build option
  for older distros.
- new debugfs functions for people who like hex numbers
- platform devices now have the platform: alias added to their
  modalias to fix the recursive modprobe loops that Red Hat,
  OLPC, SuSE, and Debian have reported in the current code.
- some struct class_device to struct device conversions were
  done for video and some various char drivers.  More of these
  are on the way.
- cdev kobject name cleanups.  The kobject name of a cdev does
  not do anything, so it should not be set.
- firmware collision fix between i2c and i2c-dev.
- uevent files for bus and driver have been added.  SuSE has
  shipped this for quite some time now.
- if CONFIG_HOTPLUG is not enabled, some more space is saved in
  the uevent code.
- the path to the uevent helper program (traditionally
  /sbin/hotplug) can be specified in the kernel config.  This
  keeps the kernel from having to call a program that is not
  present 300+ times before init starts up, speeding up boot
  time in theory.

New driver core api changes for 2.6.24:
- debugfs_create_x8(), debugfs_create_x16(), and
  debugfs_create_x32() have been added
- struct kobject.name field has been removed.  Use
  kobject_set_name() and kobject_name() to set and get the name.
- uevent callbacks in the driver core and for kobjects have been
  changed from:
int (*uevent)(struct device *dev, char **envp, int num_envp, char 
*buffer, int buffer_size);
  to:
int (*uevent)(struct device *dev, struct kobj_uevent_env *env);
  and struct kobj_uevent_env has been created to make it simpler
  to create environment variables for uevents.
- struct platform_device.id has changed from an u32 to an int.
- the following functions have been removed either entirely or
  from the global namespace:
get_bus()