Re: [PATCH 3/5] media: Rename graph and pipeline structs and functions

2016-12-08 Thread Laurent Pinchart
Hi Sakari,

Thank you for the patch.

On Friday 25 Nov 2016 15:55:44 Sakari Ailus wrote:
> The media_entity_pipeline_start() and media_entity_pipeline_stop()
> functions are renamed as media_pipeline_start() and media_pipeline_stop(),
> respectively. The reason is two-fold: the pipeline struct is, rightly,
> already called media_pipeline (rather than media_entity_pipeline) and what
> this really is about is a pipeline. A pipeline consists of entities ---
> and, well, other objects embedded in these entities.
> 
> As the pipeline object will be in the future moved from entities to pads
> in order to support multiple pipelines through a single entity, do the
> renaming now.
> 
> Similarly, functions operating on struct media_entity_graph as well as the
> struct itself are renamed by dropping the "entity_" part from the prefix
> of the function family and the data structure. The graph traversal which
> is what the functions are about is not specifically about entities only
> and will operate on pads for the same reason as the media pipeline.
> 
> The patch has been generated using the following command:
> 
> git grep -l media_entity |xargs perl -i -pe '
>   s/media_entity_pipeline/media_pipeline/g;
>   s/media_entity_graph/media_graph/g'
> 
> And a few manual edits related to line start alignment and line wrapping.
> 
> Signed-off-by: Sakari Ailus 

Acked-by: Laurent Pinchart 

> ---
>  Documentation/media/kapi/mc-core.rst   | 18 ++---
>  drivers/media/media-device.c   |  8 +--
>  drivers/media/media-entity.c   | 77 ++-
>  drivers/media/platform/exynos4-is/fimc-capture.c   |  8 +--
>  drivers/media/platform/exynos4-is/fimc-isp-video.c |  8 +--
>  drivers/media/platform/exynos4-is/fimc-lite.c  |  8 +--
>  drivers/media/platform/exynos4-is/media-dev.c  | 16 ++---
>  drivers/media/platform/exynos4-is/media-dev.h  |  2 +-
>  drivers/media/platform/omap3isp/ispvideo.c | 16 ++---
>  drivers/media/platform/s3c-camif/camif-capture.c   |  6 +-
>  drivers/media/platform/vsp1/vsp1_drm.c |  4 +-
>  drivers/media/platform/vsp1/vsp1_video.c   | 16 ++---
>  drivers/media/platform/xilinx/xilinx-dma.c | 16 ++---
>  drivers/media/usb/au0828/au0828-core.c |  4 +-
>  drivers/media/v4l2-core/v4l2-mc.c  | 18 ++---
>  drivers/staging/media/davinci_vpfe/vpfe_video.c| 25 ---
>  drivers/staging/media/davinci_vpfe/vpfe_video.h|  2 +-
>  drivers/staging/media/omap4iss/iss_video.c | 32 -
>  include/media/media-device.h   |  2 +-
>  include/media/media-entity.h   | 65 +-
>  20 files changed, 174 insertions(+), 177 deletions(-)

-- 
Regards,

Laurent Pinchart

--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH 3/5] media: Rename graph and pipeline structs and functions

2016-11-25 Thread Sakari Ailus
The media_entity_pipeline_start() and media_entity_pipeline_stop()
functions are renamed as media_pipeline_start() and media_pipeline_stop(),
respectively. The reason is two-fold: the pipeline struct is, rightly,
already called media_pipeline (rather than media_entity_pipeline) and what
this really is about is a pipeline. A pipeline consists of entities ---
and, well, other objects embedded in these entities.

As the pipeline object will be in the future moved from entities to pads
in order to support multiple pipelines through a single entity, do the
renaming now.

Similarly, functions operating on struct media_entity_graph as well as the
struct itself are renamed by dropping the "entity_" part from the prefix
of the function family and the data structure. The graph traversal which
is what the functions are about is not specifically about entities only
and will operate on pads for the same reason as the media pipeline.

The patch has been generated using the following command:

git grep -l media_entity |xargs perl -i -pe '
s/media_entity_pipeline/media_pipeline/g;
s/media_entity_graph/media_graph/g'

And a few manual edits related to line start alignment and line wrapping.

Signed-off-by: Sakari Ailus 
---
 Documentation/media/kapi/mc-core.rst   | 18 ++---
 drivers/media/media-device.c   |  8 +--
 drivers/media/media-entity.c   | 77 +++---
 drivers/media/platform/exynos4-is/fimc-capture.c   |  8 +--
 drivers/media/platform/exynos4-is/fimc-isp-video.c |  8 +--
 drivers/media/platform/exynos4-is/fimc-lite.c  |  8 +--
 drivers/media/platform/exynos4-is/media-dev.c  | 16 ++---
 drivers/media/platform/exynos4-is/media-dev.h  |  2 +-
 drivers/media/platform/omap3isp/ispvideo.c | 16 ++---
 drivers/media/platform/s3c-camif/camif-capture.c   |  6 +-
 drivers/media/platform/vsp1/vsp1_drm.c |  4 +-
 drivers/media/platform/vsp1/vsp1_video.c   | 16 ++---
 drivers/media/platform/xilinx/xilinx-dma.c | 16 ++---
 drivers/media/usb/au0828/au0828-core.c |  4 +-
 drivers/media/v4l2-core/v4l2-mc.c  | 18 ++---
 drivers/staging/media/davinci_vpfe/vpfe_video.c| 25 ---
 drivers/staging/media/davinci_vpfe/vpfe_video.h|  2 +-
 drivers/staging/media/omap4iss/iss_video.c | 32 -
 include/media/media-device.h   |  2 +-
 include/media/media-entity.h   | 65 +-
 20 files changed, 174 insertions(+), 177 deletions(-)

diff --git a/Documentation/media/kapi/mc-core.rst 
b/Documentation/media/kapi/mc-core.rst
index 1a738e5..0c05503 100644
--- a/Documentation/media/kapi/mc-core.rst
+++ b/Documentation/media/kapi/mc-core.rst
@@ -162,13 +162,13 @@ framework provides a depth-first graph traversal API for 
that purpose.
currently defined as 16.
 
 Drivers initiate a graph traversal by calling
-:c:func:`media_entity_graph_walk_start()`
+:c:func:`media_graph_walk_start()`
 
 The graph structure, provided by the caller, is initialized to start graph
 traversal at the given entity.
 
 Drivers can then retrieve the next entity by calling
-:c:func:`media_entity_graph_walk_next()`
+:c:func:`media_graph_walk_next()`
 
 When the graph traversal is complete the function will return ``NULL``.
 
@@ -206,7 +206,7 @@ Pipelines and media streams
 
 When starting streaming, drivers must notify all entities in the pipeline to
 prevent link states from being modified during streaming by calling
-:c:func:`media_entity_pipeline_start()`.
+:c:func:`media_pipeline_start()`.
 
 The function will mark all entities connected to the given entity through
 enabled links, either directly or indirectly, as streaming.
@@ -218,17 +218,17 @@ in higher-level pipeline structures and can then access 
the
 pipeline through the struct :c:type:`media_entity`
 pipe field.
 
-Calls to :c:func:`media_entity_pipeline_start()` can be nested.
+Calls to :c:func:`media_pipeline_start()` can be nested.
 The pipeline pointer must be identical for all nested calls to the function.
 
-:c:func:`media_entity_pipeline_start()` may return an error. In that case,
+:c:func:`media_pipeline_start()` may return an error. In that case,
 it will clean up any of the changes it did by itself.
 
 When stopping the stream, drivers must notify the entities with
-:c:func:`media_entity_pipeline_stop()`.
+:c:func:`media_pipeline_stop()`.
 
-If multiple calls to :c:func:`media_entity_pipeline_start()` have been
-made the same number of :c:func:`media_entity_pipeline_stop()` calls
+If multiple calls to :c:func:`media_pipeline_start()` have been
+made the same number of :c:func:`media_pipeline_stop()` calls
 are required to stop streaming.
 The :c:type:`media_entity`.\ ``pipe`` field is reset to ``NULL`` on the last
 nested stop call.
@@ -245,7 +245,7 @@ operation must be done with the media_device graph_mutex 
held.
 Link validation
 ^^^
 
-Link validation is perf