Re: [PATCH/RFC 1/2] Add Dspbridge driver to OMAP GIT kernel

2008-06-14 Thread Koen Kooi

-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1


Op 14 jun 2008, om 02:01 heeft Kanigeri, Hari het volgende geschreven:



This patch adds the dspbridge driver functionality for OMAP3 platform
to the OMAP GIT kernel. DSP Bridge driver provides features to control
and communicate with DSP enabling parallel processing for multimedia
acceleration. It enables the applications running on MCU to offload
the processing to DSP.

Some of the key features of DSP Bridge are listed below.

- Messaging: Ability to exchange fixed size control messages with DSP.
- Dynamic memory management: Ability to dynamically map files to DSP
address
space.
- Dynamic loading: Ability to dynamically load new nodes on DSP at run
time.
- Power Management: Static and dynamic power management for DSP.

The patch is available at
http://www.omapzoom.org/pub/dspbridge/dspbridge_mpu_driver.patch

The documents for reference can be accessed from
http://www.omapzoom.org/pub/dspbridge/db_linux_pguide.pdf
http://www.omapzoom.org/pub/dspbridge/db_linux_rguide.pdf
http://www.omapzoom.org/pub/dspbridge/ 
Linux_Bridge_Integration_3430.pdf


Please let me know your comments on how we can work to include the
Dspbridge driver source code in OMAP GIT tree.


That still seems to have the OSAL layer. I don't think the linux  
kernel needs code to support things like symbian and windows mobile.


regards,

Koen







Please let me know if you need any additional information or questions
on dspbridge.

Thank you,
Best regards,
Hari
--
To unsubscribe from this list: send the line "unsubscribe linux- 
omap" in

the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html



-BEGIN PGP SIGNATURE-
Version: GnuPG v1.4.5 (Darwin)

iD8DBQFIU4XDMkyGM64RGpERAp1cAKCl1amRWN9D0LbELsk0veON+TR6RwCfUPv8
TPiGLJ2+cjlf0tneY0UuPHE=
=GFHv
-END PGP SIGNATURE-
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 21/21] ARM: OMAP: Add OMAP chip type structure; clean up mach-omap2/id.c

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:30:53PM -0700, Tony Lindgren wrote:
> omap_chip is set in mach-omap2/id.c by _set_omap_chip(). Other
> code should use the omap_chip_is() function to test against omap_chip.

> +/**
> + * omap_chip_is - test whether currently running OMAP matches a chip type
> + * @oc: omap_chip_t to test against
> + *
> + * Test whether the currently-running OMAP chip matches the supplied
> + * chip type 'oc'.  Returns 1 upon a match; 0 upon failure.
> + */
> +int omap_chip_is(struct omap_chip_id oci)
> +{
> + return (oci.oc & omap_chip.oc) ? 1 : 0;
> +}
> +EXPORT_SYMBOL(omap_chip_is);

I've not seen any use cases for this function, so I don't know how it's
intended to be used.  However, is it really sensible for this to take a
structure rather than just a value?
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 20/21] ARM: OMAP: Turn CM and PRM access into functions

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:30:52PM -0700, Tony Lindgren wrote:
> Otherwise compiling in omap2 and omap3 will not work.
> 
> Signed-off-by: Tony Lindgren <[EMAIL PROTECTED]>

Ok.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 19/21] ARM: OMAP: Introduce omap_globals and prcm access functions for multi-omap

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:30:51PM -0700, Tony Lindgren wrote:
> @@ -51,7 +50,7 @@ u32 omap_ctrl_readl(u16 offset)
>  void omap_ctrl_writeb(u8 val, u16 offset)
>  {
>   pr_debug("omap_ctrl_writeb: writing 0x%0x to 0x%0x\n", val,
> -  (u32)OMAP_CTRL_REGADDR(offset));
> +  (__force u32)OMAP_CTRL_REGADDR(offset));

Casting to unsigned long avoids the need for __force.  __force should be
used sparingly.  Alternatively, use '%p' to print a pointer.

Apart from that, ok.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 18/21] ARM: OMAP: Remove __REG access for multi-omap

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:30:50PM -0700, Tony Lindgren wrote:
> This does not play nicely with multi-omap as it cannot be replaced
> by a function in io.c for omaps with different IO bases.
> 
> Signed-off-by: Tony Lindgren <[EMAIL PROTECTED]>

Ok.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 02/21] ARM: OMAP: DMTimer: Optimize by adding load and start

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:30:34PM -0700, Tony Lindgren wrote:
> From: Richard Woodruff <[EMAIL PROTECTED]>
> 
> This patch optimizes the timer load and start sequence.  By combining the
> load and start a needless posted wait can be removed from the system timer
> execution path.
> 
> * Before patch register writes are taking up .078% @ 500MHz during idle.
> 
>  Address |total  |min  |max  |avr |count|ratio%
>  old\process\default_idle|7.369s |0.0us|999.902ms|14.477ms|509. |62.661%
>  ld\Global\cpu_v7_do_idle|4.265s |0.0us|375.786ms|24.374ms|175. |36.270%
> (UNKNOWN)|17.503ms|0.us|531.080us|5.119us|3419. |0.148%
>  r\omap_dm_timer_set_load|8.135ms|0.0us|79.887us|15.065us|540.  |0.069% <--
>  \vmlinux-old\Global\_end|2.023ms|0.0us|4.000us|0.560us|3613.   |0.017%
>  -old\Global\__raw_readsw|1.962ms|0.0us|108.610us|9.167us|214.  |0.016%
>  old\smc91x\smc_interrupt|1.353ms|0.0us|10.212us|2.348us|576.   |0.011%
>  s/namei\__link_path_walk|1.161ms|0.0us|4.310us|0.762us|  1524. |0.009%
>  \omap_dm_timer_write_reg|1.085ms|0.0us|126.150us|2.153us|504.  |0.009% <--
> 
> * After patch timer functions do not show up in top listings for long 
> captures.

Ok.  Not for -rc.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 10/21] ARM: OMAP: McBSP: Coding style cleanup on arch/arm/plat-omap/mcbsp.c

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:30:42PM -0700, Tony Lindgren wrote:
> From: Eduardo Valentin <[EMAIL PROTECTED]>
> 
> This patch fix lots of warnings and errors reported by
> scripts/checkpatch.pl on arch/arm/plat-omap/mcbsp.c.
> 
> Signed-off-by: Eduardo Valentin <[EMAIL PROTECTED]>
> Acked-by: Felipe Balbi <[EMAIL PROTECTED]>
> Signed-off-by: Tony Lindgren <[EMAIL PROTECTED]>
> 
> diff --git a/arch/arm/plat-omap/mcbsp.c b/arch/arm/plat-omap/mcbsp.c
> index 9cf83c4..053de31 100644
> --- a/arch/arm/plat-omap/mcbsp.c
> +++ b/arch/arm/plat-omap/mcbsp.c
> @@ -21,9 +21,8 @@
>  #include 
>  #include 
>  #include 
> -
> -#include 
> -#include 
> +#include 
> +#include 

checkpatch isn't always right.  In the case of linux/irq.h vs asm/irq.h
they are not equivalent.  linux/irq.h is the genirq header file.  asm/irq.h
is the architecture irq.h file.  The two are quite different (unlike the
linux/io.h and asm/io.h case.)

Unless you're doing something with static IRQ numbers, you shouldn't need
either of these irq.h headers - the one you generally want for drivers is
linux/interrupt.h.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 11/21] ARM: OMAP: McBSP: Prepare for splitting into omap1 and omap2 code

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:30:43PM -0700, Tony Lindgren wrote:
> +#if defined(CONFIG_OMAP_MCBSP) || defined(CONFIG_OMAP_MCBSP_MODULE)
> +
> +static struct platform_device omap_mcbsp_devices[OMAP_MAX_MCBSP_COUNT];
> +static int mcbsps_configured;
> +
> +void omap_mcbsp_register_board_cfg(struct omap_mcbsp_platform_data *config,
> + int size)
> +{
> + int i;
> +
> + if (size > OMAP_MAX_MCBSP_COUNT) {
> + printk(KERN_WARNING "Registered too many McBSPs platform_data."
> + " Using maximum (%d) available.\n",
> + OMAP_MAX_MCBSP_COUNT);
> + size = OMAP_MAX_MCBSP_COUNT;
> + }
> +
> + for (i = 0; i < size; i++) {
> + struct platform_device *new_mcbsp = &omap_mcbsp_devices[i];

Any reason this can't use the platform_device_alloc() API rather than
having a static restriction on the number (coupled with the wastage of
space for smaller 'size's ?)
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 06/21] ARM: OMAP: DMA: Clean-up code

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:30:38PM -0700, Tony Lindgren wrote:
> @@ -431,8 +474,8 @@ struct omap_dma_channel_params {
>  
>  extern void omap_set_dma_priority(int lch, int dst_port, int priority);
>  extern int omap_request_dma(int dev_id, const char *dev_name,
> - void (* callback)(int lch, u16 ch_status, void 
> *data),
> - void *data, int *dma_ch);
> + void (*callback)(int lch, u16 ch_status,
> + void *data), void *data, int *dma_ch);

This is an example where checkpatch is not entirely correct - wrapping
the 'callback' type makes it less readable.  Just let it flow over column
80, or maybe use:

void (*callback)(int, u16, void *),

since all we actually need there is the type of the callback.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 08/21] ARM: OMAP: SRAM: Move omap2 sram-fn.S to sram242x.S

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:30:40PM -0700, Tony Lindgren wrote:
> This file will get split between sram242x.S and sram243x.S
> in following patch.
> 
> Signed-off-by: Tony Lindgren <[EMAIL PROTECTED]>

Please use '-M' so git diff detects renames.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 05/21] ARM: OMAP: DMA: Remove __REG access

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:30:37PM -0700, Tony Lindgren wrote:
> Remove __REG access in DMA code, use dma_read/write instead:
> 
> - dynamically set the omap_dma_base based on the omap type
> 
> - omap_read/write becomes dma_read/write
> - dma channel registers are read with dma_ch_read/write
> 
> Cc: David Brownell <[EMAIL PROTECTED]>
> Cc: [EMAIL PROTECTED]
> Signed-off-by: Tony Lindgren <[EMAIL PROTECTED]>
> 
> diff --git a/arch/arm/plat-omap/dma.c b/arch/arm/plat-omap/dma.c
> index 02f00a9..50f83bc 100644
> --- a/arch/arm/plat-omap/dma.c
> +++ b/arch/arm/plat-omap/dma.c
> @@ -126,6 +126,7 @@ static int dma_chan_count;
>  
>  static spinlock_t dma_chan_lock;
>  static struct omap_dma_lch *dma_chan;
> +void __iomem *omap_dma_base;

Shouldn't this be static?
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 04/21] ARM: OMAP: DMA: Make channels dynamic for multi-boot

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:30:36PM -0700, Tony Lindgren wrote:
> Make DMA channels dynamic for multi-boot
> 
> Signed-off-by: Tony Lindgren <[EMAIL PROTECTED]>

Ok.  Not for -rc.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 02/02] ARM: OMAP: Correcting the gpmc prefetch control register address

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:21:48PM -0700, Tony Lindgren wrote:
> From: Thara Gopinath <[EMAIL PROTECTED]>
> 
> Correcting the GPMC_PREFETCH_CONTROL register address
> 
> Signed-off-by: Thara Gopinath <[EMAIL PROTECTED]>
> Signed-off-by: Tony Lindgren <[EMAIL PROTECTED]>

This looks like something for -rc.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 01/02] ARM: OMAP: DMA: Don't mark channel active in omap_enable_channel_irq

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:21:47PM -0700, Tony Lindgren wrote:
> From: Jarkko Nikula <[EMAIL PROTECTED]>
> 
> Channel should be marked active only when DMA is really started. Otherwise
> just omap_request_dma, omap_dma_link_lch and omap_dma_unlink_lch will cause
> incorrect dump_stack().
> 
> Signed-off-by: Jarkko Nikula <[EMAIL PROTECTED]>
> Signed-off-by: Tony Lindgren <[EMAIL PROTECTED]>

BTW, this looks like something for -rc kernels.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 03/21] ARM: OMAP: Add OMAP3430 base defines

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:30:35PM -0700, Tony Lindgren wrote:
> From: Paul Walmsley <[EMAIL PROTECTED]>
> 
> Add symbolic constants for OMAP3430 base addresses; include that file
> in hardware.h.
> 
> Signed-off-by: Paul Walmsley <[EMAIL PROTECTED]>
> Signed-off-by: Tony Lindgren <[EMAIL PROTECTED]>

> +#define IRQ_SIR_IRQ  0x0040

Aren't IRQ numbers normally decimal?
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 02/02] ARM: OMAP: Correcting the gpmc prefetch control register address

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:21:48PM -0700, Tony Lindgren wrote:
> From: Thara Gopinath <[EMAIL PROTECTED]>
> 
> Correcting the GPMC_PREFETCH_CONTROL register address
> 
> Signed-off-by: Thara Gopinath <[EMAIL PROTECTED]>
> Signed-off-by: Tony Lindgren <[EMAIL PROTECTED]>

Ok.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 01/02] ARM: OMAP: DMA: Don't mark channel active in omap_enable_channel_irq

2008-06-14 Thread Russell King - ARM Linux
On Fri, Jun 06, 2008 at 06:21:47PM -0700, Tony Lindgren wrote:
> From: Jarkko Nikula <[EMAIL PROTECTED]>
> 
> Channel should be marked active only when DMA is really started. Otherwise
> just omap_request_dma, omap_dma_link_lch and omap_dma_unlink_lch will cause
> incorrect dump_stack().
> 
> Signed-off-by: Jarkko Nikula <[EMAIL PROTECTED]>
> Signed-off-by: Tony Lindgren <[EMAIL PROTECTED]>

Ok.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html