Re: [PATCH]omap hsmmc: fix incorrect capability reporting

2010-03-30 Thread kishore kadiyala
please drop this patch , as correct patch is available at
https://patchwork.kernel.org/patch/78713/

Regards,
Kishore

On Wed, Mar 31, 2010 at 12:12 AM, Venkatraman S  wrote:
> Nishanth Menon  wrote:
>> S, Venkatraman had written, on 03/30/2010 01:11 PM, the following:
>> [..]
>
> diff --git a/drivers/mmc/host/omap_hsmmc.c
> b/drivers/mmc/host/omap_hsmmc.c
> index 83f0aff..dbf83a6 100644
> --- a/drivers/mmc/host/omap_hsmmc.c
> +++ b/drivers/mmc/host/omap_hsmmc.c
> @@ -2093,7 +2093,7 @@ static int __init omap_hsmmc_probe(struct
> platform_device *pdev)
>
>      if (mmc_slot(host).wires >= 8)
>              mmc->caps |= MMC_CAP_8_BIT_DATA;
> -     else if (mmc_slot(host).wires >= 4)
> +     if (mmc_slot(host).wires >= 4)
>              mmc->caps |= MMC_CAP_4_BIT_DATA;
>
 Since 8-bit is the max how about:

       if (mmc_slot(host).wires == 8)
               mmc->caps |= MMC_CAP_8_BIT_DATA | MMC_CAP_4_BIT_DATA;
       if (mmc_slot(host).wires == 4)
               mmc->caps |= MMC_CAP_4_BIT_DATA;

 This would be little easy to read the code.
>>>
>>> Sure. Works for me.
>>
>> nitpicky comment: might be better off using a switch(mmc_slot(host).wires)
>> statement instead of using == if that is the intention here..
>
> Too verbose for just 2 cases, with the 'case's and 'default's adding
> nothing to readability. YMMV.
>
> Thanks,
> Venkat.
> --
> To unsubscribe from this list: send the line "unsubscribe linux-omap" in
> the body of a message to majord...@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
>
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH]omap hsmmc: fix incorrect capability reporting

2010-03-30 Thread Venkatraman S
Nishanth Menon  wrote:
> S, Venkatraman had written, on 03/30/2010 01:11 PM, the following:
> [..]

 diff --git a/drivers/mmc/host/omap_hsmmc.c
 b/drivers/mmc/host/omap_hsmmc.c
 index 83f0aff..dbf83a6 100644
 --- a/drivers/mmc/host/omap_hsmmc.c
 +++ b/drivers/mmc/host/omap_hsmmc.c
 @@ -2093,7 +2093,7 @@ static int __init omap_hsmmc_probe(struct
 platform_device *pdev)

      if (mmc_slot(host).wires >= 8)
              mmc->caps |= MMC_CAP_8_BIT_DATA;
 -     else if (mmc_slot(host).wires >= 4)
 +     if (mmc_slot(host).wires >= 4)
              mmc->caps |= MMC_CAP_4_BIT_DATA;

>>> Since 8-bit is the max how about:
>>>
>>>       if (mmc_slot(host).wires == 8)
>>>               mmc->caps |= MMC_CAP_8_BIT_DATA | MMC_CAP_4_BIT_DATA;
>>>       if (mmc_slot(host).wires == 4)
>>>               mmc->caps |= MMC_CAP_4_BIT_DATA;
>>>
>>> This would be little easy to read the code.
>>
>> Sure. Works for me.
>
> nitpicky comment: might be better off using a switch(mmc_slot(host).wires)
> statement instead of using == if that is the intention here..

Too verbose for just 2 cases, with the 'case's and 'default's adding
nothing to readability. YMMV.

Thanks,
Venkat.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH]omap hsmmc: fix incorrect capability reporting

2010-03-30 Thread Nishanth Menon

S, Venkatraman had written, on 03/30/2010 01:11 PM, the following:
[..]

diff --git a/drivers/mmc/host/omap_hsmmc.c b/drivers/mmc/host/omap_hsmmc.c
index 83f0aff..dbf83a6 100644
--- a/drivers/mmc/host/omap_hsmmc.c
+++ b/drivers/mmc/host/omap_hsmmc.c
@@ -2093,7 +2093,7 @@ static int __init omap_hsmmc_probe(struct
platform_device *pdev)

  if (mmc_slot(host).wires >= 8)
  mmc->caps |= MMC_CAP_8_BIT_DATA;
- else if (mmc_slot(host).wires >= 4)
+ if (mmc_slot(host).wires >= 4)
  mmc->caps |= MMC_CAP_4_BIT_DATA;


Since 8-bit is the max how about:

   if (mmc_slot(host).wires == 8)
   mmc->caps |= MMC_CAP_8_BIT_DATA | MMC_CAP_4_BIT_DATA;
   if (mmc_slot(host).wires == 4)
   mmc->caps |= MMC_CAP_4_BIT_DATA;

This would be little easy to read the code.


Sure. Works for me.
nitpicky comment: might be better off using a 
switch(mmc_slot(host).wires) statement instead of using == if that is 
the intention here..


--
Regards,
Nishanth Menon
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH]omap hsmmc: fix incorrect capability reporting

2010-03-30 Thread Venkatraman S
> Madhusudhan  wrote:
>
>
>> -Original Message-
>> From: Venkatraman S
>> Sent: Tuesday, March 30, 2010 9:37 AM
>> To: linux-...@vger.kernel.org; linux-omap@vger.kernel.org;
>> kishore.kadiy...@ti.com
>> Cc: Madhusudhan Chikkature
>> Subject: [PATCH]omap hsmmc: fix incorrect capability reporting
>>
>> MMC slots that support 8 bit mode also support 4 bit mode.
>> The capability flag has to reflect this, otherwise SDHC cards operate
>> in 1 bit mode.
>>
>> Signed-off-by: Kishore Kadiyala 
>> Signed-off-by: Venkatraman S 
>> ---
>>  drivers/mmc/host/omap_hsmmc.c |    2 +-
>>  1 files changed, 1 insertions(+), 1 deletions(-)
>>
>> diff --git a/drivers/mmc/host/omap_hsmmc.c b/drivers/mmc/host/omap_hsmmc.c
>> index 83f0aff..dbf83a6 100644
>> --- a/drivers/mmc/host/omap_hsmmc.c
>> +++ b/drivers/mmc/host/omap_hsmmc.c
>> @@ -2093,7 +2093,7 @@ static int __init omap_hsmmc_probe(struct
>> platform_device *pdev)
>>
>>       if (mmc_slot(host).wires >= 8)
>>               mmc->caps |= MMC_CAP_8_BIT_DATA;
>> -     else if (mmc_slot(host).wires >= 4)
>> +     if (mmc_slot(host).wires >= 4)
>>               mmc->caps |= MMC_CAP_4_BIT_DATA;
>>
>
> Since 8-bit is the max how about:
>
>        if (mmc_slot(host).wires == 8)
>                mmc->caps |= MMC_CAP_8_BIT_DATA | MMC_CAP_4_BIT_DATA;
>        if (mmc_slot(host).wires == 4)
>                mmc->caps |= MMC_CAP_4_BIT_DATA;
>
> This would be little easy to read the code.

Sure. Works for me.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


RE: [PATCH]omap hsmmc: fix incorrect capability reporting

2010-03-30 Thread Madhusudhan


> -Original Message-
> From: svenk...@gmail.com [mailto:svenk...@gmail.com] On Behalf Of
> Venkatraman S
> Sent: Tuesday, March 30, 2010 9:37 AM
> To: linux-...@vger.kernel.org; linux-omap@vger.kernel.org;
> kishore.kadiy...@ti.com
> Cc: Madhusudhan Chikkature
> Subject: [PATCH]omap hsmmc: fix incorrect capability reporting
> 
> MMC slots that support 8 bit mode also support 4 bit mode.
> The capability flag has to reflect this, otherwise SDHC cards operate
> in 1 bit mode.
> 
> Signed-off-by: Kishore Kadiyala 
> Signed-off-by: Venkatraman S 
> ---
>  drivers/mmc/host/omap_hsmmc.c |2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/drivers/mmc/host/omap_hsmmc.c b/drivers/mmc/host/omap_hsmmc.c
> index 83f0aff..dbf83a6 100644
> --- a/drivers/mmc/host/omap_hsmmc.c
> +++ b/drivers/mmc/host/omap_hsmmc.c
> @@ -2093,7 +2093,7 @@ static int __init omap_hsmmc_probe(struct
> platform_device *pdev)
> 
>   if (mmc_slot(host).wires >= 8)
>   mmc->caps |= MMC_CAP_8_BIT_DATA;
> - else if (mmc_slot(host).wires >= 4)
> + if (mmc_slot(host).wires >= 4)
>   mmc->caps |= MMC_CAP_4_BIT_DATA;
> 

Since 8-bit is the max how about:

if (mmc_slot(host).wires == 8)
mmc->caps |= MMC_CAP_8_BIT_DATA | MMC_CAP_4_BIT_DATA;
if (mmc_slot(host).wires == 4)
mmc->caps |= MMC_CAP_4_BIT_DATA;

This would be little easy to read the code.

Regards,
Madhu

>   if (mmc_slot(host).nonremovable)
> --
> 1.6.3.3

--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH]omap hsmmc: fix incorrect capability reporting

2010-03-30 Thread Venkatraman S
MMC slots that support 8 bit mode also support 4 bit mode.
The capability flag has to reflect this, otherwise SDHC cards operate
in 1 bit mode.

Signed-off-by: Kishore Kadiyala 
Signed-off-by: Venkatraman S 
---
 drivers/mmc/host/omap_hsmmc.c |2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/drivers/mmc/host/omap_hsmmc.c b/drivers/mmc/host/omap_hsmmc.c
index 83f0aff..dbf83a6 100644
--- a/drivers/mmc/host/omap_hsmmc.c
+++ b/drivers/mmc/host/omap_hsmmc.c
@@ -2093,7 +2093,7 @@ static int __init omap_hsmmc_probe(struct
platform_device *pdev)

if (mmc_slot(host).wires >= 8)
mmc->caps |= MMC_CAP_8_BIT_DATA;
-   else if (mmc_slot(host).wires >= 4)
+   if (mmc_slot(host).wires >= 4)
mmc->caps |= MMC_CAP_4_BIT_DATA;

if (mmc_slot(host).nonremovable)
-- 
1.6.3.3
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html