Re: [PATCH v2 00/17] Big OMAP I2C Cleanup

2012-07-02 Thread Shubhrajyoti
On Monday 02 July 2012 05:07 PM, Felipe Balbi wrote:
> Hi,
>
> On Tue, Jun 26, 2012 at 04:21:30PM +0530, Shubhrajyoti wrote:
>> On Thursday 14 June 2012 11:29 PM, Wolfram Sang wrote:
- removed dev_err() which was introduced on patch 09/17
>>> To prevent the list being flooded, I would appreciate if you could wait
>>> a few days to collect reviews before resending. It will take some time
>>> until I pick this series anyhow, because I want people to have time to
>>> donate Tested-by tags.
>> Felipe thats a good cleanup.
>> The series look good to me.
>>
>> Also draining interrupt I had some queries.
>> Looks good to me.
>>
>> I have tested it after rebasing.
> rebasing on top of what ? 
On top of embedded i2c branch of Wolfram.

> You should resend the series so that I know
> what changes you have made to my original patchset. Make sure to list on
> the commit log what where the changes you made, so that it looks
> something like this commit below where I changed commit log a bit:
Will do that.
Thanks,

> | commit 3daf74d78dfcd552445c35f1b82a271ca305ceb9
> | Author: Pratyush Anand 
> | Date:   Sat Jun 23 02:23:08 2012 +0530
> | 
> | usb: dwc3: remove WARN_ON from dwc_stop_active_transfer
> | 
> | Now we are sure that, if res_trans_idx is zero, then endpoint has been
> | stopped. So it's safe to just return if endpoint is already stopped. No
> | need to generate warning anymore.
> | 
> | While doing so, it's better to return when res_trans_idx is zero and
> | decrease one level of indentation.
> | 
> | Signed-off-by: Pratyush Anand 
> | 
> | [ ba...@ti.com: slightly changed commit log ]
> | 
> | Signed-off-by: Felipe Balbi 
>
>> Tested-by : Shubhrajyoti 
> since you will send, you should, probably, add your Signed-off-by,
> instead of Tested-by. dunno.
>

--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH v2 00/17] Big OMAP I2C Cleanup

2012-07-02 Thread Felipe Balbi
Hi,

On Tue, Jun 26, 2012 at 04:21:30PM +0530, Shubhrajyoti wrote:
> On Thursday 14 June 2012 11:29 PM, Wolfram Sang wrote:
> >>- removed dev_err() which was introduced on patch 09/17
> > To prevent the list being flooded, I would appreciate if you could wait
> > a few days to collect reviews before resending. It will take some time
> > until I pick this series anyhow, because I want people to have time to
> > donate Tested-by tags.
> Felipe thats a good cleanup.
> The series look good to me.
> 
> Also draining interrupt I had some queries.
> Looks good to me.
> 
> I have tested it after rebasing.

rebasing on top of what ? You should resend the series so that I know
what changes you have made to my original patchset. Make sure to list on
the commit log what where the changes you made, so that it looks
something like this commit below where I changed commit log a bit:

| commit 3daf74d78dfcd552445c35f1b82a271ca305ceb9
| Author: Pratyush Anand 
| Date:   Sat Jun 23 02:23:08 2012 +0530
| 
| usb: dwc3: remove WARN_ON from dwc_stop_active_transfer
| 
| Now we are sure that, if res_trans_idx is zero, then endpoint has been
| stopped. So it's safe to just return if endpoint is already stopped. No
| need to generate warning anymore.
| 
| While doing so, it's better to return when res_trans_idx is zero and
| decrease one level of indentation.
| 
| Signed-off-by: Pratyush Anand 
| 
| [ ba...@ti.com: slightly changed commit log ]
| 
| Signed-off-by: Felipe Balbi 

> Tested-by : Shubhrajyoti 

since you will send, you should, probably, add your Signed-off-by,
instead of Tested-by. dunno.

-- 
balbi


signature.asc
Description: Digital signature


Re: [PATCH v2 00/17] Big OMAP I2C Cleanup

2012-06-26 Thread Shubhrajyoti
On Thursday 14 June 2012 11:29 PM, Wolfram Sang wrote:
>>  - removed dev_err() which was introduced on patch 09/17
> To prevent the list being flooded, I would appreciate if you could wait
> a few days to collect reviews before resending. It will take some time
> until I pick this series anyhow, because I want people to have time to
> donate Tested-by tags.
Felipe thats a good cleanup.
The series look good to me.

Also draining interrupt I had some queries.
Looks good to me.

I have tested it after rebasing.
Tested-by : Shubhrajyoti 


Thanks,


--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH v2 00/17] Big OMAP I2C Cleanup

2012-06-14 Thread Wolfram Sang
On Thu, Jun 14, 2012 at 07:24:10PM +0300, Felipe Balbi wrote:
> Hi guys,
> 
> I have dropped a few patches from the series and also
> tested every single patch on my pandaboard. I2C messages
> are still working fine with panda after each patch.
> 
> There's still lots of work to be done on the i2c-omap.c
> driver but it's now easier to read, IMO.
> 
> Changes since v1:
>   - removed tabification on patch 6/17
>   - removed dev_err() which was introduced on patch 09/17

To prevent the list being flooded, I would appreciate if you could wait
a few days to collect reviews before resending. It will take some time
until I pick this series anyhow, because I want people to have time to
donate Tested-by tags.

-- 
Pengutronix e.K.   | Wolfram Sang|
Industrial Linux Solutions | http://www.pengutronix.de/  |


signature.asc
Description: Digital signature


[PATCH v2 00/17] Big OMAP I2C Cleanup

2012-06-14 Thread Felipe Balbi
Hi guys,

I have dropped a few patches from the series and also
tested every single patch on my pandaboard. I2C messages
are still working fine with panda after each patch.

There's still lots of work to be done on the i2c-omap.c
driver but it's now easier to read, IMO.

Changes since v1:
- removed tabification on patch 6/17
- removed dev_err() which was introduced on patch 09/17

Felipe Balbi (17):
  i2c: omap: simplify num_bytes handling
  i2c: omap: decrease indentation level on data handling
  i2c: omap: add blank lines
  i2c: omap: simplify omap_i2c_ack_stat()
  i2c: omap: split out [XR]DR and [XR]RDY
  i2c: omap: improve 1p153 errata handling
  i2c: omap: re-factor receive/transmit data loop
  i2c: omap: switch over to do {} while loop
  i2c: omap: ack IRQ in parts
  i2c: omap: get rid of the "complete" label
  i2c: omap: switch to devm_* API
  i2c: omap: switch to platform_get_irq()
  i2c: omap: bus: add a receiver flag
  i2c: omap: simplify errata check
  i2c: omap: always return IRQ_HANDLED
  i2c: omap: simplify IRQ exit path
  i2c: omap: resize fifos before each message

 drivers/i2c/busses/i2c-omap.c |  385 +++--
 1 file changed, 220 insertions(+), 165 deletions(-)

-- 
1.7.10.4

--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html