Re: [PATCH v2 04/10] OMAP4: DSS: HDMI: Move the common header file

2011-09-01 Thread Tomi Valkeinen
On Mon, 2011-08-29 at 11:44 +0530, mythr...@ti.com wrote:
 From: Mythri P K mythr...@ti.com
 
 Some of the header file definitions of HDMI IP are needed by audio driver thus
 moving the common defintion to more generic Include/video.
 
 Signed-off-by: Mythri P K mythr...@ti.com
 ---
  drivers/video/omap2/dss/dss.h  |   10 -
  drivers/video/omap2/dss/hdmi.c |1 +
  drivers/video/omap2/dss/hdmi.h |   53 
  include/video/omaphdmi.h   |   86 
 
  4 files changed, 87 insertions(+), 63 deletions(-)
  create mode 100644 include/video/omaphdmi.h

As the functions will be renamed to hdmi_ti_4xxx_*, perhaps the header
file is a bit misnamed.

Also, please first do the changes/renamings/etc, and only then move the
finished header file to include/video/ to prevent unnecessary changes in
include/video.

 Tomi


--
To unsubscribe from this list: send the line unsubscribe linux-omap in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH v2 04/10] OMAP4: DSS: HDMI: Move the common header file

2011-09-01 Thread K, Mythri P
Hi,

On Thu, Sep 1, 2011 at 2:30 PM, Tomi Valkeinen tomi.valkei...@ti.com wrote:
 On Mon, 2011-08-29 at 11:44 +0530, mythr...@ti.com wrote:
 From: Mythri P K mythr...@ti.com

 Some of the header file definitions of HDMI IP are needed by audio driver 
 thus
 moving the common defintion to more generic Include/video.

 Signed-off-by: Mythri P K mythr...@ti.com
 ---
  drivers/video/omap2/dss/dss.h  |   10 -
  drivers/video/omap2/dss/hdmi.c |    1 +
  drivers/video/omap2/dss/hdmi.h |   53 
  include/video/omaphdmi.h       |   86 
 
  4 files changed, 87 insertions(+), 63 deletions(-)
  create mode 100644 include/video/omaphdmi.h

 As the functions will be renamed to hdmi_ti_4xxx_*, perhaps the header
 file is a bit misnamed.

 Also, please first do the changes/renamings/etc, and only then move the
 finished header file to include/video/ to prevent unnecessary changes in
 include/video.

The Include/video hdmi header file is a generic file that can be used
across 4 ,5 and Netra. Actually even the hdmi_ti_5xxx_ definitions
would come in this header so what do you think it can be named as ? ,
If you have any better name for hdmi_ti_4xxx_ip as well please suggest
would be happy to take it , as it doesn't sound that intuitive to me
as well.

  Tomi



--
To unsubscribe from this list: send the line unsubscribe linux-omap in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH v2 04/10] OMAP4: DSS: HDMI: Move the common header file

2011-09-01 Thread Tomi Valkeinen
On Fri, 2011-09-02 at 10:45 +0530, K, Mythri P wrote:
 Hi,
 
 On Thu, Sep 1, 2011 at 2:30 PM, Tomi Valkeinen tomi.valkei...@ti.com wrote:
  On Mon, 2011-08-29 at 11:44 +0530, mythr...@ti.com wrote:
  From: Mythri P K mythr...@ti.com
 
  Some of the header file definitions of HDMI IP are needed by audio driver 
  thus
  moving the common defintion to more generic Include/video.
 
  Signed-off-by: Mythri P K mythr...@ti.com
  ---
   drivers/video/omap2/dss/dss.h  |   10 -
   drivers/video/omap2/dss/hdmi.c |1 +
   drivers/video/omap2/dss/hdmi.h |   53 
   include/video/omaphdmi.h   |   86 
  
   4 files changed, 87 insertions(+), 63 deletions(-)
   create mode 100644 include/video/omaphdmi.h
 
  As the functions will be renamed to hdmi_ti_4xxx_*, perhaps the header
  file is a bit misnamed.
 
  Also, please first do the changes/renamings/etc, and only then move the
  finished header file to include/video/ to prevent unnecessary changes in
  include/video.
 
 The Include/video hdmi header file is a generic file that can be used
 across 4 ,5 and Netra. Actually even the hdmi_ti_5xxx_ definitions
 would come in this header so what do you think it can be named as ? ,
 If you have any better name for hdmi_ti_4xxx_ip as well please suggest
 would be happy to take it , as it doesn't sound that intuitive to me
 as well.

Well, I think whatever the header name is, it should somehow match the
functions and the .c file. So if the functions and the .c file in this
case are hdmi_ti_4xxx, then it'd be logical for the .h file to be named
similarly.

So, if it will contain functions for other IPs also, perhaps just leave
the 4xxx out of it and name it hdmi_ti.h. Then the functions could be
named hdmi_ti_4xxx_yyy(), and accordingly the .c file can be
hdmi_ti_4xxx.c.

Or, perhaps ti_hdmi.h (and funcs  .c files accordingly) would be more
standard, as it's quite usual to name drivers etc. starting with the
company name.

 Tomi


--
To unsubscribe from this list: send the line unsubscribe linux-omap in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH v2 04/10] OMAP4: DSS: HDMI: Move the common header file

2011-09-01 Thread K, Mythri P
Hi,

On Fri, Sep 2, 2011 at 10:54 AM, Tomi Valkeinen tomi.valkei...@ti.com wrote:
 On Fri, 2011-09-02 at 10:45 +0530, K, Mythri P wrote:
 Hi,

 On Thu, Sep 1, 2011 at 2:30 PM, Tomi Valkeinen tomi.valkei...@ti.com wrote:
  On Mon, 2011-08-29 at 11:44 +0530, mythr...@ti.com wrote:
  From: Mythri P K mythr...@ti.com
 
  Some of the header file definitions of HDMI IP are needed by audio driver 
  thus
  moving the common defintion to more generic Include/video.
 
  Signed-off-by: Mythri P K mythr...@ti.com
  ---
   drivers/video/omap2/dss/dss.h  |   10 -
   drivers/video/omap2/dss/hdmi.c |    1 +
   drivers/video/omap2/dss/hdmi.h |   53 
   include/video/omaphdmi.h       |   86 
  
   4 files changed, 87 insertions(+), 63 deletions(-)
   create mode 100644 include/video/omaphdmi.h
 
  As the functions will be renamed to hdmi_ti_4xxx_*, perhaps the header
  file is a bit misnamed.
 
  Also, please first do the changes/renamings/etc, and only then move the
  finished header file to include/video/ to prevent unnecessary changes in
  include/video.
 
 The Include/video hdmi header file is a generic file that can be used
 across 4 ,5 and Netra. Actually even the hdmi_ti_5xxx_ definitions
 would come in this header so what do you think it can be named as ? ,
 If you have any better name for hdmi_ti_4xxx_ip as well please suggest
 would be happy to take it , as it doesn't sound that intuitive to me
 as well.

 Well, I think whatever the header name is, it should somehow match the
 functions and the .c file. So if the functions and the .c file in this
 case are hdmi_ti_4xxx, then it'd be logical for the .h file to be named
 similarly.

 So, if it will contain functions for other IPs also, perhaps just leave
 the 4xxx out of it and name it hdmi_ti.h. Then the functions could be
 named hdmi_ti_4xxx_yyy(), and accordingly the .c file can be
 hdmi_ti_4xxx.c.

 Or, perhaps ti_hdmi.h (and funcs  .c files accordingly) would be more
 standard, as it's quite usual to name drivers etc. starting with the
 company name.

Thanks i shall change it to ti_hdmi.h and rename functions accordingly.

Thanks and regards,
Mythri.
  Tomi



--
To unsubscribe from this list: send the line unsubscribe linux-omap in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH v2 04/10] OMAP4: DSS: HDMI: Move the common header file

2011-08-29 Thread mythripk
From: Mythri P K mythr...@ti.com

Some of the header file definitions of HDMI IP are needed by audio driver thus
moving the common defintion to more generic Include/video.

Signed-off-by: Mythri P K mythr...@ti.com
---
 drivers/video/omap2/dss/dss.h  |   10 -
 drivers/video/omap2/dss/hdmi.c |1 +
 drivers/video/omap2/dss/hdmi.h |   53 
 include/video/omaphdmi.h   |   86 
 4 files changed, 87 insertions(+), 63 deletions(-)
 create mode 100644 include/video/omaphdmi.h

diff --git a/drivers/video/omap2/dss/dss.h b/drivers/video/omap2/dss/dss.h
index a095a62..7c9565f 100644
--- a/drivers/video/omap2/dss/dss.h
+++ b/drivers/video/omap2/dss/dss.h
@@ -150,16 +150,6 @@ struct dsi_clock_info {
bool use_sys_clk;
 };
 
-/* HDMI PLL structure */
-struct hdmi_pll_info {
-   u16 regn;
-   u16 regm;
-   u32 regmf;
-   u16 regm2;
-   u16 regsd;
-   u16 dcofreq;
-};
-
 struct seq_file;
 struct platform_device;
 
diff --git a/drivers/video/omap2/dss/hdmi.c b/drivers/video/omap2/dss/hdmi.c
index ba1ad06..39d1a7e 100644
--- a/drivers/video/omap2/dss/hdmi.c
+++ b/drivers/video/omap2/dss/hdmi.c
@@ -33,6 +33,7 @@
 #include linux/pm_runtime.h
 #include linux/clk.h
 #include video/omapdss.h
+#include video/omaphdmi.h
 #if defined(CONFIG_SND_OMAP_SOC_OMAP4_HDMI) || \
defined(CONFIG_SND_OMAP_SOC_OMAP4_HDMI_MODULE)
 #include sound/soc.h
diff --git a/drivers/video/omap2/dss/hdmi.h b/drivers/video/omap2/dss/hdmi.h
index 7046ff3..0a3342b 100644
--- a/drivers/video/omap2/dss/hdmi.h
+++ b/drivers/video/omap2/dss/hdmi.h
@@ -198,39 +198,12 @@ struct hdmi_reg { u16 idx; };
 #define REG_GET(base, idx, start, end) \
FLD_GET(hdmi_read_reg(base, idx), start, end)
 
-struct hdmi_video_timings {
-   u16 x_res;
-   u16 y_res;
-   /* Unit: KHz */
-   u32 pixel_clock;
-   u16 hsw;
-   u16 hfp;
-   u16 hbp;
-   u16 vsw;
-   u16 vfp;
-   u16 vbp;
-};
-
-/* HDMI timing structure */
-struct hdmi_timings {
-   struct hdmi_video_timings timings;
-   int vsync_pol;
-   int hsync_pol;
-};
-
 enum hdmi_phy_pwr {
HDMI_PHYPWRCMD_OFF = 0,
HDMI_PHYPWRCMD_LDOON = 1,
HDMI_PHYPWRCMD_TXON = 2
 };
 
-enum hdmi_pll_pwr {
-   HDMI_PLLPWRCMD_ALLOFF = 0,
-   HDMI_PLLPWRCMD_PLLONLY = 1,
-   HDMI_PLLPWRCMD_BOTHON_ALLCLKS = 2,
-   HDMI_PLLPWRCMD_BOTHON_NOPHYCLK = 3
-};
-
 enum hdmi_clk_refsel {
HDMI_REFSEL_PCLK = 0,
HDMI_REFSEL_REF1 = 1,
@@ -266,11 +239,6 @@ enum hdmi_core_packet_mode {
HDMI_PACKETMODE48BITPERPIXEL = 7
 };
 
-enum hdmi_core_hdmi_dvi {
-   HDMI_DVI = 0,
-   HDMI_HDMI = 1
-};
-
 enum hdmi_core_tclkselclkmult {
HDMI_FPLL05IDCK = 0,
HDMI_FPLL10IDCK = 1,
@@ -571,27 +539,6 @@ struct hdmi_video_interface {
int tm; /* Timing mode */
 };
 
-struct hdmi_cm {
-   int code;
-   int mode;
-};
-
-struct hdmi_config {
-   struct hdmi_timings timings;
-   u16 interlace;
-   struct hdmi_cm cm;
-};
-
-struct hdmi_ip_data {
-   void __iomem*base_wp;   /* HDMI wrapper */
-   unsigned long   core_sys_offset;
-   unsigned long   core_av_offset;
-   unsigned long   pll_offset;
-   unsigned long   phy_offset;
-   struct hdmi_config cfg;
-   struct hdmi_pll_info pll_data;
-};
-
 struct hdmi_audio_format {
enum hdmi_stereo_channels   stereo_channels;
u8  active_chnnls_msk;
diff --git a/include/video/omaphdmi.h b/include/video/omaphdmi.h
new file mode 100644
index 000..bd51529
--- /dev/null
+++ b/include/video/omaphdmi.h
@@ -0,0 +1,86 @@
+/*
+ * omaphdmi.h
+ *
+ * HDMI driver definition for TI OMAP4, DM81xx, DM38xx  Processor.
+ *
+ * Copyright (C) 2010-2011 Texas Instruments Incorporated - http://www.ti.com/
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published by
+ * the Free Software Foundation.
+ *
+ * This program is distributed in the hope that it will be useful, but WITHOUT
+ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+ * FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for
+ * more details.
+ *
+ * You should have received a copy of the GNU General Public License along with
+ * this program.  If not, see http://www.gnu.org/licenses/.
+ */
+
+#ifndef _OMAP_OMAPHDMI_H
+#define _OMAP_OMAPHDMI_H
+
+enum hdmi_pll_pwr {
+   HDMI_PLLPWRCMD_ALLOFF = 0,
+   HDMI_PLLPWRCMD_PLLONLY = 1,
+   HDMI_PLLPWRCMD_BOTHON_ALLCLKS = 2,
+   HDMI_PLLPWRCMD_BOTHON_NOPHYCLK = 3
+};
+
+enum hdmi_core_hdmi_dvi {
+   HDMI_DVI = 0,
+   HDMI_HDMI = 1
+};
+
+struct hdmi_video_timings {
+   u16 x_res;
+   u16 y_res;
+   /* Unit: KHz */
+   u32 pixel_clock;
+   u16 hsw;
+   u16 hfp;
+   u16 hbp;
+