Re: [PATCH v7 10/44] [media] media: rename the function that create pad links
Em Wed, 26 Aug 2015 11:54:03 -0300 Mauro Carvalho Chehab escreveu: > Em Tue, 25 Aug 2015 12:55:41 -0600 > Shuah Khan escreveu: > > > On 08/23/2015 02:17 PM, Mauro Carvalho Chehab wrote: > > > Now that a link can be either between two different graph > > > objects, we'll need to add more functions to create links. > > > > Is this an incomplete sentence. Should it read: "either between > > two different graph objects or two pads" ? > > That would be redundant, as pad is a graph object ;) Renamed the patch description to: With the new API, a link can be either between two PADs or between an interface and an entity. So, we need to use a better name for the function that create links between two pads. So, rename the such function to media_create_pad_link(). No functional changes. This patch was created via this shell script: for i in $(find drivers/media -name '*.[ch]' -type f) $(find drivers/staging/media -name '*.[ch]' -type f) $(find include/ -name '*.h' -type f) ; do sed s,media_entity_create_link,media_create_pad_link,g <$i >a && mv a $i; done Signed-off-by: Mauro Carvalho Chehab Acked-by: Hans Verkuil Regards, Mauro > > > > > > So, rename the existing one that create links only between > > > two pads as media_create_pad_link(). > > > > > > > > No functional changes. > > > > > > This patch was created via this shell script: > > > for i in $(find drivers/media -name '*.[ch]' -type f) $(find > > > drivers/staging/media -name '*.[ch]' -type f) $(find include/ -name '*.h' > > > -type f) ; do sed s,media_entity_create_link,media_create_pad_link,g <$i > > > >a && mv a $i; done > > > > > > > Didn't want to experiment with Coccinelle?? :) > > I use Coccinelle, but only when I need more complex changes, as > Coccinelle may mangle with comments. > > > > > > Signed-off-by: Mauro Carvalho Chehab > > > Acked-by: Hans Verkuil > > > Signed-off-by: Mauro Carvalho Chehab > > > > > > > Changes look good to me. After fixing the commit log: > > > > Acked-by: Shuah Khan > > > > thanks, > > -- Shuah > > > > > -- > To unsubscribe from this list: send the line "unsubscribe linux-media" in > the body of a message to majord...@vger.kernel.org > More majordomo info at http://vger.kernel.org/majordomo-info.html -- To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
Re: [PATCH v7 10/44] [media] media: rename the function that create pad links
Em Tue, 25 Aug 2015 12:55:41 -0600 Shuah Khan escreveu: > On 08/23/2015 02:17 PM, Mauro Carvalho Chehab wrote: > > Now that a link can be either between two different graph > > objects, we'll need to add more functions to create links. > > Is this an incomplete sentence. Should it read: "either between > two different graph objects or two pads" ? That would be redundant, as pad is a graph object ;) > > > So, rename the existing one that create links only between > > two pads as media_create_pad_link(). > > > > > No functional changes. > > > > This patch was created via this shell script: > > for i in $(find drivers/media -name '*.[ch]' -type f) $(find > > drivers/staging/media -name '*.[ch]' -type f) $(find include/ -name '*.h' > > -type f) ; do sed s,media_entity_create_link,media_create_pad_link,g <$i >a > > && mv a $i; done > > > > Didn't want to experiment with Coccinelle?? :) I use Coccinelle, but only when I need more complex changes, as Coccinelle may mangle with comments. > > > Signed-off-by: Mauro Carvalho Chehab > > Acked-by: Hans Verkuil > > Signed-off-by: Mauro Carvalho Chehab > > > > Changes look good to me. After fixing the commit log: > > Acked-by: Shuah Khan > > thanks, > -- Shuah > > -- To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
Re: [PATCH v7 10/44] [media] media: rename the function that create pad links
On 08/23/2015 02:17 PM, Mauro Carvalho Chehab wrote: > Now that a link can be either between two different graph > objects, we'll need to add more functions to create links. Is this an incomplete sentence. Should it read: "either between two different graph objects or two pads" ? > So, rename the existing one that create links only between > two pads as media_create_pad_link(). > > No functional changes. > > This patch was created via this shell script: > for i in $(find drivers/media -name '*.[ch]' -type f) $(find > drivers/staging/media -name '*.[ch]' -type f) $(find include/ -name '*.h' > -type f) ; do sed s,media_entity_create_link,media_create_pad_link,g <$i >a > && mv a $i; done > Didn't want to experiment with Coccinelle?? :) > Signed-off-by: Mauro Carvalho Chehab > Acked-by: Hans Verkuil > Signed-off-by: Mauro Carvalho Chehab > Changes look good to me. After fixing the commit log: Acked-by: Shuah Khan thanks, -- Shuah -- Shuah Khan Sr. Linux Kernel Developer Open Source Innovation Group Samsung Research America (Silicon Valley) shua...@osg.samsung.com | (970) 217-8978 -- To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html