RE: [PATCH v2 1/3] usb: renesas_usbhs: Add support for RZ/A1

2018-01-05 Thread Chris Brandt
Hi Geert,

On Friday, January 05, 2018, Geert Uytterhoeven wrote:
> > +   {
> > +   .compatible = "renesas,usbhs-r7s72100",
> > +   .data = (void *)USBHS_TYPE_RZA1,
> > +   },
> 
> I think it suffices to drop the part above...
> 
> > {
> > .compatible = "renesas,rcar-gen2-usbhs",
> > .data = (void *)USBHS_TYPE_RCAR_GEN2,
> > @@ -488,6 +493,10 @@ static const struct of_device_id usbhs_of_match[] =
> {
> > .compatible = "renesas,rcar-gen3-usbhs",
> > .data = (void *)USBHS_TYPE_RCAR_GEN3,
> > },
> > +   {
> > +   .compatible = "renesas,rza1-usbhs",
> > +   .data = (void *)USBHS_TYPE_RZA1,
> > +   },
> 
> ... and just let the driver match against the generic compatible value.
> But then you have to add "renesas,rza1-usbhs" to the DTS, too.

OK. I can do that.

I keep forgetting all the new/old DT rules.
I thought there was something about you always need a generic name and
also a device specific name.

I'm happy with just "renesas,rza1-usbhs".


> > --- /dev/null
> > +++ b/drivers/usb/renesas_usbhs/rza.c
> > @@ -0,0 +1,52 @@
> > +// SPDX-License-Identifier: GPL-1.0+
> 
> Not GPL-2.0?

Oops. Copy/paste error.


I'll submit a V3 of the series.


Thanks!

Chris



Re: [PATCH v2 1/3] usb: renesas_usbhs: Add support for RZ/A1

2018-01-05 Thread Geert Uytterhoeven
Hi Chris,

On Fri, Jan 5, 2018 at 7:46 PM, Chris Brandt  wrote:
> This patch adds the capability to support RZ/A1 SoCs.
>
> Signed-off-by: Chris Brandt 

Thanks for your patch!

> index c5289b3ecf8d..2abefd3d6050 100644
> --- a/drivers/usb/renesas_usbhs/common.c
> +++ b/drivers/usb/renesas_usbhs/common.c

> @@ -480,6 +481,10 @@ static const struct of_device_id usbhs_of_match[] = {
> .compatible = "renesas,usbhs-r8a77995",
> .data = (void *)USBHS_TYPE_RCAR_GEN3_WITH_PLL,
> },
> +   {
> +   .compatible = "renesas,usbhs-r7s72100",
> +   .data = (void *)USBHS_TYPE_RZA1,
> +   },

I think it suffices to drop the part above...

> {
> .compatible = "renesas,rcar-gen2-usbhs",
> .data = (void *)USBHS_TYPE_RCAR_GEN2,
> @@ -488,6 +493,10 @@ static const struct of_device_id usbhs_of_match[] = {
> .compatible = "renesas,rcar-gen3-usbhs",
> .data = (void *)USBHS_TYPE_RCAR_GEN3,
> },
> +   {
> +   .compatible = "renesas,rza1-usbhs",
> +   .data = (void *)USBHS_TYPE_RZA1,
> +   },

... and just let the driver match against the generic compatible value.
But then you have to add "renesas,rza1-usbhs" to the DTS, too.

> --- /dev/null
> +++ b/drivers/usb/renesas_usbhs/rza.c
> @@ -0,0 +1,52 @@
> +// SPDX-License-Identifier: GPL-1.0+

Not GPL-2.0?

> +++ b/drivers/usb/renesas_usbhs/rza.h
> @@ -0,0 +1,4 @@
> +// SPDX-License-Identifier: GPL-2.0

like here?

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- ge...@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html