Re: [PATCH] wireless: ipw2x00: Remove unnecessary parentheses

2018-09-24 Thread Stanislav Yakovlev
On 21/09/2018, Nathan Chancellor  wrote:
> Clang warns when multiple pairs of parentheses are used for a single
> conditional statement.
>
> drivers/net/wireless/intel/ipw2x00/ipw2200.c:5655:28: warning: equality
> comparison with extraneous parentheses [-Wparentheses-equality]
> if ((priv->ieee->iw_mode == IW_MODE_ADHOC)) {
>  ^~~~
> drivers/net/wireless/intel/ipw2x00/ipw2200.c:5655:28: note: remove
> extraneous parentheses around the comparison to silence this warning
> if ((priv->ieee->iw_mode == IW_MODE_ADHOC)) {
> ~^   ~
> drivers/net/wireless/intel/ipw2x00/ipw2200.c:5655:28: note: use '=' to
> turn this equality comparison into an assignment
> if ((priv->ieee->iw_mode == IW_MODE_ADHOC)) {
>  ^~
>  =
> 1 warning generated.
>
> Link: https://github.com/ClangBuiltLinux/linux/issues/134
> Signed-off-by: Nathan Chancellor 
> ---
>  drivers/net/wireless/intel/ipw2x00/ipw2200.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>

Looks fine, thanks!

Stanislav.


Re: [PATCH 3/8] wireless: ipw2200: fix old-style declaration

2016-06-24 Thread Stanislav Yakovlev
On 16 June 2016 at 17:52, Arnd Bergmann  wrote:
> Modern C standards expect the 'inline' keyword to come before the return
> type in a declaration, and we get a warning for this with "make W=1":
>
> drivers/net/wireless/intel/ipw2x00/ipw2200.c:4096:1: error: 'inline' is not 
> at beginning of declaration [-Werror=old-style-declaration]
>
> Signed-off-by: Arnd Bergmann 
> ---
>  drivers/net/wireless/intel/ipw2x00/ipw2200.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>

Acked-by: Stanislav Yakovlev 

Stanislav.
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 02/19] ipw2x00: use to_pci_dev()

2016-03-24 Thread Stanislav Yakovlev
On 18 March 2016 at 06:20, Julian Calaby  wrote:
> From: Geliang Tang 
>
> Use to_pci_dev() instead of open-coding it.
>
> Signed-off-by: Geliang Tang 
> Signed-off-by: Julian Calaby 
> ---
>  drivers/net/wireless/intel/ipw2x00/ipw2100.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>

Acked-by: Stanislav Yakovlev 

Stanislav.
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH] wireless: ipw2100: fix timeout bug - always evaluated to 0

2015-06-15 Thread Stanislav Yakovlev
On 15 June 2015 at 21:24, Nicholas Mc Guire  wrote:
> commit: commit 2c86c275015c ("Add ipw2100 wireless driver.") introduced
> HW_PHY_OFF_LOOP_DELAY (HZ / 5000) which always evaluated to 0. Clarified
> by Stanislav Yakovlev  that it should be 50
> milliseconds thus fixed up to msecs_to_jiffies(50).
>
> Signed-off-by: Nicholas Mc Guire 
> ---
>
> Patch was compile tested with x86_64_defconfig + CONFIG_IPW2100=m
> (with a few buildwarnings in ipw2100.c though not related to this patch)
>
> Patch is against 4.1-rc7 (localversion-next is -next-20150615)
>
>  drivers/net/wireless/ipw2x00/ipw2100.c |2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>

Acked-by: Stanislav Yakovlev 

Stanislav.
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [BUG ?] delay always evaluates to 0

2015-06-15 Thread Stanislav Yakovlev
Hi Nicholas,

On 12 June 2015 at 20:58, Nicholas Mc Guire  wrote:
> Hi !
>
> commit 2c86c275015c ("Add ipw2100 wireless driver.") introduced
>
> drivers/net/wireless/ipw2100.c - line-numbers are from next-20150511
> 1410 static int ipw2100_hw_phy_off(struct ipw2100_priv *priv)
> 1411 {
> 1412
> 1413 #define HW_PHY_OFF_LOOP_DELAY (HZ / 5000)
> 1414
> ...
> 1437
> 1438 schedule_timeout_uninterruptible(HW_PHY_OFF_LOOP_DELAY);
> 1439 }
>
> but (HZ / 5000) will evaluate to 0 for all configurable HZ values - typo ?
> and this schedule_timeout_uninterruptible() is probably not doing what
> is intended.

Yes, you are right. This is a bug. I think it should be:

-#define HW_PHY_OFF_LOOP_DELAY (HZ / 5000)
+#define HW_PHY_OFF_LOOP_DELAY (msecs_to_jiffies(50))

Will you send us a patch?

Stanislav.


>
> thx!
> hofrat
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH] treewide: Fix typo compatability -> compatibility

2015-06-04 Thread Stanislav Yakovlev
On 27 May 2015 at 16:05, Laurent Pinchart
 wrote:
> Even though 'compatability' has a dedicated entry in the Wiktionary,
> it's listed as 'Mispelling of compatibility'. Fix it.
>
> Signed-off-by: Laurent Pinchart 
> ---
>  drivers/net/wireless/ipw2x00/ipw2100.h   | 2 +-
>

Acked-by: Stanislav Yakovlev 

for ipw2100 part.

Stanislav.
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [patch] ipw2x00: shift wrap bugs setting ->rt_tsf

2014-10-28 Thread Stanislav Yakovlev
Hello, Joe,

On 24 October 2014 02:43, Joe Perches  wrote:
>
> struct ipw_rt_hdr {
> struct ieee80211_radiotap_header rt_hdr;
> u64 rt_tsf;  /* TSF */  /* XXX */
> u8 rt_flags;/* radiotap packet flags *
> u8 rt_rate; /* rate in 500kb/s */
> __le16 rt_channel;  /* channel in mhz */
> __le16 rt_chbitmask;/* channel bitfield */
> s8 rt_dbmsignal;/* signal in dbM, kluged to signed */
> s8 rt_dbmnoise;
> u8 rt_antenna;  /* antenna number */
> u8 payload[0];  /* payload... */
> } __packed;
>
> Maybe rt_tsf (which is otherwise unused in this code),
> should be __le64 so maybe use (u32) ?
>

Yes, you are right, the field definition should be __le64 as you
suggest. All values in radiotap header are specified in little endian
byte order according to the documentation at www.radiotap.org.

> ipw_rt->rt_txf = cpu_to_le64((u32)(frame->parent_tsf[3] << 24 |
>frame->parent_tsf[2] << 16 |
>frame->parent_tsf[1] << 8  |
>frame->parent_tsf[0]));
>

That looks fine for me. Will you send a patch?

Stanislav.
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: ipw2200 driver in kernels 3+

2014-10-15 Thread Stanislav Yakovlev
Hello Frank,

On 15 October 2014 12:34, Frank Langille  wrote:
> ... the menuconfig option to select this
> driver seems to have disappeared sometime after kernel 3.4.104, which
> is the last longterm version I can see that allows me to include the
> driver in my build.
>
> Is it possible to have the option made available again?

Yes it is, to do so you need to enable old wireless extensions support
(CONFIG_CFG80211_WEXT), Network support-> Wireless-> cfg80211 wireless
configuration API -> cfg80211 wireless extension computability.

Stanislav.
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [patch 2/2] ipw2x00: clean up a condition

2014-10-15 Thread Stanislav Yakovlev
Hello Dan,

On 9 October 2014 02:59, Dan Carpenter  wrote:
> The original condition was "(PAGE_SIZE - len)" when "(len < PAGE_SIZE)"
> is intended.
>
> This condition is not really sufficient, but also not really needed...
> If "len > PAGE_SIZE" then it we will print a warning message in dmesg
> but there are no other effects.  Maybe we should just remove the
> condition?
>
> Signed-off-by: Dan Carpenter 

Looks fine, thanks.

Stanislav.
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [patch 1/2] ipw2x00: remove unused ->ibss_dfs pointer

2014-10-15 Thread Stanislav Yakovlev
Hello Dan,

On 9 October 2014 02:57, Dan Carpenter  wrote:
> The ->ibss_dfs pointer is always allocated with a user controlled
> length.  This caused a static checker warning because what if the length
> was zero?  In that case, any dereference of ->ibss_dfs would lead to an
> Oops.
>
> It turns out that this isn't a problem because the ->ibss_dfs pointer is
> never used.  This patch deletes it along with all the related code.  In
> particular the entire libipw_network_reset() function can be removed.
>
> Signed-off-by: Dan Carpenter 

Looks fine, thanks.

Stanislav.
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH] Check ieee80211softmac_auth_resp kmalloc result

2014-10-06 Thread Stanislav Yakovlev
Hello Dan,

> So far as I can see this is harmless because we never use ->ibss_dfs
> and we should just delete it along with all the related code?

Yes, you are right. This code is not used by ipw2x00 driver, so it can
be deleted. Will you send a patch?

Stanislav.
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html