Patches added to powerpc.git master and powerpc-next branches

2008-09-15 Thread Paul Mackerras
The following patches have been added to the the master and
powerpc-next branches of the powerpc.git repository.

This represents all of the patches that I have from the old
patchwork.  If you have a patch that you want to go in that isn't on
the new patchwork page, please repost it.

Paul.

Becky Bruce (1):
  powerpc: Rename PTE_SIZE to HPTE_SIZE

Chandru (1):
  powerpc: Add support for dynamic reconfiguration memory in kexec/kdump 
kernels

Christoph Hellwig (1):
  powerpc: Use sys_pause for 32-bit pause entry point

David Gibson (1):
  powerpc: Clean up hugepage pagetable allocation for powerpc with 16G pages

Mark Nelson (2):
  powerpc: Add new CPU feature: CPU_FTR_CP_USE_DCBTZ
  powerpc: New copy_4K_page()

Martin Langer (1):
  powerpc: Fix major revision number for Freescale cores

Nathan Fontenot (1):
  powerpc: Check rc of notifier chain for memory remove

Paul Mackerras (4):
  powerpc: Rearrange head_64.S to move interrupt handler code to the 
beginning
  powerpc: Make it possible to move the interrupt handlers away from the 
kernel
  powerpc: Use LOAD_REG_IMMEDIATE only for constants on 64-bit
  powerpc: Make the 64-bit kernel as a position-independent executable

Sebastien Dugue (2):
  powerpc: Separate the irq radix tree insertion and lookup
  powerpc: Make the irq reverse mapping radix tree lockless

Thiemo Seufer (1):
  powerpc: Enforce a non-spe kernel build even on broken compilers

roel kluin (1):
  powerpc: Fix duplicate test of MACIO_FLAG_SCCB_ON

___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Re: Patches added to powerpc.git master and powerpc-next branches

2008-04-23 Thread Kumar Gala


On Apr 21, 2008, at 7:15 PM, Paul Mackerras wrote:

Kumar Gala writes:

Once again I want to go through it carefully and understand how it  
all

works, and in particular understand things like the way it ensures
that the base address for the kmap region is aligned to a 4M  
boundary

so all the kmap ptes are in a single page (assuming it does :).


I'm not clear on why this is needed.  I can see value in having the
PGD entry in place but the pte PAs would be changing all the time  
so I

don't see what benefit there is in keeping them in one page.


Have a look at map_new_virtual in mm/highmem.c.  In particular:

   set_pte_at(init_mm, vaddr,
  (pkmap_page_table[last_pkmap_nr]), mk_pte(page,  
kmap_prot));


assumes that the ptes that kmap uses are in a contiguous array whose
base is pkmap_page_table.


For normal kmap ptes we cover things in one PGD via:

#define PKMAP_BASE  ((FIXADDR_BOOT_START -  
PAGE_SIZE*(LAST_PKMAP +

1))  PMD_MASK)


OK, that probably does the trick ... checks ... yes it does.

We seem to have a distinction without a difference between
FIXADDR_START and FIXADDR_BOOT_START, and similarly between
__FIXADDR_SIZE and __FIXADDR_BOOT_SIZE.  Is there any actual
difference and if not why do we have two names for the same thing?


Also, we seem to have an unnecessary distinction (and unnecessary
casting) between __FIXADDR_TOP and FIXADDR_TOP.


its left over from the x86 port.  I'll get rid of __FIXADDR_BOOT_SIZE,  
FIXADDR_BOOT_START, and __FIXADDR_TOP.


If we want the early ioremap support in the future we can add back  
__FIXADDR_BOOT_SIZE and FIXADDR_BOOT_START.


- k
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Re: Patches added to powerpc.git master and powerpc-next branches

2008-04-23 Thread Benjamin Herrenschmidt

On Wed, 2008-04-23 at 07:49 -0500, Kumar Gala wrote:
 its left over from the x86 port.  I'll get rid of
 __FIXADDR_BOOT_SIZE,  
 FIXADDR_BOOT_START, and __FIXADDR_TOP.
 
 If we want the early ioremap support in the future we can add back  
 __FIXADDR_BOOT_SIZE and FIXADDR_BOOT_START.

Our early ioremap works differently. Do you see any reason why we may
want to do it like x86 instead ? Is it any better ?

Ben.


___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Re: Patches added to powerpc.git master and powerpc-next branches

2008-04-22 Thread Benjamin Herrenschmidt

On Mon, 2008-04-21 at 12:51 -0500, Kumar Gala wrote:

 I'm not clear on why this is needed.  I can see value in having the  
 PGD entry in place but the pte PAs would be changing all the time so
 I  
 don't see what benefit there is in keeping them in one page.

Because they are accessed as an array by the C code ?

Ben.


___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Re: Patches added to powerpc.git master and powerpc-next branches

2008-04-21 Thread Kumar Gala


On Apr 19, 2008, at 7:18 AM, Paul Mackerras wrote:

Kumar Gala writes:

[POWERPC] 85xx: Add support for relocatble kernel (and booting at  
non-

zero)


Should be OK to go though probably not in the first batch.  I want to
look through it carefully again since it's touching code that is
common to a lot of platforms.  The patch description looks reasonable
as to what it explains but the english could use a touch-up here or
there (e.g. a physical address that is module 256M doesn't actually
mean anything; a physical address that is 0 modulo 256M would be
correct).


Ok.  I'll have my grammar police review it and repost.


[POWERPC] Port fixmap from x86 and use for kmap_atomic


Once again I want to go through it carefully and understand how it all
works, and in particular understand things like the way it ensures
that the base address for the kmap region is aligned to a 4M boundary
so all the kmap ptes are in a single page (assuming it does :).


I'm not clear on why this is needed.  I can see value in having the  
PGD entry in place but the pte PAs would be changing all the time so I  
don't see what benefit there is in keeping them in one page.


For normal kmap ptes we cover things in one PGD via:

#define PKMAP_BASE  ((FIXADDR_BOOT_START - PAGE_SIZE*(LAST_PKMAP +  
1))  PMD_MASK)


The kmap_atomic ptes do NOT have a similar guarantee as they are  
controlled via fixmap.  However we do pre-allocate the PGD via  
calling map_page() on all fixmap addresses.


- k
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Re: Patches added to powerpc.git master and powerpc-next branches

2008-04-21 Thread Paul Mackerras
Kumar Gala writes:

  Once again I want to go through it carefully and understand how it all
  works, and in particular understand things like the way it ensures
  that the base address for the kmap region is aligned to a 4M boundary
  so all the kmap ptes are in a single page (assuming it does :).
 
 I'm not clear on why this is needed.  I can see value in having the  
 PGD entry in place but the pte PAs would be changing all the time so I  
 don't see what benefit there is in keeping them in one page.

Have a look at map_new_virtual in mm/highmem.c.  In particular:

set_pte_at(init_mm, vaddr,
   (pkmap_page_table[last_pkmap_nr]), mk_pte(page, kmap_prot));

assumes that the ptes that kmap uses are in a contiguous array whose
base is pkmap_page_table.

 For normal kmap ptes we cover things in one PGD via:
 
 #define PKMAP_BASE  ((FIXADDR_BOOT_START - PAGE_SIZE*(LAST_PKMAP +  
 1))  PMD_MASK)

OK, that probably does the trick ... checks ... yes it does.

We seem to have a distinction without a difference between
FIXADDR_START and FIXADDR_BOOT_START, and similarly between
__FIXADDR_SIZE and __FIXADDR_BOOT_SIZE.  Is there any actual
difference and if not why do we have two names for the same thing?

Also, we seem to have an unnecessary distinction (and unnecessary
casting) between __FIXADDR_TOP and FIXADDR_TOP.

Regards,
Paul.
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Re: Patches added to powerpc.git master and powerpc-next branches

2008-04-19 Thread Paul Mackerras
Kumar Gala writes:

 [POWERPC] 85xx: Add support for relocatble kernel (and booting at non- 
 zero)

Should be OK to go though probably not in the first batch.  I want to
look through it carefully again since it's touching code that is
common to a lot of platforms.  The patch description looks reasonable
as to what it explains but the english could use a touch-up here or
there (e.g. a physical address that is module 256M doesn't actually
mean anything; a physical address that is 0 modulo 256M would be
correct).

 [POWERPC] Port fixmap from x86 and use for kmap_atomic

Once again I want to go through it carefully and understand how it all
works, and in particular understand things like the way it ensures
that the base address for the kmap region is aligned to a 4M boundary
so all the kmap ptes are in a single page (assuming it does :).

Paul.
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Patches added to powerpc.git master and powerpc-next branches

2008-04-18 Thread Paul Mackerras
I have pushed out the following commits to the master and powerpc-next
branches of the powerpc.git tree.  This includes commits from Kumar's
and Jeremy's trees.

I am intending to ask Linus to pull the powerpc-next branch once we
have the breakage from the OF helpers for i2c patch sorted out.

Paul.

Alexander van Heukelum (1):
  [POWERPC] Use asm-generic/bitops/find.h in bitops.h

Anton Vorontsov (9):
  [POWERPC] QE: UCC nodes cleanup
  [POWERPC] fsl_elbc_nand: factor out localbus defines
  [POWERPC] fsl_lbc: implement few UPM routines
  [POWERPC] QE: implement qe_muram_offset
  [POWERPC] QE: immap_qe.h should include asm/io.h
  [POWERPC] QE: export qe_get_brg_clk()
  [POWERPC] QE: fix sparse warnings
  [POWERPC] 83xx: mpc837x_rdb: add simple-bus compatible matching
  [POWERPC] 83xx: mpc8315 - fix USB UTMI Host setup

Benjamin Herrenschmidt (3):
  [POWERPC] Fix device-tree locking vs. interrupts
  [POWERPC] Move stackframe definitions to common header
  [POWERPC] irqtrace support for 64-bit powerpc

Christoph Hellwig (1):
  [POWERPC] Stacktrace support for lockdep

Gerhard Stenzel (1):
  [POWERPC] spufs: fix incorrect file descriptors in SPU coredump note names

Haiying Wang (1):
  [POWERPC] 85xx: Fix the size of qe muram for MPC8568E

Jeremy Kerr (3):
  [POWERPC] spufs: add newline to signal{1,2}_type files
  [POWERPC] spufs: reacquire LS pointer in spu_process_callback
  [POWERPC] spufs: save MFC command channel before purging MFC queue

Kumar Gala (8):
  [POWERPC] Rework Book-E debug exception handling
  [POWERPC] 83xx/85xx: Reorganize defconfigs
  [POWERPC] Make Book-E debug handling SMP safe
  [POWERPC] 83xx: Enable FCM NAND and OF partitions in defconfig
  [POWERPC] 85xx: Fix compile warning
  [POWERPC] 85xx: Convert dts to v1 syntax
  [POWERPC] 85xx: minor .dts cleanups
  [POWERPC] fsl: Convert dts to v1 syntax

Laurent Pinchart (6):
  [POWERPC] cpm_uart: Allocate DPRAM memory for SMC ports on CPM2-based 
platforms.
  [POWERPC] Add bootwrapper function to get virtual reg from the device 
tree.
  [POWERPC] cpm-serial: Relocate CPM buffer descriptors and SMC parameter 
ram.
  [POWERPC] ep8248e: Reference SMC parameter RAM base in the device tree.
  [POWERPC] CPM2: Reset the CPM when early debugging is not enabled.
  [POWERPC] CPM: Move opcodes common to CPM1 and CPM2 to 
include/asm-powerpc/cpm.h

Michael Ellerman (4):
  [POWERPC] Move xics_setup_8259_cascade() into platforms/pseries/setup.c
  [POWERPC] Turn xics_setup_8259_cascade() into a generic 
pseries_setup_i8259_cascade()
  [POWERPC] Use pseries_setup_i8259_cascade() in pseries_mpic_init_IRQ()
  [POWERPC] Simplify xics direct/lpar irq_host setup

Olof Johansson (1):
  [POWERPC] Remove unused __max_memory variable

Paul Gortmaker (5):
  [POWERPC] 86xx: Add support for Wind River SBC8641D board
  [POWERPC] 86xx: Add defconfig for Wind River SBC8641D board
  [POWERPC] 86xx: Add device tree source for Wind River SBC8641D
  [POWERPC] 86xx: mark functions static, other minor cleanups
  [POWERPC] 86xx: mpc86xx_hpcn - Temporarily accept old dts node identifier.

Paul Mackerras (1):
  [POWERPC] Optimize fls64() on 64-bit processors

Scott Wood (4):
  [POWERPC] CPM: Always use new binding.
  [POWERPC] fsl_soc: Factor fsl_get_sys_freq() out of the wdt and spi inits.
  [POWERPC] cuboot-pq2: PCI fixes
  [POWERPC] 83xx: mpc8313erdb - Enable FCM NAND and OF partitions in 
defconfig

Sebastian Siewior (1):
  [POWERPC] 85xx: Enable DMA engine on the MPC8544 DS

Timur Tabi (1):
  [POWERPC] Make rheap safe for spinlocks

Trent Piepho (1):
  [POWERPC] Make pci_bus_to_host()'s struct pci_bus * argument const

___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Re: Patches added to powerpc.git master and powerpc-next branches

2008-04-18 Thread Kumar Gala


On Apr 18, 2008, at 6:38 AM, Paul Mackerras wrote:

I have pushed out the following commits to the master and powerpc-next
branches of the powerpc.git tree.  This includes commits from Kumar's
and Jeremy's trees.

I am intending to ask Linus to pull the powerpc-next branch once we
have the breakage from the OF helpers for i2c patch sorted out.

Paul.


What are we doing with these two patches:

[POWERPC] 85xx: Add support for relocatble kernel (and booting at non- 
zero)

[POWERPC] Port fixmap from x86 and use for kmap_atomic

I know the second was late, but I'd like us to think about putting it  
in for v2.6.26.  It gives us a good basis for the PCIe 44x and 83xx  
config cycle work and kexec/kdump work for v2.6.27.


thanks.

- k
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev