Re: [PATCH 1/3] add default device trees for MPC837x MDS board

2008-01-17 Thread Kumar Gala

On Jan 7, 2008, at 6:03 AM, Li Yang wrote:

 Signed-off-by: Li Yang [EMAIL PROTECTED]
 ---
 address comments and use new dts spec.

 arch/powerpc/boot/dts/mpc8377_mds.dts |  277  
 +++
 arch/powerpc/boot/dts/mpc8378_mds.dts |  263  
 +
 arch/powerpc/boot/dts/mpc8379_mds.dts |  291  
 +
 3 files changed, 831 insertions(+), 0 deletions(-)

applied.

- k

___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Re: [PATCH 1/3] add default device trees for MPC837x MDS board

2008-01-09 Thread David Gibson
On Tue, Jan 08, 2008 at 08:58:17AM -0700, Grant Likely wrote:
 Hi Leo,
 
 comments below.  I've made my comments on the first file, but they
 apply to the other two also.
 
 Cheers,
 g.

[snip]
  +   ranges = 0 e000 0010;
  +   reg = e000 0200;
  +   bus-frequency = 0;
  +
  +   [EMAIL PROTECTED] {
  +   compatible = mpc83xx_wdt;
 
 fsl,mpc8377_wdt, fsl,mpc83xx_wdt as per generic names recommended 
 practice.

Uh.. that's reasonable advice, but it has nothing to do with the
generic names recommended practice.

-- 
David Gibson| I'll have my music baroque, and my code
david AT gibson.dropbear.id.au  | minimalist, thank you.  NOT _the_ _other_
| _way_ _around_!
http://www.ozlabs.org/~dgibson
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Re: [PATCH 1/3] add default device trees for MPC837x MDS board

2008-01-09 Thread Grant Likely
On 1/9/08, David Gibson [EMAIL PROTECTED] wrote:
 On Tue, Jan 08, 2008 at 08:58:17AM -0700, Grant Likely wrote:
   +   compatible = mpc83xx_wdt;
 
  fsl,mpc8377_wdt, fsl,mpc83xx_wdt as per generic names recommended 
  practice.

 Uh.. that's reasonable advice, but it has nothing to do with the
 generic names recommended practice.

Actually, that *is* advice given in the generic names recommended
practice document:

http://www.openfirmware.org/1275/practice/gnames/gnamv14a.html#HDR11
Section 6.2, last sentence.

:-)

Cheers,
g.

-- 
Grant Likely, B.Sc., P.Eng.
Secret Lab Technologies Ltd.
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Re: [PATCH 1/3] add default device trees for MPC837x MDS board

2008-01-08 Thread Grant Likely
Hi Leo,

comments below.  I've made my comments on the first file, but they
apply to the other two also.

Cheers,
g.


On 1/7/08, Li Yang [EMAIL PROTECTED] wrote:
 Signed-off-by: Li Yang [EMAIL PROTECTED]
 ---
 address comments and use new dts spec.

  arch/powerpc/boot/dts/mpc8377_mds.dts |  277 +++
  arch/powerpc/boot/dts/mpc8378_mds.dts |  263 +
  arch/powerpc/boot/dts/mpc8379_mds.dts |  291 
 +
  3 files changed, 831 insertions(+), 0 deletions(-)

 diff --git a/arch/powerpc/boot/dts/mpc8377_mds.dts 
 b/arch/powerpc/boot/dts/mpc8377_mds.dts
 new file mode 100644
 index 000..b50b5f9
 --- /dev/null
 +++ b/arch/powerpc/boot/dts/mpc8377_mds.dts
 @@ -0,0 +1,277 @@
 +/*
 + * MPC8377E MDS Device Tree Source
 + *
 + * Copyright 2007 Freescale Semiconductor Inc.
 + *
 + * This program is free software; you can redistribute  it and/or modify it
 + * under  the terms of  the GNU General  Public License as published by the
 + * Free Software Foundation;  either version 2 of the  License, or (at your
 + * option) any later version.
 + */
 +
 +/ {
 +   model = fsl,mpc8377emds;
 +   compatible = fsl,mpc8377emds,fsl,mpc837xmds;

Compatibility at the board level is a really hard thing to claim.  I'd
drop the fsl,mpc837xmds here and make the platform code bind to
either.

 +   #address-cells = 1;
 +   #size-cells = 1;
 +
 +   aliases {
 +   ethernet0 = enet0;
 +   ethernet1 = enet1;
 +   serial0 = serial0;
 +   serial1 = serial1;
 +   pci0 = pci0;
 +   };
 +
 +   cpus {
 +   #address-cells = 1;
 +   #size-cells = 0;
 +
 +   PowerPC,[EMAIL PROTECTED] {
 +   device_type = cpu;
 +   reg = 0;
 +   d-cache-line-size = 20;
 +   i-cache-line-size = 20;
 +   d-cache-size = 8000;  // L1, 32K
 +   i-cache-size = 8000;  // L1, 32K
 +   timebase-frequency = 0;
 +   bus-frequency = 0;
 +   clock-frequency = 0;
 +   };
 +   };
 +
 +   memory {
 +   device_type = memory;
 +   reg =  2000;  // 512MB at 0
 +   };
 +
 +   [EMAIL PROTECTED] {
 +   #address-cells = 1;
 +   #size-cells = 1;
 +   device_type = soc;

I recommend dropping device_type and adding 'compatible = fsl,mpc8377-immr;'

 +   ranges = 0 e000 0010;
 +   reg = e000 0200;
 +   bus-frequency = 0;
 +
 +   [EMAIL PROTECTED] {
 +   compatible = mpc83xx_wdt;

fsl,mpc8377_wdt, fsl,mpc83xx_wdt as per generic names recommended practice.

 +   reg = 200 100;
 +   };
 +
 +   [EMAIL PROTECTED] {
 +   #address-cells = 1;
 +   #size-cells = 0;
 +   cell-index = 0;
 +   compatible = fsl-i2c;
 +   reg = 3000 100;
 +   interrupts = e 8;
 +   interrupt-parent =  ipic ;
 +   dfsrr;
 +   };
 +
 +   [EMAIL PROTECTED] {
 +   #address-cells = 1;
 +   #size-cells = 0;
 +   cell-index = 1;
 +   compatible = fsl-i2c;
 +   reg = 3100 100;
 +   interrupts = f 8;
 +   interrupt-parent =  ipic ;
 +   dfsrr;
 +   };
 +
 +   [EMAIL PROTECTED] {
 +   compatible = fsl_spi;
 +   reg = 7000 1000;
 +   interrupts = 10 8;
 +   interrupt-parent =  ipic ;
 +   mode = cpu;
 +   };
 +
 +   /* phy type (ULPI, UTMI, UTMI_WIDE, SERIAL) */
 +   [EMAIL PROTECTED] {
 +   compatible = fsl-usb2-dr;
 +   reg = 23000 1000;
 +   #address-cells = 1;
 +   #size-cells = 0;
 +   interrupt-parent =  ipic ;
 +   interrupts = 26 8;
 +   phy_type = utmi_wide;

fsl,phy_type please.

 +   };
 +
 +   [EMAIL PROTECTED] {
 +   #address-cells = 1;
 +   #size-cells = 0;
 +   compatible = fsl,gianfar-mdio;
 +   reg = 24520 20;
 +   phy2: [EMAIL PROTECTED] {
 +   interrupt-parent =  ipic ;
 +   interrupts = 11 8;
 +   reg = 2;
 +   device_type = 

Re: [PATCH 1/3] add default device trees for MPC837x MDS board

2008-01-08 Thread Scott Wood
On Tue, Jan 08, 2008 at 08:58:17AM -0700, Grant Likely wrote:
 On 1/7/08, Li Yang [EMAIL PROTECTED] wrote:
  +   [EMAIL PROTECTED] {
  +   #address-cells = 1;
  +   #size-cells = 1;
  +   device_type = soc;
 
 I recommend dropping device_type and adding 'compatible = fsl,mpc8377-immr;'

I recommend fixing the code that looks for this device_type before
recommending that people drop it. :-)

  +   [EMAIL PROTECTED] {
  +   compatible = mpc83xx_wdt;
 
 fsl,mpc8377_wdt, fsl,mpc83xx_wdt as per generic names recommended 
 practice.

Speaking of generic names, can we change the node name to watchdog?

  +   /* phy type (ULPI, UTMI, UTMI_WIDE, SERIAL) */
  +   [EMAIL PROTECTED] {
  +   compatible = fsl-usb2-dr;
  +   reg = 23000 1000;
  +   #address-cells = 1;
  +   #size-cells = 0;
  +   interrupt-parent =  ipic ;
  +   interrupts = 26 8;
  +   phy_type = utmi_wide;
 
 fsl,phy_type please.

Again, code will break.  Can we stop ambushing people submitting board
support with complaints against existing, non-board-specific code/device
trees?  Fix that first, then complain if new code reintroduces the crud.

Also, if we're going to change the property name, we should also change the
underscore to a dash.

  +   enet0: [EMAIL PROTECTED] {
  +   cell-index = 0;
  +   device_type = network;
  +   model = eTSEC;
 
 Drop model property

Fix the code that checks for it.

-Scott
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Re: [PATCH 1/3] add default device trees for MPC837x MDS board

2008-01-08 Thread Grant Likely
On 1/8/08, Scott Wood [EMAIL PROTECTED] wrote:
 On Tue, Jan 08, 2008 at 08:58:17AM -0700, Grant Likely wrote:
  On 1/7/08, Li Yang [EMAIL PROTECTED] wrote:
   +   phy_type = utmi_wide;
 
  fsl,phy_type please.

 Again, code will break.  Can we stop ambushing people submitting board
 support with complaints against existing, non-board-specific code/device
 trees?  Fix that first, then complain if new code reintroduces the crud.

I disagree (about bringing up these comments).  New board port is the
time to bring these issue up.  It keeps the issue in the forefront so
it actually gets fixed.


 Also, if we're going to change the property name, we should also change the
 underscore to a dash.

Good point, I missed that

g.

-- 
Grant Likely, B.Sc., P.Eng.
Secret Lab Technologies Ltd.
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


RE: [PATCH 1/3] add default device trees for MPC837x MDS board

2008-01-07 Thread Li Yang
 -Original Message-
 From: Kumar Gala [mailto:[EMAIL PROTECTED] 
 Sent: Tuesday, January 08, 2008 3:37 PM
 To: Li Yang
 Cc: linuxppc-dev@ozlabs.org; [EMAIL PROTECTED]
 Subject: Re: [PATCH 1/3] add default device trees for MPC837x 
 MDS board
 
 
 On Jan 7, 2008, at 6:03 AM, Li Yang wrote:
 
  Signed-off-by: Li Yang [EMAIL PROTECTED]
  ---
  address comments and use new dts spec.
 
  arch/powerpc/boot/dts/mpc8377_mds.dts |  277 
 
  +++
  arch/powerpc/boot/dts/mpc8378_mds.dts |  263 
 
  +
  arch/powerpc/boot/dts/mpc8379_mds.dts |  291 
 
  +
  3 files changed, 831 insertions(+), 0 deletions(-)
 
 Could I convince you to convert these to dts-v1 format?

Ok, I can do it.  The DTS spec changes too much lately.  :(

- Leo
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev


Re: [PATCH 1/3] add default device trees for MPC837x MDS board

2008-01-07 Thread Kumar Gala

On Jan 7, 2008, at 6:03 AM, Li Yang wrote:

 Signed-off-by: Li Yang [EMAIL PROTECTED]
 ---
 address comments and use new dts spec.

 arch/powerpc/boot/dts/mpc8377_mds.dts |  277  
 +++
 arch/powerpc/boot/dts/mpc8378_mds.dts |  263  
 +
 arch/powerpc/boot/dts/mpc8379_mds.dts |  291  
 +
 3 files changed, 831 insertions(+), 0 deletions(-)

Could I convince you to convert these to dts-v1 format?

- k

___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev